Todos os produtos
Search
Central de documentação

ApsaraDB RDS:DeleteBackup

Última atualização: Sep 18, 2026

Exclui arquivos de backup de dados de uma instância do ApsaraDB RDS.

Descrição da operação

Mecanismos suportados

  • ApsaraDB RDS for MySQL

  • ApsaraDB RDS for PostgreSQL

Nota

Apenas instâncias da High-availability Edition são suportadas.

Descrição do recurso

Ao invocar esta operação para excluir arquivos de backup de dados, apenas os conjuntos de backup da própria instância são excluídos. Os conjuntos de backup de instâncias associadas, como instâncias somente leitura, instâncias de recuperação de desastres e instâncias clonadas, não são excluídos.

Precauções

Ao invocar esta operação, a instância deve atender às seguintes condições. Caso contrário, a operação falhará:

  • O status da instância é Running.

  • Se o backup de log estiver desativado, a instância do ApsaraDB RDS não oferece suporte à restauração em um ponto no tempo. Nesse caso, você pode excluir quaisquer arquivos de backup de dados que foram gerados há mais de sete dias.

  • Se o backup de log estiver ativado e o período de retenção do backup de log for menor que o período de retenção do backup de dados, os arquivos de backup de dados que excederem o período de retenção do backup de log poderão ser excluídos.

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:DeleteBackup

delete

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

Nenhuma Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância. Você pode chamar DescribeDBInstances para consultar o ID da instância.

rm-uf6wjk5****

BackupId

string

Sim

O ID do conjunto de backup. Você pode chamar DescribeBackups para consultar o ID do conjunto de backup. Separe vários IDs com vírgulas (,). Você pode especificar até 100 IDs em uma única solicitação.

Nota

Apenas conjuntos de backup cujo StoreStatus seja Enabled na resposta do DescribeBackups podem ser excluídos.

32490****

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

37441409-FFD1-40AA-8EC5-9ECF5E2F7C29

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": "37441409-FFD1-40AA-8EC5-9ECF5E2F7C29"
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 ReadDBInstanceNotSupport The operation is not permitted due to type of the instance. Esta operação não é permitida em uma instância somente leitura.
400 ParameterLeastAssociate Must input at least one optional parameter O horário de restauração e o conjunto de backups não podem estar ambos vazios. Especifique pelo menos um e tente novamente.
400 DeleteBackupSetNumExceed Delete backup set number is more than 100. O número de conjuntos de backup a serem excluídos excede 100.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. As instâncias em um pacote não podem ser operadas individualmente.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. O resultado do plano de preços não foi encontrado.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. O saldo da sua conta é inferior a 0. Recarregue sua conta antes de tentar realizar uma compra.
400 CommodityServiceCalling.Exception Failed to call commodity service. A chamada para o serviço de commodities falhou.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos a sua compreensão e apoio.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. O módulo que você comprou é inválido. Compre um módulo válido.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. A região especificada foi desativada.
400 Price.CommoditySys Commodity system call exception. Ocorreu uma exceção ao chamar o sistema de commodities.
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. O período de assinatura selecionado é inválido. Selecione um período de assinatura diferente.
400 pay.noCreditCard Account not bound to credit card. A conta não está associada a um cartão de crédito.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido existente antes de fazer um novo.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. Nenhum método de pagamento está especificado para a sua conta. Adicione um método de pagamento.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Suas informações estão incompletas. Complete suas informações antes de prosseguir.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Sua conta apresenta uma exceção. Entre em contato com o atendimento ao cliente para obter detalhes.
400 Api.NotSupport Specified api is not supported. A operação atual não é suportada.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para resolver este problema.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. A instância especificada não existe. Verifique se a instância existe e se não foi excluída.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type O tipo de instância atual não suporta este tipo de armazenamento.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. A operação falhou. O parâmetro é inválido.
400 KmsApiError User secret key invalid. A chave do usuário é inválida.
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. A conta não existe.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. A execução do comando SQL falhou ou atingiu o tempo limite.
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. A versão atual do kernel não suporta o arquivamento de dados frios.
400 IncorrectTargetClasscode The current instance type does not support this operation. O tipo de instância atual não suporta esta operação.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. O nome do endereço de conexão está duplicado. Especifique uma string de conexão diferente.
400 RequiredParam.NotFound Required input param is not found. Parâmetros obrigatórios estão ausentes.
400 Parameters.Invalid Parameter error, please check the parameters. O parâmetro é inválido. Verifique os parâmetros.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. O arquivamento de dados frios não suporta backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup.
400 InvalideStatus.Format The instance status does not support this operation. O status da instância não suporta esta operação.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. A política de retenção de dados de backup arquivados após a liberação da instância é inválida.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. O tipo de mecanismo de banco de dados da instância não suporta esta operação.
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. Esta operação não é suportada para instâncias do tipo de rede VPC.
400 MirrorInsExists Specified DB instance mirror ins already existed. A imagem da instância de banco de dados já existe.
400 UnsupportedClassCode The specified DB instance class stops selling. O tipo de instância não está mais disponível para compra.
400 InvalidBackupSet The specified database does not exist in the backup set. O banco de dados especificado não existe no conjunto de backup.
400 OrdTCommodityQueryError Failed to query for product. Falha ao consultar o produto.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. A instância foi liberada. Verifique a instância antes de fazer um pedido.
400 RegionEndTimeDissolvedIndia The region is no longer supported. A região especificada foi desativada.
500 ExternalFailure The request processing has failed due to external service failure. A solicitação falhou. Tente novamente mais tarde.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. A solicitação falhou. Tente novamente mais tarde ou entre em contato com o suporte técnico.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. A solicitação falhou devido a uma falha no serviço da API do RDS.
403 IncorrectDBInstanceState Current DB instance state does not support this operation. A operação falhou. O status atual da instância não oferece suporte a esta operação. Tente novamente mais tarde.
403 IncorrectDBInstanceType Current DB instance engine and type does not support operations. A operação falhou. O mecanismo e o tipo da instância de banco de dados atual não são suportados.
403 IncorrectDBInstanceCharacterType Current DB Instance character_type does not support this operation. Esta operação não é suportada para o conjunto de caracteres atual da instância de banco de dados.
403 OperationDenied.BackupSetDeleteNotSupport The Specified backup does not support this operation. O conjunto de backup atual não pode ser excluído.
403 OrderStatus.UnPaid The specified db instance has unpaid order. A instância possui um pedido não pago. Pague o pedido e tente novamente.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual.
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. Esta operação não é suportada para discos em nuvem SSD. Faça upgrade para ESSD.
403 InvalidUserOperatorPermission The user permission does not support this operation. As permissões do usuário não permitem esta operação.
403 InvalidVswitchId Specified conn vswitch id is not valid. O VSwitchId especificado está em um formato inválido ou está vazio.
403 IncorrectMinorVersion Current engine minor version does not support operations. A versão secundária atual do mecanismo não suporta esta operação.
403 OperationDenied.ZoneResource There is no available zone for inventory. Não há zonas de inventário disponíveis.
403 NotInFlowController Sorry,no permission. Esta operação não está disponível para usuários de nuvem não corporativos. Você não tem as permissões necessárias.
403 InvalidKmsKey Kms key is disabled. A chave KMS está desativada.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. A operação falhou. O código de especificação especificado não suporta o número de endpoints especificado. Verifique o número de shards e o número atual de endpoints.
403 Permission.NotSupport User's permission not support the action. O backup de dados e o backup de logs da conta atual estão sujeitos a uma política de proteção. As seguintes operações não são suportadas: excluir backups, reduzir o período de retenção de backup ou reduzir a frequência de backup.
403 IncorrectBackupSetMethod Current backup set method does not support operations. A operação falhou. O conjunto de backup especificado não suporta a restauração de banco de dados e tabelas.
403 IncorrectBackupSetState Current backup set state does not support operations. A operação falhou. O status atual do conjunto de backup não oferece suporte a esta operação.
404 InvalidDBInstanceName.NotFound Invalid DBInstanceId NotFound. O ID da instância especificado não existe. Verifique o ID da instância e tente novamente.
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation. A operação falhou. A instância está bloqueada.
404 InvalidBackupSetID.NotFound Specified backup set ID does not exist. O conjunto de backups não existe. Verifique os conjuntos de backups existentes.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. A instância atual não está autorizada a acessar o Key Management Service.
404 Request.NotFound The requested resource is not available. O recurso solicitado não está disponível.
404 HostInfo.NotFound The specified host info is not found. As informações do host especificado não existem.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.