Modifica um recurso de serviço de uma zona à qual uma conexão de endpoint pertence.
Descrição da operação
Pré-requisitos
Por padrão, a funcionalidade de modificar um recurso de serviço de uma zona à qual uma conexão de endpoint pertence não está disponível. Para usar essa funcionalidade, faça login no console do Quota Center. Clique em Cotas da lista de permissões no painel de navegação à esquerda e clique em PrivateLink na seção Rede. Na página exibida, pesquise por privatelink_whitelist/svc_res_mgt_uat e clique em Aplicar na coluna Ações.
Notas de uso
-
Se a conexão do endpoint estiver no estado Disconnected, você poderá alocar manualmente o recurso de serviço na zona.
-
Se a conexão do endpoint estiver no estado Connected, você poderá migrar manualmente o recurso de serviço na zona. Nesse caso, a conexão pode ser interrompida.
-
UpdateVpcEndpointZoneConnectionResourceAttribute é uma operação assíncrona. Após o envio de uma solicitação, o sistema retorna um ID de solicitação e executa a tarefa em segundo plano. Você pode chamar a operação GetVpcEndpointServiceAttribute para verificar se o recurso de serviço foi modificado.
-
Se o serviço de endpoint estiver no estado Pending, o recurso de serviço está sendo modificado.
-
Se o serviço de endpoint estiver no estado Active, o recurso de serviço foi modificado.
-
-
Você não pode chamar repetidamente a operação UpdateVpcEndpointZoneConnectionResourceAttribute para modificar um recurso de serviço na zona à qual uma conexão de endpoint pertence dentro de um período de tempo especificado.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
privatelink:UpdateVpcEndpointZoneConnectionResourceAttribute |
update |
*VpcEndpointService
*LoadBalancer
|
Nenhuma | Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| RegionId |
string |
Sim |
O ID da região da conexão de endpoint cuja largura de banda você deseja modificar. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
| ClientToken |
string |
Não |
O token de cliente usado para garantir a idempotência da solicitação. Você pode usar o cliente para gerar o token, mas deve garantir que o token seja exclusivo entre diferentes solicitações. O token pode conter apenas caracteres ASCII. |
0c593ea1-3bea-11e9-b96b-88e9fe637760 |
| DryRun |
boolean |
Não |
Especifica se deve ser realizado apenas um dry run, sem executar a solicitação real. Valores válidos:
|
false |
| ServiceId |
string |
Sim |
O ID do serviço de endpoint. |
epsrv-hp3vpx8yqxblby3i**** |
| EndpointId |
string |
Sim |
O ID do endpoint. |
ep-hp33b2e43fays7s8**** |
| ZoneId |
string |
Sim |
O ID da zona. |
cn-hangzhou-b |
| ResourceAllocateMode |
string |
Não |
O modo de alocação de recursos. Você pode alterar o modo de alocação de recursos apenas se a conexão do endpoint estiver no estado Disconnected. Valores válidos:
|
Auto |
| ResourceReplaceMode |
string |
Não |
O modo de migração do recurso de serviço. Valores válidos:
Nota
Você precisa especificar este parâmetro apenas se desejar migrar recursos de serviço e a conexão do endpoint estiver no estado Connected. Se você especificar este parâmetro, também deverá especificar os parâmetros ResourceId e ResourceType. |
Graceful |
| ResourceType |
string |
Não |
O tipo do recurso de serviço. Valores válidos:
Nota
Se ResourceAllocateMode estiver definido como Mannual ou ResourceReplaceMode estiver definido, este parâmetro será obrigatório. |
slb |
| ResourceId |
string |
Não |
O ID do recurso de serviço que você deseja alocar ou migrar manualmente na zona onde a conexão do endpoint está implantada. Nota
Se ResourceAllocateMode estiver definido como Mannual ou ResourceReplaceMode estiver definido, este parâmetro será obrigatório. |
lb-hp32z1wp5peaoox2q**** |
| RegionId |
string |
Sim |
O ID da região da conexão de endpoint cuja largura de banda você deseja modificar. Você pode chamar a operação DescribeRegions para consultar a lista de regiões mais recente. |
cn-hangzhou |
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
|||
| RequestId |
string |
O ID da solicitação. |
0ED8D006-F706-4D23-88ED-E11ED28DCAC0 |
Exemplos
Resposta de sucesso
JSON formato
{
"RequestId": "0ED8D006-F706-4D23-88ED-E11ED28DCAC0"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | EndpointServiceNotFound | The specified Service does not exist. | The specified Service does not exist. |
| 400 | EndpointConnectionNotFound | The specified endpoint connection does not exist. | The specified endpoint connection does not exist. |
| 400 | EndpointConnectionOperationDenied | The endpoint is being connected. | The endpoint is being connected. |
| 400 | EndpointNotFound | The specified Endpoint does not exist. | The specified Endpoint does not exist. |
| 400 | EndpointServiceLocked | The specified Service is locked. | The specified Service is locked. |
| 400 | EndpointLocked | The specified Endpoint is locked. | The specified Endpoint is locked. |
| 400 | EndpointZoneNotFound | The specified zone of Endpoint does not exist. | The specified zone of Endpoint does not exist. |
| 400 | EndpointServiceResourceTypeNotSupport | The specified resource type is not supported. | The specified resource type is not supported. |
| 400 | EndpointServiceResourceNotFound | The specified service resource is not found. | |
| 400 | ZoneOperationDenied | You cannot operate the specified zone. | You cannot operate the specified zone. |
| 400 | IllegalParam.ResourceAllocateMode | The param of %s is illegal. | |
| 400 | IllegalParam.ResourceReplaceMode | The param of %s is illegal. | |
| 400 | MissingParam.ResourceId | The param of %s is missing. | Missing parameter ResourceId. |
| 400 | MissingParam.ResourceAllocateMode | The param of %s is missing. | Missing ResourceAllocateMode parameter. |
| 400 | OperationDenied.CurrentResourceAutoAllocated | The operation is not allowed because of CurrentResourceAutoAllocated. | The operation is denied because auto allocation is not disabled for the resource in the zone. |
| 400 | Mismatch.ZoneId | The %s is mismatched for %s and %s. | |
| 400 | GatewayLoadBalancerNotSupportZoneConnection | The gateway load balancer not support zone connection. | Gateway-based load balancing type does not support operational zone connection |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.