Use a ferramenta de gerenciamento de banco de dados DBeaver para acessar projetos do MaxCompute e gerencie dados. Este tópico descreve como se conectar a um projeto com o driver JDBC do MaxCompute.
Informações de contexto
O DBeaver é uma ferramenta de banco de dados gratuita e multiplataforma para desenvolvedores, administradores de banco de dados, analistas e qualquer pessoa que trabalhe com bancos de dados. Para mais informações, consulte DBeaver.
Pré-requisitos
Antes de começar, certifique-se de ter o seguinte:
-
crie um projeto do MaxCompute.
Para mais informações, consulte Create a MaxCompute project.
-
crie um par de AccessKey (um AccessKey ID e um AccessKey Secret) com permissões para acessar seu projeto do MaxCompute.
Para mais informações, consulte Create an AccessKey pair.
-
baixe o pacote JAR jar-with-dependencies, que contém todas as dependências.
Para isso, clique em odps-jdbc-3.9.0.jar para baixá-lo, ou obtenha a versão mais recente do pacote JAR do MaxCompute no GitHub ou no repositório Maven. Os exemplos neste tópico usam a versão v3.9.0 do driver JDBC do MaxCompute.
-
baixe e instale o DBeaver.
Para mais informações sobre a instalação, consulte Install. Os exemplos neste tópico usam o DBeaver Community Edition 24.3.1.
Etapa 1: Conectar o DBeaver ao MaxCompute
Inicie o DBeaver.
-
Primeiro, selecione o tipo de banco de dados para conexão.
Na barra de menu superior, clique em ícone de nova conexão
. Na caixa de diálogo Select your database, selecione e, em seguida, clique em Next. A caixa de diálogo Generic JDBC Connection Settings abre. -
Agora, edite as configurações do driver.
Na aba Main da caixa de diálogo Generic JDBC Connection Settings, clique em Edit Driver Settings.
-
Em seguida, defina o nome da classe e o modelo de URL.
Na caixa de diálogo Edit Driver 'SQLite', na aba Settings, defina Class Name como com.aliyun.odps.jdbc.OdpsDriver e URL Template como jdbc:odps:{file}.
-
Adicione o pacote JAR do driver JDBC.
Na aba Libraries da caixa de diálogo Edit Driver Edit Driver 'SQLite', clique em Add File para adicionar o pacote JAR do driver JDBC do MaxCompute
odps-jdbc-3.9.0-rc4-jar-with-dependencies.jarà biblioteca do driver. Por fim, clique em OK.
-
Agora, insira a URL JDBC.
Na aba Main da caixa de diálogo Generic JDBC Connection Settings, configure a JDBC URL.
Parâmetro
Descrição
Connection Method
selecione URL.
JDBC URL
A URL para conexão ao projeto do MaxCompute.
Exemplo:
jdbc:odps:http://service.cn-hangzhou.maxcompute.aliyun.com/api?project=test&accessId=xx&accessKey=xx.Formato:
jdbc:odps:http://<MaxCompute_endpoint>/api?project=<MaxCompute_project_name>&accessId=<accessId>&accessKey=<accessKey>[&interactiveMode={true|false}]. Não inclua os sinais de menor e maior (<>) na URL.<MaxCompute_endpoint>: Obrigatório. O endpoint da região do seu projeto do MaxCompute. Para mais informações, consulte Endpoints.
<MaxCompute_project_name>: Obrigatório. O nome do projeto do MaxCompute ao qual se conectar.
accessId: Obrigatório. O AccessKey ID com permissões para acessar o projeto do MaxCompute. Obtenha seu AccessKey ID na página AccessKey Management do RAM.
accessKey: Obrigatório. O AccessKey Secret correspondente ao AccessKey ID.
-
interactiveMode: Opcional. Especifica se o recurso Query Acceleration está ativado.
ative o Query Acceleration. Para isso, adicione
&interactiveMode=trueà URL. Para mais informações, consulte Query Acceleration.
Por fim, clique em Test Connection. O status Connected na caixa de diálogo Connection Test indica uma conexão bem-sucedida. clique em OK para fechar esta caixa de diálogo e, em seguida, clique em Finish para concluir a configuração.
Etapa 2: Consultar e analisar dados
Após conectar o DBeaver ao MaxCompute, a nova conexão aparece no painel de navegação à esquerda. Use SQL e gerencie seu projeto do MaxCompute. As próximas seções descrevem operações comuns. Para uma lista completa de recursos, consulte a documentação do DBeaver.
-
visualize todas as tabelas
visualize informações sobre todas as tabelas na conexão do MaxCompute criada.
No painel Database Navigator à esquerda, expanda o nó da conexão do MaxCompute, expanda o nome do banco de dados, expanda default e, em seguida, expanda Tables para exibir a lista de tabelas. insira também uma palavra-chave na caixa de pesquisa na parte superior para filtrar tabelas por nome.
-
visualize o esquema da tabela
Na conexão do MaxCompute, clique com o botão direito em uma tabela e selecione View Table.
Por exemplo, a tabela sale_detail possui as seguintes cinco colunas:
shop_name(STRING),customer_id(STRING),total_price(DOUBLE),sale_date(STRING) eregion(STRING). -
visualize dados da tabela
-
Na conexão do MaxCompute, clique em . No editor, insira e execute uma consulta SQL para a tabela de destino para visualizar seus dados.
Por exemplo, insira a consulta
SELECT * FROM pyodps_ml_100k_lens;. Se o recurso Schema Syntax Switch não estiver ativado para o seu projeto, visualize também os dados: clique com o botão direito na tabela de destino na conexão do MaxCompute e selecione View Table. Em seguida, clique na aba Data. Para mais informações, consulte Schema Syntax Switch.
-
Perguntas frequentes
O que fazer se eu receber o erro "Internal error connecting to SQLite" ou falhar ao conectar ao MaxCompute ao usar o DBeaver?
Cenário 1: Ocorre o erro "Internal error connecting to SQLite"
Esse erro geralmente ocorre devido a um problema de configuração do cliente DBeaver ou a um driver ausente, e não é um problema do service do MaxCompute. Para resolver esse problema, execute as seguintes etapas:
Primeiro, verifique se o driver sqlite-jdbc está instalado no cliente DBeaver. Se o driver estiver ausente, baixe e instale-o.
Siga as instruções na seção "Etapa 1: Conectar o DBeaver ao MaxCompute" deste tópico e verifique o nome da classe do driver, o modelo de URL e a configuração do pacote JAR.
Cenário 2: O DBeaver falha ao conectar ao MaxCompute sem uma mensagem de erro específica ou com outros erros de compatibilidade
A incompatibilidade de versão do DBeaver pode causar essa falha de conexão. Recomendamos usar o DBeaver Community Edition 24.3.1, que é a versão recomendada neste tópico. Evite usar versões muito recentes, como a 26.x, ou versões que não possuem compatibilidade verificada.