Se um warehouse não tiver nós suficientes para sua carga de trabalho, adicione ou remova nós de computação (CNs) ou nós de backend (BEs).
Pré-requisitos
A instância está no estado Running.
-
Sua conta Alibaba Cloud não tem pedidos pendentes de pagamento referentes a scale-out, scale-in ou renovação.
Pague ou cancele quaisquer pedidos pendentes antes de continuar.
Notas de uso
O service pode sofrer interrupções durante operações de scale-out ou scale-in. Configure um mecanismo de nova tentativa nas aplicações cliente.
Durante uma operação de scale-out ou scale-in, não é possível executar outras ações, como upgrade de configuração, downgrade de configuração, modificação de configuração ou upgrade de versão.
Limitações
Não é possível reduzir o número de nós do warehouse padrão para zero. Pelo menos três nós devem permanecer em execução. Outros warehouses podem ser reduzidos até zero nós.
Scale-out
Se o Scale-out Precheck falhar com o status Precheck Failed devido a estoque insuficiente na região ou zona atual, adicione menos nós ou entre em contato com a equipe do EMR Serverless StarRocks para solicitar mais recursos.
-
Acesse a página de detalhes de uma instância do EMR Serverless StarRocks.
Faça login no console do EMR.
No painel de navegação à esquerda, escolha .
Na barra de navegação superior, selecione uma região conforme suas necessidades de negócio.
Na seção Instances, localize a instância StarRocks desejada e clique em nome da instância.
Na aba Computing Group, clique em nome do warehouse de destino.
Na página Manage Warehouse, clique em Permanent Nodes à direita de Scale Out.
-
No painel Scale Out, defina o Number of Nodes. Quando o Scale-out Precheck exibir Check Passed, marque a caixa de seleção do contrato de serviço e clique em OK.
O scale-out será concluído com sucesso quando o status do warehouse mudar de Scaling Out para Running.
Scale-in
Uma falha no Scale-in Precheck (status: Precheck Failed) indica que a operação faria o volume total de dados ultrapassar 70% da capacidade de armazenamento. O sistema impede essa operação para evitar alta utilização do armazenamento. Para prosseguir, reduza o volume de dados fazendo backup ou migrando os dados e tente novamente.
Na página Manage Warehouse, clique em Permanent Nodes à direita de Scale In.
-
No painel Scale In, ajuste o Number of Nodes. Quando o Scale-in Precheck exibir Check Passed, marque a caixa de seleção do contrato de serviço e clique em OK.
O scale-in será concluído com sucesso quando o status do warehouse mudar de Scaling In para Running.