Todos os produtos
Search
Central de documentação

Edge Security Acceleration:Configure o Serve Stale Content

Última atualização: Sep 09, 2026

O recurso Serve Stale Content é uma medida essencial de tolerância a falhas e disponibilidade no ESA. Quando o servidor de origem apresenta problemas, como timeout ou retorno de erros 4xx ou 5xx, os pontos de presença (POPs) do ESA podem fornecer conteúdo em cache expirado para recursos estáticos. Isso garante a acessibilidade do site e melhora a disponibilidade e a experiência do usuário, mesmo durante breves interrupções do servidor de origem. Esse recurso não se aplica a solicitações de recursos dinâmicos.

Como funciona

image

Casos de uso

Falha ou indisponibilidade do servidor de origem: Se o servidor de origem ficar indisponível devido a travamento, interrupção de rede ou erro de aplicativo, os pontos de presença (POPs) do ESA não conseguirão buscar o conteúdo mais recente.

  • Sem o recurso Serve Stale Content ativado, um nó do ESA encaminha as solicitações do usuário para o servidor de origem. Contudo, essas solicitações podem falhar se o servidor de origem estiver indisponível, impedindo o acesso ao site.

  • Com o recurso Serve Stale Content ativado, os POPs do ESA retornam conteúdo em cache expirado aos usuários mesmo com o servidor de origem indisponível, garantindo a acessibilidade do site.

Procedimento

  1. No console do ESA, acesse Websites. Na coluna Websites, clique em nome do site desejado.

  2. No painel de navegação à esquerda, selecione Websites > Website.

  3. Clique em Rules e insira um Cache Rules.

  4. Na seção Create Rule, defina as condições de correspondência. Para mais informações, consulte Rule expression syntax.

  5. Na seção Rule Name, especifique se deseja ignorar o cache. Para mais informações, consulte Cache eligibility.

  6. Ative a chave If requests match....

    image

  7. Clique em Cache Eligibility.

FAQ

Por que o conteúdo obsoleto não é fornecido após a exclusão de um arquivo de origem?

O recurso Serve Stale Content é acionado apenas quando o servidor de origem retorna um código de status HTTP 4xx ou 5xx, ou quando a solicitação atinge o timeout. A exclusão isolada de um arquivo do servidor de origem, mantendo-se o servidor respondendo normalmente (por exemplo, retornando uma página padrão com código de status 200 ou um código de status 404), não configure falha na busca de origem e não aciona o Serve Stale Content.

Para acessar um arquivo do cache após sua exclusão no servidor de origem, confirme os seguintes pontos:

  • O servidor de origem deve estar inacessível (por exemplo, servidor travado, interrupção de rede ou retorno de código de erro 5xx), e não apenas com um único arquivo excluído.

  • Uma cópia do arquivo já deve estar em cache no nó de borda antes da exclusão. Caso o arquivo nunca tenha sido armazenado em cache ou se o cache tiver sido limpo, não haverá conteúdo obsoleto para servir, mesmo que o recurso seja acionado.

Documentação relacionada

Os recursos relacionados a regras variam em prioridade efetiva, reentrância e granularidade. Para obter detalhes, consulte Characteristics of rule-based features.