O Data Transmission Service (DTS) sincroniza dados do RDS SQL Server para o AnalyticDB for MySQL 3.0, permitindo análises em tempo real sobre dados operacionais. 3.0
3.0
Bancos de dados de origem suportados
O DTS suporta a sincronização de dados dos seguintes bancos de dados de origem para o AnalyticDB for MySQL. Este tópico descreve o processo de configuração usando uma instância RDS SQL Server como banco de dados de origem. O procedimento é semelhante para outros bancos de dados de origem.
Uma instância RDS SQL Server.
Um banco de dados autogerenciado em uma instância ECS.
Pré-requisitos
Antes de começar, verifique se você tem:
Uma instância RDS SQL Server. Para versões suportadas, consulte Visão geral da sincronização. Para criar uma, consulte Criar e usar rapidamente uma instância RDS SQL Server.
Um cluster AnalyticDB for MySQL 3.0. Para criar um, consulte Criar um cluster. O espaço de armazenamento do cluster deve exceder o da instância RDS SQL Server de origem.
-
Divida a sincronização em várias tarefas se alguma das condições a seguir se aplicar à instância de origem:
O número de bancos de dados excede 10.
Backups de log são executados em um único banco de dados mais de uma vez por hora.
Operações DDL são executadas em um único banco de dados mais de 100 vezes por hora.
O volume de log de um único banco de dados excede 20 MB/s.
É necessário ativar o Change Data Capture (CDC) para mais de 1.000 tabelas.
No modo de análise híbrida de logs, em que o SQL Server Incremental Synchronization Mode está definido como Log-based Parsing for Non-heap Tables and CDC-based Incremental Synchronization for Heap Tables (Hybrid Log-based Parsing), as seguintes versões de banco de dados de origem são suportadas:
Enterprise ou Enterprise Evaluation Edition: versões 2012, 2014, 2016, 2019, 2022 ou 2025.
Standard Edition: versões 2016, 2019, 2022 ou 2025.
Limitações
Comportamento de esquema e DML
Durante a sincronização de esquema, o DTS não sincroniza chaves estrangeiras do banco de dados de origem para o de destino.
Nas sincronizações completa e incremental, o DTS desativa temporariamente as verificações de restrições e operações em cascata de chave estrangeira no nível da sessão. Se ocorrerem operações de atualização ou exclusão em cascata no banco de dados de origem durante a execução da tarefa, poderá haver inconsistência de dados.
Limites do banco de dados de origem
|
Categoria |
Limite |
|
Requisito de chave primária |
As tabelas a serem sincronizadas devem ter uma chave primária ou uma restrição UNIQUE, e os campos devem ser únicos. Caso contrário, dados duplicados podem aparecer no banco de dados de destino. |
|
Contagem de tabelas por tarefa |
Para sincronização no nível de tabela com mapeamento de colunas, uma única tarefa suporta no máximo 5.000 tabelas. Se a contagem exceder esse valor, divida as tabelas em várias tarefas ou configure uma tarefa para sincronizar todo o banco de dados. |
|
Contagem de bancos de dados por tarefa |
Uma única tarefa suporta no máximo 10 bancos de dados. Exceder esse limite pode causar problemas de estabilidade e desempenho. |
|
Nomenclatura de objetos |
Ao sincronizar objetos específicos para o mesmo banco de dados de destino, não é possível selecionar juntos objetos com o mesmo nome de tabela, mas com nomes de esquema diferentes. |
|
Acesso a logs |
O DTS usa a função |
|
Retenção de logs (apenas incremental) |
Os logs de dados devem estar ativados com o modo de backup definido como Full, e um backup físico completo deve ter sido realizado. O DTS exige que os logs sejam retidos por mais de 24 horas. |
|
Retenção de logs (completa + incremental) |
O DTS exige que o banco de dados de origem retenha logs de dados por pelo menos 7 dias. Após a conclusão da sincronização completa, reduza o período de retenção para mais de 24 horas. Se o período de retenção for muito curto, a tarefa do DTS poderá falhar, ou poderão ocorrer inconsistência ou perda de dados. Esses problemas não são cobertos pelo Acordo de Nível de Serviço (SLA) do DTS. |
|
Transparent Data Encryption (TDE) |
Se o banco de dados de origem for uma instância RDS for SQL Server, garanta que o recurso Transparent Data Encryption (TDE) esteja desativado para assegurar a estabilidade da instância de sincronização. Para mais informações, consulte Desativar TDE. |
|
Instâncias somente leitura |
Operações DDL não podem ser sincronizadas a partir de uma instância de origem somente leitura. |
|
Azure SQL Database |
Uma única tarefa pode sincronizar apenas um banco de dados quando a origem é o Azure SQL Database. |
|
Modo híbrido: DDL consecutiva |
Não execute operações consecutivas de adição ou exclusão de colunas dentro de um intervalo de 10 minutos. Por exemplo, as seguintes instruções consecutivas causam falha na tarefa: |
|
sp_rename |
Usar |
|
DDL durante a sincronização |
Não execute operações DDL que alterem esquemas de banco de dados ou tabelas durante a sincronização de esquema ou a sincronização completa. Caso contrário, a tarefa de sincronização falhará. Durante a sincronização completa, o DTS consulta o banco de dados de origem, criando bloqueios de metadados que podem impedir operações DDL. |
|
RDS SQL Server Web-based |
Defina o SQL Server Incremental Synchronization Mode como Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported) quando a origem for um RDS SQL Server web-based. |
|
READ_COMMITTED_SNAPSHOT |
Mantenha o modo de processamento de transações |
Requisitos de CDC
Se for necessário ativar o Change Data Capture (CDC) para tabelas no banco de dados de origem, as seguintes condições devem ser atendidas. Caso contrário, a pré-verificação falhará.
O campo
srvnamena viewsys.sysserversdeve corresponder ao valor retornado pela funçãoSERVERPROPERTY.SQL Server autogerenciado: o proprietário do banco de dados deve ser
sa.RDS for SQL Server: o proprietário do banco de dados deve ser
sqlsa.Enterprise Edition: SQL Server 2008 ou posterior.
Standard Edition: SQL Server 2016 SP1 ou posterior.
O SQL Server 2017 (Standard ou Enterprise Edition) não é suportado. Atualize a versão antes de configurar a tarefa.
Outros limites
Objetos suportados para sincronização inicial de esquema: Schema, Table, View, Function e Procedure.
Este cenário envolve sincronização de dados entre bancos de dados heterogêneos. Os tipos de dados não podem ser mapeados um a um, o que pode causar falha na tarefa ou resultar em perda de dados. Avalie como o mapeamento de tipos de dados afeta seu negócio antes de prosseguir. Para mais informações, consulte Mapeamentos de tipos de dados para sincronização inicial de esquema.
Objetos não suportados para sincronização inicial de esquema: assemblies, service broker, índices full-text, catálogos full-text, esquemas distribuídos, funções distribuídas, procedimentos armazenados CLR, funções escalares CLR, funções com valor de tabela CLR, tabelas internas, objetos de sistema e funções de agregação.
Tipos de dados não suportados: CURSOR, ROWVERSION, SQL_VARIANT, HIERARCHYID, POLYGON, GEOMETRY, GEOGRAPHY e tipos definidos pelo usuário criados com o comando CREATE TYPE.
Tabelas com colunas computadas não podem ser sincronizadas.
Destination Database: O banco de dados de destino deve conter uma chave primária personalizada. Alternativamente, configure uma Primary Key Column na etapa Configurations for Databases, Tables, and Columns. Caso contrário, a sincronização poderá falhar.
Restrição do modo de análise baseada em logs: Se o SQL Server Incremental Synchronization Mode estiver definido como Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported), as tabelas a serem sincronizadas devem ter um índice clusterizado que contenha a coluna de chave primária. Tabelas heap, tabelas sem chave primária, tabelas compactadas, tabelas com colunas computadas e tabelas com colunas esparsas não são suportadas.
Para obter informações sobre como visualizar esses tipos de tabela no SQL Server, consulte Como visualizar informações sobre tabelas heap, tabelas sem chave primária, tabelas compactadas, tabelas com colunas computadas e tabelas com colunas esparsas no SQL Server .
Limites adicionais do modo de análise híbrida de logs:
A tarefa de sincronização incremental do DTS depende do componente CDC. Garanta que o job de CDC no banco de dados de origem esteja funcionando corretamente. Caso contrário, a tarefa do DTS falhará.
Por padrão, o CDC retém dados incrementais por 3 dias. Ajuste o período de retenção usando
exec console.sys.sp_cdc_change_job @job_type = 'cleanup', @retention= <time>;, onde<time>está em minutos. Se o número médio diário de instruções SQL de alteração incremental para uma única tabela exceder 10 milhões, defina<time>como 1440.O módulo de pré-requisito para uma tarefa de sincronização incremental do DTS ativa o CDC nos níveis de banco de dados e tabela. Durante esse processo, o banco de dados de origem pode ser brevemente bloqueado.
Uma única tarefa suporta no máximo 1.000 tabelas com CDC ativado. Exceder esse limite pode causar latência ou instabilidade.
Limites adicionais do modo de consulta e polling de instâncias CDC:
-
A conta de banco de dados usada pela instância do DTS deve ter permissão para ativar o CDC. Ativar o CDC no nível do banco de dados requer a função
sysadmin. Ativar o CDC no nível da tabela requer uma conta privilegiada.A conta privilegiada no console do Azure SQL Database atende aos requisitos. Para bancos de dados baseados em vCore, todas as especificações suportam CDC. Para bancos de dados baseados em DTU, a especificação deve ser S3 ou superior. A conta privilegiada para Amazon RDS for SQL Server suporta a ativação de CDC no nível do banco de dados para procedimentos armazenados. O CDC não pode ser ativado para tabelas com índices columnstore clusterizados.
O DTS faz polling na instância CDC de cada tabela para obter dados incrementais. Não sincronize mais de 1.000 tabelas. Caso contrário, a tarefa pode apresentar latência ou tornar-se instável.
Por padrão, o CDC retém dados incrementais por 3 dias. Ajuste o período de retenção usando
exec console.sys.sp_cdc_change_job @job_type = 'cleanup', @retention= <time>;, onde<time>está em minutos. Se as instruções SQL de alteração incremental diária para uma única tabela excederem 10 milhões, defina<time>como 1440.Não há suporte para executar mais de duas operações DDL consecutivas de adição ou exclusão de coluna dentro de um minuto. Caso contrário, a tarefa poderá falhar.
Não modifique a instância CDC no banco de dados de origem. Caso contrário, a tarefa poderá falhar ou dados poderão ser perdidos.
Objetos de heartbeat e trigger: Para garantir um rastreamento preciso de latência, o DTS cria o trigger dts_cdc_sync_ddl, a tabela de heartbeat dts_sync_progress e a tabela de armazenamento DDL dts_cdc_ddl_history no banco de dados de origem. No modo de sincronização incremental híbrida, o DTS também ativa o CDC no nível do banco de dados e no nível da tabela. O volume de alterações de dados para tabelas com CDC ativado não deve exceder 1.000 registros por segundo (RPS).
Uso de disco do AnalyticDB for MySQL: Se o uso de disco em um nó exceder 80%, o desempenho de gravação diminuirá, causando latência na tarefa do DTS. Se o uso de disco exceder 90%, as gravações serão bloqueadas e a tarefa do DTS ficará anormal. Estime o espaço de armazenamento necessário antes de iniciar a tarefa.
Sincronização fora de pico: Avalie o desempenho de ambos os bancos de dados antes de sincronizar. Execute a tarefa durante horários de baixa demanda para evitar aumento da carga do banco de dados.
Fragmentação de tabela: A sincronização completa inicial executa operações INSERT simultâneas, causando fragmentação de tabela no banco de dados de destino. O tablespace da instância de destino será maior que o da instância de origem após a conclusão da sincronização completa.
Acesso exclusivo de gravação: Não grave dados no banco de dados de destino a partir de nenhuma fonte além do DTS durante a sincronização. Caso contrário, ocorrerá inconsistência de dados. Por exemplo, usar o DMS para operações DDL online enquanto outra fonte grava no banco de dados de destino pode causar perda de dados.
Reindexação: A reindexação não é suportada para uma instância de sincronização. Essa operação pode causar falha na tarefa ou levar à perda de dados. Alterações relacionadas à chave primária não são suportadas para tabelas com CDC ativado.
Limite de tabelas CDC: Se o número de tabelas com CDC ativado em uma única tarefa exceder o valor definido para The maximum number of tables for which CDC is enabled that DTS supports., a pré-verificação falhará.
Tamanho grande de campo: Se um único campo em uma tabela com CDC ativado precisar armazenar mais de 64 KB de dados, execute exec sp_configure 'max text repl size', -1; antecipadamente para ajustar a configuração do banco de dados de origem.
Falhas de gravação DDL: Se uma instrução DDL falhar ao ser gravada no banco de dados de destino, a tarefa do DTS continuará em execução. Verifique os logs da tarefa para encontrar a instrução com falha. Para mais informações, consulte Consultar logs de tarefas.
Modificar objetos sincronizados: Para usar o recurso de modificação de objetos sincronizados, você não pode remover um banco de dados.
Conflito de backup do AnalyticDB: Se o cluster AnalyticDB for MySQL 3.0 de destino estiver fazendo backup enquanto a tarefa do DTS é executada, a tarefa falhará.
Várias instâncias de sincronização: Se várias instâncias de sincronização usarem o mesmo banco de dados SQL Server como origem, seus módulos de ingestão de dados incrementais operarão independentemente.
Recuperação de falha de tarefa: Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la dentro de oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros. Apenas os parâmetros da tarefa do DTS são modificados — não os parâmetros do banco de dados. Os parâmetros que podem ser ajustados estão listados em Modificar parâmetros da instância.
Formato de log do SQL Server: O SQL Server é um banco de dados comercial e de código fechado. Seu formato de log pode causar problemas inevitáveis durante o CDC incremental e a análise. Antes de usar o DTS para sincronização incremental ou de migração a partir do SQL Server em um ambiente de produção, realize uma prova de conceito (POC) abrangente cobrindo todos os tipos de alterações de negócios, ajustes de esquema de tabela e testes de estresse em horários de pico. Certifique-se de que sua lógica de negócios de produção seja consistente com o que foi testado durante a POC.
Casos especiais
Se a instância de origem for uma instância RDS for SQL Server, o DTS criará uma conta rdsdt_dtsacct na instância de origem para sincronização de dados. Não exclua essa conta nem altere sua senha enquanto a tarefa estiver em execução. Caso contrário, a tarefa poderá falhar. Para mais informações, consulte Contas de sistema.
Quando o AnalyticDB for MySQL é o destino, o DTS suporta a gravação dos tipos de dados básicos e complexos (ARRAY, MAP e JSON) do AnalyticDB for MySQL. Se a tabela de destino contiver colunas de tipos de dados não suportados pelo DTS, como MULTIVALUE, a tarefa de sincronização ou migração de dados poderá falhar. Para mais informações, consulte Tipos de dados básicos.
Faturamento
|
Tipo de sincronização |
Preço |
|
Sincronização de esquema e sincronização completa de dados |
Gratuito |
|
Sincronização incremental de dados |
Pago. Para mais informações, consulte Visão geral do faturamento. |
Topologias de sincronização suportadas
Sincronização unidirecional um para um
Sincronização unidirecional um para muitos
Sincronização em cascata unidirecional
Sincronização unidirecional muitos para um
Para detalhes sobre cada topologia, consulte Topologias de sincronização.
Operações SQL suportadas
|
Tipo de operação |
Instruções SQL |
|
DML |
INSERT, UPDATE, DELETE |
|
DDL |
CREATE TABLE, ALTER TABLE (apenas ADD COLUMN e DROP COLUMN), DROP TABLE, CREATE INDEX, DROP INDEX |
Observações sobre DML:
A sincronização incremental de instruções UPDATE que modificam apenas campos de objeto grande não é suportada.
Quando os dados são gravados no AnalyticDB for MySQL, as instruções UPDATE são automaticamente convertidas em instruções REPLACE INTO. Se a chave primária for atualizada, elas serão convertidas em instruções DELETE+INSERT.
Observações sobre DDL: As seguintes operações DDL não são suportadas:
Tipos de dados personalizados
DDL transacional (por exemplo, adicionar várias colunas em uma única instrução ou misturar DDL e DML em uma única instrução)
DDL online
Palavras-chave reservadas como nomes de propriedades
DDL executado por procedimentos armazenados do sistema
TRUNCATE TABLE
Definições de partição ou definições de tabela que contêm funções
Criar uma tarefa de sincronização
-
Acesse a página da lista de tarefas de sincronização de dados na região de destino. Você pode fazer isso de duas maneiras.
Console do DTS
Faça login no console do DTS.
No painel de navegação à esquerda, clique em Data Synchronization.
No canto superior esquerdo da página, selecione a região onde a instância de sincronização está localizada.
Console do DMS
Nota
As etapas reais podem variar dependendo do modo e do layout do console do DMS. Para mais informações, consulte Console do modo simples e Personalizar o layout e o estilo do console do DMS.
Faça login no console do DMS.
Na barra de menu superior, escolha Data + AI > DTS (DTS) > Data Synchronization.
À direita de Data Synchronization Tasks, selecione a região da instância de sincronização.
Clique em Create Task para abrir a página de configuração da tarefa.
-
Configure os bancos de dados de origem e de destino.
AvisoApós selecionar as instâncias de origem e de destino, revise os Limits na parte superior da página antes de prosseguir. Caso contrário, a tarefa poderá falhar ou poderá ocorrer inconsistência de dados.
Categoria Configuração Descrição (nenhum) Task Name O DTS gera automaticamente um nome de tarefa. Especifique um nome descritivo para facilitar a identificação. O nome não precisa ser único. Source Database Select Existing Connection Selecione uma instância de banco de dados registrada na lista suspensa para preencher automaticamente as informações do banco de dados. Se você não registrou a instância, configure os campos abaixo manualmente. NotaNo console do DMS, este campo é Select a DMS database instance.
Database Type Selecione SQL Server. Connection Type Selecione Cloud instance. Instance Region Selecione a região onde reside a instância RDS SQL Server de origem. Replicate Data Across Alibaba Cloud Accounts Selecione No se estiver usando a mesma conta Alibaba Cloud. RDS Instance ID Selecione o ID da instância RDS SQL Server de origem. Database Account Insira a conta do banco de dados para a instância de origem. Esta conta deve ter permissões de propriedade sobre os objetos a serem sincronizados. Database Password Insira a senha da conta do banco de dados. Encryption Selecione Non-encrypted se a criptografia SSL não estiver ativada. Selecione SSL-encrypted se a criptografia SSL estiver ativada. O DTS confia no certificado do lado do servidor por padrão. Destination Database Select Existing Connection Selecione uma instância de banco de dados registrada na lista suspensa para preencher automaticamente as informações do banco de dados. Se você não registrou a instância, configure os campos abaixo manualmente. NotaNo console do DMS, este campo é Select a DMS database instance.
Database Type Selecione AnalyticDB MySQL 3.0. Connection Type Selecione Cloud instance. Instance Region Selecione a região onde reside o cluster AnalyticDB for MySQL de destino. Instance ID Selecione o ID do cluster AnalyticDB for MySQL de destino. Database Account Insira a conta do banco de dados para o cluster de destino. Esta conta deve ter permissões de leitura e gravação. Database Password Insira a senha da conta do banco de dados. -
Clique em Test Connectivity and Proceed na parte inferior da página.
Adicione os blocos CIDR dos servidores DTS às configurações de segurança dos bancos de dados de origem e de destino para permitir o acesso. Para mais informações, consulte Adicionar a lista de permissões de endereços IP dos servidores DTS . Se qualquer um dos bancos de dados for autogerenciado (onde Access Method não é Alibaba Cloud Instance ), clique também em Test Connectivity na caixa de diálogo CIDR Blocks of DTS Servers .
-
Configure os objetos da tarefa.
-
Na página Configure Objects, configure as opções de sincronização.
Configuração
Descrição
Synchronization Types
O DTS sempre seleciona Incremental Data Synchronization. Por padrão, também seleciona Schema Synchronization e Full Data Synchronization. Após a pré-verificação, o DTS inicializa o cluster de destino com os dados completos dos objetos selecionados como linha de base para a sincronização incremental. Nota: Selecionar Full Synchronization sincroniza tanto o esquema quanto os dados para tabelas que possuem uma instrução CREATE TABLE.
Processing Mode of Conflicting Tables
Precheck and Report Errors: Verifica se existem tabelas com os mesmos nomes no banco de dados de destino. Se encontradas, um erro é relatado durante a pré-verificação e a tarefa não inicia. Nota: Se você não puder excluir ou renomear a tabela conflitante, mapeie-a para um nome diferente. Consulte Mapeamento de nomes de colunas de tabelas de banco de dados. Ignore Errors and Proceed: Ignora a verificação de tabelas com o mesmo nome. Warning: Esta opção pode causar inconsistência de dados. Durante a sincronização completa de dados, se existir um registro com a mesma chave primária ou única no destino, o DTS mantém o registro de destino e ignora o registro de origem. Durante a sincronização incremental, o DTS substitui o registro de destino. Se os esquemas das tabelas forem inconsistentes, a inicialização de dados poderá falhar. Use com cautela.
Schema Mapping Mode of Source and Destination Databases
Selecione um modo de mapeamento de esquema para mapear esquemas entre os bancos de dados de origem e de destino. Warning: Tabelas em esquemas diferentes do banco de dados de origem não podem ter o mesmo nome. Caso contrário, poderá ocorrer inconsistência de dados ou falha na tarefa.
SQL Server Incremental Synchronization Mode
Selecione com base na configuração do seu banco de dados de origem. Consulte a tabela de comparação abaixo.
The maximum number of tables for which CDC is enabled that DTS supports.
Defina o número máximo de tabelas para as quais o CDC pode ser ativado na instância de sincronização atual. O valor padrão é 1.000. Note: Esta opção fica indisponível quando o SQL Server Incremental Synchronization Mode está definido como Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported).
Select DDL and DML operations for instance-level synchronization
Selecione as operações SQL a serem sincronizadas no nível da instância. Para operações suportadas, consulte Operações SQL suportadas. Nota: Para selecionar operações SQL no nível do banco de dados ou da tabela, clique com o botão direito em um objeto de sincronização na caixa Selected Objects.
Source Objects
Na caixa Source Objects, clique nos objetos e, em seguida, clique em
para movê-los para a caixa Selected Objects. Nota: Este cenário envolve sincronização entre bancos de dados heterogêneos, portanto, você só pode selecionar objetos no nível da tabela. Views, triggers e procedimentos armazenados não são sincronizados.Selected Objects
Para renomear um único objeto na instância de destino, clique com o botão direito nele na caixa Selected Objects. Consulte Mapear um único nome de objeto. Para renomear vários objetos em massa, clique em Batch Edit. Consulte Mapear vários nomes de objetos em massa. Nota: Para filtrar dados usando uma condição WHERE, clique com o botão direito em uma tabela e defina a condição de filtro. Consulte Definir condições de filtro. O mapeamento de nomes de objetos pode causar falha na sincronização de objetos dependentes.
Choosing an incremental synchronization mode
Recurso
Análise baseada em logs (apenas tabelas não heap)
Análise híbrida baseada em logs
Polling de CDC
Tabelas heap
Não suportado
Suportado
Suportado
Tabelas sem chave primária
Não suportado
Suportado
Suportado
Tabelas compactadas
Não suportado
Suportado
—
Tabelas com colunas computadas
Não suportado
Suportado
—
Intrusividade no banco de dados de origem
Não intrusivo
Cria trigger, tabela de heartbeat, tabela de armazenamento DDL; ativa CDC
Ativa CDC nos níveis de banco de dados e tabela
Suporte a DDL
Limitado
Instruções DDL completas; ampla variedade de cenários DDL
Limitado
Tipos de origem suportados
RDS SQL Server (não web)
RDS SQL Server
Amazon RDS for SQL Server, Azure SQL Database, Azure SQL Managed Instance, Azure SQL Server on Virtual Machine, Google Cloud SQL for SQL Server
Latência de dados incrementais
Baixa
Baixa
~10 segundos
-
Clique em Next: Advanced Settings.
Configuração
Descrição
Dedicated Cluster for Task Scheduling
Por padrão, o DTS usa um cluster compartilhado. Para maior estabilidade, adquira um cluster dedicado. Para mais informações, consulte O que é um cluster dedicado do DTS?.
Retry Time for Failed Connections
Se a conexão com a origem ou o destino falhar após o início da tarefa, o DTS tentará novamente imediatamente. A duração padrão de nova tentativa é de 720 minutos. Defina um valor de 10 a 1.440 minutos. Recomenda-se uma duração de 30 minutos ou mais. Se a conexão for restaurada dentro desse período, a tarefa será retomada. Nota: Se várias instâncias do DTS compartilharem uma origem ou destino, o DTS usará a menor duração de nova tentativa configurada entre todas as instâncias. O DTS cobra pelo tempo de execução da tarefa durante as novas tentativas de conexão.
Retry Time for Other Issues
Para problemas que não sejam de conexão (por exemplo, erros de execução DDL ou DML), o DTS tentará novamente imediatamente. A duração padrão de nova tentativa é de 10 minutos. Defina um valor de 1 a 1.440 minutos. Recomenda-se uma duração de 10 minutos ou mais. Important: Este valor deve ser menor que Retry Time for Failed Connections.
Enable Throttling for Full Data Synchronization
Limite a taxa de migração definindo Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s) para reduzir a carga em ambos os bancos de dados. Note: Esta opção está disponível apenas se Full Data Synchronization estiver selecionado. Você também pode ajustar a taxa enquanto a instância estiver em execução.
Enable Throttling for Incremental Data Synchronization
Limite a taxa de sincronização incremental definindo RPS of Incremental Data Synchronization e Data synchronization speed for incremental synchronization (MB/s).
Environment Tag
Selecione um rótulo de ambiente para identificar a instância.
Configure ETL
Escolha se deseja ativar o recurso de extração, transformação e carga (ETL). Selecione Yesnotificações de alerta para ativar o ETL e insira instruções de processamento de dados no editor de código. Consulte Configurar ETL em uma tarefa de migração ou sincronização de dados. Selecione No para desativar o ETL. Para mais informações sobre ETL, consulte O que é ETL?.
Monitoring and Alerting
Selecione Yes para configurar alertas para falhas de tarefa ou latência que exceda um limiar. Defina o limiar de alerta e as notificações. Consulte Configurar monitoramento e alertas durante a configuração da tarefa. Selecione No para não receber alertas.
Clique em Data Verification para configurar uma tarefa de verificação de dados. Para detalhes, consulte Configurar verificação de dados.
(Opcional) Clique em Next: Configure Database and Table Fields para definir o Type, a Primary Key Column, a Distribution Key e as informações de chave de partição (Partition Key, Partitioning Rules e Partition Lifecycle) para tabelas no banco de dados de destino. > Note: Esta etapa está disponível apenas se Schema Synchronization estiver selecionado em Synchronization Types. Defina Definition Status como All para fazer modificações. A Primary Key Column suporta chaves primárias compostas consistindo em várias colunas. Selecione uma ou mais colunas da Primary Key Column para servir como Distribution Key e Partition Key. Para mais informações, consulte CREATE TABLE.
-
-
Salve a tarefa e execute a pré-verificação.
Para visualizar os parâmetros da API para esta configuração de instância, passe o mouse sobre Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters na dica de ferramenta.
Clique em Next: Save Task Settings and Precheck na parte inferior da página.
Antes de iniciar uma tarefa de sincronização, o DTS realiza uma pré-verificação. A tarefa só inicia se a pré-verificação for aprovada. Se a pré-verificação falhar, clique em View Details ao lado do item com falha, corrija o problema conforme indicado e execute a pré-verificação novamente. Para avisos não ignoráveis, corrija o problema e execute a pré-verificação novamente. Para avisos ignoráveis, clique em Confirm Alert Details , depois em Ignore , em seguida em OK e finalmente em Precheck Again para ignorar o aviso. Ignorar avisos de pré-verificação pode levar a inconsistências de dados e outros riscos comerciais. Prossiga com cautela.
-
Adquira a instância.
Quando a Success Rate atingir 100%, clique em Next: Purchase Instance.
-
Na página Purchase, selecione o método de faturamento e as especificações da instância.
Categoria Parâmetro Descrição New Instance Class Billing Method Subscription: Pague antecipadamente por uma duração fixa. Custo-benefício para tarefas contínuas e de longo prazo. Pay-as-you-go: Faturado por hora pelo uso real. Adequado para tarefas de curto prazo ou de teste. Resource Group Settings O grupo de recursos para a instância. O padrão é o default resource group. Para mais informações, consulte O que é Resource Management?. Instance Class Especificações diferentes afetam a taxa de sincronização. Selecione com base nos requisitos do seu negócio. Para mais informações, consulte Especificações de link de sincronização de dados. Subscription Duration Disponível apenas no modo de assinatura. As opções mensais variam de 1 a 9 meses. As opções anuais incluem 1, 2, 3 ou 5 anos. Leia e marque a caixa de seleção dos Data Transmission Service (Pay-as-you-go) Service Terms.
Clique em Buy and Start e, em seguida, clique em OK na caixa de diálogo de confirmação.
Monitore o progresso da tarefa na página de sincronização de dados.