Todos os produtos
Search
Central de documentação

Data Transmission Service:Sincronizar o PolarDB for MySQL com o AnalyticDB for MySQL 3.0

Última atualização: Sep 18, 2026

Use o DTS para sincronizar dados de um cluster do PolarDB for MySQL com um cluster do AnalyticDB for MySQL 3.0 e crie rapidamente sistemas internos de business intelligence (BI), consultas interativas e relatórios em tempo real.

Pré-requisitos

  • O cluster de origem do PolarDB for MySQL já deve estar criado. Para mais informações, consulte Custom Purchase e Purchase a subscription cluster.

    2070624_v1_3_4.dita" data-node="2755247">.

  • O cluster de destino do AnalyticDB for MySQL 3.0 já deve estar criado. Para mais detalhes, consulte Create a cluster.

  • A instância de destino do AnalyticDB for MySQL requer mais espaço de armazenamento do que a instância de origem do PolarDB for MySQL.

Limitações

Nota
  • Durante a sincronização de schema do banco de dados e das tabelas, o DTS não sincroniza chaves estrangeiras do banco de dados de origem para o de destino.

  • Durante as sincronizações completa e incremental, o DTS desativa temporariamente as verificações de restrições e as operações em cascata de chaves estrangeiras no nível da sessão. Se ocorrerem atualizações ou exclusões em cascata no banco de dados de origem durante a execução da tarefa, poderá haver inconsistência de dados.

  • O DTS não suporta a sincronização de visões materializadas para a instância de destino do AnalyticDB for MySQL durante a sincronização de schema. Se forem necessárias, crie-as manualmente na instância de destino após a conclusão da sincronização.

Tipo

Descrição

Limites do banco de dados de origem

  • As tabelas a serem sincronizadas devem ter uma chave primária ou restrição UNIQUE, e todos os campos devem ser exclusivos. Caso contrário, poderão surgir dados duplicados no banco de dados de destino.

  • Se você sincronizar dados no nível da tabela e precisar editar tabelas (por exemplo, mapear nomes de colunas), uma única tarefa de sincronização suporta até 1.000 tabelas. Se exceder esse limite, um erro será relatado ao enviar a tarefa. Para resolver, divida as tabelas em várias tarefas de sincronização ou sincronize o banco de dados inteiro e envie a tarefa novamente.

  • Logs binários:

    • Ative o log binário e defina o parâmetro loose_polar_log_bin como ON. Caso contrário, um erro será relatado durante a pré-verificação e a instância do DTS não será iniciada. Para mais informações sobre como ativar o log binário e modificar parâmetros, consulte Enable binary logging e Set cluster and node parameters.

      Nota

      Ativar o log binário para um cluster do PolarDB for MySQL consome espaço de armazenamento e gera taxas.

    • Os logs binários do cluster do PolarDB for MySQL devem ser retidos por pelo menos 3 dias. Recomendamos retê-los por 7 dias. Caso contrário, a tarefa do DTS poderá falhar por não conseguir obter os logs binários. Em casos extremos, isso pode causar inconsistência ou perda de dados. Problemas causados por um período de retenção de log binário menor que o necessário não são cobertos pelo Acordo de Nível de Serviço (SLA) do DTS.

      Nota

      Para mais informações sobre como definir o período de retenção para logs binários de um cluster do PolarDB for MySQL, consulte Modify the retention period.

  • Durante a sincronização, não execute operações DDL para modificar chaves primárias ou adicionar comentários às tabelas, como ALTER TABLE table_name COMMENT='Table comment';. Caso contrário, as operações DDL falharão durante a sincronização de dados.

  • Não execute operações DDL que alterem os schemas do banco de dados ou das tabelas durante a sincronização de schema ou completa. Caso contrário, a tarefa de sincronização falhará.

    Nota

    Durante a sincronização completa, o DTS consulta o banco de dados de origem, o que cria bloqueios de metadados que podem impedir operações DDL no banco de dados de origem.

Outros limites

  • Não há suporte para sincronização de índices de prefixo. Se o banco de dados de origem tiver índices de prefixo, a sincronização de dados poderá falhar.

  • Não há suporte para failover primário/secundário da instância de banco de dados durante a sincronização inicial completa de dados. Se ocorrer um failover, atualize e reconfigure a tarefa de sincronização.

  • Se o banco de dados de origem usar operações DDL online no modo de tabela temporária (incluindo cenários de mesclagem de várias tabelas) ou adicionar índices baseados em funções a colunas de chave exclusiva, poderá ocorrer perda de dados ou falha na tarefa no banco de dados de destino.

  • Se ocorrer um conflito de chave primária ou exclusiva durante a execução da tarefa:

    • Se os schemas das tabelas forem iguais e um registro no banco de dados de destino tiver o mesmo valor de chave primária ou exclusiva que um registro no banco de dados de origem:

      • Durante a sincronização completa, o DTS mantém o registro no cluster de destino. O registro correspondente do banco de dados de origem não é sincronizado.

      • Durante a sincronização incremental, o registro do banco de dados de origem sobrescreve o registro no banco de dados de destino.

    • Se os schemas das tabelas forem diferentes, a sincronização inicial de dados poderá falhar. Isso pode resultar na sincronização de apenas dados parciais de colunas ou em uma falha completa. Prossiga com cautela.

  • O banco de dados de destino deve conter uma chave primária personalizada. Como alternativa, na etapa Configurations for Databases, Tables, and Columns, configure uma Primary Key Column. Caso contrário, a sincronização poderá falhar.

  • Não é possível sincronizar dados de um nó somente leitura do cluster de origem do PolarDB for MySQL.

  • Não há suporte para sincronização de INDEX, PARTITION, VIEW, PROCEDURE, FUNCTION, TRIGGER e FK.

  • Não há suporte para sincronização de dados do tipo VECTOR.

  • Não é possível sincronizar tabelas externas do OSS a partir do cluster de origem do PolarDB for MySQL.

  • Devido aos limites do AnalyticDB for MySQL, se o uso de espaço em disco de um nó no cluster do AnalyticDB for MySQL exceder 80%, a tarefa do DTS ficará anormal e ocorrerá latência. Estime o espaço necessário com base nos objetos a serem sincronizados para garantir que o cluster de destino tenha espaço de armazenamento suficiente.

  • Se o cluster de destino do AnalyticDB for MySQL 3.0 estiver em backup durante a execução da tarefa do DTS, a tarefa falhará.

  • Antes de sincronizar os dados, avalie o desempenho dos bancos de dados de origem e de destino. Recomendamos sincronizar os dados em horários de menor movimento. Caso contrário, a sincronização inicial completa de dados consumirá recursos de leitura e gravação em ambos os bancos, o que pode aumentar a carga.

  • A sincronização inicial completa de dados executa operações INSERT simultâneas, causando fragmentação nas tabelas do banco de dados de destino. Como resultado, o tablespace da instância de destino ficará maior que o da instância de origem após essa etapa.

  • Para sincronização de dados no nível da tabela, não use ferramentas como pt-online-schema-change para executar operações DDL online nos objetos de sincronização no banco de dados de origem. Caso contrário, a sincronização falhará.

  • Para sincronização de dados no nível da tabela, se nenhum dado além dos dados do DTS for gravado no banco de dados de destino, use o Data Management (DMS) para executar operações DDL online. Para mais informações, consulte Alterar schemas sem bloquear tabelas.

  • Durante a sincronização do DTS, não grave dados externos no banco de dados de destino. Caso contrário, poderá ocorrer inconsistência de dados entre a origem e o destino. Por exemplo, se você usar o DMS para executar operações DDL online enquanto outros dados estão sendo gravados no banco de dados de destino, os dados poderão ser perdidos.

  • Se uma operação DDL não for gravada no banco de dados de destino, a tarefa do DTS continuará em execução. Verifique os logs da tarefa para encontrar a operação DDL com falha. Para mais informações sobre como visualizar os logs da tarefa, consulte View task logs.

  • Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la em até oito horas. Durante a restauração, eles poderão reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Apenas os parâmetros da tarefa do DTS são modificados, e não os parâmetros do banco de dados. Os parâmetros que podem ser ajustados incluem aqueles listados em Modify instance parameters.

Outras observações

O DTS executa periodicamente o comando CREATE DATABASE IF NOT EXISTS test no banco de dados de origem para avançar o deslocamento do log binário.

Faturamento

Tipo de sincronização

Preço

Sincronização de schema e sincronização completa de dados

Gratuito.

Sincronização incremental de dados

Cobrado. Para mais informações, consulte Billing overview.

Topologias de sincronização suportadas

  • Sincronização unidirecional um para um

  • Sincronização unidirecional um para muitos

  • Sincronização unidirecional muitos para um

Operações SQL suportadas

Tipo de operação

Instrução SQL

DML

INSERT, UPDATE e DELETE

Nota

Quando os dados são gravados no cluster do AnalyticDB for MySQL, a instrução UPDATE é convertida automaticamente para REPLACE INTO.

DDL

CREATE TABLE, DROP TABLE, RENAME TABLE, TRUNCATE TABLE, ADD COLUMN e DROP COLUMN

Aviso

Se o tipo de dados de um campo na tabela de origem for alterado durante a sincronização de dados, um erro será retornado e a tarefa de sincronização será interrompida. Para solucionar esse problema:

  1. Enquanto o DTS sincroniza dados com o cluster de destino do AnalyticDB for MySQL, o tipo de dados de um campo na tabela de origem é alterado, causando a falha da tarefa. Neste exemplo, a tabela de origem chama-se customer.

  2. No cluster de destino do AnalyticDB for MySQL V3.0, crie uma tabela chamada customer_new que tenha o mesmo schema da tabela customer.

  3. Execute a instrução INSERT INTO SELECT para copiar dados da tabela customer para a tabela customer_new.

  4. Renomeie ou exclua a tabela customer. Em seguida, altere o nome da tabela customer_new para customer.

  5. Reinicie a tarefa de sincronização de dados no console do DTS.

Procedimento

  1. Acesse a página da lista de tarefas de sincronização da região de destino. Use um dos seguintes métodos:

    Pelo console do DTS

    1. Faça login no console do Data Transmission Service (DTS).

    2. No painel de navegação à esquerda, clique em Data Synchronization.

    3. No canto superior esquerdo da página, selecione a região onde a instância de sincronização está localizada.

    Pelo console do DMS

    Nota

    As operações reais podem variar de acordo com o modo e o layout do console do DMS. Para mais informações, consulte Simple mode e Customize the layout and style of the DMS interface.

    1. Faça login no Data Management (DMS).

    2. Na barra de menu superior, escolha Data + AI > Data Transmission (DTS) > Data Synchronization.

    3. À direita de Data Synchronization Tasks, selecione a região onde a instância de sincronização está localizada.

  2. Clique em Create Task para abrir a página de configuração da tarefa.

  3. Configure os bancos de dados de origem e de destino.

    Aviso

    Após selecionar as instâncias de origem e de destino, leia atentamente os limites exibidos na parte superior da página. Se não seguir os limites, a tarefa poderá falhar ou ocorrer inconsistência de dados.

    Categoria

    Parâmetro

    Descrição

    N/D

    Task Name

    O DTS gera automaticamente um nome para a tarefa. Especifique um nome descritivo para facilitar a identificação. O nome não precisa ser exclusivo.

    Source Database

    Select Existing Connection

    • Para usar uma instância de banco de dados added to the system (recém-criada ou salva), selecione-a na lista suspensa. As informações do banco de dados são configuradas automaticamente.

      Nota

      No console do DMS, este item de configuração chama-se Select a DMS database instance..

    • Se não adicionou a instância de banco de dados ao sistema ou não precisa usar uma instância já adicionada, configure manualmente as seguintes informações.

    Database Type

    Selecione PolarDB for MySQL.

    Connection Type

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região do cluster de origem do PolarDB for MySQL.

    PolarDB Cluster ID

    Selecione o ID da instância do cluster de origem do PolarDB for MySQL.

    Database Account

    Insira a conta do banco de dados do cluster de origem do PolarDB for MySQL. Essa conta deve ter permissões de leitura nos objetos a serem sincronizados.

    Database Password

    Insira a senha correspondente à conta do banco de dados.

    Encryption

    Selecione uma opção conforme necessário. Para mais informações, consulte Configure SSL encryption.

    Destination Database

    Select Existing Connection

    • Para usar uma instância de banco de dados added to the system (recém-criada ou salva), selecione-a na lista suspensa. As informações do banco de dados são configuradas automaticamente.

      Nota

      No console do DMS, este item de configuração chama-se Select a DMS database instance..

    • Se não adicionou a instância de banco de dados ao sistema ou não precisa usar uma instância já adicionada, configure manualmente as seguintes informações.

    Database Type

    Selecione AnalyticDB for MySQL 3.0.

    Connection Type

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região do cluster de destino do AnalyticDB for MySQL 3.0.

    Instance ID

    Selecione o ID da instância do cluster de destino do AnalyticDB for MySQL 3.0.

    Database Account

    Insira a conta do banco de dados do cluster de destino do AnalyticDB for MySQL 3.0. Essa conta deve ter permissões de leitura e gravação.

    Database Password

    Insira a senha correspondente à conta do banco de dados.

  4. Após concluir a configuração, clique em Test Connectivity and Proceed na parte inferior da página.

    Nota

    Certifique-se de que os blocos CIDR de endereços IP dos servidores do DTS foram adicionados às configurações de segurança (lista de permissões) dos bancos de dados de origem e de destino para permitir o acesso. Isso pode ser feito automática ou manualmente. Para mais informações, consulte Add the IP address CIDR blocks of DTS servers to a whitelist.

  5. Configure os objetos da tarefa.

    1. Na página Configure Objects, configure os objetos a serem sincronizados.

      Parâmetro

      Descrição

      Synchronization Types

      A opção Incremental Data Synchronization está selecionada. Por padrão, você também deve selecionar Schema Synchronization e Full Data Synchronization. Após a pré-verificação, o DTS executa uma sincronização completa de dados dos objetos selecionados da instância de origem para o cluster de destino. Isso serve como linha de base para a sincronização incremental subsequente.

      Nota

      Se a opção Full Data Synchronization estiver selecionada, será possível sincronizar o schema e os dados da tabela criada pela instrução CREATE TABLE com o banco de dados de destino.

      DDL and DML Operations to Be Synchronized

      Selecione as operações DDL ou DML a serem sincronizadas no nível da instância. Para obter informações sobre as operações suportadas, consulte Operações SQL suportadas.

      Nota

      Para selecionar operações SQL a serem sincronizadas no nível do banco de dados ou da tabela, clique com o botão direito do mouse em um objeto na lista Selected Objects e selecione as operações desejadas no menu de atalho.

      Merge Tables

      • Selecione Yes: em cenários OLTP, o particionamento (sharding) de bancos de dados e tabelas é frequentemente usado para melhorar o tempo de resposta. Em cenários OLAP, como o banco de dados de destino neste exemplo, uma única tabela pode armazenar grandes quantidades de dados, tornando as consultas mais convenientes. Nesses cenários, use o recurso de mesclagem de várias tabelas do DTS para sincronizar várias tabelas com o mesmo schema do banco de dados de origem em uma única tabela no banco de dados de destino. Para obter instruções, consulte Enable multi-table merge.

        Nota
        • Após selecionar várias tabelas no banco de dados de origem, use o recurso de mapeamento de nomes de objetos para alterar seus nomes para o mesmo nome de tabela no banco de dados de destino. Para mais informações, consulte Map table and column names.

        • O DTS adiciona a coluna __dts_data_source do tipo texto à tabela de destino para armazenar a origem dos dados. O valor da coluna usa o formato DTS instance ID:database name:schema name:table name para identificar a origem da tabela, por exemplo, dts****:dtstestdata:testschema:customer1.

        • O recurso de mesclagem de várias tabelas atua no nível da tarefa, o que significa que não é possível executar a mesclagem no nível da tabela. Se quiser mesclar apenas algumas tabelas, crie duas tarefas de sincronização de dados.

        Aviso

        Não execute operações DDL para alterar o schema do banco de dados ou da tabela no banco de dados de origem. Caso contrário, poderá ocorrer inconsistência de dados ou falha na tarefa de sincronização.

      • Selecione No. Esta é a opção padrão.

      Processing Mode of Conflicting Tables

      • Precheck and Report Errors: Verifica se existe uma tabela com o mesmo nome no banco de dados de destino. Se não existir, a pré-verificação é aprovada. Se existir, a pré-verificação falhará e a tarefa de sincronização de dados não será iniciada.

        Nota

        Se não for possível excluir ou renomear a tabela com o mesmo nome no banco de dados de destino, mapeie-a para um nome diferente. Para mais informações, consulte Map table and column names.

      • Ignore Errors and Proceed: Ignora a verificação de nomes de tabelas duplicados no banco de dados de destino.

        Aviso

        Selecionar Ignore Errors and Proceed pode causar inconsistência de dados e colocar seus negócios em risco. Por exemplo:

        • Se os schemas das tabelas forem iguais e um registro no banco de dados de destino tiver o mesmo valor de chave primária ou exclusiva que um registro no banco de dados de origem:

          • Durante a sincronização completa, o DTS mantém o registro no cluster de destino. O registro correspondente do banco de dados de origem não é sincronizado.

          • Durante a sincronização incremental, o registro do banco de dados de origem sobrescreve o registro no banco de dados de destino.

        • Se os schemas das tabelas forem diferentes, a sincronização inicial de dados poderá falhar. Isso pode resultar na sincronização de apenas dados parciais de colunas ou em uma falha completa. Prossiga com cautela.

      Capitalization of Object Names in Destination Instance

      Configure a política de diferenciação de maiúsculas e minúsculas para os nomes de objetos de banco de dados, tabelas e colunas sincronizados com a instância de destino. Por padrão, a DTS default policy é selecionada. Você também pode optar por usar as políticas padrão dos bancos de dados de origem e de destino. Para mais informações, consulte Case sensitivity policy for destination object names.

      Source Objects

      Na caixa Source Objects, clique em um objeto a ser sincronizado e, em seguida, clique em 向右 para movê-lo para a caixa Selected Objects.

      Nota
      • Você pode selecionar colunas, tabelas ou bancos de dados como objetos a serem sincronizados. Se selecionar tabelas ou colunas, o DTS não sincronizará outros objetos, como visões, gatilhos ou procedimentos armazenados, com o banco de dados de destino.

      • Se selecionar um banco de dados como objeto a ser sincronizado, o DTS aplicará as seguintes regras padrão:

        • Se a tabela de origem tiver uma chave primária (coluna única ou composta), as colunas de chave primária serão usadas como chaves de distribuição.

        • Se a tabela de origem não tiver uma chave primária, uma coluna de chave primária de incremento automático será gerada na tabela de destino. Isso pode causar inconsistência de dados entre a origem e o destino.

      Selected Objects

      • Para renomear um único objeto de sincronização na instância de destino, clique com o botão direito do mouse no objeto na caixa Selected Objects. Para mais informações, consulte Map a single database, table, or column.

      • Para alterar os nomes de vários objetos de sincronização na instância de destino em lote, clique em Batch Edit no canto superior direito da caixa Selected Objects. Para mais informações, consulte Map databases, tables, and columns in a batch.

      Nota
      • Para selecionar operações SQL a serem sincronizadas no nível do banco de dados ou da tabela, clique com o botão direito do mouse no objeto na lista Selected Objects e selecione as operações SQL desejadas na caixa de diálogo exibida. Para obter uma lista de operações suportadas, consulte Operações SQL suportadas.

      • Para filtrar dados usando uma cláusula WHERE, clique com o botão direito do mouse na tabela na lista Selected Objects e especifique a condição de filtro na caixa de diálogo exibida. Para obter instruções, consulte Configure data filtering.

    2. Clique em Next: Advanced Settings para configurar parâmetros avançados.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda tarefas em um cluster compartilhado, e você não precisa selecionar um cluster. Para um desempenho mais estável, adquira um cluster dedicado para executar tarefas de sincronização do DTS. Para mais informações, consulte What is a DTS dedicated cluster?.

      Copy the temporary table of the Online DDL tool that is generated in the source table to the destination database.

      Não há suporte para operações DDL na sincronização. Selecione No, Adapt to DMS Online DDL ou No, Adapt to gh-ost. Se a sincronização DDL for suportada neste cenário no futuro e você usar o Data Management (DMS) ou gh-ost para fazer alterações DDL online no banco de dados de origem, poderá escolher se deseja sincronizar dados das tabelas temporárias geradas durante as alterações.

      Importante

      Os métodos de processamento para cada etapa são os seguintes: as etapas de Schema Synchronization e Full Data Synchronization não permitem operações DDL que alterem o schema do banco de dados ou da tabela. Portanto, essas etapas não são controladas pela política de DDL Online.

      • Schema Synchronization: Esta etapa não é controlada pela política de DDL Online. As tabelas temporárias relacionadas são criadas.

      • Full Data Synchronization: Esta etapa não é controlada pela política de DDL Online. As tabelas temporárias não estão incluídas nos objetos de sincronização completa. Todas as tabelas cujos nomes correspondem à expressão regular (^_(.+)_(?:gho|new)$ ou ^_(.+)_(?:ghc|del|old)$) são filtradas.

      • Incremental Data Synchronization: Esta etapa é controlada pela política de DDL Online.

        • Yes: Sincroniza alterações de dados em tabelas temporárias (por exemplo, _table-name_gho) geradas por operações DDL online.

        • No, Adapt to DMS Online DDL e No, Adapt to gh-ost: Filtra alterações de dados em tabelas temporárias (por exemplo, _table-name_gho) geradas por ferramentas como gh-ost com base em regras de expressão regular.

      • Yes: Sincroniza dados de tabelas temporárias gerados por alterações DDL online.

        Nota

        Se os dados das tabelas temporárias gerados por alterações DDL online forem muito grandes, poderá ocorrer latência na sincronização.

      • No, Adapt to DMS Online DDL: Não sincroniza dados de tabelas temporárias geradas por alterações DDL online. Em vez disso, sincroniza apenas as instruções DDL originais executadas no banco de dados de origem usando o Data Management (DMS).

        Nota

        Esta opção causa o bloqueio de tabelas no banco de dados de destino.

      • No, Adapt to gh-ost: Não sincroniza tabelas temporárias geradas por alterações DDL online. Suporta regras de filtragem personalizadas. O DTS filtra alterações de dados em tabelas temporárias (por exemplo, _table-name_gho) geradas por ferramentas como gh-ost com base em regras de expressão regular. Modifique as expressões regulares padrão usadas para corresponder a tabelas sombra e tabelas inúteis conforme necessário:

        • Tabela sombra: ^_(.+)_(?:gho|new)$

        • Tabela inútil: ^_(.+)_(?:ghc|del|old)$

        Nota

        Esta opção causa o bloqueio de tabelas no banco de dados de destino.

      Retry Time for Failed Connections

      Após o início de uma tarefa de sincronização, se a conexão com o banco de dados de origem ou de destino falhar, o DTS relatará um erro e começará imediatamente a tentar reconectar. A duração padrão da nova tentativa é de 720 minutos. Você também pode especificar uma duração personalizada de 10 a 1.440 minutos. Recomendamos definir a duração para 30 minutos ou mais. Se o DTS se reconectar com sucesso ao banco de dados dentro da duração especificada, a tarefa de sincronização será retomada automaticamente. Caso contrário, a tarefa falhará.

      Nota
      • Se você tiver várias instâncias do DTS (por exemplo, Instância A e Instância B) que compartilham a mesma origem ou destino, e definir o tempo de nova tentativa de rede para 30 minutos para a Instância A e 60 minutos para a Instância B, a duração mais curta (30 minutos) será usada para ambas.

      • Como o DTS cobra pelo tempo de execução da tarefa durante o período de nova tentativa de conexão, recomendamos personalizar a duração da nova tentativa com base nas necessidades do seu negócio ou liberar a instância do DTS o mais rápido possível após a liberação das instâncias de banco de dados de origem e de destino.

      Retry Time for Other Issues

      Após o início da tarefa de sincronização, se ocorrerem outros problemas não relacionados à conectividade com o banco de dados de origem ou de destino (como exceções de execução DDL ou DML), o DTS relatará um erro e iniciará imediatamente operações contínuas de nova tentativa. A duração padrão é de 10 minutos. Você também pode personalizar a duração dentro do intervalo de 1 a 1.440 minutos. Recomendamos definir para 10 minutos ou mais. Se as operações relevantes forem bem-sucedidas dentro da duração definida, a tarefa de sincronização será retomada automaticamente. Caso contrário, a tarefa falhará.

      Importante

      O valor para Retry Time for Other Issues deve ser menor que o valor para Retry Time for Failed Connections.

      Enable Throttling for Full Data Synchronization

      Durante a etapa de sincronização completa, o DTS consome recursos de leitura e gravação dos bancos de dados de origem e de destino, o que pode aumentar a carga. Para reduzir a carga, defina um limite de taxa para a tarefa de sincronização completa configurando os parâmetros Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s).

      Nota
      • Este item de configuração está disponível apenas quando Synchronization Types está definido como Full Data Synchronization.

      • Você também pode ajustar a taxa de sincronização completa após a instância de sincronização estar em execução.

      Enable Throttling for Incremental Data Synchronization

      Você também pode definir um limite de taxa para a tarefa de sincronização incremental. Para aliviar a pressão no banco de dados de destino, defina RPS of Incremental Data Synchronization e Data synchronization speed for incremental synchronization (MB/s).

      Environment Tag

      Selecione uma tag de ambiente para identificar a instância de acordo com suas necessidades. Este parâmetro é opcional.

      Whether to delete SQL operations on heartbeat tables of forward and reverse tasks

      Escolha se deseja gravar informações SQL de heartbeat no banco de dados de origem enquanto a instância do DTS está em execução.

      • Yes: As informações SQL de heartbeat não são gravadas no banco de dados de origem. Isso pode fazer com que a instância do DTS relate um atraso.

      • No: Grava informações SQL de heartbeat no banco de dados de origem. Isso pode interferir em recursos como backup físico e clonagem do banco de dados de origem.

      Configure ETL

      Escolha se deseja ativar o recurso de extração, transformação e carregamento (ETL). Para mais informações, consulte What is ETL?. Valores válidos:

      Monitoring and Alerting

      Especifique se deseja configurar alertas. Se a sincronização falhar ou a latência exceder o limiar especificado, uma notificação será enviada para um contato de alerta.

    3. Clique em Next: Data Validation para configurar uma tarefa de validação de dados.

      Para usar o recurso de validação de dados, consulte Configure data validation para obter instruções de configuração.

    4. Opcional: Após concluir a configuração anterior, clique em Next: Configure Database and Table Fields para definir o Type, a Primary Key Column, a Distribution Key e as informações da chave de partição (Partition Key, Partitioning Rules e Partition Lifecycle) para a tabela a ser sincronizada no banco de dados de destino.

      Nota
      • Esta etapa está disponível apenas se você selecionar Schema Synchronization para Synchronization Types ao configurar os objetos da tarefa. Em seguida, defina Definition Status como All para fazer modificações.

      • A Primary Key Column pode ser uma chave primária composta por várias colunas. Selecione uma ou mais colunas da Primary Key Column para servir como Distribution Key e Partition Key. Para mais informações, consulte CREATE TABLE.

  6. Salve a tarefa e execute uma pré-verificação.

    • Visualize os parâmetros da API para configurar esta instância: passe o mouse sobre o botão Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters na dica.

    • Após visualizar os parâmetros da API, clique em Next: Save Task Settings and Precheck na parte inferior da página.

    Nota
    • Antes do início da tarefa de sincronização, o DTS executa uma pré-verificação. A tarefa só pode começar após a aprovação de todos os itens.

    • Se a pré-verificação falhar, clique em View Details no item com falha. Corrija o problema conforme solicitado e execute a pré-verificação novamente.

    • Se a pré-verificação retornar um aviso:

      • Se um item de verificação falhar e não puder ser ignorado, clique em View Details ao lado do item. Siga as instruções para corrigir o problema e execute a pré-verificação novamente.

      • Para itens de verificação que podem ser ignorados, clique em Confirm Alert Details, Ignore, OK e Precheck Again em sequência para pular o aviso e executar a pré-verificação novamente. Se optar por ignorar o item de aviso, isso poderá causar problemas como inconsistência de dados e representar riscos para o seu negócio.

  7. Adquira a instância.

    1. Quando a Success Rate for de 100%, clique em Next: Purchase Instance.

    2. Na página Purchase, selecione o método de faturamento e a especificação do link para a instância de sincronização de dados. A tabela a seguir descreve esses parâmetros em detalhes.

      Categoria

      Parâmetro

      Descrição

      New Instance Class

      Método de faturamento

      • Assinatura: você paga ao criar a instância. Adequado para necessidades de longo prazo e mais econômico que o pagamento conforme o uso. Quanto maior a duração da assinatura, maior o desconto.

      • Pagamento conforme o uso: você é cobrado por hora. Adequado para necessidades de curto prazo. Libere a instância imediatamente após o uso para economizar custos.

      Configuração do grupo de recursos

      O grupo de recursos ao qual a instância pertence. O padrão é o grupo de recursos padrão. Para mais informações, consulte What is Resource Management?.

      Especificação do link

      O DTS fornece especificações de sincronização com diferentes níveis de desempenho. A especificação do link de sincronização afeta a taxa de sincronização. Escolha uma especificação com base no seu cenário de negócios. Para mais informações, consulte Data synchronization link specifications.

      Duração da assinatura

      No modo de assinatura, selecione a duração e a quantidade para a instância. Você pode escolher uma assinatura mensal de 1 a 9 meses ou uma assinatura anual de 1, 2, 3 ou 5 anos.

      Nota

      Esta opção está disponível apenas quando o método de faturamento é Subscription.

    3. Após concluir a configuração, leia e selecione Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start. Na caixa de diálogo OK, confirme a ação e clique em OK.

      Visualize o progresso da tarefa na página Data Synchronization.