Todos os produtos
Search
Central de documentação

Data Transmission Service:Migrar RDS for MySQL para PolarDB-X 1.0

Última atualização: Jul 16, 2026

Use o Data Transmission Service (DTS) para migrar dados de uma instância ApsaraDB RDS for MySQL para uma instância PolarDB-X 1.0.

Bancos de dados de origem suportados

Você pode migrar dados dos seguintes tipos de bancos de dados de origem MySQL para uma instância PolarDB-X 1.0. Este tópico usa uma instância ApsaraDB RDS for MySQL para demonstrar o procedimento de configuração. O processo para outros tipos de banco de dados de origem é semelhante.

  • Instância ApsaraDB RDS for MySQL.

  • Os seguintes tipos de bancos de dados autogerenciados:

    • Banco de dados autogerenciado com endereço IP público

    • Banco de dados autogerenciado hospedado no Elastic Compute Service (ECS)

    • Banco de dados autogerenciado conectado via Express Connect, VPN Gateway ou Smart Access Gateway

    • Banco de dados autogerenciado conectado via Database Gateway

Pré-requisitos

  • Você deve ter uma instância de origem ApsaraDB RDS for MySQL. Para mais informações, consulte Criar uma instância ApsaraDB RDS for MySQL.

    Nota

    Para migrações incrementais, verifique se o conjunto de caracteres dos dados de origem não é utf8mb3.

  • Você deve ter uma instância PolarDB-X 1.0. Para mais informações, consulte Criar uma instância PolarDB-X 1.0.

  • A instância PolarDB-X 1.0 deve ter mais espaço de armazenamento do que o utilizado pela instância de origem ApsaraDB RDS for MySQL.

Limitações

Tipo

Descrição

Limitações do banco de dados de origem

  • Requisito de largura de banda: o servidor que hospeda o banco de dados de origem precisa ter largura de banda de saída suficiente. Caso contrário, a velocidade de migração de dados será afetada.

  • As tabelas a serem migradas devem ter uma chave primária ou uma restrição única, e as colunas da chave precisam ser exclusivas. Do contrário, podem ocorrer dados duplicados no banco de dados de destino.

  • Ao migrar dados no nível de tabela e precisar editar configurações (como mapeamento de colunas), uma única tarefa de migração suporta no máximo 1.000 tabelas. Se esse limite for excedido, um erro será reportado após o envio da tarefa. Nesse caso, recomenda-se dividir as tabelas em vários lotes com tarefas separadas ou migrar todo o banco de dados em uma única tarefa.

  • Se você precisar de migração incremental, ative o log binário:

    • Defina binlog_format como ROW e binlog_row_image como FULL. Caso contrário, a pré-verificação falhará e a tarefa não poderá ser iniciada.

      Importante

      Se sua origem MySQL autogerenciada for um cluster dual-master — onde cada instância atua como master e slave — ative o parâmetro log_slave_updates. Isso garante que o DTS possa ler todos os logs binários.

    • Para instâncias RDS for MySQL, retenha logs binários locais por pelo menos três dias (sete dias é o recomendado). Para bancos de dados MySQL autogerenciados, retenha logs binários locais por pelo menos sete dias. Se o DTS não conseguir acessar os logs binários, a tarefa falhará. Em casos extremos, pode ocorrer inconsistência ou perda de dados. Problemas causados por períodos de retenção de logs binários menores do que o exigido pelo DTS não são cobertos pelo SLA do DTS.

      Nota

      Para definir o retention period dos logs binários locais em uma instância RDS for MySQL, consulte Excluir automaticamente logs locais.

  • Durante as fases de migração de esquema e migração completa, não execute operações DDL que alterem a estrutura do banco de dados ou das tabelas. Caso contrário, a tarefa de migração de dados falhará.

    Nota

    Durante a fase de migração completa, o DTS consulta o banco de dados de origem. Isso cria um bloqueio de metadados que pode impedir operações DDL no banco de dados de origem.

  • Se você executar apenas uma migração completa de dados, não grave novos dados no banco de dados de origem. Caso contrário, os dados nos bancos de origem e destino ficarão inconsistentes. Para manter a consistência dos dados em tempo real, selecione tanto a migração completa quanto a migração incremental de dados.

  • Se você precisar de migração incremental, instâncias RDS for MySQL que não registram logs de transações — como instâncias somente leitura do RDS for MySQL 5.6 — não são suportadas como origem.

  • O tipo de armazenamento de uma instância PolarDB-X 1.0 deve ser ApsaraDB RDS for MySQL, referindo-se a instâncias personalizadas do ApsaraDB RDS. O PolarDB for MySQL não é suportado.

  • O DTS não migra dados gerados por alterações que não gravam em logs binários. Exemplos incluem dados restaurados de backups físicos ou criados por operações em cascata.

    Nota

    Se isso ocorrer, execute novamente a migração completa assim que sua aplicação permitir.

  • Se seu banco de dados MySQL de origem for versão 8.0.23 ou posterior e contiver colunas ocultas invisíveis, o DTS não conseguirá ler essas colunas. Isso pode causar perda de dados.

    Nota

    Execute ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; para tornar a coluna oculta visível. Para mais informações, consulte Invisible Columns.

Outras limitações

  • A migração incremental de dados não suporta dados que utilizam o conjunto de caracteres utf8mb3. Caso contrário, a tarefa falhará.

  • Se seu banco de dados de origem usar operações DDL online no modo de tabela temporária — incluindo cenários de mesclagem de várias tabelas — ou adicionar índices baseados em funções a colunas de chave única, pode ocorrer perda de dados ou falha na tarefa no banco de dados de destino.

  • A migração de esquema não é suportada. Antes de configurar uma tarefa de migração, crie os bancos de dados e tabelas correspondentes na instância de destino PolarDB-X 1.0.

  • Antes de migrar dados, avalie o desempenho dos bancos de dados de origem e destino. Recomendamos realizar a migração de dados fora dos horários de pico. Durante a migração completa, o DTS consome alguns recursos de leitura e gravação tanto na origem quanto no destino, o que pode aumentar a carga do banco de dados.

  • A migração completa executa operações INSERT simultâneas, o que pode causar fragmentação de tabelas no banco de dados de destino. Como resultado, após a conclusão da migração completa, o espaço de armazenamento das tabelas no destino será maior do que na instância de origem.

  • Confirme se a precisão da migração para colunas dos tipos de dados FLOAT ou DOUBLE atende aos requisitos da sua aplicação. O DTS lê valores dessas colunas usando a função ROUND(COLUMN,PRECISION). Se você não definir explicitamente a precisão, o DTS usará uma precisão de 38 dígitos para FLOAT e 308 dígitos para DOUBLE.

  • O DTS tenta retomar tarefas de migração com falha dentro de sete dias. Antes de transferir suas cargas de trabalho para a instância de destino, pare ou libere a tarefa. Alternativamente, use o comando revoke para revogar as permissões de gravação da conta que o DTS usa para acessar a instância de destino. Isso evita que uma tarefa retomada automaticamente sobrescreva dados na instância de destino.

  • Se sua instância RDS for MySQL tiver Always-Encrypted ativado, a migração completa não é suportada.

    Nota

    Instâncias RDS for MySQL com Transparent Data Encryption (TDE) ativado suportam migração de esquema, migração completa e migração incremental.

  • Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la dentro de oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Apenas os parâmetros da tarefa DTS são modificados — não os parâmetros do banco de dados. Os parâmetros que podem ser ajustados incluem aqueles listados em Modificar parâmetros da instância.

Casos especiais

  • Para origens MySQL autogerenciadas:

    • Um failover entre master e standby no banco de dados de origem causa falha na tarefa de migração.

    • O DTS calcula a latência comparando o timestamp do último registro migrado para o banco de dados de destino com a hora atual. Se nenhuma operação DML for executada na origem por um longo período, o relatório de latência torna-se impreciso. Se a latência parecer muito alta, execute uma operação DML na origem para atualizar o valor da latência.

      Nota

      Se você selecionar a migração de banco de dados completo, crie uma tabela de heartbeat. Atualize-a ou grave nela a cada segundo.

    • O DTS executa periodicamente CREATE DATABASE IF NOT EXISTS test no banco de dados de origem para avançar o offset do log binário.

    • Se sua origem for Amazon Aurora MySQL ou outra instância MySQL em cluster, garanta que o nome de domínio ou endereço IP configurado para a tarefa — e sua resolução DNS — aponte sempre para um nó de leitura e gravação (RW). Caso contrário, a tarefa de migração pode falhar.

  • Para origens RDS for MySQL:

    • Se você precisar de migração incremental, instâncias RDS for MySQL que não registram logs de transações — como instâncias somente leitura do RDS for MySQL 5.6 — não são suportadas como origem.

    • O DTS executa periodicamente CREATE DATABASE IF NOT EXISTS test no banco de dados de origem para avançar o offset do log binário.

Faturamento

Tipo de migração

Taxa de configuração da instância

Taxa de tráfego de Internet

Migração completa de dados

Gratuito.

Quando o parâmetro Access Method do banco de dados de destino estiver definido como Public IP Address, haverá cobrança de tráfego de Internet. Para mais informações, consulte Visão geral do faturamento.

Migração incremental de dados

Pago. Para mais informações, consulte Visão geral do faturamento.

Tipos de migração

  • Migração completa

    O DTS migra todos os dados históricos dos objetos de migração especificados do banco de dados de origem para o banco de dados de destino.

  • Migração incremental

    Após a conclusão da migração completa, o DTS migra as atualizações incrementais de dados do banco de origem para o banco de destino. A migração incremental permite migrar dados sem problemas e sem interromper suas aplicações autogerenciadas.

Operações SQL para migração incremental

Tipo de operação

Instrução SQL

DML

INSERT, UPDATE e DELETE

Permissões de contas de banco de dados

Banco de dados

Migração completa de dados

Migração incremental de dados

Instância ApsaraDB RDS for MySQL

Permissão SELECT

Permissões REPLICATION CLIENT, REPLICATION SLAVE, SHOW VIEW e SELECT

Instância PolarDB-X 1.0

Permissões de leitura e gravação

Para mais informações sobre como criar contas de banco de dados e conceder permissões, consulte os seguintes tópicos:

Procedimento

  1. Acesse a página da lista de tarefas de migração da região de destino usando um dos métodos a seguir.

    Pelo console do DTS

    1. Faça login no console do Data Transmission Service (DTS).

    2. No painel de navegação à esquerda, clique em Data Migration.

    3. No canto superior esquerdo da página, selecione a região onde a instância de migração está localizada.

    Pelo console do DMS

    Nota

    As operações reais podem variar dependendo do modo e do layout do console do DMS. Para mais informações, consulte Console no modo simples e Personalizar o layout e o estilo do console do DMS.

    1. Faça login no console do Data Management (DMS).

    2. Na barra de menu superior, escolha Data + AI > Data Transmission (DTS) > Data Migration.

    3. À direita de Data Migration Tasks, selecione a região onde a instância de migração está localizada.

  2. Clique em Create Task para acessar a página de configuração da tarefa.

  3. Configure os bancos de dados de origem e de destino.

    Aviso

    Após selecionar as instâncias de origem e de destino, leia os Limits no topo da página para garantir que sua tarefa de migração de dados possa ser criada e executada com sucesso.

    Categoria

    Parâmetro

    Descrição

    N/A

    Task Name

    O DTS gera automaticamente um nome para a tarefa. Recomenda-se especificar um nome descritivo para facilitar a identificação. O nome não precisa ser único.

    Source Database

    Select Existing Connection

    • Para usar uma instância de banco de dados que foi adicionada ao sistema (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.

      Nota

      No console do DMS, este parâmetro é denominado Select a DMS database instance..

    • Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.

    Database Type

    Selecione MySQL.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde a instância RDS for MySQL de origem está localizada.

    Cross-account

    Neste exemplo, os dados são migrados dentro da mesma conta Alibaba Cloud. Selecione No.

    RDS Instance ID

    Selecione o ID da instância RDS for MySQL de origem.

    Database Account

    Insira a conta do banco de dados da instância RDS for MySQL de origem. Para informações sobre as permissões necessárias, consulte Permissões necessárias para contas de banco de dados.

    Database Password

    Insira a senha da conta do banco de dados.

    Connection Method

    Selecione Non-encrypted ou SSL-encrypted com base nos requisitos do seu banco de dados. Se você definir este parâmetro como SSL-encrypted, deverá ativar a criptografia SSL para a instância RDS for MySQL antecipadamente. Para mais informações, consulte Ativar rapidamente a criptografia SSL usando um certificado cloud.

    Destination Database

    Select Existing Connection

    • Para usar uma instância de banco de dados que foi adicionada ao sistema (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.

      Nota

      No console do DMS, este parâmetro é denominado Select a DMS database instance..

    • Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.

    Database Type

    Selecione PolarDB-X 1.0.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde a instância PolarDB-X 1.0 de destino está localizada.

    Instance ID

    Selecione a instância PolarDB-X 1.0 de destino.

    Database Account

    Insira a conta do banco de dados da instância PolarDB-X 1.0 de destino. Para informações sobre as permissões necessárias, consulte Permissões necessárias para contas de banco de dados.

    Database Password

    Insira a senha da conta do banco de dados.

  4. Após concluir a configuração, clique em Test Connectivity and Proceed na parte inferior da página.

    Nota

    Certifique-se de que os segmentos de endereço IP do service DTS foram adicionados automática ou manualmente às configurações de segurança dos bancos de dados de origem e de destino para permitir o acesso dos servidores DTS. Para mais informações, consulte Adicionar endereços IP do servidor DTS a uma lista de permissões.

  5. Configure os objetos da tarefa.

    1. Na página Configure Objects, configure os objetos que deseja migrar.

      Parâmetro

      Descrição

      Migration Types

      • Se você precisar apenas realizar uma migração completa, selecione Full Data Migration.

      • Para realizar uma migração sem tempo de inatividade, selecione tanto Full Data Migration quanto Incremental Data Migration.

      Nota

      Se você não selecionar Incremental Data Migration, não grave novos dados na instância de origem durante a migração de dados para garantir a consistência dos dados.

      Processing Mode for Existing Destination Tables

      • Precheck and Report Errors: Verifica se existem tabelas com os mesmos nomes no banco de dados de destino. Se não existirem tabelas com os mesmos nomes, a pré-verificação é aprovada. Se existirem tabelas com os mesmos nomes, um erro será reportado durante a pré-verificação e a tarefa de migração de dados não será iniciada.

        Nota

        Se uma tabela no banco de dados de destino tiver o mesmo nome, mas não puder ser facilmente excluída ou renomeada, você poderá alterar o nome da tabela no banco de dados de destino. Para mais informações, consulte Mapeamento de nomes de objetos.

      • Ignore Errors and Proceed: Ignora a verificação de tabelas com os mesmos nomes.

        Aviso

        Selecionar Ignore Errors and Proceed pode causar inconsistência de dados e riscos ao negócio. Por exemplo:

        • Se os esquemas das tabelas forem consistentes e um registro no banco de dados de destino tiver o mesmo valor de chave primária que um registro no banco de dados de origem:

          • Durante a migração completa, o DTS mantém o registro no banco de dados de destino. O registro do banco de dados de origem não é migrado.

          • Durante a migração incremental, o DTS não mantém o registro no banco de dados de destino. O registro do banco de dados de origem sobrescreve o registro no banco de dados de destino.

        • Se os esquemas das tabelas forem inconsistentes, apenas algumas colunas de dados poderão ser migradas ou a migração poderá falhar. Prossiga com cautela.

      Capitalization of Object Names in Destination Instance

      Você pode configurar a política de diferenciação de maiúsculas e minúsculas para os nomes dos objetos migrados, como bancos de dados, tabelas e colunas, na instância de destino. Por padrão, DTS default policy está selecionado. Você também pode optar por manter a diferenciação de maiúsculas e minúsculas consistente com a política padrão do banco de dados de origem ou de destino. Para mais informações, consulte Diferenciação de maiúsculas e minúsculas de nomes de objetos no banco de dados de destino.

      Source Objects

      Na caixa Source Objects, clique nos objetos a serem migrados e, em seguida, clique em Right arrow para movê-los para a caixa Selected Objects.

      Nota

      Os objetos de migração são selecionados no nível de tabela.

      Selected Objects

      Nota
      • Se você usar o recurso de mapeamento de nomes de objetos, outros objetos que dependem do objeto renomeado podem falhar na migração.

      • Para especificar uma cláusula WHERE para filtrar dados, clique com o botão direito do mouse na tabela a ser migrada na caixa Selected Objects e especifique a condição de filtro na caixa de diálogo exibida. Para mais informações, consulte Definir condições de filtro.

      • Para selecionar as operações DML para migração incremental de dados, clique com o botão direito do mouse no objeto a ser migrado na caixa Selected Objects e selecione as operações DML desejadas na caixa de diálogo exibida.

    2. Clique em Next: Advanced Settings para configurar parâmetros avançados.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda tarefas em um cluster compartilhado. Não é necessário selecionar um. Se desejar tarefas mais estáveis, adquira um cluster dedicado para executar tarefas de migração do DTS.

      Retry Time for Failed Connections

      Após o início da tarefa de migração, se a conexão com o banco de dados de origem ou de destino falhar, o DTS reportará um erro e iniciará imediatamente uma nova tentativa de conexão. A duração padrão de nova tentativa é de 720 minutos. Você pode personalizar o tempo de nova tentativa para um valor entre 10 e 1440 minutos. Recomendamos definir a duração para mais de 30 minutos. Se o DTS reconectar aos bancos de dados de origem e de destino dentro da duração especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.

      Nota
      • Para múltiplas instâncias DTS que compartilham a mesma origem ou destino, o tempo de nova tentativa de rede é determinado pela configuração da última tarefa criada.

      • Como há cobrança pela tarefa durante o período de nova tentativa de conexão, recomendamos personalizar o tempo de nova tentativa com base nas necessidades do seu negócio ou liberar a instância DTS o mais rápido possível após a liberação das instâncias de banco de dados de origem e de destino.

      Retry Time for Other Issues

      Após o início da tarefa de migração, se ocorrer um problema não relacionado à conectividade, como uma exceção de execução DDL ou DML, no banco de dados de origem ou de destino, o DTS reportará um erro e iniciará imediatamente uma nova tentativa da operação. A duração padrão de nova tentativa é de 10 minutos. Você pode personalizar o tempo de nova tentativa para um valor entre 1 e 1440 minutos. Recomendamos definir a duração para mais de 10 minutos. Se as operações relacionadas forem bem-sucedidas dentro da duração de nova tentativa especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.

      Importante

      O valor de Retry Time for Other Issues deve ser menor que o valor de Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      Durante a migração completa, o DTS consome recursos de leitura e gravação nos bancos de dados de origem e de destino, o que pode aumentar a carga do banco de dados. Se necessário, ative o limitador de taxa para a tarefa de migração completa. Defina Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s) para reduzir a carga no banco de dados de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Full Data Migration em Migration Types.

      • Você também pode ajustar a velocidade da migração completa depois que a instância de migração estiver em execução.

      Enable Throttling for Incremental Data Migration

      Se necessário, você também pode optar por definir limites de velocidade para a tarefa de migração incremental. Defina RPS of Incremental Data Migration e Data migration speed for incremental migration (MB/s) para reduzir a carga no banco de dados de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Incremental Data Migration em Migration Types.

      • Você também pode ajustar a velocidade da migração incremental depois que a instância de migração estiver em execução.

      Environment Tag

      Selecione uma tag de ambiente para identificar a instância. Isso não é obrigatório para este exemplo.

      Whether to delete SQL operations on heartbeat tables of forward and reverse tasks

      Escolha se deseja gravar informações SQL de heartbeat no banco de dados de origem enquanto a instância DTS estiver em execução.

      • Yes: As informações SQL de heartbeat não são gravadas no banco de dados de origem. Isso pode fazer com que a instância DTS reporte atraso.

      • No: Grava informações SQL de heartbeat no banco de dados de origem. Isso pode interferir em recursos como backup físico e clonagem do banco de dados de origem.

      Configure ETL

      Com base nas necessidades do seu negócio, selecione se deseja configurar o recurso ETL para processar dados.

      Monitoring and Alerting

      Selecione se deseja definir alertas e receber notificações de alerta com base nas necessidades do seu negócio.

      • No: Não define alerta.

      • Yes: Configure alertas definindo um limiar de alerta e um notificações de alerta. Se uma migração falhar ou a latência exceder o limiar, o sistema enviará uma notificação de alerta.

  6. Salve a tarefa e execute uma pré-verificação.

    • Para visualizar os parâmetros de configuração desta instância ao chamar a operação da API, passe o ponteiro do mouse sobre o botão Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters na dica que aparecer.

    • Se você não precisar visualizar os parâmetros da API ou já tiver terminado de visualizá-los, clique em Next: Save Task Settings and Precheck na parte inferior da página.

    Nota
    • Antes do início da tarefa de migração, o DTS realiza uma pré-verificação. A tarefa só começa após passar na pré-verificação.

    • Se a pré-verificação falhar, clique em View Details ao lado do item de verificação com falha, corrija o problema conforme a instrução e execute a pré-verificação novamente.

    • Se um aviso for reportado durante a pré-verificação:

      • Para itens de verificação que não podem ser ignorados, clique em View Details ao lado do item com falha, corrija o problema conforme a instrução e execute a pré-verificação novamente.

      • Para itens de verificação que podem ser ignorados, clique em Confirm Alert Details, Ignore, OK e Precheck Again para pular o item de alerta e executar a pré-verificação novamente. Se você optar por ignorar um aviso, isso pode causar problemas como inconsistência de dados e representar riscos ao seu negócio.

  7. Adquira a instância.

    1. Quando a Success Rate for 100%, clique em Next: Purchase Instance.

    2. Na página Purchase, selecione a especificação de link para a instância de migração de dados. Para mais informações, consulte a tabela a seguir.

      Categoria

      Parâmetro

      Descrição

      New Instance Class

      Resource Group Settings

      Selecione o grupo de recursos ao qual a instância pertence. O valor padrão é default resource group. Para mais informações, consulte O que é Resource Management?

      Instance Class

      O DTS fornece especificações de migração com diferentes níveis de desempenho. A especificação do link afeta a velocidade da migração. Selecione uma especificação com base no cenário do seu negócio. Para mais informações, consulte Especificações de link de migração de dados.

    3. Após concluir a configuração, leia e selecione Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start. Na caixa de diálogo OK exibida, clique em OK.

      Visualize o progresso da tarefa de migração na página de lista Data Migration Tasks.

      Nota
      • Se a tarefa de migração não incluir migração incremental, ela será interrompida automaticamente após a conclusão da migração completa. Após a interrupção da tarefa, seu Status muda para Completed.

      • Se a tarefa de migração incluir migração incremental, ela não será interrompida automaticamente. A tarefa de migração incremental continua em execução. Enquanto a tarefa de migração incremental estiver em execução, o Status da tarefa será Running.