Este tópico descreve como usar o Data Transmission Service (DTS) para migrar dados de uma instância do ApsaraDB RDS for MySQL para o DataHub.
Pré-requisitos
-
Crie a instância de origem do ApsaraDB RDS for MySQL.
NotaPara criar uma instância do ApsaraDB RDS for MySQL, consulte Criar uma instância do ApsaraDB RDS for MySQL.
Para obter informações sobre as versões compatíveis, consulte Visão geral das soluções de migração.
Ative o DataHub e crie um projeto para receber os dados migrados. Para mais informações, consulte Introdução ao DataHub e Gerenciar projetos.
Limitações
|
Tipo |
Descrição |
|
Limites do banco de dados de origem |
|
|
Outros limites |
|
|
Casos especiais |
|
Faturamento
|
Tipo de migração |
Taxa de configuração da instância |
Taxa de tráfego pela Internet |
|
Migração de schema e migração completa de dados |
Gratuito. |
Quando o parâmetro Access Method do banco de dados de destino estiver definido como Public IP Address, haverá cobrança de tráfego pela Internet. Para mais informações, consulte Visão geral do faturamento. |
|
Migração incremental de dados |
Pago. Para mais informações, consulte Visão geral do faturamento. |
Tipos de migração
-
Migração de schema
O DTS migra as definições de schema dos objetos de migração do banco de dados de origem para o banco de dados de destino.
-
Migração completa
O DTS migra todos os dados históricos dos objetos de migração especificados do banco de dados de origem para o banco de dados de destino.
-
Migração incremental
Após a conclusão da migração completa, o DTS migra as atualizações incrementais de dados do banco de dados de origem para o banco de dados de destino. A migração incremental permite migrar dados sem problemas, sem interromper suas aplicações autogerenciadas.
Operações SQL suportadas para migração incremental
|
Tipo de operação |
Instrução SQL |
|
DML |
INSERT, UPDATE, DELETE |
|
DDL |
ADD COLUMN |
Permissões da conta do banco de dados
|
Banco de dados |
Permissões |
|
Instância ApsaraDB RDS for MySQL de origem |
Permissões de leitura nos objetos a serem migrados. |
Procedimento
-
Acesse a página da lista de tarefas de migração da região de destino usando um dos métodos a seguir.
Pelo console do DTS
Faça login no console do Data Transmission Service (DTS).
No painel de navegação à esquerda, clique em Data Migration.
No canto superior esquerdo da página, selecione a região onde a instância de migração está localizada.
Pelo console do DMS
NotaAs operações reais podem variar dependendo do modo e do layout do console do DMS. Para mais informações, consulte Console do modo simples e Personalizar o layout e o estilo do console do DMS.
Faça login no console do Data Management (DMS).
Na barra de menu superior, escolha .
À direita de Data Migration Tasks, selecione a região onde a instância de migração está localizada.
Clique em Create Task para acessar a página de configuração da tarefa.
-
Configure os bancos de dados de origem e de destino.
AvisoApós selecionar as instâncias de origem e de destino, leia atentamente os limites exibidos na parte superior da página. Se você não seguir os limites, a tarefa poderá falhar ou poderá ocorrer inconsistência de dados.
Seção
Parâmetro
Descrição
N/A
Task Name
O DTS gera automaticamente um nome para a tarefa. Recomendamos especificar um nome descritivo para facilitar a identificação. O nome não precisa ser exclusivo.
Source Database
Select Existing Connection
-
Para usar uma instância de banco de dados já adicionada ao sistema (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.
NotaNo console do DMS, este parâmetro é denominado Select a DMS database instance..
-
Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.
Database Type
Selecione MySQL.
Connection Type
Selecione Alibaba Cloud.
Instance Region
Selecione a região onde reside a instância ApsaraDB RDS for MySQL de origem.
Cross-account
Como este cenário migra dados dentro da mesma conta Alibaba Cloud, selecione No.
RDS Instance ID
Selecione o ID da instância ApsaraDB RDS for MySQL de origem.
Database Account
Insira a conta do banco de dados para a instância ApsaraDB RDS for MySQL de origem. Para requisitos de permissão, consulte Permissões da conta do banco de dados.
Database Password
Insira a senha correspondente à conta do banco de dados.
Encryption
Selecione Non-encrypted ou SSL-encrypted conforme necessário. Se selecionar SSL-encrypted, ative a criptografia SSL para a instância RDS for MySQL antecipadamente. Para mais informações, consulte Usar um certificado cloud para ativar rapidamente a criptografia SSL.
Destination Database
Select Existing Connection
-
Para usar uma instância de banco de dados já adicionada ao sistema (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.
NotaNo console do DMS, este parâmetro é denominado Select a DMS database instance..
-
Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.
Database Type
Selecione DataHub.
Connection Type
Selecione Alibaba Cloud.
Instance Region
Selecione a região onde reside a instância do DataHub.
Project
Selecione o Project do DataHub de destino.
-
-
Após concluir a configuração, clique em Test Connectivity and Proceed na parte inferior da página.
NotaCertifique-se de que o segmento de endereços IP do service DTS foi adicionado automática ou manualmente às configurações de segurança dos bancos de dados de origem e de destino para permitir o acesso dos servidores DTS. Para mais informações, consulte Adicionar endereços IP do servidor DTS a uma whitelist.
Se o banco de dados de origem ou de destino for autogerenciado (o Access Method não for Alibaba Cloud Instance), clique também em Test Connectivity na caixa de diálogo CIDR Blocks of DTS Servers exibida.
-
Configure os objetos da tarefa.
-
Na página Configure Objects, configure os objetos que deseja migrar.
Parâmetro
Descrição
Synchronization Types
-
Se precisar apenas realizar uma migração completa, selecione tanto Schema Migration quanto Full Data Migration.
-
Para realizar uma migração sem tempo de inatividade, selecione Schema Migration, Full Data Migration e Incremental Data Migration.
Nota-
Se não selecionar Schema Migration, garanta que exista um banco de dados e tabelas para receber os dados no banco de dados de destino. Também é possível usar o recurso de mapeamento de nomes de objetos na caixa Selected Objects conforme necessário.
-
Se não selecionar Incremental Data Migration, não grave novos dados na instância de origem durante a migração de dados para garantir a consistência dos dados.
Naming Rules of Additional Columns
Quando o DTS migra dados para o DataHub, ele adiciona colunas extras à tabela de destino. Se ocorrer um conflito de nomes entre uma coluna adicional e uma coluna existente na tabela de destino, a migração de dados falhará. Selecione New Rule ou Previous Rule com base nas necessidades da sua aplicação.
AvisoAntes de selecionar uma regra para colunas adicionais, avalie se ocorrerão conflitos de nomes entre as colunas adicionais e as colunas existentes na tabela de destino. Caso contrário, pode ocorrer perda de dados ou falha na tarefa. Para mais informações sobre as regras e definições de colunas adicionais, consulte Nomes e definições de colunas adicionais.
Processing Mode for Existing Tables in Destination
-
Precheck and Report Errors: verifica se o banco de dados de destino contém tabelas com os mesmos nomes das tabelas no banco de dados de origem. Se não existirem tabelas com o mesmo nome, a pré-verificação será aprovada. Se existirem tabelas com o mesmo nome, um erro será relatado durante a pré-verificação e a tarefa de migração de dados não poderá ser iniciada.
NotaSe for inconveniente excluir ou renomear as tabelas com o mesmo nome no banco de dados de destino, altere seus nomes no banco de dados de destino. Para mais informações, consulte Mapear nomes de tabelas e colunas.
-
Ignore Errors and Proceed: ignora a verificação de tabelas com o mesmo nome no banco de dados de destino.
AvisoSelecionar Ignore Errors and Proceed pode causar inconsistência de dados e apresentar riscos à sua aplicação. Por exemplo:
-
Se os schemas das tabelas forem consistentes e um registro no banco de dados de destino tiver o mesmo valor de chave primária que um registro no banco de dados de origem:
-
Durante a migração incremental, o registro do banco de dados de origem sobrescreverá o registro no banco de dados de destino.
-
-
Se os schemas das tabelas forem inconsistentes, a inicialização de dados pode falhar, apenas algumas colunas podem ser migradas ou a migração pode falhar.
-
Source Objects
Na caixa Source Objects, clique nos objetos a serem migrados e, em seguida, clique em
para movê-los para a caixa Selected Objects.NotaÉ possível selecionar objetos para migrar no nível de tabela.
Selected Objects
-
Para alterar o nome de um único objeto de migração na instância de destino, clique com o botão direito do mouse no objeto na caixa Selected Objects. Para mais informações, consulte Mapear nomes individuais de schema, tabela e coluna.
-
Para alterar os nomes de vários objetos de migração na instância de destino, clique em Selected Objects no canto superior direito da caixa Batch Edit. Para mais informações, consulte Mapear múltiplos nomes de schema, tabela e coluna.
Nota-
Se você usar o recurso de mapeamento de nomes de objetos, a migração de outros objetos dependentes do objeto renomeado pode falhar.
-
Para filtrar dados usando condições WHERE, clique com o botão direito do mouse na tabela a ser migrada na caixa Selected Objects e especifique as condições de filtro na caixa de diálogo exibida. Para instruções, consulte Definir condições de filtro.
-
Para selecionar as operações DML ou DDL para migração incremental no nível de banco de dados ou tabela, clique com o botão direito do mouse no objeto de migração e selecione as operações DML e DDL desejadas na caixa de diálogo exibida. Para obter uma lista de operações suportadas, consulte Operações SQL suportadas para migração incremental.
-
Clique com o botão direito do mouse em uma tabela a ser migrada na caixa Selected Objects, desmarque a caixa de seleção Sync All Columns na caixa de diálogo exibida e defina a Shardkey (a chave usada para particionamento).
-
-
Clique em Next: Advanced Settings para configurar parâmetros avançados.
Parâmetro
Descrição
Dedicated Cluster for Task Scheduling
Por padrão, o DTS agenda tarefas em um cluster compartilhado. Não é necessário selecionar um. Se desejar tarefas mais estáveis, adquira um cluster dedicado para executar tarefas de migração do DTS.
Set Alerts
Selecione se deseja definir alertas e receber notificações de alerta com base nas necessidades da sua aplicação.
-
No: não define alerta.
-
Yes: configure alertas definindo um limiar de alerta e um notificações de alerta. Se uma migração falhar ou a latência exceder o limiar, o sistema enviará uma notificação de alerta.
Retry Time for Failed Connections
Após o início da tarefa de migração, se a conexão com o banco de dados de origem ou de destino falhar, o DTS relatará um erro e começará imediatamente a tentar reconectar. A duração padrão de nova tentativa é de 720 minutos. Personalize o tempo de nova tentativa para um valor entre 10 e 1440 minutos. Recomendamos definir a duração para mais de 30 minutos. Se o DTS se reconectar aos bancos de dados de origem e de destino dentro da duração especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.
Nota-
Para várias instâncias DTS que compartilham a mesma origem ou destino, o tempo de nova tentativa de rede é determinado pela configuração da última tarefa criada.
-
Como há cobrança pela tarefa durante o período de nova tentativa de conexão, recomendamos personalizar o tempo de nova tentativa com base nas necessidades da sua aplicação ou liberar a instância DTS o mais rápido possível após a liberação das instâncias de banco de dados de origem e de destino.
Retry Time for Other Issues
Após o início da tarefa de migração, se ocorrer um problema não relacionado à conectividade, como uma exceção de execução DDL ou DML, no banco de dados de origem ou de destino, o DTS relatará um erro e começará imediatamente a tentar repetir a operação. A duração padrão de nova tentativa é de 10 minutos. Personalize o tempo de nova tentativa para um valor entre 1 e 1440 minutos. Recomendamos definir a duração para mais de 10 minutos. Se as operações relacionadas forem bem-sucedidas dentro da duração de nova tentativa especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.
ImportanteO valor de Retry Time for Other Issues deve ser menor que o valor de Retry Time for Failed Connections.
Enable Throttling for Full Data Migration
Durante a migração completa, o DTS consome recursos de leitura e gravação nos bancos de dados de origem e de destino, o que pode aumentar a carga do banco de dados. Se necessário, ative o limitador de taxa para a tarefa de migração completa. Defina Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s) para reduzir a carga no banco de dados de destino.
Nota-
Este item de configuração está disponível apenas se você selecionar Full Data Migration em Migration Types.
-
Também é possível ajustar a velocidade da migração completa depois que a instância de migração estiver em execução.
Enable Throttling for Incremental Data Migration
Se necessário, defina limites de velocidade para a tarefa de migração incremental. Defina RPS of Incremental Data Migration e Data migration speed for incremental migration (MB/s) para reduzir a carga no banco de dados de destino.
Nota-
Este item de configuração está disponível apenas se você selecionar Incremental Data Migration em Migration Types.
-
Também é possível ajustar a velocidade da migração incremental depois que a instância de migração estiver em execução.
Environment Tag
Selecione uma tag de ambiente para identificar a instância conforme necessário. Nenhuma seleção é necessária para este exemplo.
Configure ETL
Com base nas necessidades da sua aplicação, selecione se deseja configurar o recurso ETL para processar dados.
-
Yes: configura o recurso ETL. Insira também instruções de processamento de dados na caixa de texto.
-
No: não configura o recurso ETL.
Whether to delete SQL operations on heartbeat tables of forward and reverse tasks
Escolha se deseja gravar informações SQL de heartbeat no banco de dados de origem enquanto a instância DTS estiver em execução.
-
Yes: as informações SQL de heartbeat não são gravadas no banco de dados de origem. Isso pode fazer com que a instância DTS relate um atraso.
-
No: grava informações SQL de heartbeat no banco de dados de origem. Isso pode interferir em recursos como backup físico e clonagem do banco de dados de origem.
-
-
-
Salve a tarefa e execute uma pré-verificação.
Para visualizar os parâmetros de configuração desta instância ao chamar a operação da api, passe o ponteiro do mouse sobre o botão Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters no balão exibido.
Se não precisar visualizar os parâmetros da api ou se já tiver terminado de visualizá-los, clique em Next: Save Task Settings and Precheck na parte inferior da página.
NotaAntes do início da tarefa de migração, o DTS realiza uma pré-verificação. A tarefa só começa após passar na pré-verificação.
Se a pré-verificação falhar, clique em View Details ao lado do item de verificação com falha, corrija o problema conforme indicado e execute a pré-verificação novamente.
-
Se um aviso for relatado durante a pré-verificação:
Para itens de verificação que não podem ser ignorados, clique em View Details ao lado do item com falha, corrija o problema conforme indicado e execute a pré-verificação novamente.
Para itens de verificação que podem ser ignorados, clique em Confirm Alert Details, Ignore, OK e Precheck Again para pular o item de alerta e executar a pré-verificação novamente. Se optar por ignorar um aviso, isso pode causar problemas como inconsistência de dados e apresentar riscos à sua aplicação.
-
Adquira a instância.
Quando a Success Rate for de 100%, clique em Next: Purchase Instance.
-
Na página Purchase, selecione a especificação de link para a instância de migração de dados. Para mais informações, consulte a tabela a seguir.
Categoria
Parâmetro
Descrição
New Instance Class
Resource Group Settings
Selecione o grupo de recursos ao qual a instância pertence. O valor padrão é default resource group. Para mais informações, consulte O que é Resource Management?
Instance Class
O DTS fornece especificações de migração com diferentes níveis de desempenho. A especificação do link afeta a velocidade da migração. Selecione uma especificação com base no cenário da sua aplicação. Para mais informações, consulte Especificações de link de migração de dados.
Após concluir a configuração, leia e selecione Data Transmission Service (Pay-as-you-go) Service Terms.
-
Clique em Buy and Start. Na caixa de diálogo OK exibida, clique em OK.
Visualize o progresso da tarefa de migração na página de lista Data Migration Tasks.
NotaSe a tarefa de migração não incluir migração incremental, ela será interrompida automaticamente após a conclusão da migração completa. Após a interrupção da tarefa, seu Status mudará para Completed.
Se a tarefa de migração incluir migração incremental, ela não será interrompida automaticamente. A tarefa de migração incremental continuará em execução. Enquanto a tarefa de migração incremental estiver em execução, o Status da tarefa será Running.