Todos os produtos
Search
Central de documentação

Data Management:Criar um workspace e adicionar recursos

Última atualização: Aug 28, 2026

Este tópico descreve como criar um workspace do Notebook, adicionar recursos e configurar um espaço de armazenamento de código.

Etapa 1: Criar e acessar um workspace

  1. Faça login no DMS 5.0.

  2. Passe o ponteiro sobre o ícone 2023-01-28_15-57-17.png no canto superior esquerdo e selecione All Features > Data+AI > Notebook.

    Nota

    Se você utiliza o console do DMS no modo normal, selecione Data+AI > Notebook na barra de navegação superior.

  3. Clique em Create Workspace. Na caixa de diálogo exibida, insira um Workspace Name, selecione uma Region e clique em OK.

    Nota
    • O nome do workspace pode conter apenas letras, dígitos e sublinhados (_).

    • Somente a região Singapore está disponível para seleção.

  4. Na coluna Actions do workspace desejado, clique em Go to Workspace.

    Nota

    Por padrão, somente o criador do workspace tem acesso a ele. Para desenvolvimento colaborativo, o criador deve conceder permissões de desenvolvimento a outros usuários.

Etapa 2: Adicionar membros ao projeto

Quando vários usuários colaboram em um workspace, é necessário atribuir funções a eles.

Adicione os usuários ao DMS antes de atribuir funções. Para mais informações, consulte User management.

Clique no ícone de configurações na parte inferior do painel de navegação à esquerda e selecione Member Management. Em seguida, clique em Add Members. Na caixa de diálogo exibida, selecione os membros a adicionar e atribua as funções correspondentes. As funções disponíveis incluem Administrator, Developer e Read-only User.

Etapa 3: Configurar o espaço de armazenamento de código

  1. No workspace, acesse a aba Project Settings image e clique em Storage Management.

  2. Na página Storage Management, clique no ícone image à direita de Code Space.

  3. Na caixa de diálogo Select OSS Directory, selecione o Bucket desejado.

    O bucket selecionado deve estar na mesma região do workspace atual e sua classe de armazenamento deve ser Standard.

    Nota

    Caso não haja buckets disponíveis na região atual, acesse o console do Object Storage Service (OSS) para criar um. Para mais informações, consulte Create buckets.

  4. Clique em OK.

Etapa 4: Adicionar recursos

Para consultar e analisar dados com o Notebook, adicione e inicie um recurso primeiro.

  1. No workspace, acesse a aba Project Settings image e clique em Resource Configuration.

  2. Clique em Add Resource e configure as informações do recurso.

    Parameter

    Description

    Resource name

    Insira um nome descritivo.

    Resource description

    Descreva a finalidade deste recurso.

    Image

    • Spark 3.5+Python 3.9

    • Spark 3.3+Python 3.9

    • Python 3.9

    ADB instance

    Selecione uma instância AnalyticDB for MySQL.

    Nota
    • Caso escolha uma imagem com Spark 3.3 ou 3.5, selecione também um cluster AnalyticDB for MySQL.

    • Se o cluster alvo não for encontrado, verifique se ele foi registrado no DMS. Para mais informações, consulte Register a cloud database instance.

    ADB resource group

    Selecione um grupo de recursos.

    Executor spec

    Especificações de recurso para o executor Spark. Modelos diferentes possuem especificações distintas. Para mais detalhes, veja a coluna Model em Spark application configuration parameters.

    Executor count

    Quantidade de executores Spark.

    Nota

    Durante o preview público do Notebook, o total de executores em todos os recursos de um workspace não pode exceder seis. Para aumentar esse limite, entre em contato com o suporte técnico do DMS.

    Driver spec

    Especificações de recurso para o driver Spark.

    • General_XSmall_v1 (2 vCores, 8 GB)

    • General_Small_v1 (4 vCores, 16 GB)

    • General_Medium_v1 (8 vCores, 32 GB)

    • General_Large_v1 (16 vCores, 64 GB)

    Notebook specification

    Este parâmetro aparece apenas ao selecionar uma imagem com Python 3.9.

    • General_XSmall_v1 (2 vCores, 8 GB)

    • General_Small_v1 (4 vCores, 16 GB)

    • General_Medium_v1 (8 vCores, 32 GB)

    • General_Large_v1 (16 vCores, 64 GB)

    VPC ID

    Selecione uma Virtual Private Cloud (VPC) disponível.

    Zone ID

    Selecione uma zona na VPC.

    vSwitch ID

    Selecione um vSwitch na VPC.

    Security group ID

    Selecione um grupo de segurança disponível.

  3. Clique em Save.

  4. Inicie o recurso.

    Na coluna Actions do recurso, clique em Start e confirme clicando em OK.

    Nota

    A inicialização leva cerca de um minuto. Após o início, o Resource Status muda para Running.

Etapa 5: Configurar um espaço de armazenamento do usuário

Para ler dados de fontes externas com o Notebook, configure caminhos para múltiplos buckets do OSS.

  1. No workspace, acesse a aba Settings image e clique em Storage Management.

  2. Na área User Storage Space, configure o caminho do OSS.

    Nota

    O caminho de montagem deve começar com /mnt/.

  3. Clique no ícone Save image.

Etapa 6: Visualizar dados

  1. No workspace, acesse a aba Data image.

  2. No SQL Console, execute as seguintes operações:

    • Consultar dados

      Use o Copilot para gerar consultas SQL ou escreva-as manualmente. A sintaxe SQL deve ser consistente com a do data warehouse lógico .

      Nota

      Use sintaxe padrão MySQL para consultar tabelas independentemente do banco de dados de origem, como AnalyticDB for MySQL ou RDS for MySQL. O DMS gerencia automaticamente a conversão e otimização.

      Ao gerar SQL, o Copilot aprende automaticamente conhecimentos de negócio a partir do seu feedback e dos metadados de tabelas e colunas. Se o conhecimento aprendido estiver impreciso, edite-o para melhorar a precisão. O Copilot usará esse conhecimento corrigido como referência para fornecer respostas mais precisas a perguntas semelhantes no futuro.

      Caso o SQL gerado pelo Copilot atenda aos requisitos de negócio e esteja satisfatório, curta a consulta gerada. Esse feedback ajuda a aprimorar futuras gerações de SQL.

    • Visualizar notas de uso da tabela

      O sistema gera automaticamente uma descrição baseada nos metadados da tabela e das colunas. Expanda um banco de dados, dê um duplo clique no nome da tabela e visualize ou edite a descrição na aba Usage Notes.

Próximos passos

Develop with Notebook

Gerenciar recursos do Notebook

Gerencie os recursos adicionados na página Resource Configuration. Para instruções sobre como acessar essa página, consulte Step 4: Add resources.

  • Parar manualmente um recurso.

  • Editar informações do recurso.

    Nota

    A edição das informações só é permitida quando o recurso está parado.

  • Iniciar manualmente um recurso parado.

  • Liberar automaticamente recursos do Notebook.

    Um recurso torna-se ocioso quando todos os kernels de notebook associados são encerrados. A liberação automática ocorre se o recurso permanecer ocioso por um período especificado.

  • Visualizar jobs históricos do Spark para um recurso do Notebook.

    1. Na página Resource Configuration, clique em SparkUI à direita do recurso para acessar a lista de jobs.

      A página de lista de jobs (Spark History Server) exibe uma tabela com registros de aplicações Spark concluídas. A tabela inclui colunas como Version, App ID, App Name, Started, Completed, Duration, Spark User e Last Updated. Cada entrada possui um botão Download para baixar o log de eventos correspondente.

    2. Clique em um App ID para ver detalhes da execução Spark.

      image