O Bastionhost pode exibir mensagens de erro específicas quando operações de O&M via SSH, RDP ou banco de dados falham. As seções a seguir descrevem as causas desses erros comuns e como resolvê-los.
Índice rápido
Localize sua mensagem de erro nas listas abaixo e acesse a seção correspondente.
Erros de O&M SSH
[USM] Invalid host fingerprint— consulte Invalid host fingerprintConnection refused(111)— consulte Connection refused (111)SSH protocol handshake error— consulte SSH handshake errorPermission denied, please try again(falha na autenticação de logon do host) — consulte Permission deniedssh connect target failed— consulte SSH connect target failed
Erros de O&M RDP
remote desktop service CALs request failed— consulte Remote desktop service CALs request failedNLA or TLS security negotiation failure— consulte NLA or TLS security negotiation failure
Erros de O&M de banco de dados
Protocol error in TDS stream— consulte SQL Server: Protocol error in TDS stream1043 - bad handshake— consulte Bad handshake2013 - Lost connection to MySQL server— consulte Navicat 11: Lost connection to MySQL serverUnknown system variable 'transaction_isolation'— consulte DBeaver: Unknown system variable 'transaction_isolation'Exhausted available authentication methods— consulte DBeaver: Exhausted available authentication methodsarraycopy: out of bounds— consulte DBeaver: Arraycopy out of bounds
Erros de O&M SSH
Fingerprint de host inválida
[USM] Invalid host fingerprint: ssh-ed25519 17:xxx (code: 11)
Causa
O Bastionhost V3.2 registra uma fingerprint exclusiva para cada host. Se a fingerprint mudar, a autenticação falha. A fingerprint muda nos seguintes cenários:
|
Cenário |
Causa |
|
Reinstalação do sistema operacional |
O service SSH é redefinido e gera uma nova fingerprint. |
|
Substituição do par de chaves SSH |
A troca do par de chaves SSH do servidor altera a fingerprint. |
|
Alteração do algoritmo de criptografia ou método de troca de chaves |
Modificar a configuração do servidor SSH para usar um algoritmo de criptografia ou método de troca de chaves diferente afeta a fingerprint. |
|
Alteração na configuração do service SSH |
Mudanças nas configurações de chave e verificação de identidade no servidor SSH podem afetar a fingerprint. |
|
Clonagem ou migração de servidor |
A nova instância pode gerar uma nova chave SSH. |
|
Restauração de snapshot de máquina virtual |
A chave SSH reverte para o estado no momento do snapshot. |
|
Atualização do software do servidor SSH |
Algumas atualizações de software do servidor alteram a configuração da chave e afetam a fingerprint. |
|
Invalidação ou expiração de certificado |
Para chaves SSH baseadas em certificado, um certificado expirado ou atualizado altera a fingerprint. |
Solução
Limpe a fingerprint do host nas configurações de informações do host e tente fazer logon novamente:
-
Na página Asset management > Hosts, clique em no host desejado. Na aba Basic information à direita, clique em Clear na seção host fingerprint.
Para mais detalhes, consulte Clear host fingerprints.
Conexão recusada (111)
connect to [Default Network] xx.xx.xx.xx:xx failed, Connection refused(111)
O Bastionhost não consegue alcançar o host de destino. Verifique os itens a seguir:
|
Possível causa |
Ação |
|
Configuração de porta incorreta |
Verifique se a porta do protocolo do host configurada no Bastionhost está correta. Consulte Configure Bastionhost. |
|
Grupo de segurança ou firewall bloqueando o acesso |
Confirme se o Alibaba Cloud Firewall está ativado para a instância do Bastionhost e se alguma política de segurança bloqueia o acesso à porta especificada. Consulte Access policies for Cloud Firewall and Bastionhost. |
Erro de handshake SSH
SSH protocol handshake error, Socket error: Connection reset by peer
Causa
Um firewall ou política de configuração está bloqueando a conexão.
Solução
Verifique se o endereço IP do Bastionhost consta em
/etc/hosts.allowno servidor de destino. Caso contrário, adicione-o.Confirme se o endereço IP do Bastionhost está listado em
/etc/hosts.deny. Se estiver, remova-o.-
Verifique se algum dispositivo de rede entre o Bastionhost e o servidor está bloqueando a conexão.
Para mais informações, consulte Troubleshoot Bastionhost server connection issues.
Permissão negada
Permission denied, please try again
Esse erro indica falha na autenticação de logon ao conectar-se a um host. Analise as seguintes causas:
|
Possível causa |
Ação |
|
Conta ou senha incorretas |
Valide as credenciais de logon configuradas para o host no Bastionhost. |
|
Logon root desativado |
Ao fazer logon como |
|
Restrições adicionais de logon |
Inspecione os registros de log do servidor em |
Falha na conexão SSH ao destino
ssh connect target xx failed (ssh: rejected: administratively prohibited (open failed))
Geralmente, esse erro resulta de um problema de conexão com o servidor proxy, como senha expirada. Verifique a conexão com o servidor proxy e renove a senha se ela tiver expirado.
Erros de O&M RDP
Falha na solicitação de CALs do service de área de trabalho remota
remote desktop service CALs request failed
Verifique os seguintes pontos:
|
Possível causa |
Ação |
|
Licença de área de trabalho remota expirada |
Valide se a licença de área de trabalho remota expirou conectando-se ao servidor diretamente a partir de outro computador Windows. |
|
Permissões de área de trabalho remota desativadas |
Confirme se as permissões de área de trabalho remota estão ativadas no servidor. |
Falha na negociação de segurança NLA ou TLS
NLA or TLS security negotiation failure, Please check the username and password
Primeiro, use o Microsoft Terminal Services Client (MSTSC) para conectar-se diretamente ao servidor, ignorando o Bastionhost, e verifique se o logon ocorre com sucesso. Se ainda não conseguir fazer logon, solucione o problema usando os cenários a seguir.
Cenário 1: Autenticação no Nível da Rede (NLA) obrigatória
Verifique se a opção Allow connections only from computers running Remote Desktop with Network Level Authentication está selecionada nas configurações remotas do sistema Windows. Se estiver selecionada, o logon automático via Bastionhost falhará quando qualquer uma das condições a seguir se aplicar:
A conta e a senha do Windows não estão hospedadas no Bastionhost.
A conta do host não foi concedida ao pessoal de O&M.
A conta ou a senha está incorreta.
Cenário 2: Service Host de Sessão de Área de Trabalho Remota expirado
Verifique se o service de função Host de Sessão de Área de Trabalho Remota está instalado na instância ECS. Quando instalado, esse service de host de sessão permite mais de dois logons simultâneos. Se a licença do service expirar, o RDP torna-se indisponível por padrão, embora o certificado do servidor possa permanecer armazenado em cache localmente.
Para testar isso, conecte-se a partir de vários ambientes. Para configurar o logon multiusuário, consulte Configure multi-user logon for a Windows ECS instance.
Cenário 3: Contas padrão não conseguem se conectar
Se apenas a conta Administrator se conectar com sucesso e as contas padrão não conseguirem, significa que faltam permissões de acesso remoto às contas padrão. Por padrão, apenas administradores possuem essas permissões de acesso. Para concedê-las, adicione as contas em Remote Desktop nas configurações do sistema Windows.
Erros de O&M de banco de dados
SQL Server: Erro de protocolo no fluxo TDS
[SQL Server Native Client 11.0] Protocol error in TDS stream (0)
Feche a conexão com o servidor de banco de dados ou saia do Navicat, reabra e tente novamente. Se o erro persistir, mude para outra ferramenta de conexão de banco de dados.
Bad handshake
1043 - bad handshake
Analise as seguintes causas:
|
Possível causa |
Ação |
|
Incompatibilidade entre nome de domínio e endereço IP |
O endereço do banco de dados armazenado no Bastionhost é um nome de domínio. Use o nome de domínio em vez de um endereço IP ao se conectar. |
|
Espaço no nome da conta do banco de dados |
Remova o espaço do nome da conta do banco de dados. |
|
Desconexão de rede entre o Bastionhost e o banco de dados |
Verifique a configuração da lista de permissões. |
Para mais informações, consulte Database connection issues.