Lista os códigos de erro que instâncias do API Gateway do tipo Virtual Private Cloud (VPC) podem retornar.
Estes códigos de erro aplicam-se a serverless instances e dedicated instances do tipo VPC.
Se o cabeçalho
X-Ca-Error-Codeem uma resposta não estiver vazio, o API Gateway gerou o código de erro. Cada código de erro é uma string de seis caracteres. A tabela a seguir lista todos os códigos de erro que o API Gateway pode retornar. Para mensagens de erro detalhadas, verifique o cabeçalhoX-Ca-Error-Message.Caso o cabeçalho
X-Ca-Error-Codeesteja vazio, o código de status HTTP tem origem no serviço de backend. O API Gateway repassa as informações de erro do serviço de backend.
Códigos de erro
|
Código de erro |
Código de status HTTP |
Mensagem |
Descrição |
|
I400HD |
400 |
Invalid Header |
Cabeçalho da requisição HTTP inválido. |
|
I400MH |
400 |
Header |
Cabeçalho obrigatório ausente na requisição HTTP. |
|
I400BD |
400 |
Invalid Body: ${Reason} |
Corpo da requisição HTTP com formato inválido. |
|
I400PA |
400 |
Invalid Request Path |
Caminho da requisição HTTP inválido. |
|
I405UM |
405 |
Unsupported Method |
Método da requisição HTTP não suportado. |
|
I400RU |
400 |
Invalid Request Uri |
URL da requisição HTTP inválida. |
|
I403PT |
403 |
Invalid protocol ${Protocol} unsupported |
Protocolo não suportado conforme a configuração da API. Verifique a configuração da API. |
|
I413RL |
413 |
Request body too Large |
Corpo da requisição excede o tamanho máximo permitido. Para mais informações, consulte Limites. |
|
I413UL |
413 |
Request URL too Large |
URL da requisição muito longa. Para mais detalhes, consulte Limites. |
|
I400CT |
400 |
Invalid Content-Type: |
Valor do Content-Type inválido na requisição. |
|
I404DO |
404 |
Invalid Domain |
Domínio solicitado desconhecido. Utilize um nome de domínio vinculado para a chamada. |
|
I410GG |
410 |
Group's instance invalid |
Instância solicitada inválida. O grupo de APIs pode não pertencer à instância atual. |
|
I400SG |
400 |
Invalid Stage |
Ambiente solicitado desconhecido ou inexistente. |
|
I404NF |
404 |
API not found ${Reason} |
API não encontrada no ambiente atual com base nos parâmetros de caminho e método da requisição. Para mais informações, consulte O que fazer se o erro I404NF for reportado? |
|
X400PM |
400 |
Invalid plugin meta ${PluginName} ${Reason} |
Metadados do plug-in inválidos. |
|
X500ED |
500 |
Expired api definition |
Metadados expirados de versões anteriores não são mais suportados pela nova versão do API Gateway. Para modifique metadados de uma versão anterior, abra um ticket. |
|
X500AM |
500 |
Invalid Api Meta, try deploy again or contact us via ticket |
Formato dos metadados salvos inválido. Para corrigir esse problema, abra um ticket. |
|
X403DG |
403 |
Bad Domain or Group: ${Reason} |
Dados do grupo de APIs inválidos. |
|
B451DO |
451 |
Unavailable Domain for Legal Reasons |
Nome de domínio em desacordo com leis ou regulamentos aplicáveis. |
|
B451GO |
451 |
Unavailable Group for Legal Reasons |
Grupo de APIs viola requisitos legais ou regulamentares vigentes. |
|
B403OD |
403 |
Provider Account Overdue |
Pagamento pendente por parte do provedor da API. Se você adquiriu a API no Alibaba Cloud Marketplace, entre em contato com o prestador de serviços. |
|
A401AC |
401 |
Invalid AppCode ${Reason} |
Falha na autenticação via AppCode porque o AppCode não foi encontrado. Verifique se a aplicação está autorizada e se o AppCode está correto. |
|
A400IK |
400 |
Invalid AppKey |
AppKey não encontrado durante a autorização com par chave-segredo. |
|
A403IS |
403 |
Invalid Signature, Server StringToSign: |
Assinatura do cliente não corresponde à assinatura do servidor. Para mais informações, consulte A403IS. |
|
A403EP |
403 |
App authorization expired |
Autorização expirada. Conceda as permissões novamente. |
|
A403PR |
403 |
Plugin Authorization Needed |
Autorização de plug-in necessária. |
|
A400MA |
400 |
Need authorization, |
Requer autorização no modo AppCode ou mediante par chave-segredo. |
|
I400I5 |
400 |
Invalid Content-MD5 ${Reason} |
Valor do Content-MD5 inválido. |
|
I400NC |
400 |
X-Ca-Nonce is required |
Cabeçalho X-Ca-Nonce não fornecido após ativar a Verificação Forçada de Nonce (Anti Replay por X-Ca-Nonce). |
|
S403NU |
403 |
Nonce Used |
Ataque de replay detectado. O cabeçalho X-Ca-Nonce da requisição já foi utilizado. |
|
S403TE |
403 |
X-Ca-Timestamp is expired |
Timestamp fornecido no cabeçalho X-Ca-Timestamp expirou. A validade do timestamp é de 15 minutos. |
|
I400MP |
400 |
Parameter |
Um ou mais parâmetros obrigatórios na configuração da API estão vazios. |
|
I400IP |
400 |
Invalid parameter |
Valor de um parâmetro na configuração da API é inválido. |
|
I400JR |
400 |
JWT required |
Parâmetros relacionados ao JSON Web Token (JWT) não encontrados. |
|
S403JI |
403 |
Claim |
Nenhuma claim jti válida incluída na requisição quando o parâmetro preventJtiReplay está definido como true em um plug-in de autenticação JWT. |
|
A403SV |
403 |
Claim |
Claim jti incluída na requisição já foi usada, com o parâmetro preventJtiReplay definido como true no plug-in de autenticação JWT. |
|
I400JD |
400 |
JWT Deserialize Failed: |
Impossível analisar o JWT presente na requisição. |
|
A403JT |
403 |
Invalid JWT: ${Reason} |
JWT na requisição é inválido. |
|
A403JK |
403 |
No matching JWK, |
Nenhum JWK corresponde ao kid configurado no JWT da requisição. |
|
A403JE |
403 |
JWT is expired at |
JWT da requisição expirou. |
|
I400JP |
400 |
Invalid JWT plugin config: ${JWT} |
Configuração incorreta no plug-in de autenticação JWT. |
|
A403OL |
403 |
OAuth2 Login failed: ${Reason} |
|
|
A403OU |
403 |
OAuth2 Get User Info failed: ${Reason} |
|
|
A401OT |
401 |
Invalid OAuth2 Access Token |
|
|
A401OM |
401 |
OAuth2 Access Token is required |
|
|
T429ID |
429 |
Throttled by INNER DOMAIN Flow Control, ${Domain} is a test domain, only 1000 requests per day |
Limite de chamadas de API excedido. Ao usar o nome de domínio de segundo nível padrão, o limite é de 1.000 chamadas por dia para regiões na China continental e 100 chamadas por dia para regiões fora da China continental. |
|
T429IN |
429 |
Throttled by INSTANCE Flow Control |
Limitação de taxa acionada para a instância atual. Atualize a especificação da instância. |
|
T429GR |
429 |
Throttled by GROUP Flow Control |
Controle de fluxo ativado para o grupo de APIs atual. Atualize a especificação da instância. |
|
T429PA |
429 |
Throttled by API Flow Control |
Política padrão de limitação no nível da API, definida no plug-in de throttling, foi acionada. |
|
T429PR |
429 |
Throttled by PLUGIN Flow Control |
Política especial de limitação definida no plug-in de throttling foi acionada. |
|
T429SR |
429 |
Throttled by SERVER Flow Control |
|
|
T429MR |
429 |
Too Many Requests, throttle by |
|
|
A403IP |
403 |
Access denied by IP Control Policy |
Acesso negado pelo plug-in de controle de acesso baseado em endereço IP. |
|
A403IN |
403 |
Access from internet is disabled ${Reason} |
Não é possível chamar APIs e grupos de APIs pela Internet. Use uma rede privada. Para mais informações, consulte Chamadas de API baseadas em VPC. |
|
A403VN |
403 |
Access from invalid VPC is disabled |
Acesso pela VPC especificada foi negado. |
|
A403AC |
403 |
Access Control Forbidden by ${RuleName} |
Plug-in de controle de acesso bloqueou a solicitação. |
|
A403CO |
403 |
Cross origin resource forbidden ${Domain} |
Acesso negado pelo plug-in de compartilhamento de recursos de origem cruzada (CORS). |
|
I404CO |
404 |
Cross origin resource not found ${Method} - ${Path} |
Definição da API não encontrada com base no caminho e método da requisição pré-verificados pelo plug-in CORS. |
|
I404CH |
404 |
Content not cached, with |
|
|
I404NR |
404 |
${Resource} not found |
|
|
I404SR |
404 |
Stage route missing: ${Reason} |
|
|
B403MO |
403 |
Api Market Subscription overdue |
Pagamento pendente do provedor da API. Entre em contato com o prestador de serviços. |
|
B403MQ |
403 |
Api Market Subscription quota exhausted |
Cota de APIs adquiridas no Alibaba Cloud Marketplace esgotada. Renove a cota. |
|
B403ME |
403 |
Api Market Subscription expired |
Assinatura da API expirou. Crie uma nova assinatura. |
|
B403MI |
403 |
Api Market Subscription invalid |
Serviço de API assinado é inválido. |
|
D504RE |
504 |
Backend domain |
Falha na resolução do nome de domínio de backend. Verifique o nome de domínio de backend. |
|
D504IL |
504 |
Backend domain |
Resultado da resolução do nome de domínio do serviço de backend é inválido. |
|
D504CO |
504 |
Backend service connect failed |
API Gateway falhou ao acessar o serviço de backend. Nesse caso, verifique as configurações de grupo de segurança e firewall ou o status do servidor de backend. Para mais informações, consulte Solucionar erros D504CO. |
|
504 |
Backend service connect failed |
Falha na conexão com o serviço de backend devido ao pool de conexões esgotado. Atualize a especificação da instância. |
|
|
D504CS |
504 |
Backend http ssl connect failed |
Falha ao conectar ao serviço de backend via HTTPS. Verifique se o protocolo configurado para o serviço de backend corresponde à porta. |
|
D504TO |
504 |
Backend service request timeout |
Tempo limite atingido na requisição ao serviço de backend. Aumente o tempo limite do backend ou melhore a capacidade de processamento do serviço de backend. |
|
X504VE |
504 |
Backend service vpc mapped failed |
Falha no mapeamento VPC do serviço de backend. |
|
D503BB |
503 |
Backend circuit breaker busy |
API protegida pelo seu disjuntor (circuit breaker). |
|
D503CB |
503 |
Backend circuit breaker open, ${Reason} |
Disjuntor aberto para a API. Verifique o desempenho do serviço de backend. |
|
I508LD |
508 |
Loop Detected |
Chamada em loopback detectada. |
|
I404DD |
404 |
Device id ${DeviceId} not found |
ID do dispositivo não encontrado ao chamar APIs via WebSocket. |
|
A403FC |
403 |
Function Compute AssumeRole failed ${RequestId}:${Reason} |
Erro de autorização ocorrido ao usar o Function Compute como serviço de backend. |
|
D502FC |
502 |
Function Compute response invalid: ${Reason} |
Resposta inválida recebida do serviço de backend ao utilizar o Function Compute. |
|
N502RE |
502 |
Send Response IO Exception: ${Reason} |
Exceção ocorrida quando o servidor envia uma resposta ao cliente. Verifique se o cliente fechou a conexão prematuramente ou se houve um erro de rede. |
|
X500ER |
500 |
Service Internal Error |
Erro interno no servidor. Para resolver este problema, abra um ticket para contatar o suporte técnico do API Gateway. |
|
X503BZ |
503 |
Service Busy |
Serviço do API Gateway ocupado. Tente novamente mais tarde. |
|
X504TO |
504 |
Service timeout |
Erro de tempo limite no API Gateway. Para falar com o suporte técnico, abra um ticket. |
Códigos de erro específicos podem mudar quando o serviço é atualizado ou novos recursos são adicionados.