カスタムルートエントリの名前、説明、またはネクストホップを変更します。
操作説明
ModifyRouteEntry 操作は、同じカスタムルートエントリの名前と説明の同時変更をサポートしていません。
ModifyRouteEntry 操作は、同時実行シナリオで TaskConflict エラーコードを返す場合があります。必要に応じて操作を再試行してください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
vpc:ModifyRouteEntry |
update |
*RouteTable。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
必須 |
ルートエントリのリージョン ID。 DescribeRegions 操作を呼び出してリージョン ID をクエリできます。 |
cn-hangzhou |
| RouteEntryName |
string |
任意 |
ルートエントリの名前。 名前は 1~128 文字で、 |
EntryName |
| RouteEntryId |
string |
任意 |
カスタムルートエントリの ID。 |
rte-acfvgfsghfdd**** |
| Description |
string |
任意 |
ルートエントリの説明。 説明は 1~256 文字で、 |
EntryDescription |
| NewNextHopType |
string |
任意 |
ルートエントリの新しいネクストホップタイプ。有効な値:
列挙値:
|
NetworkInterface |
| NewNextHopId |
string |
任意 |
ルートエントリの新しいネクストホップのインスタンス ID。 |
eni-bp17y37ytsenqyim**** |
| RouteTableId |
string |
任意 |
ルートテーブルの ID。 |
vtb-bp1nk7zk65du3pni8z9td |
| DestinationCidrBlock |
string |
任意 |
ルートエントリの IPv4 CIDR ブロック。IPv4 および IPv6 CIDR ブロックがサポートされています。 説明
RouteEntryId パラメーターが指定されていない場合、DestinationCidrBlock および RouteTableId パラメーターは必須です。 ルートの IPv4 CIDR ブロックをプレフィックスリストに変更するには、RouteEntryId パラメーターを指定する必要があります。DestinationCidrBlock パラメーターは、プレフィックスリスト CIDR ブロックまたはプレフィックスリストインスタンス ID をサポートしていません。 |
192.168.0.0/24 |
| DryRun |
boolean |
任意 |
ドライランを実行するかどうかを指定します。有効な値: true: ルートを変更せずにドライランを実行します。システムは、AccessKey ペア、Resource Access Management (RAM) ユーザーの権限付与、および必須パラメーターをチェックします。チェックが失敗した場合、対応するエラーが返されます。チェックが成功した場合、 false (デフォルト): 通常のリクエストを送信します。チェックが成功した場合、2xx HTTP 状態コードが返され、ルートは変更済みです。 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンスパラメーター。 |
||
| RequestId |
string |
リクエストの ID。 |
861E6630-AEC0-4B2D-B214-6CB5E44B7F04 |
例
成功レスポンス
JSONJSON
{
"RequestId": "861E6630-AEC0-4B2D-B214-6CB5E44B7F04"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidRouteEntryId.NotFound | Specified RouteEntryId does not exist. | 指定されたルートエントリが存在しません。 |
| 400 | InvalidRouteEntryName.Malformed | Specified RouteEntry name is not valid. | 指定されたルートエントリ名が無効なため、変更に失敗しました。 |
| 400 | OperationDenied.ModifyManagedRouteEntry | The operation is not allowed because of route entry is managed. | 管理対象のルートは変更できません。 |
| 400 | OperationDenied.RouteTableTypeNotPermitted | The operation is not allowed because the type of route table is not permitted. | 指定されたルートテーブルタイプでは、ルートエントリを作成できません。 |
| 400 | MissingParam.NewNextHopId | The parameter NewNextHopId is mandatory. | 変更済みのルートエントリのネクストホップインスタンス ID が指定されていません。 |
| 400 | IllegealParam.NextHopType | The parameter NewNextHopType is illegal. | ルートエントリのネクストホップタイプが無効です。 |
| 400 | UnsupportedFeature.NormalTypeNatGateway | Normal nat gateways do not support modifying the next hop of the route. | 通常の NAT ゲートウェイをポイントするルートエントリでは、ネクストホップの変更はサポートされていません。 |
| 400 | UnsupportedFeature.NextHopType | The route type does not support modifying the next hop of the route. | 現在のルートエントリではネクストホップの変更はサポートされていません。 |
| 400 | InvalidRouteTable.NotFound | The specified routetable does not exist. | ルートテーブルインスタンスが存在しません。 |
| 400 | InvalidNetworkInterface.NotFound | The specified network interface does not exist. | 添付ファイル上のネットワークインターフェイス (ENI) が存在しません。 |
| 400 | OperationDenied.NextHopExist | The operation is not allowed because the nexthop already exists. | 変更対象のルートエントリのターゲットネクストホップは既に存在します。 |
| 400 | MissingParam.NewNextHopType | The parameter NewNextHopType is mandatory. | 変更済みのルートエントリのネクストホップインスタンスタイプが指定されていません。 |
| 400 | UnsupportedFeature.ModifyRouteEntryNextHop | The current region does not support the function of modifying the route next hop. | 現在のリージョンではルートのネクストホップの変更はサポートされていません。 |
| 400 | IncorrectRouteEntryStatus | Some route entry status blocked this operation. | |
| 400 | ResourceNotFound.VSwitch | The vSwitch where the specified networkinterface is located does not exist. | 指定された vSwitch インスタンスが存在しません。 |
| 400 | MissingParam.RouteEntryId | The param of %s is missing. | 必須パラメーターがありません。 |
| 400 | IllegalParam.RouteEntryName | The param of %s is illegal. | 指定されたルート名が無効です。 |
| 400 | OperationDenied.LocalRouteEntryModified | The next hop of a local route is modified. | ネクストホップが変更済みの Local ルートがすでに存在します。 |
| 400 | OperationDenied.IllegalNewNextHopType | When modifying the next hop of a route of the local type, a new next hop type that is not supported is passed in. | Local ルートのネクストホップを変更しようとした際に、サポートされていないネクストホップタイプが指定されました。 |
| 400 | UnsupportedFeature.VpcAdvancedFeature | The VPC does not support some advanced features. | 指定された vSwitch が属する VPC は高度な特徴をサポートしていません。別の vSwitch を使用して再試行してください。 |
| 400 | UnsupportedRegion | The feature is not supported in current region. | 現在のリージョンでは、プレフィックスリストルートの操作はサポートされていません。 |
| 400 | OperationFailed.NotSupportIPV6 | The specified next hop does not support IPv6. | 指定されたネクストホップは IPv6 をサポートしていません。 |
| 400 | UnsupportedFeature.ModifyIpv6RouteEntryNextHop | The current region does not support the feature of modifying the IPv6 route next hop. | 現在のリージョンでは IPv6 ルートのネクストホップの変更がサポートされていないため、操作は失敗しました。 |
| 400 | OperationDenied.NewNextHopNotSupportPublish | New nexthop is not supported for published route entry. | ルートエントリは既に別のコンポーネントに公開されています。指定されたネクストホップタイプはルート公開をサポートしていません。 |
| 400 | IllegalParam.DestCidrBlock | The destCidrBlock is invalid. | 指定された送信先アドレスが無効です。 |
| 400 | IllegalParamFormat.DstCidrBlock | The format of the specified destination CIDR block is invalid. | 送信先 CIDR ブロックのフォーマットが無効です。 |
| 400 | MissingParam.RouteEntryIdOrRouteTableDstCidr | The request is missing required parameters. You must provide either the RouteEntryId or the combination of RouteTableId and DestinationCidrBlock to proceed. Please ensure that one of these parameter sets is included in your request. | リクエストに必須パラメーターがありません。RouteEntryId を指定するか、または RouteTableId と DestinationCidrBlock の両方を指定する必要があります。 |
| 400 | MissingParam.ParameterMustNotNull | %s, %s. | 必須パラメーターがありません。 |
| 400 | ResourceNotFound.RouteTable | The specified resource gatewayRouteTable is not found. | ゲートウェイルートテーブルが存在しません。 |
| 400 | OperationDenied.UpdateGatewayRouteEntry | The operation is not allowed because of need switch to local first. | ゲートウェイルートエントリの変更に失敗しました。カスタムネクストホップを指定する前に、まずネクストホップをローカルルートに変更する必要があります。 |
| 400 | ResourceNotFound.RouteEntry | The specified resource routeEntry is not found. | 指定されたルートエントリが存在しません。 |
| 400 | IncorrectStatus.RouteEntry | The status of %s [%s] is incorrect. | ルートエントリが過渡状態にあります。 |
| 400 | IncorrectStatus.Vswitch | The status of %s [%s] is incorrect. | |
| 400 | ResourceNotFound.Instance | The specified resource nextHop is not found. | ネクストホップインスタンスが存在しません。 |
| 400 | IncorrectStatus.NextHop | The status of %s [%s] is incorrect. | 指定されたネクストホップリソースが過渡状態にあります。 |
| 400 | OperationDenied.NextHopTypeNonsupport | The operation is not allowed because of nextHopType is nonsupport. | 指定されたリソースタイプはネクストホップとしてサポートされていません。 |
| 400 | OperationDenied.LocalEntryCanOnlyModifyNextHop | Only the nextHop parameter can be modified for a local route entry. | ローカルルートのネクストホップ属性のみ変更済みです。 |
| 400 | ExclusiveParam.NextHopTypeAndNextHopId | The param of nextHopType and nextHopId are mutually exclusive. | ネクストホップタイプがネクストホップインスタンスと一致しません。 |
| 400 | InvalidRouterInterfaceId.NotFound | The specified RouterInterfaceId does not exist in our record. | |
| 400 | OperationUnsupported.OnlySupportNormalNetworkInterface | Next hop only supports binding normal network Interface. | ネクストホップは、ネットワークインターフェイスコントローラー (NIC) にアタッチされた通常のネットワークインターフェイス (ENI) のみをサポートします。 |
| 400 | UnsupportedFeature.Ipv6GatewayRouteTable | The feature of %s is not supported. | 指定されたゲートウェイルートテーブルは、このゲートウェイインスタンスとのバインドをサポートしていません。 |
| 400 | OperationDenied.TrAttachmentIpv6Disabled | The operation is not allowed because tr attachment Ipv6 is disabled. | トランジットルーターアタッチメントで IPv6 が有効になっていません。 |
| 400 | InvalidAttachment.NotFound | The attachment is not found. | 添付ファイルが存在しません。 |
| 400 | OperationDenied.LocalRouteEntryInSystemRouteTable | The Local Route Entry In System Route Table Can Not Be Modify. | システムルートテーブル内の Local ルートの変更は許可されていません。 |
| 400 | OperationDenied.LocalRouteEntryBoundToVSwitch | The VSwitch to which the local route you modified belongs is bound to the current routing table. You are not allowed to modify its next hop. | 変更しようとしている Local ルートに関連付けられた vSwitch が現在のルートテーブルにバインドされています。ネクストホップの変更は許可されていません。 |
| 400 | OperationFailed.ModifyEcmpRoute | Operation is failed because ecmp route can not modify. | ECMP ルートはネクストホップなどの属性の変更をサポートしていないため、操作に失敗しました。 |
| 400 | InvalidRouteEntry.NotFound | vpc route entry not exist. | ルートエントリが存在しません。ルートエントリが正しいかどうかを確認してください。 |
| 400 | OperationDenied.IllegalRouteTargetGroupMemberType | This operation does not support route target groups with NAT gateway members. | 現在の操作では、NAT ゲートウェイタイプのメンバーを持つルートターゲットグループはサポートされていません。 |
| 400 | OperationUnsupported.Ipv6EntryOnPrimaryNetworkInterface | You cannot create IPv6 route entries on a primary network interface. | プライマリ ENI をネクストホップとする IPv6 ルートの作成は許可されていません。 |
| 400 | IncorrectStatus.Vpc | Vpc incorrect status. | 現在のインスタンスステータスが安定していません。 |
| 403 | Forbbiden | User not authorized to operate on the specified resource. | EIP が現在の呼び出し元に属していません。この EIP を呼び出す権限があるかどうかを確認してください。 |
| 404 | ResourceNotFound.NatGateway | The specific NAT gateway is not found. | NAT ゲートウェイが存在しません。 |
| 404 | ResourceNotFound.GatewayLoadBalancerEndpoint | GatewayLoadBalancerEndpoint instance not found. | GatewayLoadBalancerEndpoint インスタンスが見つかりませんでした。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。