vRouter または Virtual Border Router (VBR) のルートテーブルからルートエントリを削除します。
操作説明
この操作を呼び出してルートを削除する場合は、次の点に注意してください。
-
Available 状態のルートのみ削除できます。
-
ルートテーブルを含む VPC が vSwitch またはルートを作成または削除している間は、ルートを削除できません。
-
VBR のルートテーブルからルートを削除するには、 DescribeRouteEntryList 操作を呼び出して削除するルートの NextHopId をクエリし、その後この操作を呼び出してルートを削除します。
-
DeleteRouteEntry 操作は非同期です。リクエストを送信すると、システムはリクエスト ID を返しますが、ルートはまだ削除されていません。削除タスクはバックグラウンドで実行されます。 DescribeRouteEntryList を呼び出して、ルートの削除ステータスをクエリできます。
ルートが Deleting 状態の場合、ルートは削除中です。
指定されたルートが見つからない場合、ルートは削除されています。
-
DeleteRouteEntry 操作は、同じ VPC または VBR 内のルートテーブルからのルートの同時削除をサポートしていません。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
vpc:DeleteRouteEntry |
delete |
*RouteTable。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
任意 |
ルートテーブルが存在するリージョンの ID。 DescribeRegions 操作を呼び出して、リージョン ID をクエリできます。 |
cn-hangzhou |
| RouteTableId |
string |
任意 |
ルートを含むルートテーブルの ID。 説明
RouteEntryId パラメーターが指定されていない場合、DestinationCidrBlock パラメーターと RouteTableId パラメーターは必須です。必要に応じて NextHopId パラメーターまたは NextHopList パラメーターを設定します。 |
vtb-2ze3jgygk9bmsj23s**** |
| RouteEntryId |
string |
任意 |
削除するルートの ID。このパラメーターは DestinationCidrBlock パラメーターと相互排他です。 説明
DestinationCidrBlock パラメーターが指定されていない場合、RouteEntryId パラメーターは必須です。 |
rte-bp1mnnr2al0naomnpv**** |
| DestinationCidrBlock |
string |
任意 |
ルートの送信先 CIDR ブロック。IPv4 CIDR ブロック、IPv6 CIDR ブロック、プレフィックスリスト CIDR ブロック、およびプレフィックスリストインスタンス ID がサポートされています。このパラメーターは RouteEntryId パラメーターと相互排他です。 説明
RouteEntryId パラメーターが指定されていない場合、DestinationCidrBlock パラメーターと RouteTableId パラメーターは必須です。必要に応じて NextHopId パラメーターまたは NextHopList パラメーターを設定します。 |
47.100.XX.XX/16 |
| NextHopId |
string |
任意 |
ネクストホップインスタンスの ID。
|
ri-2zeo3xzyf38r4urzd**** |
| NextHopList |
array<object> |
任意 |
ECMP ルートのネクストホップインスタンスの情報。ネクストホップインスタンスの最大値は 16 です。 |
|
|
object |
任意 |
ECMP ルートのネクストホップインスタンスの情報。ネクストホップインスタンスの最大値は 16 です。 |
||
| NextHopId |
string |
任意 |
ECMP ルートのネクストホップインスタンスの ID。ネクストホップインスタンスの最大値は 16 です。 |
ri-2zeo3xzyf38r43cd**** |
| NextHopType |
string |
任意 |
ECMP ルートのネクストホップのタイプ。値を RouterInterface (ルーターインターフェイス) に設定します。ネクストホップインスタンスの最大値は 16 です。 |
RouterInterface |
| DryRun |
boolean |
任意 |
ドライランを実行するかどうかを指定します。有効な値: true: ルートを削除せずにドライランを実行します。システムは、AccessKey ペア、Resource Access Management (RAM) ユーザーの権限付与、および必須パラメーターをチェックします。チェックに失敗した場合、対応するエラーが返されます。チェックに成功した場合、エラーコード false (デフォルト): 通常のリクエストを送信します。チェックに成功した場合、2xx HTTP 状態コードが返され、ルートが削除されます。 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
応答。 |
||
| RequestId |
string |
リクエスト ID。 |
0ED8D006-F706-4D23-88ED-E11ED28DCAC0 |
例
成功レスポンス
JSONJSON
{
"RequestId": "0ED8D006-F706-4D23-88ED-E11ED28DCAC0"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | MissingParameter | Miss mandatory parameter. | |
| 400 | IncorrcetRouteEntryStatus | Some route entry status blocked this operation. | |
| 400 | InvalidCidrBlock.Malformed | Specified CIDR block is not valid. | |
| 400 | OperationDenied | Specified operation is denied as route entry type is system. | |
| 400 | InvalidRouteEntry.NotFound | Route entry not exists. | |
| 400 | InvalidVRouter.NotFound | vRouter not exists. | |
| 400 | IncorrectRouteEntryStatus | Some route entry status blocked this operation. | |
| 400 | Forbbiden | Specified RouteEntry cannot allowed delete by openApi. | |
| 400 | InvalidNextHop | Specified nexthop and nexthop list cannot both null. | |
| 400 | InvalidRouteEntry | Specified routeEntry not exist. | |
| 400 | Forbidden.VRouterNotFound | pecified virtual switch is not found during access authentication. | |
| 400 | TaskConflict | The operation is too frequent, TaskConflict. | EIP に対する操作が頻繁すぎます。 |
| 400 | InvalidRouteEntryId.NotFound | Specified RouteEntryId does not exist. | 指定されたルートエントリが存在しません。 |
| 400 | IncorrectVpcStatus | Current VPC status does not support this operation. | |
| 400 | InvalidVpnInstanceId.NotFound | %s | |
| 400 | ParamExclusive.RouteEntryIdAndRouteTableIdOrDestCidrBlock | %s | |
| 400 | InvalidNextHopList.Size | Nexthop list size should be between 2 and 16 | |
| 400 | ParamExclusive.NextHopIdAndList | NextHopId and NextHopList cannot both be not null. | |
| 400 | OperationFailed.DeleteMultiScopeEntry | Multi or ecmp scope must delete with force. | |
| 400 | OperationFailed.DistibuteLock | Distibute lock fail. | リソースがロック済みです。操作は許可されていません。 |
| 400 | OperationDenied.DeleteManagedRouteEntry | The operation is not allowed because of route entry is managed. | クラウドサービスによって管理されているルートは削除できません。 |
| 400 | OperationDenied.RouteTableTypeNotPermitted | The operation is not allowed because the type of route table is not permitted. | 指定されたルートテーブルタイプでは、ルートエントリを作成できません。 |
| 400 | IncorrectStatus.VpcRouteEntry | The status of the specified routeEntry is invalid. | VPC ルートエントリのステータスが正しくありません。 |
| 400 | OperationDenied.NextHopNotChanged | The operation is not allowed because of NextHopNotChanged. | ネクストホップが変更されていないため、操作は許可されていません。 |
| 400 | OperationDenied.DeleteGatewayEndpointRoute | The operation is not allowed to delete route entry pointing gateway endpoint.. | ゲートウェイエンドポイントを指すルートは手動で削除できません。 |
| 400 | IncorrectStatus.PrefixList | The status of prefixList is incorrect. | プレフィックスリストがトランジション中の状態であるため、操作を実行できません。 |
| 400 | InvalidCidrBlock | Specified CIDR block is not valid. | 考えられる原因: 1. 10.0.0.0/8 CIDR ブロックのホワイトリストに含まれていないため、この CIDR ブロックを使用できません。 2. カスタムルートの送信先 CIDR ブロックは、同じ VPC 内のいずれかの vSwitch の CIDR ブロックのサブセットにすることはできません。 3. 100.64.0.0/10 はクラウドサービスアドレスであるため、オンプレミスデータセンターを指すようにこの CIDR ブロックを追加することはできません。 4. 100.64.0.0/10 に加えて、100.64.0.0/11 や 100.96.0.0/11 などの特定の CIDR ブロックはオンプレミスデータセンターに使用できません。 |
| 400 | OperationDenied.VbrAttachEcrInMiddleStatus | The operation is not allowed because of VBR attach or detach ECR in middle status. | ボーダーゲートウェイルーティングデバイスが Express Connect Router (ECR) のロードまたはアンロード処理中のため、操作を実行できません。後でもう一度お試しください。 |
| 400 | UnsupportedFeature.NextHopType | The operation is not allowed because the NextHopType of specified RouteEntry is modified from Local type. | 現在のルートエントリではネクストホップの変更はサポートされていません。 |
| 400 | ResourceNotFound.PrefixList | The specified resource of prefixList is not found. | 指定されたプレフィックスが存在しません。 |
| 400 | IncorrectStatus.PrefixListRelation | The related prefix list relation is in an intermediate state and cannot perform the current operation. | |
| 500 | Vpc.Error | error code 500,Internal server error. | |
| 500 | Internal.Error | The request processing has failed due to some unknown error, exception or failure. | |
| 500 | InternalError | The request processing has failed due to some unknown error, exception or failure. | 不明なエラーのため、リクエストの処理が失敗しました。 |
| 404 | InvalidRouteTableId.NotFound | Specified route table does not exist. | |
| 404 | InvalidVpcId.NotFound | Specified value of VpcId is not found in our record. | VPC が存在しません。指定された VPC が正しいかどうかを確認してください。 |
| 404 | ResourceNotFound.GatewayLoadBalancerEndpoint | GatewayLoadBalancerEndpoint instance not found. | GatewayLoadBalancerEndpoint インスタンスが見つかりませんでした。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。