すべてのプロダクト
Search
ドキュメントセンター

Simple Log Service:エラーコード

最終更新日:Sep 12, 2026

API 呼び出しが失敗すると、サーバーはエラーメッセージを返します。このトピックでは、エラーコードとその解決策について説明します。

概要

API リクエストが失敗すると、サーバーはエラーメッセージを返します。エラーメッセージには、HTTP ステータスコードと、特定のエラー詳細を含むレスポンスボディが含まれます。レスポンスボディのエラー詳細の形式は次のとおりです。

{
"errorCode" : <ErrorCode>,
"errorMessage" : <ErrorMessage>
}

このトピックでは、エラーの処理方法について説明します。API Error Center でエラーコードの詳細を確認することもできます。詳細については、「Simple Log Service API Error Center」をご参照ください。

操作固有のエラーコード

操作固有のエラーコードは、各 API 操作に固有です。これらのエラーコードについては、特定の API 操作のドキュメントをご参照ください。

共通エラーコード

共通エラーコードは、ほとんどの API 操作に適用されます。次の表に、API エラーレスポンスで返される可能性のある共通エラーコードを示します。

説明

Simple Log Service (SLS) は、ログのクエリと分析に関する一般的なエラーを提供しており、問題のトラブルシューティングに役立ちます。詳細については、「ログのクエリと分析に関する一般的なエラー」をご参照ください。

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

推奨されるアクション

400

RequestTimeExpired

Request time requestTime has been expired while server time is server time.

リクエストとサーバーの時刻差が 15 分を超えています。

クライアントの時刻を確認し、後でリクエストを再試行してください。

400

InvalidRequestTime

Request time requestTime not follow RFC822 spec.

リクエストの Date ヘッダーの値が RFC 822 標準に準拠していません。

リクエストヘッダーを確認し、Date ヘッダーの値が RFC 822 標準に準拠していることを確認してください。

400

InvalidHost

Host header Host is invalid.

リクエストの Host ヘッダーが無効です。

リクエストヘッダーを確認し、Host ヘッダーの形式が正しいことを確認してください。

400

ProjectAlreadyExist

Project ProjectName already exist.

プロジェクト名がすでに存在します。

プロジェクト名は、Alibaba Cloud リージョン内でグローバルに一意である必要があります。プロジェクト名を変更して、リクエストを再試行してください。

400

PostBodyInvalid

The request body is not valid JSON object.

リクエストボディが JSON 形式ではありません。

リクエストボディを修正して、リクエストを再送信してください。

400

InvalidContentType

Content-Type type is unsupported.

Content-Type はサポートされていません。

Content-Type が正しく定義されていることを確認してください。

400

ParameterInvalid

Http extend authorization : authorization pair is invalid.

Authorization リクエストヘッダーが無効です。

Authorization リクエストヘッダーが正しく定義されていることを確認してください。

Http extend x-log-bodyrawsize : x-log-bodyrawsize pair is invalid.

x-log-bodyrawsize リクエストヘッダーが無効です。

x-log-bodyrawsize リクエストヘッダーが正しく定義されていることを確認してください。

Http extend x-log-compresstype : x-log-compresstype pair is invalid.

x-log-compresstype リクエストヘッダーが無効です。

x-log-compresstype リクエストヘッダーが正しく定義されていることを確認してください。

x-log-signaturemethod: x-log-signaturemethod pair is invalid.

x-log-signaturemethod が無効です。

x-log-signaturemethod リクエストヘッダーが正しいことを確認してください。

400

MissingParameter

Missing query key : parameter.

必須のリクエストパラメーターがありません。

必要なリクエストパラメーターを追加して、リクエストを再試行してください。リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

Missing http extend header key : authorization.

Authorization リクエストヘッダーがありません。

Authorization リクエストヘッダーを追加して、リクエストを再試行してください。リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

Missing http extend header key : x-log-bodyrawsize.

x-log-bodyrawsize リクエストヘッダーがありません。

x-log-bodyrawsize リクエストヘッダーを追加して、リクエストを再試行してください。リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

Missing http extend header key : x-log-date.

x-log-date リクエストヘッダーがありません。

x-log-date リクエストヘッダーを追加して、リクエストを再試行してください。リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

Missing http extend header key : x-log-signaturemethod.

x-log-signaturemethod リクエストヘッダーがありません。

x-log-signaturemethod リクエストヘッダーを追加して、リクエストを再試行してください。リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

401

SignatureNotMatch

Signature signature not matched.

リクエストのデジタル署名が一致しません。

リクエストを再試行してください。エラーが解決しない場合は、AccessKey を交換して再試行してください。考えられる原因は次のとおりです。

  • AccessKey または Security Token Service (STS) トークンが期限切れです。有効か確認してください。

  • デプロイされている SLS のソフトウェア開発キット (SDK) のバージョンが古いです。GitHub にアクセスして、オープンソースコードとリファレンスを入手してください。詳細については、「SDKリファレンスの概要」をご参照ください。

リクエスト署名の構造と生成プロセスの詳細については、「リクエスト署名」をご参照ください。

401

Unauthorized

The AccessKeyId is unauthorized.

指定された AccessKey ID は権限がありません。

お使いの AccessKey ID に SLS へのアクセス権限があることを確認してください。Resource Access Management (RAM) ユーザーに SLS の操作を実行する権限を付与するには、「RAMユーザーの作成と権限付与」をご参照ください。

The security token you provided is invalid.

STS トークンが無効です。

STS API リクエストを確認し、STS トークンが有効であることを確認してください。

The security token you provided has expired.

STS トークンが期限切れです。

新しい STS トークンをリクエストして、リクエストを再送信してください。

AccessKeyId not found: AccessKey ID

AccessKey ID が存在しません。

お使いの AccessKey ID を確認してください。正しい AccessKey ID を取得して、リクエストを再送信してください。

AccessKeyId is disabled: AccessKey ID

AccessKey ID が無効化されています。

お使いの AccessKey ID を確認し、有効になっていることを確認してから、リクエストを再送信してください。

Your SLS service has been forbidden.

SLS が無効化されています。

お使いの SLS のステータスを確認してください。たとえば、アカウントに支払い遅延があるかどうかを確認します。

The project does not belong to you.

プロジェクトが現在のユーザーに属していません。

  • プロジェクトまたはユーザーを変更して、リクエストを再試行してください。

  • 使用する AccessKey が有効になっていることを確認してください。詳細については、「RAMユーザーのAccessKey情報を表示する」をご参照ください。

401

InvalidAccessKeyId

The access key id you provided is invalid: AccessKey ID.

AccessKey ID が無効です。

お使いの AccessKey ID を確認し、有効であることを確認してください。

Your SLS service has not been activated.

SLS がアクティブ化されていません。

SLS コンソールにログインするか、API を呼び出して SLS をアクティブ化してください。その後、リクエストを再送信してください。詳細については、「Simple Log Serviceとは」をご参照ください。

403

WriteQuotaExceed

Write quota is exceeded.

ログ書き込みクォータを超えています。

ログ書き込みリクエストを最適化して、書き込むログの数を減らしてください。詳細については、「制限」をご参照ください。

403

ReadQuotaExceed

Read quota is exceeded.

ログ読み取りクォータを超えています。

ログ読み取りリクエストを最適化して、読み取るログの数を減らしてください。詳細については、「制限」をご参照ください。

403

MetaOperationQpsLimitExceeded

Qps limit for the meta operation is exceeded.

デフォルトの秒間クエリ数 (QPS) のしきい値を超えています。

リソース操作リクエストを最適化して、操作の数を減らしてください。数秒後にリクエストを再試行することを推奨します。

SLS は、次の管理 API 操作の QPS を制限します。

  • プロジェクト操作

  • Logstore 操作

  • インデックス操作

  • データの書き込みや読み取りを行わないその他の操作

詳細については、「制限」をご参照ください。

403

ProjectForbidden

Project ProjectName has been forbidden.

プロジェクトが無効化されています。

プロジェクトのステータスを確認してください。支払い遅延により、プロジェクトが一時停止されている可能性があります。

404

ProjectNotExist

The Project does not exist : name

プロジェクトが存在しません。

プロジェクト名を確認し、プロジェクトが存在すること、およびリージョンが正しいことを確認してください。

405

InvalidMethod

Invalid request method : request URI

指定されたリソースでは、リクエストメソッドはサポートされていません。

メソッドを確認して再試行してください。

413

PostBodyTooLarge

Body size bodysize must little than 10485760.

リクエストボディは 10 MB を超えることはできません。

リクエストボディのサイズを調整して、リクエストを再試行してください。

500

InternalServerError

Internal server error message.

内部サーバーエラーが発生しました。

後でリクエストを再試行してください。

500

RequestTimeout

The request timed out. Please try again later.

リクエストがタイムアウトしました。

後でリクエストを再試行してください。

503

ServerBusy

The server is busy, please try again later.

サーバーがビジー状態です。

後でリクエストを再試行してください。

説明

エラーメッセージのイタリック体のテキストは、エラーに関する特定の情報を示します。たとえば、ProjectNotExist エラーメッセージでは、name は実際のプロジェクト名に置き換えられます。