すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:ModifyDBInstanceConfig

最終更新日:Sep 07, 2026

ApsaraDB RDS インスタンスの設定項目を変更します。

操作説明

サポートされているエンジン

  • ApsaraDB RDS for PostgreSQL

  • ApsaraDB RDS for SQL Server

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

rds:ModifyDBInstanceConfig

none

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#DbInstanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DBInstanceId

string

必須

インスタンスの ID。DescribeDBInstances を呼び出してインスタンス ID を取得できます。

pgm-2ze****

ConfigName

string

必須

変更する設定項目の名前。このパラメーターは ConfigValue と一緒に使用します。

ApsaraDB RDS for PostgreSQL の設定項目

  • pgbouncer: PgBouncer の特徴を変更します。

  • encryptionKey: クラウドディスク暗号化の特徴を変更します。

  • duckdb_create_databases: プライマリインスタンスのデータベースを DuckDB 列のストアデータベースとして一括で設定します。

  • duckdb_prepare_dependency: プライマリインスタンスをワンクリックで設定し、そのパラメーターとマイナーエンジンバージョンが DuckDB ベースの分析インスタンスを作成するための前提条件を満たすようにします。プライマリインスタンスに読み取り専用インスタンスがすでにある場合、読み取り専用インスタンスも更新されます。

  • enable_db_visible_by_connect_rls: インスタンスで CONNECT RLS を有効にして、データベースの可視性をコントロールします。

  • set_db_visible_by_connect_rls: データベースで CONNECT RLS を有効にして、データベースの可視性をコントロールします。これは、インスタンスで CONNECT RLS が有効になった後にのみ呼び出しが可能です。

ApsaraDB RDS for SQL Server の設定項目

  • clear_errorlog: エラーログをクリアします。

  • encryptionKey: クラウドディスク暗号化の特徴を変更します。サーバーレスインスタンスと共有インスタンスタイプでは、この特徴はサポートされていません。

pgbouncer

ConfigValue

string

必須

変更する設定項目の値。このパラメーターは ConfigName と一緒に使用します。

ApsaraDB RDS for PostgreSQL の設定項目の値

  • PgBouncer の特徴: true (有効) または false (無効)。

  • クラウドディスク暗号化の特徴:
    • ServiceKey: Alibaba Cloud によって自動生成されたキー (RDS 管理のサービスキー (デフォルトサービス CMK)) を使用して、クラウドディスク暗号化を有効にします。

    • : カスタムキーを使用してクラウドディスク暗号化を有効にするか、現在のキーを置き換えます。例: 494c98ce-f2b5-48ab-96ab-36c986b6****。

    • disabled: クラウドディスク暗号化を無効にします。

  • DuckDB ベースの分析インスタンスを作成するための前提条件のワンクリック修正: duckdb_prepare_dependency

  • プライマリインスタンスのデータベースを DuckDB 列のストアデータベースとして一括で設定します。値は JSON 文字列です。例: {"dbNames": "db1,db2,db3", "accountName": "yourSuperAccountName"}。各項目は以下の通りです。
    • dbNames: DuckDB 列のストアデータベースに変換するデータベースの名前。複数のデータベース名はコンマ (,) で区切ります。

    • accountName: 特権ユーザー。特権ユーザーは 1 つだけ指定します。

  • インスタンスで CONNECT RLS を有効にしてデータベースの可視性をコントロール: 有効にする場合は true。

  • データベースで CONNECT RLS を有効にしてデータベースの可視性をコントロール: CONNECT RLS によって管理されるデータベース名。複数のデータベース名はコンマ (,) で区切ります。例: testdb1,testdb2。クライアントが CONNECT RLS が有効なデータベースに接続すると、クライアントが他のデータベースに対する CONNECT 権限を持っているかどうかに基づいてデータベースリストが表示されます。

ApsaraDB RDS for SQL Server の設定項目の値

  • エラーログのクリーンアップの特徴: 1 (クリーンアップの確認)。

  • クラウドディスク暗号化の特徴 (この特徴は、有効にした後は無効にできません):
    • serviceKey: Alibaba Cloud によって自動生成されたキー (RDS 管理のサービスキー (デフォルトサービス CMK)) を使用して、クラウドディスク暗号化を有効にします。

    • : カスタムキーを使用してクラウドディスク暗号化を有効にするか、現在のキーを置き換えます。例: 494c98ce-f2b5-48ab-96ab-36c986b6****。

true

ResourceGroupId

string

任意

リソースグループの ID。DescribeDBInstanceAttribute を呼び出してリソースグループ ID を取得できます。

rg-bp67acfmxazb4p****

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認する必要があります。トークンには ASCII 文字のみを使用でき、長さは 64 文字を超えることはできません。

6000170000591aed949d0f****

SwitchTime

string

任意

変更の効果が適用される時間。スペック変更はオフピーク時に実行することを推奨します。フォーマット: yyyy-MM-ddTHH:mm:ssZ (協定世界時 (UTC))。

2025-05-06T09:24:00Z

SwitchTimeMode

string

任意

スイッチオーバー時間。有効な値:

  • Immediate: 変更は直ちに効果が適用されます。

  • MaintainTime: 変更はメンテナンスウィンドウ中に効果が適用されます。ModifyDBInstanceMaintainTime を呼び出してメンテナンスウィンドウを変更できます。

Immediate

レスポンスフィールド

フィールド

型

説明

例

object

レスポンスパラメーター。

RequestId

string

リクエストの ID。

76364A52-E0AB-5CC8-9818-CF1DC482C092

例

成功レスポンス

JSONJSON

{
  "RequestId": "76364A52-E0AB-5CC8-9818-CF1DC482C092"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 %s DB Operation Failed:%s.
400 InvalidDBInstanceName.NotFound The specified DB instance name does not exist. 指定されたインスタンス ID が存在しません。インスタンス ID を確認して再試行してください。
400 MinorVersionNotSupport The current database minor version does not support the operation. インスタンスの現在のマイナーエンジンバージョンはこの操作をサポートしていません。マイナーエンジンバージョンのアップグレードをお試しください。
400 InvalidConfigName The ConfigName is not valid. 指定された ConfigName が有効ではありません。
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. パッケージ内のインスタンスは個別に操作できません。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 料金プランの価格結果が見つかりませんでした。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 実名認証が完了していないため、購入資格がありません。実名認証を完了するには、Expenses and Costs にログインしてください。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. アカウント残高が 0 未満です。購入を試みる前にアカウントに入金してください。
400 CommodityServiceCalling.Exception Failed to call commodity service. 商品サービスの呼び出しが失敗しました。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Alibaba Cloud は現在のリージョンの最適化と調整を計画しています。このリージョンのクラウドサービスは提供を終了します。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことはできません。ご理解とご支援のほどよろしくお願いいたします。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 購入したモジュールが無効です。有効なモジュールを購入してください。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. 指定されたリージョンは廃止されました。
400 Price.CommoditySys Commodity system call exception. 商品システムの呼び出し時に例外が発生しました。
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 選択したサブスクリプション期間が無効です。別のサブスクリプション期間を選択してください。
400 pay.noCreditCard Account not bound to credit card. アカウントにクレジットカードが関連付けられていません。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 選択したサービスに未払いの注文が存在します。新規注文を行う前に、既存の注文の支払いを行うか、キャンセルしてください。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. アカウントに支払方法が指定されていません。支払方法を追加してください。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 情報が不完全です。続行する前に情報を補完してください。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. アカウントに異常があります。詳細については、カスタマーサービスにお問い合わせください。
400 Api.NotSupport Specified api is not supported. 現在の操作はサポートされていません。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 注文をブロックするタグが存在します。この問題を解決するには、ディストリビューターにお問い合わせください。
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 指定されたインスタンスが存在しません。インスタンスが存在し、削除されていないかどうかを確認してください。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 現在のインスタンスタイプはこのストレージタイプをサポートしていません。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 操作が失敗しました。パラメーターが無効です。
400 KmsApiError User secret key invalid. ユーザーキーが無効です。
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. アカウントが存在しません。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL コマンドの実行に失敗したか、またはタイムアウトしました。
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. インスタンスの現在の DPI エンジンバージョンはコールドデータアーカイブをサポートしていません。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 現在のカーネルバージョンはコールドデータアーカイブをサポートしていません。
400 IncorrectTargetClasscode The current instance type does not support this operation. 現在のインスタンスタイプでは、この操作はサポートされていません。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. エンドポイント名が重複しています。別の接続文字列を指定してください。
400 RequiredParam.NotFound Required input param is not found. 必須パラメーターが不足しています。
400 Parameters.Invalid Parameter error, please check the parameters. パラメーターが無効です。パラメーターを確認してください。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. コールドデータアーカイブは、クロスリージョンバックアップまたは高頻度スナップショットバックアップをサポートしていません。バックアップポリシーを確認してください。
400 InvalideStatus.Format The instance status does not support this operation. インスタンスステータスではこの操作はサポートされていません。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. インスタンスリリース後のアーカイブ済みバックアップデータの保持ポリシーが無効です。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. インスタンスのデータベースエンジンタイプでは、この操作はサポートされていません。
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。
400 MirrorInsExists Specified DB instance mirror ins already existed. データベースインスタンスのイメージはすでに存在します。
400 UnsupportedClassCode The specified DB instance class stops selling. このインスタンスタイプは購入できなくなりました。
400 InvalidBackupSet The specified database does not exist in the backup set. 指定されたデータベースがバックアップセットに存在しません。
400 OrdTCommodityQueryError Failed to query for product. プロダクトのクエリに失敗しました。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. インスタンスはリリースされました。注文を行う前にインスタンスを確認してください。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定されたリージョンは廃止されました。
400 InvalidSourceCategory specified source category is invalid. 指定されたソースカテゴリが無効です。
400 InvalidParameter Invalid parameter. パラメーターが無効です。
400 InvalidConfigValue The ConfigValue is not valid. 操作に失敗しました。指定されたパラメーター設定のセットが無効です。
400 InvalidParameters.Format Specified parameters is not valid. パラメーターが無効です。有効なパラメーターを指定してください。
400 DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance Current instance is already attached to another duckdb instance, operation is conflict. 現在のインスタンスは既に別の DuckDB ベースの分析インスタンスに関連付けられており、現在の DuckDB 読み取り操作と競合しています。
400 KmsServiceLinkedRoleNotGranted The service linked role is not granted, please check.
500 ExternalFailure The request processing has failed due to external service failure. リクエストが失敗しました。後でもう一度お試しください。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. リクエストが失敗しました。後でもう一度試すか、テクニカルサポートにお問い合わせください。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. ApsaraDB RDS API サービスのエラーにより、リクエストが失敗しました。
403 IncorrectDBInstanceType Current DB instance type does not support this operation. 操作が失敗しました。現在のデータベースインスタンスのエンジンおよびタイプはサポートされていません。
403 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation.
403 IncorrectDBInstanceState Current DB instance state does not support this operation. 操作が失敗しました。現在のインスタンスステータスではこの操作はサポートされていません。後でもう一度お試しください。
403 CloudDiskEncryptionNotSupport The encryption key is not allowed for general-purpose instance. 汎用インスタンスではクラウドディスクを暗号化することはサポートされていません。
403 OrderStatus.UnPaid The specified db instance has unpaid order. インスタンスに未払いの注文があります。注文の支払いを完了してから、もう一度お試しください。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. スペックダウンの対象容量は、現在のストレージ使用量より小さくすることはできません。
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD クラウドディスクでは、この操作はサポートされていません。ESSD にアップグレードしてください。
403 InvalidUserOperatorPermission The user permission does not support this operation. ユーザー権限ではこの操作はサポートされていません。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定された VSwitchId のフォームが無効であるか、または空です。
403 IncorrectMinorVersion Current engine minor version does not support operations. 現在のマイナーエンジンバージョンでは、この操作はサポートされていません。
403 OperationDenied.ZoneResource There is no available zone for inventory. 利用可能な在庫ゾーンが存在しません。
403 NotInFlowController Sorry,no permission. この操作は、エンタープライズユーザー以外のクラウドユーザーにはご利用いただけません。必須の権限がありません。
403 InvalidKmsKey Kms key is disabled. KMS キーが無効になっています。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 操作が失敗しました。指定された仕様コードは、指定されたエンドポイント数をサポートしていません。シャード数と現在のエンドポイント数を確認してください。
403 UnsupportedByBlueGreenDeployment Operation prohibited due to blue green deployment. ブルーグリーンデプロイメントが存在するため、この操作は許可されていません。
403 EncryptionKeyNotSupport The encryption key is not support to generate encryption disk. 指定されたキーは、クラウドディスクを暗号化するインスタンスの作成をサポートしていません。
403 IncorrectDBState The current DB state does not support this operation. 操作は失敗しました。現在のデータベースステータスが無効です。たとえば、データベースが作成中であるか、クラウドへの移行中です。
403 UnsupportedReadOrBakReadState Current DB instance has read or bak read running in unsupport states 現在のデータベースインスタンスは、読み取りまたはバックアップ読み取りが有効なサポートされていない状態で既に実行中です。ポートを確認してください。
403 IncorrectAccountPrivilegeType the current account privilege type does not support this operation. 現在のアカウント権限タイプでは、この操作はサポートされていません。
403 DBInstanceStatusNotActive The status of the current instance is not active. 操作が失敗しました。インスタンスの実行中ステータスを確認してください。
403 ReadOnlyInstanceNotSupport Read-only instance does not support this operation. 読み取り専用インスタンスはこの操作をサポートしていないため、操作に失敗しました。
403 Invalid.Parameter Specified parameters is not valid. 指定されたパラメーターが無効です。
403 TargetMajorVesionNotSupported The specified major version is not supported. ターゲットメジャーバージョンはサポートされていません。
403 ReadInstanceNotSupport Instances with read-only do not support this operation. 読み取り専用インスタンスを持つインスタンスでは、この操作はサポートされていません。
403 IncorrectDBInstance The current DB instance does not support this operation. 操作に失敗しました。現在のインスタンスはこの操作をサポートしていません。
404 InvalidDBInstance.NotFound Specified instance does not exist or not support. 指定されたインスタンスが存在しないか、この操作をサポートしていません。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 現在のインスタンスには Key Management サービスへのアクセス権限が付与されていません。
404 Request.NotFound The requested resource is not available. リクエストされたリソースは利用できません。
404 HostInfo.NotFound The specified host info is not found. 指定されたホスト情報がフォームまたはフォーマットに従っていません。
404 InvalidAccountName.NotFound The specified account is not found. アカウントが見つかりませんでした。アカウントを作成するかパスワードをリセットする場合は、アカウントを指定してください。
404 InvalidReadDBInstance.NotFound The specified read only database instance does not exist. 読み取り専用インスタンスが作成されていないか、リクエストのインスタンスパラメーターが有効ではありません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。