すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:DeleteBackup

最終更新日:Sep 18, 2026

ApsaraDB RDS インスタンスのデータバックアップファイルを削除します。

操作説明

サポート対象エンジン

  • ApsaraDB RDS for MySQL

  • ApsaraDB RDS for PostgreSQL

説明

高可用性エディションのインスタンスのみがサポートされています。

機能の説明

この操作を呼び出してデータバックアップファイルを削除する場合、インスタンス自体のバックアップセットのみが削除されます。読み取り専用インスタンス、ディザスタリカバリインスタンス、クローンインスタンスなどの関連インスタンスのバックアップセットは削除されません。

注意事項

この操作を呼び出す場合、インスタンスは以下の条件を満たしている必要があります。満たしていない場合、操作は失敗します。

  • インスタンスステータスが Running である。

  • ログバックアップが無効になっている場合、ApsaraDB RDS インスタンスはポイントインタイム復元をサポートしません。この場合、7 日以上前に生成されたデータバックアップファイルを削除できます。

  • ログバックアップが有効になっており、ログバックアップの保持期間がデータバックアップの保持期間よりも短い場合、ログバックアップの保持期間を超えたデータバックアップファイルを削除できます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

rds:DeleteBackup

delete

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DBInstanceId

string

必須

インスタンスの ID。DescribeDBInstances を呼び出してインスタンスの ID を照会できます。

rm-uf6wjk5****

BackupId

string

必須

バックアップセットの ID。DescribeBackups を呼び出してバックアップセットの ID を照会できます。複数の ID はコンマ (,) で区切ります。1 回のリクエストで最大 100 個の ID を指定できます。

説明

DescribeBackups の応答で StoreStatus が Enabled であるバックアップセットのみを削除できます。

32490****

レスポンスフィールド

フィールド

型

説明

例

object

レスポンス要素。

RequestId

string

リクエストの ID。

37441409-FFD1-40AA-8EC5-9ECF5E2F7C29

例

成功レスポンス

JSONJSON

{
  "RequestId": "37441409-FFD1-40AA-8EC5-9ECF5E2F7C29"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 ReadDBInstanceNotSupport The operation is not permitted due to type of the instance. 読み取り専用インスタンスでは、この操作は許可されていません。
400 ParameterLeastAssociate Must input at least one optional parameter 解凍時間とバックアップセットの両方を空にすることはできません。少なくともいずれか一方を指定して再試行してください。
400 DeleteBackupSetNumExceed Delete backup set number is more than 100. 削除するバックアップセットの数が 100 を超えています。
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. パッケージ内のインスタンスは個別に操作できません。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 料金プランの結果が見つかりませんでした。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 実名認証が完了していないため、購入する資格がありません。実名認証を完了するには、費用とコストにログインしてください。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. アカウント残高が 0 未満です。購入を試みる前にアカウントに入金してください。
400 CommodityServiceCalling.Exception Failed to call commodity service. 商品サービスの呼び出しに失敗しました。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Alibaba Cloud は現在のリージョンの最適化と調整を計画しており、このリージョンのクラウドサービスの操作は停止されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新しい購入注文を行うことはできません。ご理解とサポートのほどよろしくお願いいたします。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 購入したモジュールは無効です。モジュールを再度購入してください。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. 指定されたリージョンは廃止されています。
400 Price.CommoditySys Commodity system call exception. 商品システムの呼び出し時に例外が発生しました。
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 選択したサブスクリプション期間が無効です。別のサブスクリプション期間を選択してください。
400 pay.noCreditCard Account not bound to credit card. アカウントにクレジットカードが関連付けられていません。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 選択したサービスに未払いの注文が存在します。新しい注文を行う前に、既存の注文の支払いを行うか、キャンセルしてください。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. アカウントに支払方法が指定されていません。支払方法を追加してください。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 情報が不完全です。続行する前に情報の入力を完了してください。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. アカウントに異常があります。詳細については、カスタマーサービスにお問い合わせください。
400 Api.NotSupport Specified api is not supported. 現在の操作はサポートされていません。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 注文をブロックするタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 指定されたインスタンスは存在しません。インスタンスが存在し、削除されていないことを確認してください。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 現在のインスタンスタイプでは、このストレージタイプはサポートされていません。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 操作に失敗しました。パラメーターが無効です。
400 KmsApiError User secret key invalid. ユーザーキーが無効です。
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. アカウントが存在しません。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL コマンドの実行に失敗したか、タイムアウトしました。
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 現在のインスタンスの DPI エンジンバージョンでは、コールドデータアーカイブはサポートされていません。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 現在のカーネルバージョンでは、コールドデータアーカイブはサポートされていません。
400 IncorrectTargetClasscode The current instance type does not support this operation. 現在のインスタンスタイプではこの操作はサポートされていません。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. エンドポイント名が重複しています。別の接続文字列を指定してください。
400 RequiredParam.NotFound Required input param is not found. 必須パラメーターが不足しています。
400 Parameters.Invalid Parameter error, please check the parameters. パラメーターが有効ではありません。パラメーターを確認してください。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. コールドデータアーカイブは、クロスリージョンバックアップまたは高頻度スナップショットバックアップをサポートしていません。バックアップポリシーを確認してください。
400 InvalideStatus.Format The instance status does not support this operation. 現在のインスタンスステータスでは、この操作は実行できません。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. インスタンスリリース後のアーカイブ済みバックアップデータの保持ポリシーが有効ではありません。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. インスタンスのデータベースエンジンタイプでは、この操作はサポートされていません。
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. VPC ネットワークタイプのインスタンスでは、この操作はサポートされていません。
400 MirrorInsExists Specified DB instance mirror ins already existed. データベースインスタンスのイメージはすでに存在します。
400 UnsupportedClassCode The specified DB instance class stops selling. 指定されたインスタンスタイプは購入できなくなりました。
400 InvalidBackupSet The specified database does not exist in the backup set. 指定されたデータベースがバックアップセットに存在しません。
400 OrdTCommodityQueryError Failed to query for product. プロダクトのクエリに失敗しました。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. インスタンスはリリース済みです。注文前にインスタンスを確認してください。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定されたリージョンは廃止されています。
500 ExternalFailure The request processing has failed due to external service failure. リクエストが失敗しました。後でもう一度お試しください。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. リクエストが失敗しました。後でもう一度試すか、テクニカルサポートにお問い合わせください。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. RDS API サービスの障害により、リクエストは失敗しました。
403 IncorrectDBInstanceState Current DB instance state does not support this operation. 操作に失敗しました。現在のインスタンスステータスではこの操作はサポートされていません。しばらくしてから再試行してください。
403 IncorrectDBInstanceType Current DB instance engine and type does not support operations. 操作は失敗した。現在のデータベースインスタンスのエンジンとタイプはサポートされていません。
403 IncorrectDBInstanceCharacterType Current DB Instance character_type does not support this operation. データベースインスタンスの現在の文字タイプでは、この操作はサポートされていません。
403 OperationDenied.BackupSetDeleteNotSupport The Specified backup does not support this operation. 現在のバックアップセットは削除できません。
403 OrderStatus.UnPaid The specified db instance has unpaid order. インスタンスに未払いの注文があります。注文の支払いを完了してから、もう一度お試しください。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. スケールダウンのターゲット容量は、現在のストレージ使用量未満に設定できません。
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD クラウドディスクではこの操作はサポートされていません。ESSD にアップグレードしてください。
403 InvalidUserOperatorPermission The user permission does not support this operation. ユーザー権限が不足しているため、この操作はサポートされていません。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定された VSwitchId の形式が無効か、または空です。
403 IncorrectMinorVersion Current engine minor version does not support operations. 現在のエンジンのマイナーバージョンでは、この操作はサポートされていません。
403 OperationDenied.ZoneResource There is no available zone for inventory. 利用可能なゾーンに在庫がありません。
403 NotInFlowController Sorry,no permission. この操作はエンタープライズユーザー以外では利用できません。必須の権限がありません。
403 InvalidKmsKey Kms key is disabled. KMS キーが無効化されています。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 操作に失敗しました。指定された仕様コードでは、指定されたエンドポイント数がサポートされていません。シャード数と現在のエンドポイント数を確認してください。
403 Permission.NotSupport User's permission not support the action. 現在のアカウントのデータバックアップおよびログバックアップは、保護ポリシーの主題として扱われます。以下の操作はサポートされていません: バックアップの削除、バックアップ保持期間の短縮、またはバックアップ周波数の削減。
403 IncorrectBackupSetMethod Current backup set method does not support operations. 操作に失敗しました。指定されたバックアップセットでは、データベースとテーブルの復元はサポートされていません。
403 IncorrectBackupSetState Current backup set state does not support operations. 操作が失敗しました。現在のバックアップセットのステータスでは、この操作はサポートされていません。
404 InvalidDBInstanceName.NotFound Invalid DBInstanceId NotFound. 指定されたインスタンス ID は存在しません。インスタンス ID を確認して再試行してください。
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation. 操作に失敗しました。インスタンスはロック済みです。
404 InvalidBackupSetID.NotFound Specified backup set ID does not exist. バックアップセットが存在しません。既存のバックアップセットを確認してください。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 現在のインスタンスには、Key Management サービスへのアクセスが許可されていません。
404 Request.NotFound The requested resource is not available. リクエストされたリソースは利用できません。
404 HostInfo.NotFound The specified host info is not found. 指定されたホスト情報が存在しません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。