すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:CreateReadOnlyDBInstance

最終更新日:Aug 17, 2026

ApsaraDB RDS インスタンスの読み取り専用インスタンスを作成します。

操作説明

対象エンジン。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

rds:CreateReadOnlyDBInstance

create

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認する必要があります。トークンには ASCII 文字のみを使用でき、長さは 64 文字以下である必要があります。

ETnLKlblzczshOTUbOC****

RegionId

string

必須

リージョン ID。読み取り専用インスタンスのリージョンは、プライマリインスタンスのリージョンと同じである必要があります。DescribeRegions を呼び出してリージョン ID をクエリできます。

cn-hangzhou

ZoneId

string

必須

ゾーン ID。DescribeRegions を呼び出して利用可能なゾーンを照会できます。

  • インスタンスをシングルゾーンにデプロイする場合、cn-hangzhou-b のように 1 つのゾーン ID を指定します。

  • インスタンスを複数のゾーンにまたがってデプロイする場合、cn-hangzhou-b:cn-hangzhou-c のようにコロン (:) で区切って複数のゾーン ID を指定します。

  • 指定するゾーンの数は、読み取り専用インスタンスのノード数以下である必要があります。Basic Edition の読み取り専用インスタンスにはノードが 1 つのみ含まれます。高可用性シリーズの読み取り専用インスタンスにはノードが 2 つ(プライマリノード 1 つとセカンダリノード 1 つ)含まれます。

cn-hangzhou-b

DBInstanceId

string

必須

プライマリインスタンスの ID。DescribeDBInstances を呼び出してインスタンス ID をクエリできます。

rm-uf6wjk5****

DBInstanceClass

string

必須

インスタンスタイプ。詳細については、「読み取り専用インスタンスタイプ」をご参照ください。読み取り専用インスタンスのスペックは、プライマリインスタンスと同等以上であることを推奨します。そうでない場合、読み取り専用インスタンスで高レイテンシや高ロードが発生する可能性があります。

mysqlro.n2.small.1c

DBInstanceStorage

integer

必須

インスタンスストレージ容量。読み取り専用インスタンスのインスタンスストレージ容量は、プライマリインスタンスの容量以上である必要があります。詳細については、「読み取り専用インスタンスタイプ」の ストレージ容量 列をご参照ください。値は 5 GB フォーマットで増分されます。単位: GB。

20

EngineVersion

string

必須

データベースエンジンのバージョン。バージョンはプライマリインスタンスと同じである必要があります。

5.6

PayType

string

必須

課金方法。有効な値:

  • Postpaid: 従量課金。

  • Prepaid: サブスクリプション。

Postpaid

DBInstanceDescription

string

任意

インスタンスの説明。説明の長さは 2~256 文字で、英数字、アンダースコア (_)、ハイフン (-) を含めることができます。先頭は英字または漢字である必要があります。

testReadOnly

InstanceNetworkType

string

任意

読み取り専用インスタンスのネットワークタイプ。有効な値:

Classic

VPCId

string

任意

読み取り専用インスタンスの VPC ID。このパラメーターは、InstanceNetworkType が空または VPC に設定されている場合に必須です。

vpc-uf6f7l4fg90****

VSwitchId

string

任意

読み取り専用インスタンスの vSwitch ID。このパラメーターは、InstanceNetworkType が空または VPC に設定されている場合に必須です。

vsw-uf6adz52c2p****

PrivateIpAddress

string

任意

読み取り専用インスタンスの内部ネットワーク IP アドレスの設定項目。IP アドレスは、指定された vSwitch のアドレス範囲内である必要があります。デフォルトでは、システムは VPCId および VSwitchId の値に基づいて内部ネットワーク IP アドレスを自動的に割り当てます。

172.16.XX.XX

ResourceGroupId

string

任意

リソースグループの ID。

rg-acfmy****

Category

string

任意

インスタンスエディション。有効な値:

HighAvailability

DBInstanceStorageType

string

任意

インスタンスのストレージタイプ。有効な値:

  • local_ssd: Premium Local SSD

  • cloud_ssd: 標準 SSD

  • cloud_essd: PL1 ESSD

  • cloud_essd2: PL2 ESSD

  • cloud_essd3: PL3 ESSD

  • general_essd: Premium ESSD

説明
  • プライマリ ApsaraDB RDS for MySQL インスタンスが Premium Local SSD を使用している場合、このパラメーターには local_ssd のみを設定できます。プライマリ ApsaraDB RDS for MySQL インスタンスがクラウドディスクを使用している場合、このパラメーターにはクラウドディスクのストレージタイプのみを設定できます。

  • SQL Server はクラウドディスクのストレージタイプのみをサポートしています。

local_ssd

DedicatedHostGroupId

string

任意

専用クラスターの ID。このパラメーターは、専用クラスターに読み取り専用インスタンスを作成する場合に必須です。

dhg-4n****

TargetDedicatedHostIdForMaster

string

任意

プライマリインスタンスのホスト ID。このパラメーターは、専用クラスターに読み取り専用インスタンスを作成する場合に必須です。

i-bp****

GdnInstanceName

string

任意

予約済みパラメーター。このパラメーターを設定する必要はありません。

test

TddlBizType

string

任意

予約済みパラメーター。このパラメーターを設定する必要はありません。

test

TddlRegionConfig

string

任意

予約済みパラメーター。このパラメーターを設定する必要はありません。

test

InstructionSetArch

string

任意

予約済みパラメーター。このパラメーターを設定する必要はありません。

test

UsedTime

string

任意

サブスクリプション期間。有効な値:

  • Period が Year に設定されている場合、UsedTime は 1 から 5 まで設定できます。

  • Period が Month に設定されている場合、UsedTime は 1 から 9 まで設定できます。

説明

PayType が Prepaid に設定されている場合、このパラメーターは必須です。

1

Period

string

任意

サブスクリプションインスタンスの課金を年単位または月単位で行うかどうかを指定します。有効な値:

Month

AutoRenew

string

任意

インスタンスの自動更新を有効にするかどうかを指定します。このパラメーターは、サブスクリプションインスタンスを作成する場合にのみ有効です。有効な値:

  • true: 有効。

  • false: 無効。

説明
  • インスタンスを月額で購入した場合、自動更新サイクルは 1 か月です。

  • インスタンスを年額で購入した場合、自動更新サイクルは 1 年です。

true

DeletionProtection

boolean

任意

インスタンスのリリース保護特徴を有効にするかどうかを指定します。有効な値:

true

Port

string

任意

ApsaraDB RDS for MySQL プライマリインスタンスの読み取り専用インスタンスを作成する際に初期化されるポート。

3306

BurstingEnabled

boolean

任意

非推奨のパラメーター。このパラメーターを設定する必要はありません。

0

IsAnalyticReadOnlyIns

boolean

任意

プレミアムパフォーマンスディスク クラウドディスクの I/O バースト特徴を有効にするかどうかを指定します。有効な値:

false

AutoPay

boolean

任意

DuckDB ベースの分析インスタンスを作成するかどうかを指定します。有効な値:

  • true: 有効。

  • false: 無効。

説明

現在、DuckDB ベースの分析インスタンスの作成は、ApsaraDB RDS for MySQL および ApsaraDB RDS for PostgreSQL のみでサポートされています。

false

AutoCreateProxy

boolean

任意

自動支払いを有効にするかどうかを指定します。有効な値:

  • true: 自動支払いが有効になります。アカウントの残高が十分であることを確認してください。

  • false: 注文のみが生成され、支払いは行われません。

説明

デフォルト値: true。支払方法の残高が不足している場合は、AutoPay を false に設定できます。この場合、未払いの注文が生成されます。ApsaraDB RDS コンソールにログインして支払いを完了できます。

false

IoAccelerationEnabled

string

任意

データベースプロキシの自動作成が有効かどうかを示します。有効な値:

false

AutoUseCoupon

boolean

任意

プレミアムパフォーマンスディスククラウドディスクの Buffer Pool Extension (BPE) 機能を有効にするかどうかを指定します。有効な値:

0

PromotionCode

string

任意

クーポンを使用するかどうかを指定します。有効な値:

true

CustomExtraInfo

string

任意

クーポンコード。

71744626****

任意

予約済みパラメーター。このパラメーターを設定する必要はありません。

None

レスポンスフィールド

フィールド

型

説明

例

object

レスポンスパラメーター。

ConnectionString

string

作成された読み取り専用インスタンスの内部データベース接続エンドポイント。

rr-****.mysql.rds.aliyuncs.com

DBInstanceId

string

作成された読み取り専用インスタンスのインスタンス ID。

rr-uf6wjk5****

OrderId

string

注文 ID。

10078937****

Port

string

作成された読み取り専用インスタンスの内部データベース接続ポート。

3306

RequestId

string

リクエスト ID。

1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC

例

成功レスポンス

JSONJSON

{
  "ConnectionString": "rr-****.mysql.rds.aliyuncs.com",
  "DBInstanceId": "rr-uf6wjk5****",
  "OrderId": "10078937****",
  "Port": "3306",
  "RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2AA0724DC"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidEngineVersion.Malformed The specified parameter EngineVersion is not valid.
400 InvalidNetworkTypeClassicWhenCloudStorage The Specified InstanceNetworkType value Classic is not valid when choose cloud storage type. クラウドストレージタイプが選択されている場合、InstanceNetworkType を Classic に設定することは無効であり、有効な値ではありません。
400 InvalidSecurityIPList.Malformed The specified parameter SecurityIPList is not valid.
400 InvalidSecurityIPList.Duplicate The Security IP address is not in the available range or occupied. 指定されたセキュリティ IP リストは有効ではありません。重複する値が含まれています。
400 InvalidParameter The specified parameter dbInstanceId is not valid.
400 OperationDenied VPC IP is in use, please check. インスタンスタイプはこの操作をサポートしていません。
400 InvalidZoneId.NotSupported The Specified vpc Zone not supported. 現在のゾーンでは、VPC ネットワークタイプを使用するインスタンスの作成はサポートされていません。別のゾーンで VPC を作成するか、このネットワークタイプをサポートするゾーンを選択してください。
400 InvalidAvZone.NotSupport Specified availableArea multiZone does not support in RDS. 指定された availableArea マルチゾーンは ApsaraDB RDS ではサポートされていません。
400 CDDC.AvailableHostsNotEnoughInZone Not enough available hosts are in the target zone. ターゲットゾーンに十分なホストリソースがありません。 해당 ゾーンにホストを作成してください。
400 InvalidReadEngineVersionPattern The engine versions of the primary instance and the read-only instance do not match. プライマリインスタンスと読み取り専用インスタンスの engineVersion が一致しません。
400 InvalidDBInstanceClass.Offline The specified instance type is no longer provided. Please specify another instance type. 選択したインスタンスタイプは廃止されました。別のインスタンスタイプを選択してください。
400 SYSTEM.CONCURRENT_OPERATE Concurrent operation is detected. システム内で同時実行中の操作が存在します。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 料金プランの価格結果が見つかりませんでした。
400 InvalidDBInstanceName.Duplicate Specified DB instance name already exists in the Aliyun RDS. インスタンス名が既に存在するため、操作は失敗しました。インスタンス名を変更して再試行してください。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 現在のインスタンスタイプは、指定されたストレージタイプをサポートしていません。
400 InvalidRequestId The request is copy, check your token. リクエストが重複しています。トークンを確認してください。
400 InvalidParam.InstanceNetworkType Creation of classic network instances is not supported. クラシックネットワーククラスは非推奨になりました。クラシックネットワークインスタンスの作成はサポートされていません。
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. パッケージインスタンスに対して個別の操作を行うことはできません。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 実名認証が完了していないため、購入資格がありません。料金・コスト管理にログインして実名認証を完了してください。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. アカウントの利用可能額が 0 未満です。購入を試みる前にアカウントをチャージしてください。
400 CommodityServiceCalling.Exception Failed to call commodity service. 商品サービスへの呼び出しに失敗しました。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Alibaba Cloud は現在のリージョンの最適化および調整を予定しています。このリージョンのクラウドサービスは終了されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことができません。ご理解とご支援のほどよろしくお願いいたします。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 購入したモジュールが無効です。有効なモジュールを購入してください。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. リージョンが廃止されました。
400 Price.CommoditySys Commodity system call exception. 商品システムの呼び出し時に例外が発生しました。
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 選択したサブスクリプション期間が無効です。有効な期間を選択してください。
400 pay.noCreditCard Account not bound to credit card. 利用可能なクレジットカードがありません。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 選択したサービスに未払いの注文があります。新しい注文を行う前に、既存の注文の支払いを完了するかキャンセルしてください。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. アカウントに支払方法が設定されていません。支払方法を追加してください。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 基本情報が不完全です。この操作を実行する前に、基本情報のフォームを完了させてください。フォーマットを確認してください。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. アカウントで例外が発生しました。詳細についてはカスタマーサービスにお問い合わせください。
400 Api.NotSupport Specified api is not supported. 現在の API オペレーションはサポートされていません。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 注文ブロックタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 指定された DBInstanceId が存在しません。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 入力パラメーターが無効です。
400 KmsApiError User secret key invalid. ユーザーキーが無効です。
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Alibaba Cloud アカウントが存在しないか、AccessKey が期限切れです。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL コマンドの実行に失敗したか、または時間切れになりました。
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 現在のインスタンスの DPI エンジンバージョンは、コールドデータアーカイブをサポートしていません。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 現在のカーネルバージョンは、コールドデータアーカイブをサポートしていません。
400 IncorrectTargetClasscode The current instance type does not support this operation. 現在のインスタンスの仕様では、この操作はサポートされていません。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. エンドポイント名が重複しています。接続文字列を再設定してください。
400 RequiredParam.NotFound Required input param is not found. 必須パラメーターが不足しています。
400 Parameters.Invalid Parameter error, please check the parameters. パラメーターが正しくありません。パラメーターを確認してください。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. 現在のバックアップポリシーではこの操作はサポートされていません。
400 InvalideStatus.Format The instance status does not support this operation. インスタンスステータスはこの操作をサポートしていません。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. インスタンスリリース後のアーカイブバックアップデータの保持ポリシーが無効です。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. インスタンスのデータベースエンジンタイプはこの操作をサポートしていません。
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。
400 MirrorInsExists Specified DB instance mirror ins already existed. 現在のデータベースインスタンスのイメージが既に存在します。読み取りを確認してください。
400 UnsupportedClassCode The specified DB instance class stops selling. このインスタンスタイプは購入できなくなりました。
400 InvalidBackupSet The specified database does not exist in the backup set. 指定されたデータベースがバックアップセットに存在しません。
400 OrdTCommodityQueryError Failed to query for product. プロダクトのクエリに失敗しました。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. インスタンスはリリースされています。注文を行う前にインスタンスを確認してください。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定されたリージョンが無効です。
400 InvalidVSwitchId.Format The specified vswitch Id format is incorrect. 指定された vSwitch ID のフォーマットが正しくありません。
400 InvalidParameterValue.NotStandard Invalid parameter format. 指定されたパラメーターのフォーマットが無効です。
400 AtLeastThreeVSwitchAvailableIp The primary vswitch requires at least three available IP addresses. プライマリ vSwitch には、少なくとも 3 つの利用可能な IP アドレスが必要です。
400 AtLeastTwoVSwitchAvailableIp The primary vswitch requires at least two available IP addresses. プライマリ vSwitch には、少なくとも 2 つの利用可能な IP アドレスが必要です。
400 DuckDBOperationConflictBetweenPrimaryAndReadOnlyInstance Current instance is already attached to another duckdb instance, operation is conflict. 現在のインスタンスは既に別の DuckDB インスタンスに関連付けられており、現在の DuckDB 読み取り操作と競合しています。
500 CannotDecreaseEssdPerfLevel cannot decrease cloud essd performance level.
500 InvalidEssdStorageSize invalid cloud essd storage size.
500 ExternalFailure The request processing has failed due to external service failure. サービスへのリクエストが失敗しました。後でもう一度お試しください。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. サービスリクエストに失敗しました。後でもう一度お試しいただくか、サポートにお問い合わせください。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. RDS API サービスの障害により、リクエストの処理が失敗しました。
403 OperationDenied.PrimaryDBInstanceStatus The operation is not permitted due to status of primary instance. 操作に失敗しました。専用クラスター内の Running 状態ではない ApsaraDB RDS インスタンスは移行できません。
403 InvalidReadStorageTypePattern The storage type of the primary instance and the read-only instance do not match.
403 IncorrectCharacterType Current DB instance character type does not support this operation. 現在のインスタンス文字タイプではこの操作はサポートされていません。
403 InvalidMultiparamZoneInfoList Zoneinfo list is invaild. 現在のプライマリゾーンが整合していません。プライマリインスタンスを移行できません。
403 OrderStatus.UnPaid The specified db instance has unpaid order. 現在のインスタンスに未払いの注文があります。注文の支払いを完了してから再試行してください。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. スケールダウンのターゲット容量を現在のストレージ使用量より小さくすることはできません。
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD ディスクはこの操作をサポートしていません。ESSD にアップグレードしてください。
403 InvalidUserOperatorPermission The user permission does not support this operation. ユーザー権限ではこの操作はサポートされていません。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定された VSwitchId のフォーマットが正しくないか、または空です。
403 IncorrectMinorVersion Current engine minor version does not support operations. 現在のマイナーバージョンでは、この操作はサポートされていません。
403 OperationDenied.ZoneResource There is no available zone for inventory. 利用可能な在庫リージョンがありません。
403 NotInFlowController Sorry,no permission. この特徴は利用できません。法人クラウドユーザーではないため、権限がありません。
403 InvalidKmsKey Kms key is disabled. KMS キーが無効化されています。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 現在のデータベースインスタンスレベルは、この操作をサポートしていません。
403 BasicCategoryNotSupport The Basic category is not supported. Basic Edition エディションはサポートされていません。
403 GuardDBInstanceNotSupport Guard instance does not support this operation. ディザスタリカバリインスタンスではこの操作はサポートされていません。
404 IncorrectDBInstanceConnType Current DB instance conn type does not support this operation.
404 InvalidDBInstance.NotFound The specified instance does not exist or is not supported. 指定されたインスタンスが見つかりませんでした。インスタンスが有効かどうかを確認してください。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 現在のインスタンスは Key Management Service へのアクセスを許可されていません。
404 Request.NotFound The requested resource is not available. リクエストされたリソースは利用できません。
404 HostInfo.NotFound The specified host info is not found. 指定されたホスト情報が存在しません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。