すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:CreateDatabase

最終更新日:Aug 18, 2026

ApsaraDB RDS インスタンスにデータベースを作成します。

操作説明

対応エンジン

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

rds:CreateDatabase

create

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
なし

リクエストパラメーター

パラメーター

必須 / 任意

説明

DBInstanceId

string

必須

インスタンス ID。 DescribeDBInstances API を呼び出して取得できます。

rm-uf6wjk5****

DBName

string

必須

データベース名。

説明
  • 名前は 2~64 文字の長さである必要があります。

  • 先頭は小文字で、末尾は小文字または数字である必要があります。

  • 小文字、数字、アンダースコア (_)、ハイフン (-) を使用できます。

  • 名前はインスタンス内で一意である必要があります。

  • 使用できない文字の詳細については、「予約語」をご参照ください。

rds_mysql

CharacterSetName

string

必須

文字セット。有効な値は次のとおりです:

  • MySQL/MariaDB: utf8、gbk、latin1、utf8mb4

  • SQL Server: Chinese_PRC_CI_AS、Chinese_PRC_CS_AS、SQL_Latin1_General_CP1_CI_AS、SQL_Latin1_General_CP1_CS_AS、Chinese_PRC_BIN

  • PostgreSQL では、文字セット、照合順序、文字分類を 文字セット,<照合順序>,<文字分類> のフォーマットで設定する必要があります。 例: UTF8,C,en_US.utf8
    • 文字セットの有効な値: KOI8U、UTF8、WIN866、WIN874、WIN1250、WIN1251、WIN1252、WIN1253、WIN1254、WIN1255、WIN1256、WIN1257、WIN1258、EUC_CN、EUC_KR、EUC_TW、EUC_JP、EUC_JIS_2004、KOI8R、MULE_INTERNAL、LATIN1、LATIN2、LATIN3、LATIN4、LATIN5、LATIN6、LATIN7、LATIN8、LATIN9、LATIN10、ISO_8859_5、ISO_8859_6、ISO_8859_7、ISO_8859_8、SQL_ASCII

    • 照合順序 の有効な値: SELECT DISTINCT collname FROM pg_collation; コマンドを実行して、利用可能な値を照会できます。 デフォルト値: C

    • 文字分類 の有効な値: SELECT DISTINCT collctype FROM pg_collation; コマンドを実行して、利用可能な値を照会できます。 デフォルト値: en_US.utf8

gbk

CollationName

string

任意

照合順序。 このパラメーターは、MySQL インスタンスでのみ有効です。 文字セットに一致する照合順序を指定します。 たとえば、文字セットが utf8mb4 の場合、照合順序は utf8mb4_bin または utf8mb4_general_ci のいずれかである必要があります。

gbk_chinese_ci

DBDescription

string

任意

データベースの説明。 説明は 2~256 文字の長さにする必要があります。 先頭はアルファベットまたは漢字にする必要があります。 説明には、数字、漢字、アルファベット、アンダースコア (_)、ハイフン (-) を使用できます。

testdb

AccountName

string

任意

AccountPrivilege

string

任意

レスポンスフィールド

フィールド

説明

object

レスポンスパラメーターです。

RequestId

string

リクエスト ID です。

5A77D650-27A1-4E08-AD9E-59008EDB6927

成功レスポンス

JSONJSON

{
  "RequestId": "5A77D650-27A1-4E08-AD9E-59008EDB6927"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 %s DB Operation Failed:%s.
400 EngineMigration.ActionDisabled Specified action is disabled while custins is in engine migration. インスタンスのエンジン移行中は、指定された操作は無効になります。
400 Database.ConnectError Database connect error. please check instance status and database processlist データベース接続が異常です。インスタンスステータスとデータベース接続プールを確認してください。
400 InvalidDescription.Format Specified description is not valid. 説明の内容が有効ではありません。
400 InvalidDBName.Forbid Specified DB name is a keyword in RDS. データベース名の設定に失敗しました。パラメーターの命名にキーワードを使用することはできません。DBName はキーワードです。パラメーター名を変更してください。
400 InvalidAccountName.Forbid Specified account name is a keyword in RDS. アカウント名に予約キーワードが含まれているため無効です。アカウント名を変更してください。
400 InvalidAccountPrivilege.Malformed Specified account privilege is not valid. アカウントに十分な権限がありません。
400 IncorrectDBInstanceServiceType Current DB instance top type does not support this operation. 操作が失敗しました。現在のデータベースインスタンスの top タイプではこの操作はサポートされていません。
400 Database.AddError Create Db failed, please check input value and instance status. データベースの作成に失敗しました。入力パラメーターとインスタンスステータスを確認してください。
400 Database.QueryError invalid value, may include special character. 値が無効で、特殊文字が含まれている可能性があります。
400 SqlExcutionFailed Due to the limit number you can't create a database. このデータベースは削除できません。
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL コマンドの実行に失敗したか、または時間切れになりました。
400 InvalidDBInstanceIdOrDBInstanceName The specified params DBInstanceId or DBInstanceName should not be empty. 指定されたパラメーター DBInstanceId または DBInstanceName を空にすることはできません。
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. パッケージインスタンスに対して個別の操作を行うことはできません。
400 Price.PricingPlanResultNotFound Pricing plan price result not found. 料金プランの価格結果が見つかりませんでした。
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. 実名認証が完了していないため、購入資格がありません。料金・コスト管理にログインして実名認証を完了してください。
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. アカウントの利用可能額が 0 未満です。購入を試みる前にアカウントをチャージしてください。
400 CommodityServiceCalling.Exception Failed to call commodity service. 商品サービスへの呼び出しに失敗しました。
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Alibaba Cloud は現在のリージョンの最適化および調整を予定しています。このリージョンのクラウドサービスは終了されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことができません。ご理解とご支援のほどよろしくお願いいたします。
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. 購入したモジュールが無効です。有効なモジュールを購入してください。
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. リージョンが廃止されました。
400 Price.CommoditySys Commodity system call exception. 商品システムの呼び出し時に例外が発生しました。
400 Pay.InsufficientBalance Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. 選択したサブスクリプション期間が無効です。有効な期間を選択してください。
400 pay.noCreditCard Account not bound to credit card. 利用可能なクレジットカードがありません。
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. 選択したサービスに未払いの注文があります。新しい注文を行う前に、既存の注文の支払いを完了するかキャンセルしてください。
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. アカウントに支払方法が設定されていません。支払方法を追加してください。
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. 基本情報が不完全です。この操作を実行する前に、基本情報のフォームを完了させてください。フォーマットを確認してください。
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. アカウントで例外が発生しました。詳細についてはカスタマーサービスにお問い合わせください。
400 Api.NotSupport Specified api is not supported. 現在の API オペレーションはサポートされていません。
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. 注文ブロックタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. 指定された DBInstanceId が存在しません。
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type 現在のインスタンスタイプは、指定されたストレージタイプをサポートしていません。
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. 入力パラメーターが無効です。
400 KmsApiError User secret key invalid. ユーザーキーが無効です。
400 System.SaleValidateFailed Sales expression validation system error.
400 Abs.InvalidAccount.NotFound account is not found. Alibaba Cloud アカウントが存在しないか、AccessKey が期限切れです。
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. 現在のインスタンスの DPI エンジンバージョンは、コールドデータアーカイブをサポートしていません。
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. 現在のカーネルバージョンは、コールドデータアーカイブをサポートしていません。
400 IncorrectTargetClasscode The current instance type does not support this operation. 現在のインスタンスの仕様では、この操作はサポートされていません。
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. エンドポイント名が重複しています。接続文字列を再設定してください。
400 RequiredParam.NotFound Required input param is not found. 必須パラメーターが不足しています。
400 Parameters.Invalid Parameter error, please check the parameters. パラメーターが正しくありません。パラメーターを確認してください。
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. 現在のバックアップポリシーではこの操作はサポートされていません。
400 InvalideStatus.Format The instance status does not support this operation. インスタンスステータスはこの操作をサポートしていません。
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. インスタンスリリース後のアーカイブバックアップデータの保持ポリシーが無効です。
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. インスタンスのデータベースエンジンタイプはこの操作をサポートしていません。
400 Pay.NoCreditCard No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。
400 MirrorInsExists Specified DB instance mirror ins already existed. 現在のデータベースインスタンスのイメージが既に存在します。読み取りを確認してください。
400 UnsupportedClassCode The specified DB instance class stops selling. このインスタンスタイプは購入できなくなりました。
400 InvalidBackupSet The specified database does not exist in the backup set. 指定されたデータベースがバックアップセットに存在しません。
400 OrdTCommodityQueryError Failed to query for product. プロダクトのクエリに失敗しました。
400 ProductInstanceReleased The instance has been released. Please check before placing the order. インスタンスはリリースされています。注文を行う前にインスタンスを確認してください。
400 RegionEndTimeDissolvedIndia The region is no longer supported. 指定されたリージョンが無効です。
400 InvalidCharacter.DbOrAccount The database name or account name contains invalid characters. データベース名またはアカウント名に無効な文字が含まれています。
400 InvalidDBName.Duplicate Specified DB name already exists in the This instance. 現在のデータベース名が無効です。データベース名を再設定してください。
400 InvalidCollationName.Format Specified collation name is not valid. 照合順序のフォーマットが正しくありません。このパラメーターは MySQL インスタンスに対してのみ効果があり、文字セットに対応している必要があります。
500 ExternalFailure The request processing has failed due to external service failure. サービスへのリクエストが失敗しました。後でもう一度お試しください。
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. サービスリクエストに失敗しました。後でもう一度お試しいただくか、サポートにお問い合わせください。
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. RDS API サービスの障害により、リクエストの処理が失敗しました。
403 OrderStatus.UnPaid The specified db instance has unpaid order. 現在のインスタンスに未払いの注文があります。注文の支払いを完了してから再試行してください。
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. スケールダウンのターゲット容量を現在のストレージ使用量より小さくすることはできません。
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd. SSD ディスクはこの操作をサポートしていません。ESSD にアップグレードしてください。
403 InvalidUserOperatorPermission The user permission does not support this operation. ユーザー権限ではこの操作はサポートされていません。
403 InvalidVswitchId Specified conn vswitch id is not valid. 指定された VSwitchId のフォーマットが正しくないか、または空です。
403 IncorrectMinorVersion Current engine minor version does not support operations. 現在のマイナーバージョンでは、この操作はサポートされていません。
403 OperationDenied.ZoneResource There is no available zone for inventory. 利用可能な在庫リージョンがありません。
403 NotInFlowController Sorry,no permission. この特徴は利用できません。法人クラウドユーザーではないため、権限がありません。
403 InvalidKmsKey Kms key is disabled. KMS キーが無効化されています。
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. 現在のデータベースインスタンスレベルは、この操作をサポートしていません。
403 UnsupportedByBlueGreenDeployment Operation prohibited due to blue green deployment. ブルーグリーン Deployment が存在するため、この操作は許可されていません。
403 IncorrectDBInstanceType Current DB instance type does not support this operation. 操作が失敗しました。現在のインスタンスステータスでは、この操作はサポートされていません。
404 InvalidDBInstanceName.NotFound The database instance does not exist. 指定されたインスタンスが存在しないか、またはサポートされていません。
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. 現在のインスタンスは Key Management Service へのアクセスを許可されていません。
404 Request.NotFound The requested resource is not available. リクエストされたリソースは利用できません。
404 HostInfo.NotFound The specified host info is not found. 指定されたホスト情報が存在しません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。