ApsaraDB RDS インスタンスの SSL リンク構成を変更します。
操作説明
サポートされている DPI エンジン
ApsaraDB RDS for MySQL
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
関連特徴のドキュメント
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
rds:ModifyDBInstanceSSL |
update |
*DBInstance
|
|
なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| DBInstanceId |
string |
必須 |
インスタンスの ID。DescribeDBInstances を呼び出してインスタンス ID を取得できます。 |
rm-uf6wjk5**** |
| ConnectionString |
string |
必須 |
サーバー証明書を作成または更新する内部エンドポイントまたはパブリックエンドポイント。 |
rm-uf6wjk5****.mysql.rds.aliyuncs.com |
| SSLEnabled |
integer |
任意 |
SSL を有効または無効にするかどうかを指定します。有効な値:
|
1 |
| CAType |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for MySQL および ApsaraDB RDS for PostgreSQL インスタンスの証明書のタイプ。有効な値:
説明
このパラメーターは、SSLEnabled が 1 に設定されている場合に必須です。 |
aliyun |
| ServerCert |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for MySQL および ApsaraDB RDS for PostgreSQL インスタンスのサーバーのカスタム証明書コンテンツ。 説明
このパラメーターは、CAType が custom に設定されている場合に必須です。 |
-----BEGIN CERTIFICATE-----MIID*****QqEP-----END CERTIFICATE----- |
| ServerKey |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for MySQL および ApsaraDB RDS for PostgreSQL インスタンスのサーバー証明書の秘密鍵。 説明
このパラメーターは、CAType が custom に設定されている場合に必須です。 |
-----BEGIN PRIVATE KEY-----MIIE****ihfg==-----END PRIVATE KEY----- |
| ClientCAEnabled |
integer |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスのクライアント認証局 (CA) 公開鍵を有効にするかどうかを指定します。有効な値:
|
1 |
| ClientCACert |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスのクライアント証明書認証局の公開鍵。 説明
このパラメーターは、ClientCAEnabled が 1 に設定されている場合に必須です。 |
-----BEGIN CERTIFICATE-----MIID*****viXk=-----END CERTIFICATE----- |
| ClientCrlEnabled |
integer |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスのクライアント証明書失効リスト (CRL) を有効にするかどうかを指定します。有効な値:
説明
このパラメーターは、ClientCAEnabled が 1 に設定されている場合にのみ設定できます。 |
1 |
| ClientCertRevocationList |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスのクライアント証明書失効リストファイル。 説明
このパラメーターは、ClientCrlEnabled が 1 に設定されている場合に必須です。 |
-----BEGIN X509 CRL-----MIIB****19mg==-----END X509 CRL----- |
| ACL |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスの認証方式。有効な値:
説明
このパラメーターは、ClientCAEnabled が 1 に設定されている場合にのみ設定できます。 |
cert |
| ReplicationACL |
string |
任意 |
クラウドディスクを備えた ApsaraDB RDS for PostgreSQL インスタンスのレプリケーション権限の認証方式。有効な値:
説明
このパラメーターは、ClientCAEnabled が 1 に設定されている場合にのみ設定できます。 |
cert |
| ForceEncryption |
string |
任意 |
ApsaraDB RDS for MySQL および ApsaraDB RDS for SQL Server インスタンスの SSL 強制暗号化スイッチ。有効な値:
|
1 |
| TlsVersion |
string |
任意 |
ApsaraDB RDS for SQL Server インスタンスの TLS バージョンの最小値。指定されたバージョンより低い TLS バージョンのクライアントからの接続リクエストは拒否されます。有効な値: 1.0、1.1、1.2。 たとえば、このパラメーターを 1.1 に設定すると、サーバーは TLS 1.1 または TLS 1.2 を使用するクライアントからの接続リクエストのみを受け入れます。TLS 1.0 を使用するクライアントからの接続リクエストは拒否されます。 |
1.1 |
| Certificate |
string |
任意 |
ApsaraDB RDS for SQL Server インスタンスのカスタム証明書コンテンツ。pfx 証明書フォーマットのみがサポートされています。
|
oss-cn-beijing-internal.aliyuncs.com:zhttest:test.pfx |
| PassWord |
string |
任意 |
ApsaraDB RDS for SQL Server インスタンスのカスタム証明書のパスワード。 |
zht123456 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンスパラメーター。 |
||
| RequestId |
string |
リクエストの ID。 |
777C4593-8053-427B-99E2-105593277CAB |
例
成功レスポンス
JSONJSON
{
"RequestId": "777C4593-8053-427B-99E2-105593277CAB"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidServerCertOrPrivateKey | Specify server certificate or private key is invalid. | 指定されたサーバー証明書または秘密鍵が無効です。 |
| 400 | InvalidClientCACert | Specify client ca certificate is invalid. | 指定されたクライアント認証局 (CA) 証明書が無効です。 |
| 400 | InvalidClientCrl | Specify client certificate revocation list is invalid. | 指定されたクライアント証明書の失効リストが無効です。 |
| 400 | InvalidCAType.NotFound | Specify ca type is not found. | 指定されたサーバー証明書のタイプが無効です。 |
| 400 | InvalidACL.NotFound | Specify acl is not found. | 指定されたアクセスコントロールのタイプが無効です。 |
| 400 | InvalidSSLStatus | Specify ssl status is invalid. | 指定された SSL ステータスが無効なため、操作に失敗しました。 |
| 400 | IncorrectDBSslStatus | Specified DB SSLStatus does not support this operation. | 指定された DB SSLStatus では、この操作はサポートされていません。 |
| 400 | InvalidModifyMode.Format | Specified modify mode is not valid. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | パッケージ内のインスタンスは個別に操作できません。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 料金プランの価格結果が見つかりませんでした。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 実名認証が完了していないため、購入資格がありません。実名認証を完了するには、Expenses and Costs にログインしてください。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | アカウント残高が 0 未満です。購入を試みる前にアカウントに入金してください。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 商品サービスの呼び出しが失敗しました。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud は現在のリージョンの最適化と調整を計画しています。このリージョンのクラウドサービスは提供を終了します。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことはできません。ご理解とご支援のほどよろしくお願いいたします。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 購入したモジュールが無効です。有効なモジュールを購入してください。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | 指定されたリージョンは廃止されました。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品システムの呼び出し時に例外が発生しました。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 選択したサブスクリプション期間が無効です。別のサブスクリプション期間を選択してください。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | アカウントにクレジットカードが関連付けられていません。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 選択したサービスに未払いの注文が存在します。新規注文を行う前に、既存の注文の支払いを行うか、キャンセルしてください。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | アカウントに支払方法が指定されていません。支払方法を追加してください。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 情報が不完全です。続行する前に情報を補完してください。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | アカウントに異常があります。詳細については、カスタマーサービスにお問い合わせください。 |
| 400 | Api.NotSupport | Specified api is not supported. | 現在の操作はサポートされていません。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 注文をブロックするタグが存在します。この問題を解決するには、ディストリビューターにお問い合わせください。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 指定されたインスタンスが存在しません。インスタンスが存在し、削除されていないかどうかを確認してください。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 現在のインスタンスタイプはこのストレージタイプをサポートしていません。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 操作が失敗しました。パラメーターが無効です。 |
| 400 | KmsApiError | User secret key invalid. | ユーザーキーが無効です。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | アカウントが存在しません。 |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL コマンドの実行に失敗したか、またはタイムアウトしました。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | インスタンスの現在の DPI エンジンバージョンはコールドデータアーカイブをサポートしていません。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 現在のカーネルバージョンはコールドデータアーカイブをサポートしていません。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 現在のインスタンスタイプでは、この操作はサポートされていません。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | エンドポイント名が重複しています。別の接続文字列を指定してください。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 必須パラメーターが不足しています。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | パラメーターが無効です。パラメーターを確認してください。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | コールドデータアーカイブは、クロスリージョンバックアップまたは高頻度スナップショットバックアップをサポートしていません。バックアップポリシーを確認してください。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | インスタンスステータスではこの操作はサポートされていません。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | インスタンスリリース後のアーカイブ済みバックアップデータの保持ポリシーが無効です。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | インスタンスのデータベースエンジンタイプでは、この操作はサポートされていません。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | データベースインスタンスのイメージはすでに存在します。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | このインスタンスタイプは購入できなくなりました。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 指定されたデータベースがバックアップセットに存在しません。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | プロダクトのクエリに失敗しました。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | インスタンスはリリースされました。注文を行う前にインスタンスを確認してください。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 指定されたリージョンは廃止されました。 |
| 400 | MinorVersionNotSupport.SSLEnabled | Custins minor version does not support current action. | インスタンスのマイナーエンジンバージョンでは、この操作はサポートされていません。 |
| 400 | MinorVersionNotSupport | The current database minor version does not support the operation. | インスタンスの現在のマイナーエンジンバージョンはこの操作をサポートしていません。マイナーエンジンバージョンのアップグレードをお試しください。 |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | リクエストが失敗しました。後でもう一度お試しください。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | リクエストが失敗しました。後でもう一度試すか、テクニカルサポートにお問い合わせください。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | ApsaraDB RDS API サービスのエラーにより、リクエストが失敗しました。 |
| 403 | InvalidClientCrl.Permission | Client ca certificate is set first if need to set client certificate revocation list. | 必須の権限がないため、操作に失敗しました。まずクライアント CA 証明書の権限付与を設定してください。 |
| 403 | InvalidACL.Permission | Client ca certificate is set first if need to set acl. | 操作に失敗しました。まずクライアント CA 証明書の権限付与を設定してください。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | インスタンスに未払いの注文があります。注文の支払いを完了してから、もう一度お試しください。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | スペックダウンの対象容量は、現在のストレージ使用量より小さくすることはできません。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD クラウドディスクでは、この操作はサポートされていません。ESSD にアップグレードしてください。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | ユーザー権限ではこの操作はサポートされていません。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定された VSwitchId のフォームが無効であるか、または空です。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 現在のマイナーエンジンバージョンでは、この操作はサポートされていません。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 利用可能な在庫ゾーンが存在しません。 |
| 403 | NotInFlowController | Sorry,no permission. | この操作は、エンタープライズユーザー以外のクラウドユーザーにはご利用いただけません。必須の権限がありません。 |
| 403 | InvalidKmsKey | Kms key is disabled. | KMS キーが無効になっています。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 操作が失敗しました。指定された仕様コードは、指定されたエンドポイント数をサポートしていません。シャード数と現在のエンドポイント数を確認してください。 |
| 403 | MaxscaleMinorVersionNotSupport | The Maxscale version used by the instance is too low, please upgrade the Maxscale version first. | インスタンスのデータベースプロキシバージョンが古くなっています。まずデータベースプロキシバージョンをアップグレードしてください。 |
| 403 | UnsupportedByBlueGreenDeployment | Operation prohibited due to blue green deployment. | ブルーグリーンデプロイメントが存在するため、この操作は許可されていません。 |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | この操作はディザスタリカバリインスタンスではサポートされていません。 |
| 404 | Endpoint.NotFound | Specified endpoint is not existed. | 操作が失敗しました。指定されたエンドポイント情報が見つかりませんでした。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 現在のインスタンスには Key Management サービスへのアクセス権限が付与されていません。 |
| 404 | Request.NotFound | The requested resource is not available. | リクエストされたリソースは利用できません。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定されたホスト情報がフォームまたはフォーマットに従っていません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。