ApsaraDB MyBase 専用クラスターの情報を照会します。
操作説明
専用クラスターを使用すると、クラスター内の多数のインスタンスを一度に管理できます。1 つのリージョンに複数の専用クラスターを作成できます。各専用クラスターは複数のホストで構成されます。各ホストに複数のインスタンスを作成できます。詳細については、「ApsaraDB MyBase とは」をご参照ください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
rds:DescribeDedicatedHostGroups |
get |
*All Resource
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
必須 |
リージョン ID。DescribeRegions 操作を呼び出して、最新のリージョンリストを照会できます。 |
cn-hangzhou |
| DedicatedHostGroupId |
string |
任意 |
専用クラスター ID。 |
dhg-7a9xxxxxxxx |
| ImageCategory |
string |
任意 |
専用クラスター内のホストが作成されるベースとなるイメージ。有効値:
|
WindowsWithMssqlStdLicense |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンスパラメーター。 |
||
| DedicatedHostGroups |
object |
||
| DedicatedHostGroups |
array<object> |
返された専用クラスターに関する情報。 |
|
|
array<object> |
|||
| AllocationPolicy |
string |
システムが専用クラスターにリソースを割り当てる際のポリシー。有効値:
|
Evenly |
| BastionInstanceId |
string |
踏み台ホストの ID。 |
bastionhost-cn-m7xxxxxxxx |
| CpuAllocateRation |
number |
専用クラスターで割り当てられたコアの割合。単位:%です。 |
25 |
| CpuAllocatedAmount |
number |
専用クラスターで割り当てられたコア数。 |
8 |
| CpuAllocationRatio |
integer |
専用クラスターのコアオーバーコミットメント率。単位:%です。コアオーバーコミットメント率の詳細については、「専用クラスターの管理」をご参照ください。 |
200 |
| CreateTime |
string |
専用クラスターが作成されたときのタイムスタンプ。 |
1571125370000 |
| DedicatedHostCountGroupByHostType |
object |
専用クラスター内のホストに使用されるストレージメディアのタイプ。有効値:
|
dhg_cloud_ssd |
| DedicatedHostGroupDesc |
string |
専用クラスターの名前。 |
testHostGroup |
| DedicatedHostGroupId |
string |
専用クラスターの ID。 |
dhg-7a9xxxxxxxx |
| DiskAllocateRation |
number |
専用クラスターで割り当てられたディスク領域の割合。単位:%です。 |
0.49 |
| DiskAllocatedAmount |
number |
専用クラスターで割り当てられたディスク領域の量。単位:GB。 |
200 |
| DiskAllocationRatio |
integer |
専用クラスターのディスクオーバーコミットメント率。単位:%です。コアオーバーコミットメント率の詳細については、「専用クラスターの管理」をご参照ください。 |
200 |
| DiskUsedAmount |
number |
専用クラスターで使用されているディスク領域の量。単位:GB。 |
20 |
| DiskUtility |
number |
専用クラスターのディスク使用率。単位:%です。 |
0 |
| Engine |
string |
専用クラスター内のインスタンスのデータベースエンジン。 |
MySQL |
| HostNumber |
integer |
専用クラスター内のホストの総数。 |
3 |
| HostReplacePolicy |
string |
ホスト障害を処理するために使用されるポリシー。有効値:
|
Auto |
| InstanceNumber |
integer |
専用クラスター内のインスタンスの総数。 |
4 |
| MemAllocateRation |
number |
専用クラスターで割り当てられたメモリ領域の割合。単位:%です。 |
33.7 |
| MemAllocatedAmount |
number |
専用クラスターで割り当てられたメモリ領域の量。 |
16384 |
| MemAllocationRatio |
integer |
専用クラスターのメモリオーバーコミットメント率。単位:%です。コアオーバーコミットメント率の詳細については、「専用クラスターの管理」をご参照ください。 |
90 |
| MemUsedAmount |
number |
専用クラスターで使用されているメモリ領域の量。単位:MB。 |
0 |
| MemUtility |
number |
専用クラスターのメモリ使用量。単位:%です。 |
0 |
| OpenPermission |
string |
ホストの OS 権限を持つことを許可する機能が有効になっているかどうかを示します。有効値:
|
3 |
| Text |
string |
専用クラスターの名前と ID。値は DedicatedHostGroupDesc と DedicatedHostGroupId で構成されます。フォーマット:DedicatedHostGroupDesc/DedicatedHostGroupId。 |
testHostGroup/dhg-7a9xxxxxxxx |
| VPCId |
string |
専用クラスターが属する VPC (Virtual Private Cloud) の ID。 |
vpc-bp1oxxxxxx |
| ZoneIDList |
object |
||
| ZoneIDList |
array |
専用クラスターのホストが属するゾーン。 |
|
|
string |
専用クラスターのホストが属するゾーン。 |
cn-hangzhou |
|
| RequestId |
string |
リクエスト ID。 |
AB44DC0A-7E77-442A-97A9-C6418694CB22 |
例
成功レスポンス
JSONJSON
{
"DedicatedHostGroups": {
"DedicatedHostGroups": [
{
"AllocationPolicy": "Evenly",
"BastionInstanceId": "bastionhost-cn-m7xxxxxxxx",
"CpuAllocateRation": 25,
"CpuAllocatedAmount": 8,
"CpuAllocationRatio": 200,
"CreateTime": "1571125370000",
"DedicatedHostCountGroupByHostType": {
"test": "test",
"test2": 1
},
"DedicatedHostGroupDesc": "testHostGroup",
"DedicatedHostGroupId": "dhg-7a9xxxxxxxx",
"DiskAllocateRation": 0.49,
"DiskAllocatedAmount": 200,
"DiskAllocationRatio": 200,
"DiskUsedAmount": 20,
"DiskUtility": 0,
"Engine": "MySQL",
"HostNumber": 3,
"HostReplacePolicy": "Auto",
"InstanceNumber": 4,
"MemAllocateRation": 33.7,
"MemAllocatedAmount": 16384,
"MemAllocationRatio": 90,
"MemUsedAmount": 0,
"MemUtility": 0,
"OpenPermission": "3",
"Text": "testHostGroup/dhg-7a9xxxxxxxx",
"VPCId": "vpc-bp1oxxxxxx",
"ZoneIDList": {
"ZoneIDList": [
"cn-hangzhou"
]
}
}
]
},
"RequestId": "AB44DC0A-7E77-442A-97A9-C6418694CB22"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | Forbidden | User not authorized to operate on the specified resource. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。