すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:Express Connect、VPN Gateway、または Smart Access Gateway で接続されたセルフマネージド MySQL データベースを ApsaraDB RDS for MySQL インスタンスへ移行する

最終更新日:Sep 01, 2026

Data Transmission Service (DTS) を使用して、Express Connect、VPN Gateway、または Smart Access Gateway で接続されたセルフマネージド MySQL データベースを ApsaraDB RDS for MySQL インスタンスへ移行します。DTS は、構造移行、完全データ移行、増分データ移行をサポートしており、ダウンタイムを最小限に抑えることができます。

前提条件

  • セルフマネージド MySQL データベースのバージョンが 5.1、5.5、5.6、5.7、または 8.0 であること。

  • 移行先 ApsaraDB RDS for MySQL インスタンスのストレージ容量が、移行元 MySQL データベースより大きいこと。

  • セルフマネージドデータベースをホストしているオンプレミスネットワークが、Express Connect、VPN Gateway、または Smart Access Gateway 経由で Alibaba Cloud に接続されていること。

    説明

    接続のセットアップ手順については、「準備の概要」をご参照ください。

注意事項

  • 完全データ移行中、DTS はソースデータベースと移行先データベースの読み取りおよび書き込みリソースを消費するため、負荷が増加します。データベースのパフォーマンスが低い、仕様が低い、またはワークロードが高い場合 (たとえば、ソースデータベースに低速な SQL クエリやプライマリキーのないテーブルが多く存在する、または移行先データベースでデッドロックが発生するなど)、負荷の増加によってデータベースに負担がかかったり、サービスが中断したりする可能性があります。データ移行は、両方のデータベースの CPU 使用率が 30% 未満であるなど、オフピーク時に実行してください。

  • ソーステーブルにプライマリキーまたは一意制約がなく、一意でないデータが含まれている場合、移行先データベースに重複データが作成される可能性があります。

  • FLOAT または DOUBLE データ型の列の場合、DTS は ROUND(COLUMN,PRECISION) 関数を使用してその値を読み取ります。精度が明示的に定義されていない場合、DTS は FLOAT 値を 38 桁の精度で、DOUBLE 値を 308 桁の精度で移行します。これらの精度がビジネス要件を満たしていることを確認してください。

  • ソースデータベース名が ApsaraDB RDS の命名規則に違反している場合は、タスクを設定する前に、命名規則に準拠したデータベースを移行先インスタンスに作成する必要があります。そうでない場合、DTS はデータベースを自動的に作成します。

    説明

    命名規則とデータベースの作成方法の詳細については、「データベースとアカウントの作成」をご参照ください。

  • データ移行タスクが失敗した場合、DTS は自動的にタスクの再開を試みます。ビジネスワークロードを移行先インスタンスに切り替える前に、必ずタスクを停止または解放してください。これにより、自動的に再開されたタスクが、ソースデータベースのデータで移行先インスタンスのデータを上書きするのを防ぎます。

課金

移行タイプ

タスク構成料金

インターネットトラフィック料金

スキーマ移行および完全なデータ移行

無料です。

ターゲットデータベースの アクセス方法パブリック IP アドレス に設定されている場合、DTS はインターネットトラフィック料金を請求します。課金概要

増分データ移行

課金対象です。課金概要

移行タイプ

  • スキーマ移行

    DTS は、選択したオブジェクトのスキーマ定義を移行先インスタンスに移行します。DTS は、テーブル、ビュー、トリガー、ストアドプロシージャ、ストアドファンクションのスキーマ移行をサポートしています。

    説明
    • スキーマ移行中に、DTS はビュー、ストアドプロシージャ、および関数の DEFINER 属性を INVOKER に変換します。

    • DTS はユーザー情報を移行しないため、移行先データベースでビュー、ストアドプロシージャ、および関数を呼び出すには、呼び出し元に読み取りおよび書き込み権限を付与する必要があります。

  • 完全データ移行

    DTS は、セルフマネージド MySQL データベース内の選択されたオブジェクトから、すべての既存データを移行先の ApsaraDB RDS for MySQL インスタンスに移行します。

    説明

    完全データ移行中に INSERT 操作が同時に実行されると、移行先インスタンスでテーブルの断片化が発生する可能性があります。移行が完了すると、移行先データベースのテーブルスペースはソースデータベースよりも大きくなります。

  • 増分データ移行

    完全データ移行の後、DTS はソースのセルフマネージド MySQL データベースのバイナリログ (binlog) を読み取り、データの変更をキャプチャして移行先の ApsaraDB RDS for MySQL インスタンスに同期します。増分データ移行により、スムーズでダウンタイムを最小限に抑えたクラウドへの移行が可能になります。

増分移行の SQL 操作

操作タイプ

SQL 文

DML

INSERT、UPDATE、DELETE、REPLACE

DDL

  • ALTER TABLE、ALTER VIEW

  • CREATE FUNCTION、CREATE INDEX、CREATE PROCEDURE、CREATE TABLE、CREATE VIEW

  • DROP INDEX、DROP TABLE

  • RENAME TABLE

  • TRUNCATE TABLE

データベースアカウントに必要な権限

データベース

スキーマ移行

完全データ移行

増分データ移行

セルフマネージド MySQL データベース

SELECT

SELECT

REPLICATION SLAVE、REPLICATION CLIENT、SHOW VIEW、SELECT

ApsaraDB RDS for MySQL インスタンス

読み取りおよび書き込み権限

読み取りおよび書き込み権限

読み取りおよび書き込み権限

データベースアカウントの作成と権限付与については、以下をご参照ください。

事前準備

  1. セルフマネージド MySQL データベースのアカウントを作成してバイナリログを有効化する

  2. VPN Gateway 経由でオンプレミス IDC を DTS に接続する

操作手順

  1. DTS コンソールにログインします。

    説明

    Data Management (DMS) コンソールに自動的にリダイレクトされた場合は、右下隅の jiqiren アイコンをクリックし、返回旧版 をクリックして従来の DTS コンソールに戻ることができます。

  2. 左側のナビゲーションペインで、データの移行 をクリックします。

  3. [移行タスク] ページの上部で、宛先クラスターのリージョンを選択します。

  4. ページの右上隅にある 移行タスクの作成 をクリックします。

  5. 移行元および移行先データベースを構成します。

    カテゴリ

    設定

    説明

    該当なし

    タスク名

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定してください。一意である必要はありません。

    移行元データベース

    インスタンスタイプ

    [VPC アクセス付きセルフマネージドデータベース] を選択します。

    インスタンスリージョン

    Express Connect、VPN Gateway、または Smart Access Gateway に接続されている VPC のリージョンを選択します。

    ピア VPC

    Express Connect、VPN Gateway、または Smart Access Gateway に接続されている VPC を選択します。

    データベースタイプ

    MySQL を選択します。

    IP アドレス

    セルフマネージド MySQL データベースの IP アドレスを入力します。

    ポート

    自己管理型 MySQL データベースのサービスポートを入力します。デフォルト: 3306

    データベースアカウント

    セルフマネージド MySQL データベースのデータベースアカウントを入力します。必要な権限: データベースアカウントに必要な権限

    データベースパスワード

    移行元データベースアカウントのパスワードを入力します。

    説明

    ソースデータベース情報を入力した後、データベースのパスワード の横にある 接続テスト をクリックして、情報が正しいかどうかを確認できます。情報が正しい場合、合格 というメッセージが表示されます。メッセージが 失敗 と表示される場合は、失敗 の横にある チェック をクリックし、表示される指示に従ってソースデータベース情報を調整してください。

    移行先データベース

    インスタンスタイプ

    RDS インスタンス を選択します。

    インスタンスリージョン

    移行先 RDS インスタンスのリージョンを選択します。

    RDS インスタンス ID

    移行先 RDS インスタンスの ID を選択します。

    データベースアカウント

    移行先 RDS インスタンスのデータベースアカウントを入力します。必要な権限: データベースアカウントに必要な権限

    データベースパスワード

    移行先データベースアカウントのパスワードを入力します。

    説明

    宛先データベース情報を入力した後、データベースのパスワード の後に 接続テスト をクリックして、入力した情報が正しいかどうかを確認できます。情報が正しい場合、合格 というメッセージが表示されます。メッセージが 失敗 と表示される場合は、失敗 の後に チェック をクリックし、表示される指示に従って宛先データベース情報を調整してください。

    接続方法

    非暗号化 または SSL 暗号化 を選択します。 SSL 暗号化 を選択した場合は、まず RDS インスタンスの SSL 暗号化を有効にしてください (SSL 暗号化を設定する)。

    説明

    現在、暗号化 は、中国 (香港) リージョンおよび中国本土リージョンでのみ設定できます。

  6. [ホワイトリストを設定して次へ] をクリックします。

    移行元または移行先データベースが ApsaraDB RDS for MySQLApsaraDB for MongoDB インスタンスなどの Alibaba Cloud データベースインスタンスの場合、DTS は対応するリージョンの DTS サーバーの CIDR ブロックを Alibaba Cloud データベースインスタンスのホワイトリストに自動的に追加します。移行元または移行先データベースが Elastic Compute Service (ECS) インスタンスでホストされているセルフマネージドデータベースの場合、DTS は対応するリージョンの DTS サーバーの CIDR ブロックを ECS インスタンスのセキュリティルールに自動的に追加します。また、セルフマネージドデータベースが ECS インスタンスからのアクセスを許可していることを確認する必要があります。データベースが複数の ECS インスタンス上にクラスターとしてデプロイされている場合は、各 ECS インスタンスのセキュリティルールに DTS サーバーの CIDR ブロックを手動で追加する必要があります。移行元または移行先データベースがオンプレミス IDC 内のセルフマネージドデータベースまたは他のクラウドプロバイダーのデータベースの場合は、アクセスを許可するために DTS サーバーの CIDR ブロックを手動で追加する必要があります。DTS サーバーの CIDR ブロックについては、「DTS サーバーの IP アドレス」をご参照ください。

    警告

    DTS サーバーのパブリック CIDR ブロックを自動または手動で追加すると、セキュリティリスクが生じる可能性があります。本製品を使用することにより、これらの潜在的なリスクを認識し、受け入れるものとします。強力なパスワードの使用、開いているポートの制限、内部 API コールの認証の使用、不要なネットワークセグメントの定期的な確認と制限、または Express Connect、VPN Gateway、Smart Access Gateway などのプライベートネットワーク経由での接続など、基本的なセキュリティ対策を講じる責任はお客様にあります。

  7. 移行タイプとオブジェクトを選択します。

    設定

    説明

    移行タイプ

    • 完全移行のみを実行するには、スキーマ移行[完全データ移行] の両方を選択します。

    • ゼロダウンタイム移行を実行するには、スキーマ移行[完全データ移行][増分データ移行] を選択します。

    重要

    [増分データ移行] を選択しない場合は、データの一貫性を確保するために、完全データ移行中にソースデータベースに新しいデータを書き込まないでください。

    移行オブジェクト

    [利用可能] ボックスで、移行するオブジェクトをクリックし、向右小箭头 アイコンをクリックして 選択中のオブジェクト ボックスに追加します。

    重要
    • データベース、テーブル、列のレベルで移行するオブジェクトを選択できます。

    • デフォルトでは、オブジェクト名は移行後も保持されます。宛先データベースでオブジェクトの名前を変更する必要がある場合は、オブジェクト名マッピング機能を使用します。詳細については、「オブジェクト名マッピング」をご参照ください。

    • オブジェクト名マッピング機能を使用してオブジェクトの名前を変更すると、それに依存する他のオブジェクトの移行が失敗する可能性があります。

    オブジェクト名マッピング

    移行されたオブジェクトの名前を宛先インスタンスで変更する必要がある場合は、オブジェクト名マッピング機能を使用します。詳細については、「オブジェクト名マッピング」をご参照ください。

    接続再試行期間

    ソースまたは宛先データベースへの接続が中断された場合、DTS はデフォルトで 720 分 (12 時間) 再接続を試みます。この期間はカスタマイズできます。指定された時間内に DTS が正常に再接続すると、移行タスクは再開されます。それ以外の場合、タスクは失敗します。

    説明

    DTS インスタンスが再接続を試みている間、料金が発生します。不要な料金を避けるために、適切な再試行期間を設定するか、ソースおよび宛先データベースが解放された場合は速やかに DTS インスタンスを解放してください。

    DMS でのオンライン DDL 操作中に作成された一時テーブルをレプリケート

    Data Management (DMS) を使用してソースデータベースでオンライン DDL 操作を実行する場合、生成される一時テーブルを移行するかどうかを選択できます。

    • :オンライン DDL 操作によって生成された一時テーブルのデータを移行します。

      説明

      オンライン DDL 操作によって大量の一時テーブルデータが生成されると、移行タスクで高い遅延が発生する可能性があります。

    • ×:一時テーブルのデータを移行しません。ソースデータベースからの元の DDL データのみが移行されます。

      説明

      このオプションは、宛先データベースでテーブルロックを引き起こす可能性があります。

  8. 設定が完了したら、ページの右下隅にある [事前チェックと起動] をクリックします。

    説明
    • 移行タスクが開始される前に、DTS は事前チェックを実行します。タスクは、事前チェックに合格した場合にのみ開始できます。

    • 事前チェックが失敗した場合は、失敗した項目の横にある 提示 アイコンをクリックして詳細を表示します。

      • プロンプトに従って問題を修正し、事前チェックを再度実行します。

      • 警告項目を修正する必要がない場合は、無視 を選択し、[警告を無視して再実行] をクリックして事前チェックを再度実行できます。

  9. タスクが事前チェックに合格したら、次へ をクリックします。

  10. 表示される [設定の確認] ダイアログボックスで、インスタンスクラス を選択し、[Data Transmission Service (従量課金) 利用規約] チェックボックスにチェックを入れます。

  11. 購入して起動 をクリックして移行を開始します。

    • スキーマ移行 + 完全データ移行

      タスクが自動的に完了するのを待ちます。手動で停止すると、データが不完全になる可能性があります。

    • スキーマ移行 + 完全データ移行 + 増分データ移行

      移行タスクは自動的に停止しません。手動で停止する必要があります。

      重要

      オフピーク時や、ビジネスを宛先クラスターに切り替える準備ができたときなど、タスクを手動で停止する適切な時間を選択してください。

      1. 移行タスクが 増分データ移行 フェーズに入り、ステータスが 遅延なし と表示されるまで待ちます。次に、ソースデータベースへのデータ書き込みを数分間停止します。この間、増分データ移行 のステータスに遅延が発生する場合があります。

      2. 増分データ移行 のステータスが再び 遅延なし と表示されるのを待ちます。次に、移行タスクを手動で停止します。対象の移行タスクのチェックボックスにチェックを入れ、ページ下部の一括操作バーで [一時停止] をクリックします。

  12. サービスを ApsaraDB RDS for MySQL インスタンスに切り替えます。