エクストリーム NAS ファイルシステムの初期容量は最大使用可能容量です。ファイルシステムがいっぱいになると、書き込み操作は失敗します。書き込みの失敗によるサービス停止を防ぐため、ファイルシステムがいっぱいになる前に容量をスケールアップしてください。このトピックでは、エクストリーム NAS ファイルシステムをスケールアップする方法について説明します。
前提条件
エクストリーム NAS ファイルシステムが作成されていること。詳細については、「コンソールでエクストリーム NAS ファイルシステムを作成する」をご参照ください。
注意事項
エクストリーム NAS ファイルシステムをスケールアップする際は、次の点に注意してください:
-
ファイルシステムの状態が 実行中 である必要があります。そうでない場合、スケールアップできません。
-
スケールアップ処理中、ファイルシステムは最大 90 秒間利用できません。処理全体の完了までに、数分から数時間かかる場合があります。処理が完了するまで、I/O パフォーマンスが指定された目標に達しない可能性があります。業務への影響を最小限に抑えるため、オフピーク時間にスケールアップすることを推奨します。
-
ファイルシステムはスケールアップできますが、スケールダウンはできません。
-
2020 年 5 月 20 日より前に作成されたエクストリーム NAS ファイルシステムはバージョン 1、同日以降に作成されたものはバージョン 2 です。DescribeFileSystems 操作を呼び出して、ファイルシステムのバージョンを確認できます。
バージョン 1 のファイルシステムがサポートする最大容量は 32 TiB であり、スケールアップしても帯域幅は増加しません。バージョン 2 のファイルシステムは最大 256 TiB をサポートし、容量に応じて帯域幅とパフォーマンスの両方が向上します。詳細なパフォーマンスメトリクスについては、「エクストリーム NAS ファイルシステムの仕様」をご参照ください。
バージョン間の切り替えはできません。Data Transport を使用して、データをバージョン 2 のファイルシステムに移行することを推奨します。詳細については、「NAS ファイルシステム間でデータを移行する」をご参照ください。
-
スナップショットの作成中にファイルシステムをスケールアップしないでください。まず、スナップショットタスクが完了するまで待機するか、キャンセルする必要があります。これは、スケールアップ処理においてデータ保護のために独自のスナップショットが作成されるためです。
-
ファイルシステムの使用率が高いしきい値に達すると、ファイルの断片化の増加によってパフォーマンスが低下する可能性があります。使用率が 90% に達する前にファイルシステムをスケールアップすることを推奨します。
-
最適なパフォーマンスを実現するため、エクストリーム NAS はスケールアップ処理中に自動的にデータのリバランスを実行する場合があります。このリバランスにより、ディスクおよびネットワークの帯域幅の一部が消費され、一時的にパフォーマンスが低下する可能性があります。影響の程度と継続時間は、ファイルシステムのデータ量と I/O ワークロードによって異なります。
手順
-
NASコンソールにログインします。
左側のナビゲーションウィンドウで、ファイルシステム > ファイルシステムリスト を選択します。
-
上部のナビゲーションバーで、リージョンを選択します。
-
対象のファイルシステムを見つけ、操作 列で、をクリックします。
-
[スケールアウト] パネルの Extreme Capacity Configuration セクションで、スライダーを動かして容量を調整します。
容量は 100 GiB から 262,144 GiB の範囲で設定できます。重要:スケールアップ処理中、エクストリーム NAS ファイルシステムは最大 90 秒間利用できません。この操作はオフピーク時間に実行することを推奨します。
-
利用規約 エリアで利用規約を確認します。チェックボックスを選択する必要はありません。購入ボタンをクリックすると、製品の利用規約、関連するサービスレベルアグリーメント (SLA)、および選択した追加契約を読み、同意したものと見なされます。
-
今すぐ作成 をクリックし、画面の指示に従って購入を完了します。