すべてのプロダクト
Search
ドキュメントセンター

File Storage NAS:SetDirQuota

最終更新日:Jul 29, 2026

ファイルシステムのディレクトリクォータを設定します。

操作説明

ディレクトリクォータ特徴は、汎用 NAS ファイルシステムでのみサポートされています。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

nas:SetDirQuota

create

*FileSystem

acs:nas:{#regionId}:{#accountId}:filesystem/{#filesystemId}

なし なし

リクエストパラメーター

パラメーター

必須 / 任意

説明

FileSystemId

string

必須

ファイルシステムの ID。

1ca404****

Path

string

必須

ファイルシステム内のディレクトリの絶対パス。

説明
  • クォータを設定できるのは、NAS ファイルシステム内に作成済みのディレクトリのみです。クォータのディレクトリパスは、NAS ファイルシステム内の絶対パスであり、計算ノード(ECS インスタンスやコンテナなど)上のローカルパスではありません。

  • パス名に中国語文字が含まれるディレクトリはサポートされていません。

/data/sub1

QuotaType

string

必須

クォータタイプ。

有効な値:

  • Accounting: 統計クォータ。使用量のみを追跡します。

  • Enforcement: 制限クォータ。使用量が上限を超えると、ファイルやディレクトリの作成、データの追記などの操作が失敗します。

列挙値:

  • Enforcement :

    制限クォータ。

  • Accounting :

    統計クォータ。

Accounting。

UserType

string

必須

ユーザータイプ。

有効な値:

  • Uid: ユーザー ID

  • Gid: ユーザーグループ ID

  • AllUsers: すべてのユーザー

列挙値:

  • Uid :

    ユーザー ID。

  • Gid :

    ユーザーグループ ID。

  • AllUsers :

    すべてのユーザー。

Uid。

UserId

string

任意

制限対象の UID または GID。

このパラメーターは、UserType が Uid または Gid に設定されている場合にのみ必須かつ有効です。

例:

  • UID が 500 のユーザーを制限するには、UserType を Uid に、UserId を 500 に設定します。

  • GID が 100 のユーザーグループを制限するには、UserType を Gid に、UserId を 100 に設定します。

500

SizeLimit

integer

任意

ディレクトリ内のファイルの合計容量の上限。

単位: GiB。

QuotaType が Enforcement に設定されている場合、SizeLimit と FileCountLimit のうち少なくとも一方を指定する必要があります。

1024

FileCountLimit

integer

任意

ディレクトリ内のファイルの最大値。

これには、ファイル、ディレクトリ、および特殊ファイルが含まれます。

QuotaType が Enforcement にセットされている場合、SizeLimit と FileCountLimit のうち少なくとも一方を指定する必要があります。

10000

レスポンスフィールド

フィールド

説明

object

RequestId

string

リクエスト ID。

5BC5CB97-9F28-42FE-84A4-0CD0DF42****

Success

boolean

リクエスト状態。

有効な値:

  • true: リクエストが成功しました。

  • false: リクエストが失敗した。

true。

成功レスポンス

JSONJSON

{
  "RequestId": "5BC5CB97-9F28-42FE-84A4-0CD0DF42****",
  "Success": true
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

404 InvalidParameter.DirPathNotExist The Dir Path does not exist ディレクトリパスが存在しません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。