すべてのプロダクト
Search
ドキュメントセンター

Microservices Engine:イベント

最終更新日:Aug 25, 2026

Microservices Engine (MSE) コンソールのイベントセンターは、マイクロサービスレジストリ、マイクロサービスガバナンス、クラウドネイティブゲートウェイが生成するイベントデータを収集します。MSE で管理されているすべてのリソースのイベント変更を確認し、異常イベントに基づいて問題をトラブルシューティングできます。本トピックでは、MSE で生成される可能性のあるイベントについて説明し、各イベントの対処方法に関する推奨事項を提示します。

Nacos のイベント

イベントコード

イベント名

イベントの重大度

CloudMonitor イベント名

イベントの説明と影響

推奨される対処法

Nacos:TPSRateLimit

Nacos クライアントの TPS スロットリング

[Warning]

Nacos:TPSRateLimit:Normal

クライアントが Nacos エンジンにアクセスする際、1 秒あたりのトランザクション数 (TPS) が過度に高くなっています。Nacos エンジンの安定した動作を確保するため、システムはリクエストに対してスロットリングを実行しようとしています。この場合、Nacos インスタンスは監視モードになっています。TPS しきい値に達しても、後続のリクエストは引き続き許可されます。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、高い TPS が不適切な使用によって引き起こされていないか確認してください。たとえば、Nacos API が頻繁に呼び出されているか、Nacos クライアントが複数回作成されているかを確認します。

重大

Nacos:TPSRateLimit:Executing

クライアントが Nacos エンジンにアクセスする際、TPS が過度に高くなっています。Nacos エンジンの安定した動作を確保するため、システムはリクエストに対してスロットリングを実行します。TPS しきい値に達すると、後続のリクエストは拒否されます。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、高い TPS が不適切な使用によって引き起こされていないか確認してください。たとえば、Nacos API が頻繁に呼び出されているか、Nacos クライアントが複数回作成されているかを確認します。

Nacos:ConfigCapLimit

Nacos 設定数の制限

警告

Nacos:ConfigCapLimit:Normal

Nacos インスタンス内の設定数がデフォルトの上限 10,000 を超えています。システムは新しい設定に対してスロットリングを実行しようとしています。この場合、Nacos インスタンスは監視モードになっています。新しい設定は引き続き作成およびリリースできます。

早急に未使用の設定を削除し、アプリケーションが大量の設定を自動的にリリースしていないか確認してください。

重大

Nacos:ConfigCapLimit:Executing

Nacos インスタンス内の設定数がデフォルトの上限である 10,000 を超えたため、システムはユーザーによる設定の作成を許可しなくなりました。その結果、新しい設定をリリースできません。

早急に未使用の設定を削除し、アプリケーションが大量の設定を自動的にリリースしていないか確認してください。

Nacos:ServiceCapLimit

Nacos サービス数の制限

警告

Nacos:ServiceCapLimit:Normal

過剰な数のサービスが登録されており、ストレージの上限に達しています。Nacos エンジンの安定した動作を確保するため、システムはサービス登録に対してスロットリングを実行しようとしています。この場合、Nacos インスタンスは監視モードになっています。新しいサービスまたはサービスプロバイダーは引き続き Nacos インスタンスに登録できます。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、無効なサービスの公開、重複したサービスの公開、または Nacos クライアントが複数回作成されていないかを確認してください。

重大

Nacos:ServiceCapLimit:Executing

過剰な数のサービスが登録されており、ストレージの上限に達しています。Nacos エンジンの安定した動作を確保するため、システムはサービス登録を許可しなくなりました。その結果、新しいサービスまたはサービスプロバイダーを Nacos エンジンに登録できません。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、無効なサービスの公開、重複したサービスの公開、または Nacos クライアントが複数回作成されていないかを確認してください。

Nacos:ConnectionCapLimit

Nacos 接続数の制限

警告

Nacos:ConnectionCapLimit:Normal

Nacos エンジンに接続されているクライアントの数がインスタンスの上限に達しています。Nacos エンジンの安定した動作を確保するため、システムは新しい接続に対してスロットリングを実行しようとしています。この場合、Nacos インスタンスは監視モードになっています。新しい Nacos クライアントは引き続き Nacos エンジンに接続できます。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、不適切な使用がないか確認してください。たとえば、Nacos クライアントが複数回作成されているか、Nacos クライアントの有効化に起因する接続リークが発生していないかを確認します。

重大

Nacos:ConnectionCapLimit:Executing

Nacos エンジンに接続されているクライアントの数がインスタンスの上限に達しています。Nacos エンジンの安定した動作を確保するため、システムは新しい接続の確立を許可しなくなりました。その結果、新しい Nacos クライアントを Nacos エンジンに接続できません。

インスタンス構成をアップグレードするか、ノードをスケールアウトし、不適切な使用がないか確認してください。たとえば、Nacos クライアントが複数回作成されているか、Nacos クライアントの有効化に起因する接続リークが発生していないかを確認します。

Nacos:ParametersIllegalDenied

Nacos インスタンスの無効なリクエストパラメータ

警告

Nacos:ParametersIllegalDenied:Normal

クライアントから Nacos インスタンスに送信されたリクエストパラメータが無効です。サーバーは無効なパラメータを拒否しようとしています。この場合、Nacos インスタンスは監視モードになっています。正常な結果は引き続き返されます。

クライアントのリクエストパラメータが有効かどうかを確認してください。

重大

Nacos:ParametersIllegalDenied:Executing

クライアントから Nacos インスタンスに送信されたリクエストパラメータが無効です。サーバーは無効なパラメータを拒否し、エラーコードを返します。

クライアントのリクエストパラメータが有効かどうかを確認してください。

Nacos:CPUAlert

Nacos インスタンスの CPU 負荷が過度に高い

[Warning]

Nacos:CPUAlert:Executing

Nacos インスタンスの CPU 負荷が過度に高く、インスタンスが過負荷状態になっています。これにより、後続のリクエストに対する応答が遅延したり、応答しなくなったりする可能性があります。

インスタンス構成をアップグレードするか、インスタンスノードを追加し、高い CPU 負荷がインスタンスの不適切な使用によって引き起こされていないか確認してください。

Nacos:MemoryAlert

Nacos インスタンスのメモリ使用量が過度に高い

[Warning]

Nacos:MemoryAlert:Executing

Nacos インスタンスのメモリ使用量が過度に高く、メモリ不足 (OOM) キラーが実行される可能性があります。これにより、Nacos インスタンスのノードが再起動される可能性があります。

インスタンス構成をアップグレードしてください。

Nacos:FullGc

Nacos インスタンスのフル GC

[Warning]

Nacos:FullGc:Executing

頻繁なフルガベージコレクション (GC) により、Nacos インスタンスの容量が不足しています。これにより、後続のリクエストに対する応答が遅延したり、応答しなくなったりする可能性があります。

インスタンス構成をアップグレードするか、インスタンスノードを追加し、容量不足がインスタンスの不適切な使用によって引き起こされていないか確認してください。

Nacos:TooManyConfigAlert

Nacos インスタンスの設定数が過剰

[Warning]

Nacos:TooManyConfigAlert

Nacos インスタンスに対して作成しようとしている設定の数が 10,000 を超えています。超過した設定は作成できません。新しい設定のリリースが失敗する可能性があります。

不要な設定を削除してください。

Nacos:TooManyConfigLongPolling

Nacos インスタンスにおける過剰なロングポーリング

[Warning]

Nacos:TooManyConfigLongPolling

Nacos インスタンスに設定されているリスナーの数が過度に多く、過負荷の問題が発生しています。フル GC が頻繁にトリガーされる可能性があり、後続のリクエストに対する応答が遅延したり、応答しなくなったりする可能性があります。

インスタンス構成をアップグレードするか、インスタンスノードを追加し、容量不足がインスタンスの不適切な使用によって引き起こされていないか確認してください。

Nacos:ProviderDropTooFast

Nacos インスタンスにおけるプロバイダーの急激な減少

[Warning]

Nacos:ProviderDropTooFast:Executing

現在 Nacos インスタンスに登録されているサービスプロバイダーの数が、3 分前と比較して 50% 以上減少しています。このイベントが発生すると、上流サービスが下流サービスプロバイダーを認識できなくなる可能性があります。

大量のアプリケーションに障害が発生しているか、ネットワーク障害が発生していないかを確認してください。イベントが大量のアプリケーションの想定内のリリースによるものである場合は、イベントを無視できます。

ZooKeeper のイベント

イベントコード

イベント名

イベントの重大度

CloudMonitor イベント名

イベントの説明と影響

推奨される対処法

ZooKeeper:ExceedEphemeralLimit

ZooKeeper の単一セッションによって作成されたエフェメラルノードが制限を超過 (制限 = 2,000)

[Critical]

ZooKeeper:ExceedEphemeralLimit

単一のセッションによって作成されたエフェメラルノードの数が過度に多くなっています。これにより、セッションにエフェメラルノードを追加できなくなる可能性があります。

  • ビジネスコードに基づいて、作成されたエフェメラルノードの数が過剰でないか確認してください。

  • Dubbo を使用している場合は、Dubbo のバージョンを確認してください。バージョンが古い場合は、Dubbo を最新バージョンにアップグレードしてください。

  • Jute.Maxbuffer パラメータを追加して、障害から正常に回復できるようにしてください。

ZooKeeper:FullGc

ZooKeeper インスタンスのフル GC

[Warning]

ZooKeeper:FullGc:Executing

フル GC に長時間かかります。これにより処理レイテンシが増加し、応答タイムアウトが発生する可能性があります。その結果、ZooKeeper インスタンスのノードが障害から回復して再起動されます。

  • ZooKeeper のバージョンを確認してください。バージョンが古い場合は、ZooKeeper を最新バージョンにアップグレードしてください。

  • このイベントは容量不足が原因で発生します。このイベントが頻発する場合は、インスタンスにノードを追加することを推奨します。

ZooKeeper:CPUAlert

ZooKeeper インスタンスの CPU 負荷が過度に高い

[Warning]

ZooKeeper:CPUAlert:Executing

CPU 負荷が過度に高くなっています。これにより処理レイテンシが増加し、応答タイムアウトが発生する可能性があります。その結果、ZooKeeper インスタンスのノードが障害から回復して再起動されます。

このイベントは容量不足が原因で発生します。このイベントが頻発する場合は、インスタンスにノードを追加することを推奨します。

クラウドネイティブゲートウェイのイベント

イベントコード

イベント名

イベントの重大度

CloudMonitor イベント名

イベントの説明と影響

推奨される対処法

Gateway:ElasticScaleOut

クラウドネイティブゲートウェイの弾力的スケールアウト

[Warning]

Gateway:ElasticScaleOut:Failed

クラウドネイティブゲートウェイで弾力的スケールアウト操作が実行されると、クラウドネイティブゲートウェイはスケールアウトステータスに基づいてこのイベントを生成します。

コンソールのイベント詳細に基づいてイベントに対処してください。

[Info]

Gateway:ElasticScaleOut:Executing

必要に応じてイベント情報を参照してください。

[Info]

Gateway:ElasticScaleOut:Executed

必要に応じてイベント情報を参照してください。

Gateway:ElasticScaleIn

クラウドネイティブゲートウェイの弾力的スケールイン

[Warning]

Gateway:ElasticScaleIn:Failed

クラウドネイティブゲートウェイで弾力的スケールイン操作が実行されると、クラウドネイティブゲートウェイはスケールインステータスに基づいてこのイベントを生成します。

コンソールのイベント詳細に基づいてイベントに対処してください。

[Info]

Gateway:ElasticScaleIn:Executing

必要に応じてイベント情報を参照してください。

[Info]

Gateway:ElasticScaleIn:Executed

必要に応じてイベント情報を参照してください。

Gateway:ElasticOpen

クラウドネイティブゲートウェイの弾力的スケールアウトの有効化

[Warning]

Gateway:ElasticOpen:Failed

弾力的スケールアウトを有効にしようとすると、クラウドネイティブゲートウェイは有効化結果に基づいてこのイベントを生成します。

コンソールのイベント詳細に基づいてイベントに対処してください。

[Info]

Gateway:ElasticOpen:Executed

必要に応じてイベント情報を参照してください。

Gateway:ElasticClose

クラウドネイティブゲートウェイの弾力的スケールアウトの無効化

[Warning]

Gateway:ElasticClose:Failed

弾力的スケールアウトを無効にしようとすると、クラウドネイティブゲートウェイは無効化結果に基づいてこのイベントを生成します。

コンソールのイベント詳細に基づいてイベントに対処してください。

[Info]

Gateway:ElasticClose:Executed

必要に応じてイベント情報を参照してください。

Gateway:ElasticStrategyUpdate

クラウドネイティブゲートウェイの弾力性ポリシー更新

[Warning]

Gateway:ElasticStrategyUpdate:Failed

弾力的スケールアウトが有効になっている場合、クラウドネイティブゲートウェイは弾力的スケールアウトポリシーを更新し、更新結果に基づいてこのイベントを生成します。

コンソールのイベント詳細に基づいてイベントに対処してください。

[Info]

Gateway:ElasticStrategyUpdate:Executed

必要に応じてイベント情報を参照してください。

マイクロサービスガバナンスのイベント

イベントコード

イベント名

イベントの重大度

CloudMonitor イベント名

イベントの説明と影響

推奨される対処法

Governance:FlowTrafficBlock

アプリケーションのスロットリングルールのトリガー

[Warning]

Governance:FlowTrafficBlock:Executing

このイベントは、マイクロサービスガバナンスが有効になっているアプリケーションに設定されたインターフェーススロットリングルールがトリガーされたときに生成されます。

インターフェースでバーストトラフィックが発生しています。トラフィックの監視を継続することを推奨します。

Governance:CircleBreakerTrafficBlock

アプリケーションのサーキットブレークルールのトリガー

[Warning]

Governance:CircleBreakerTrafficBlock:Executing

このイベントは、マイクロサービスガバナンスが有効になっているアプリケーションに設定されたサーキットブレークルールがトリガーされたときに生成されます。

下流インターフェースのパフォーマンスが不安定な場合 (呼び出しの遅延やサービスの異常など)、下流インターフェースの依存関係を確認することを推奨します。

Governance:ParamsTrafficBlock

アプリケーションのホットスポットパラメータ保護ルールのトリガー

[Warning]

Governance:ParamsTrafficBlock:Executing

このイベントは、マイクロサービスガバナンスが有効になっているアプリケーションに設定されたホットスポットパラメータ保護ルールがトリガーされたときに生成されます。

ホットスポットパラメータが呼び出される場合は、関連するデータをプリフェッチすることを推奨します。

Governance:GracefulShutdown

マイクロサービスのグレースフルシャットダウン

[Info]

Governance:GracefulShutdown

このイベントは、マイクロサービスアプリケーションがグレースフルシャットダウンされるときに生成されます。アプリケーションでマイクロサービスガバナンスが有効になっている場合、グレースフルシャットダウン機能は自動的に有効になります。

必要に応じてイベント情報を参照してください。

Governance:RegistrationFinish

マイクロサービス登録の完了

[Info]

Governance:RegistrationFinish

このイベントは、グレースフル起動機能が有効になった後、マイクロサービスアプリケーションが登録されて起動されるときに生成されます。

必要に応じてイベント情報を参照してください。

Governance:WarmupStart

マイクロサービスのプリフェッチ開始

[Info]

Governance:WarmupStart

このイベントは、グレースフル起動機能が有効になった後、マイクロサービスガバナンスが有効になっているアプリケーションの新しいインスタンスがトラフィックのプリフェッチを開始するときに生成されます。

必要に応じてイベント情報を参照してください。

Governance:WarmupEnd

マイクロサービスのプリフェッチ完了

[Info]

Governance:WarmupEnd

このイベントは、グレースフル起動機能が有効になった後、マイクロサービスガバナンスが有効になっているアプリケーションの新しいインスタンスのトラフィックが完全にプリフェッチされたときに生成されます。

必要に応じてイベント情報を参照してください。

Governance:ReadinessFinish

マイクロサービスアプリケーションが Kubernetes Readiness チェックに合格

[Info]

Governance:ReadinessFinish

このイベントは、グレースフル起動機能が有効になった後、マイクロサービスガバナンスが有効になっているアプリケーションの Kubernetes Readiness チェックが完了したときに生成されます。

必要に応じてイベント情報を参照してください。

Governance:GracefulShutdown

マイクロサービスの手動無効化

[Info]

Governance:GracefulShutdown

マイクロサービスガバナンスのノード詳細ページでアプリケーションインスタンスを手動で無効化した場合に生成されます。この操作は Governance:GracefulShutdown イベントをトリガーします。

必要に応じてイベント情報を参照してください。

Governance:RegistrationFinish

マイクロサービスの手動有効化

[Info]

Governance:RegistrationFinish

マイクロサービスガバナンスのノード詳細ページでアプリケーションインスタンスを手動で有効化した場合に生成されます。この操作は Governance:RegistrationFinish イベントをトリガーします。

必要に応じてイベント情報を参照してください。

Governance:ApplicationStop

マイクロサービスアプリケーションのシャットダウン

[Info]

Governance:ApplicationStop

グレースフルシャットダウン機能が有効な場合、このイベントは、マイクロサービスガバナンスが有効になっているアプリケーションが停止する前に、グレースフルシャットダウンプロセスが完全に実行されたときに生成されます。

必要に応じてイベント情報を参照してください。