すべてのプロダクト
Search
ドキュメントセンター

Microservices Engine:クォータと制限

最終更新日:Aug 11, 2026

クォータは、Alibaba Cloud アカウント (プライマリアカウント) で利用可能なクラウドリソースまたはオペレーションの最大数を設定します。MSE リソースのクォータは、Quota Center で表示および管理できます。

MSE リソースのデフォルトクォータ

レジストリと設定

クォータ名

クォータコード

デフォルト

調整可能な最大値

説明

アカウントあたりの最大クラスター数

q_registry_clusters

100

200

終了したインスタンスは除きます。

単一の Nacos 設定の最大サイズ

q_nacos_config_size

100 KB

1 MB

Nacos インスタンスメタデータの最大長

q_nacos_meta_size

4,096 バイト

8,192 バイト

Nacos サーバーレスインスタンスの名前空間数

q_nacos_serverless_namespaces

20

30

標準 Nacos インスタンスの名前空間数 (Developer Edition)

q_nacos_dev_namespaces

20

30

標準 Nacos インスタンスの名前空間数 (Professional Edition、低スペック)

q_nacos_pro_low_namespaces

20

30

4 vCPU 未満の単一ノード

標準 Nacos インスタンスの名前空間数 (Professional Edition、高スペック)

q_nacos_pro_high_namespaces

40

80

4 vCPU 以上の単一ノード

標準 Nacos インスタンスの名前空間数 (Enterprise Edition、低スペック)

q_nacos_platinum_low_namespaces

50

100

Small.Platinum.x2

標準 Nacos インスタンスの名前空間数 (Enterprise Edition、高スペック)

q_nacos_platinum_high_namespaces

100

160

Medium.Platinum.x1 以上の仕様

Nacos サーバーレスインスタンスの設定数

q_nacos_serverless_cluster_configs

1,000

2,000

標準 Nacos インスタンスの設定数 (Developer Edition)

q_nacos_dev_cluster_configs

1,000

2,000

標準 Nacos インスタンスの設定数 (Professional Edition、低スペック)

q_nacos_pro_low_cluster_configs

1,000

2,000

4 vCPU 未満の単一ノード

標準 Nacos インスタンスの設定数 (Professional Edition、高スペック)

q_nacos_pro_high_cluster_configs

5,000

20,000

4 vCPU 以上の単一ノード

標準 Nacos インスタンスの設定数 (Enterprise Edition、低スペック)

q_nacos_platinum_low_cluster_configs

5,000

20,000

Small.Platinum.x2

標準 Nacos インスタンスの設定数 (Enterprise Edition、高スペック)

q_nacos_platinum_high_cluster_configs

20,000

50,000

Medium.Platinum.x1 以上の仕様

ZooKeeper の SASL ユーザー数

q_zk_sasl_user_count

10

50

マイクロサービスガバナンス

クォータ名

クォータコード

デフォルトクォータ

調整可能な最大値

名前空間数

q_msc_namespaces

200

300

スイムレーングループ内のアプリケーション数

q_msc_group_apps

100

150

名前空間内のスイムレーングループ数

q_msc_namespace_lane_group

50

70

スイムレーングループ内のスイムレーン数

q_msc_lane

50

70

スイムレーン内のルート数 (MSE ゲートウェイがフルリンクのグレースケールリリースのエントリポイントとして機能する場合に適用)

q_msc_lane_route

50

70

クォータを超えると、サービス登録が失敗します。サービスインスタンスのメタデータが Nacos インスタンスメタデータの最大長 (4,096 バイト) を超えると、Nacos Open API は次のエラーを返します:

Param 'Metadata' is illegal, the param length should not exceed 4096.

サービス登録が失敗した場合は、Quota Center または MSE コンソールのクォータ管理ページでクォータの使用状況を確認し、クォータを超過しているかどうかを判断してください。

説明

サービスインスタンスのメタデータサイズは、同じサービスコードを使用していても、環境 (たとえば、ステージング環境と本番環境) によって異なる場合があります。サービス登録が失敗した場合は、各環境の実際のメタデータサイズを比較して、q_nacos_meta_size クォータ (デフォルトで 4,096 バイト、最大 8,192 バイトまで調整可能) を超えているかどうかを判断してください。クォータを超過している場合は、Quota Center で q_nacos_meta_size のクォータ引き上げを申請してください。

MSE リソースクォータの変更

ワークロードでデフォルトのクォータで許可されているよりも多くの MSE リソースが必要な場合は、Quota Center を通じて引き上げを申請できます。

  1. Quota Center コンソール にログインします。左側のナビゲーションペインで、[Product List] > [General Quotas] を選択します。

  2. [General Quota Products] ページで、アプリケーションサービス カテゴリの下にある MSE マイクロサービス管理 または [MSE Registry and Configuration Center] をクリックします。

  3. [General Quotas List] ページで、リソースクォータの表示または引き上げができます。

    • クォータの表示:[Quota] 列には各リソースのクォータが表示され、[Used] 列には現在の使用量が表示されます。

    • クォータ引き上げの申請:操作 列で リクエスト をクリックします。表示される [Apply for Quota] ダイアログボックスで、パラメーターを設定し、[Confirm Change] をクリックします。

    説明
    • Nacos インスタンスのクォータ調整はすぐには有効になりません。クォータを調整する前に、インスタンスが実行中の状態であることを確認してください。

    • インスタンスのスケーリングや製品タイプの変換を行う場合は、対応するクォータを監視し、必要に応じて調整してください。

    • 安定性を確保するため、既存の Nacos インスタンスの設定数クォータは、現在の使用量に合わせて自動的に調整されます。このクォータをさらに引き上げるには、Quota Center で申請を提出してください。設定されたクォータは、新しいインスタンスに適用されます。

関連ドキュメント

  • クォータアラームを作成して、使用量が事前設定されたしきい値に達したときにアラートを受け取ることができます。これにより、事前にクォータの引き上げをリクエストできます。詳細については、「クォータアラーム」をご参照ください。

  • クォータの引き上げリクエストを送信した後、承認ステータスを確認できます。詳細については、「申請履歴の照会」をご参照ください。

  • 追加のクォータ操作については、「Quota Center」をご参照ください。