すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB for MongoDB:ストレージ分析

最終更新日:Aug 22, 2026

CloudDBA のストレージ分析では、ApsaraDB for MongoDB インスタンスのストレージ使用状況、傾向、例外の概要を確認できます。ストレージの異常を特定し、ディスクをデフラグして領域を回収することで、インスタンスの安定性を維持できます。

前提条件

ApsaraDB for MongoDB のレプリカセットまたはシャードクラスターインスタンスは、次のバージョン要件を満たす必要があります。

メジャーバージョン

マイナーバージョン

サポート対象

MongoDB 4.0

すべて

いいえ

MongoDB 4.2

4.2.0-4.2.22

いいえ

>= 4.2.23

はい

MongoDB 4.4

4.4.0-4.4.6

いいえ

>= 4.4.7

はい

MongoDB 5.0

すべて

はい

MongoDB 6.0

すべて

はい

MongoDB 7.0

すべて

はい

MongoDB 8.0

すべて

はい

注意事項

RAM ユーザーで CloudDBA のストレージ分析にアクセスする場合、RAM ユーザーに AliyunHDMFullAccess または AliyunHDMReadOnlyAccess 権限が付与されていることを確認してください。詳細については、「RAM ユーザーとして DAS を使用する方法」をご参照ください。

ストレージの分析

  1. ApsaraDB for MongoDB コンソールにログインします。

  2. 左側のナビゲーションペインで、インスタンスの種類に応じて レプリカセットインスタンス または シャードクラスターインスタンス をクリックします。

  3. ページの左上隅で、インスタンスが配置されているリソースグループとリージョンを選択します。

  4. 対象のインスタンスを見つけてその ID をクリックするか、操作 列の 管理 をクリックします。

  5. 左側のナビゲーションペインで、CloudDBA > 容量分析 をクリックします。

  6. データベースのストレージの概要を確認できます。

    • データベースとテーブルのストレージの概要の表示

      スペースの概要 タブをクリックすると、次の情報を確認できます。

      • ストレージ セクションで、ストレージの概要を確認できます。

        メトリック

        説明

        [異常]

        次の条件は例外と見なされます。

        • インスタンスのストレージ使用量が90%を超える。

        • データベースとテーブルの物理ストレージの推定残り日数が7日未満。

        • 単一コレクション内のインデックス数が10を超える。

        [先週の 1 日あたりの増加の平均]

        過去7日間のストレージ使用量の1日あたりの平均増加量。

        計算式: (データ収集時のストレージサイズ - 7 日前のストレージサイズ) / 7。

        説明
        • 増加率は、データ収集時点での7日間の平均値です。

        • このメトリックは、ワークロードが安定しているサービスに適しています。バッチデータインポート、履歴データの削除、またはインスタンスの移行と再作成などの急激なストレージ変更があると、このメトリックの精度が低下することがあります。

        [ストレージ使用可能日数]

        利用可能なストレージがなくなるまでの推定日数。残りのストレージ容量も表示されます。

        計算式: 利用可能な領域 / 過去1週間の日次平均増加量。

        説明
        • 90+ の値は、ディスク領域が長期間にわたって十分であると予測されることを示します。

        • このメトリックは、ワークロードが安定しているサービスに適しています。バッチデータインポート、履歴データの削除、またはインスタンスの移行と再作成などの急激なストレージ変更があると、このメトリックの精度が低下することがあります。

        [使用済み領域]

        合計ストレージサイズに対する使用済みストレージの割合。

      • 例外 セクションで、例外の詳細を確認し、ストレージの問題をトラブルシューティングします。

      • ストレージトレンド セクションで、過去1週間のデータベースとテーブルのストレージ使用量の推移を表示します。

      • テーブルスペース セクションで、各コレクションのデータ情報を表示します。

        説明

        注: コレクション名をクリックすると、そのインデックス情報を表示できます。

    • データとテーブルスペースの概要の表示

      データスペース タブをクリックすると、次の情報を確認できます。

      • データスペース名をクリックすると、そのテーブルスペース情報が表示されます。

      • コレクション名をクリックすると、そのインデックス情報が表示されます。

ディスクのデフラグ

重要

注意: ディスクのデフラグは、隠しノードに対してのみ実行できます。プライマリノードまたはセカンダリノードのディスクをデフラグするには、まずプライマリ/セカンダリ スイッチオーバーを実行してプライマリノードまたはセカンダリノードを隠しノードに変更してから、ディスクをデフラグする必要があります。または、compact コマンドを直接実行することもできます。詳細については、「ディスク使用率を向上させるためのディスクのデフラグ」をご参照ください。重要: 続行する前に、参照先のドキュメントをよくお読みください。

  1. ApsaraDB for MongoDB コンソールにログインします。

  2. 左側のナビゲーションペインで、インスタンスの種類に応じて レプリカセットインスタンス または シャードクラスターインスタンス をクリックします。

  3. ページの左上隅で、インスタンスが配置されているリソースグループとリージョンを選択します。

  4. 対象のインスタンスを見つけてその ID をクリックするか、操作 列の 管理 をクリックします。

  5. 左側のナビゲーションペインで、CloudDBA > 容量分析 をクリックします。

  6. 表領域 セクションで、断片化率 列の [回収] をクリックします。

  7. リサイクル ダイアログボックスで、ディスクをデフラグします。

    • デフラグのスケジュールを設定します。

      インスタンスのデフラグスケジュールを設定すると、DAS は毎日のメンテナンスウィンドウ中に隠しノード上のすべてのコレクションを自動的にスキャンします。データスペースとインデックススペースの合計サイズが 1 GB を超え、断片化率が20%を超えるコレクションでcompactコマンドを実行します。操作が長時間に及ぶのを防ぐため、各隠しノード上のすべてのコレクションの合計回収可能領域は、1回あたり 100 GB に制限されます。単一のコレクションの回収可能領域が 100 GB を超える場合は、デフラグタスクを手動で実行する必要があります。

    • ディスクを手動でデフラグします。

      断片化率の高いコレクションのリストで、対象のコレクションを見つけ、[操作] 列の 再利用の実行 をクリックします。次に、[今すぐ実行] または [O&M ウィンドウで実行] を選択して、領域の回収を開始します。

    説明
    • タスクを開始しても、ディスクのデフラグはすぐには完了しません。compact コマンドはバックグラウンドで実行され、断片化された領域を徐々に回収します。所要時間は回収可能な領域の量によって異なり、回収する領域が多いほど、処理に時間がかかります。

    • 同時に 10 を超えるコレクションをデフラグすることは避けてください。失敗を防ぐために、各タスクが完了するのを待ってから次のタスクを開始してください。

    • 対象コレクションの 断片化率 が低い場合、デフラグの効果はあまり期待できません。

    • デフラグスケジュールを使用して、再生可能なスペース が少ない多数のコレクションを処理します。再生可能なスペース が大きいコレクションの場合は、タスクを手動で実行してください。コレクションの再生可能なスペース が 100 GB を超えると、処理に1時間以上かかる場合があります。所要時間を考慮してスケジュールを計画してください。

デフラグの結果

デフラグタスクが完了したら、再分析 をクリックして結果を確認します。

説明

注: デフラグの効果はデータの分散状況によって異なります。十分な効果が得られない場合は、タスクを再度実行できます。

よくある質問

Q: エラー「(Interrupted) Compaction interrupted on table:*** due to cache eviction pressure 」が表示された場合の対処方法

A: このエラーは、以前のバージョンを実行している低スペックのインスタンスでキャッシュプレッシャーが原因でcompact操作が中断されたことを示します。デフラグタスクが失敗した場合は、時間をおいて再度実行してみてください。タスクが繰り返し失敗する場合は、チケットを送信してください。

関連ドキュメント

ストレージ分析は、特定のバージョンの ApsaraDB for MongoDB レプリカセットおよびシャードクラスターインスタンスで利用できます。それ以前の MongoDB バージョンを実行するインスタンスのディスクをデフラグするには、「ディスク使用率を向上させるためのディスクのデフラグ」をご参照ください。

関連タスク

ストレージデータが見つからない場合、アカウントにデータベースやコレクションに対する必要な権限がないか、コレクション数が上限を超えている可能性があります。これを解決するには、次のいずれかの方法でアクセスを再承認してください。

  • 既存のアカウントとパスワードの使用

    1. ページ上部の 再承認 をクリックしてください。

    2. データベースアカウント と Password を入力してください。

    3. Confirm をクリックしてください。

  • 権限付与コマンドの生成

    1. ページ上部の 再承認 をクリックしてください。

    2. データベースアカウント と Password を入力してください。

    3. 権限付与コマンドの生成 をクリックしてください。

    4. Confirm をクリックしてください。

API リファレンス

API

説明

CreateStorageAnalysisTask

ストレージ分析タスクを作成して、データベースとコレクションのストレージ使用状況データを取得します。

GetStorageAnalysisResult

ストレージ分析タスクのステータスと結果を照会します。