このトピックでは、MaxCompute のセキュリティ設定に関するよくある質問 (FAQ) を紹介します。
質問カテゴリ | よくある質問 |
データセキュリティ | |
プロジェクトセキュリティ |
MaxCompute はどのようにデータセキュリティを確保しますか?
MaxCompute は、データセキュリティを確保するために複数の対策を提供しています。
権限のないユーザーは MaxCompute プロジェクトにアクセスできません。アクセス権限を付与できるのは、プロジェクト所有者またはプロジェクト管理者のみです。
MaxCompute は複数の認可方法を提供しており、認可されたユーザーのみがプロジェクトにアクセスできます。
MaxCompute のサンドボックスコンテナは、悪意のある操作を効果的に防止します。詳細については、「Java sandbox」をご参照ください。
MaxCompute は AccessKey ID と AccessKey Secret を使用してユーザーを認証します。情報漏えいが発生した場合は、漏えいした AccessKey ID と AccessKey Secret を迅速に無効化できます。この操作は、他の AccessKey ID または AccessKey Secret には影響しません。
重大なセキュリティリスクが発生した場合は、
set ProjectProtection=true;コマンドを実行してデータ保護メカニズムを有効化できます。これにより、ユーザーによるデータのエクスポートが防止され、潜在的なデータ漏えいを阻止します。
MaxCompute のデータは信頼できますか?
MaxCompute は 3 レプリカストレージパターンにより、データの信頼性を確保しています。
テーブルにライフサイクルを指定した場合、MaxCompute は削除ルールを満たすとテーブルを自動的に削除します。ライフサイクルを指定しない場合、テーブルはデフォルトで永続的に保持されます。
VPC の IP アドレスホワイトリストは CIDR ブロックをサポートしていますか?
はい、サポートしています。詳細については、「Manage IP address whitelists」をご参照ください。
ジョブが "AllMachineInBlackList" エラーで失敗した場合はどうすればよいですか?
症状
MaxCompute プロジェクトでジョブを実行すると、次のエラーが返されます:
FAILED: ODPS-0010000:System internal error - fuxi task failed, AllMachineInBlackList.原因
MaxCompute のセキュリティが強化されたためです。
解決策
フィードバックのために DingTalk グループに参加するには、「DingTalk group request form」に入力してください。
プロジェクトのデータ保護メカニズムが原因で MaxCompute のデータを MySQL にエクスポートできない場合はどうすればよいですか?
プロジェクト所有者またはプロジェクト管理者は、set projectProtection=false; コマンドを実行してデータ保護メカニズムを無効にするか、例外ポリシーを設定してデータのエクスポートを許可することができます。データ保護の詳細については、「Data protection mechanism」をご参照ください。
削除されたテーブルを復元するにはどうすればよいですか?
MaxCompute のバックアップと復元機能を使用して、テーブルデータを復元できます。バックアップと復元の詳細については、「Backup and recovery」をご参照ください。