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Identity as a Service:IDaaS が同期された RAM アカウントの削除に失敗した場合の対処方法

最終更新日:May 27, 2025

問題

Alibaba Cloud IDaaS の Enterprise Identity Access Management (EIAM) システムでアカウント同期が有効になっているユーザーを削除すると、対応する RAM ユーザーが同期して削除されません。

考えられる原因

  1. RAM アカウントが特別な状態になっている (多要素認証 (MFA) デバイスにバインドされている、アクセスキーが構成されている、ユーザーグループに属しているなど)。

  2. 同期範囲の設定が正しくない。削除されたユーザーの組織が同期範囲の設定と一致していない可能性があります。

  3. パラメータ設定エラーによって同期リクエストが例外を発生させる。

使用上の注意

  1. 重要な情報を最初にバックアップする: 削除する前に、RAM アカウントに関連付けられている重要なリソースまたは権限がないことを確認します。

  2. 影響を評価する: RAM アカウントを削除すると、そのアカウントと、アカウントが偽装しているロールは強制的にログアウトされ、自動的に回復することはありません。

  3. 権限を管理する: 管理者に AliyunRAMFullAccess などの十分な権限があることを確認します。

解決策

IDaaS は特別な状態の RAM アカウントの削除を自動的に同期できないため、次の手順を手動で実行します。

ステップ 1: RAM アカウントの特別な状態を削除する

  1. ユーザーグループから削除する:

    1. [Alibaba Cloud RAM コンソール] にログオンします。

    2. 左側のナビゲーションバーで、[ID] > [ユーザー] を選択します。

    3. ターゲット RAM アカウントを見つけ、その名前をクリックして詳細ページに移動します。

    4. ユーザーグループエリアで、すべてのユーザーグループからアカウントを削除します。

  2. MFA デバイスをデタッチする (存在する場合):

    1. RAM コンソールで、ターゲット RAM アカウントの詳細ページに移動します。

    2. [ID] > [ユーザー] > [認証] > [セキュリティ情報管理] エリアで、MFA デバイスをデタッチする

  3. アクセスキーを削除する (存在する場合):

    1. ターゲット RAM アカウントの詳細ページで、[アクセスキー] 管理エリアに移動します。

    2. 構成されているすべてのアクセスキーを削除します。

ステップ 2: RAM アカウントを削除する

  1. RAM コンソールにログオンします。

  2. 左側のナビゲーションバーで、[ID] > [ユーザー] を選択します。

  3. ターゲット RAM アカウントを見つけ、[アクション] 列の [削除] をクリックします。

  4. プロンプトに従って削除を完了します。