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:Windows インスタンスへの RDP 接続の失敗:エラー 0x112f

最終更新日:Jun 22, 2026

このトピックでは、Windows インスタンスへの RDP 接続時にプロトコル エラー 0x112f が発生した場合の解決策を説明します。

現象

RDP 経由で Windows インスタンスに接続しようとすると、リモート セッションが切断され、次のエラーメッセージが表示されます:[「プロトコル エラー (コード: 0x112f) が発生したため、リモート セッションは切断されます。リモート コンピューターへの接続をもう一度試してください。」]

原因

このエラーは通常、Windows インスタンスのメモリが不足しているため、新しいリモート セッションを確立できない場合に発生します。

解決策

次のいずれかの解決策を選択してください。

解決策 1:インスタンスタイプのアップグレード

ECS インスタンスのインスタンスタイプをアップグレードして、使用可能なメモリを増やします。詳細な手順については、「サブスクリプションインスタンスのインスタンスタイプのアップグレード」または「従量課金インスタンスのインスタンスタイプの変更」をご参照ください。

解決策 2:仮想メモリの有効化

回避策として、ECS インスタンスで仮想メモリを有効にします。これにより、オペレーティングシステムはディスク領域をメモリのように使用できるようになります。手順については、「Windows インスタンスの仮想メモリを設定する方法」をご参照ください。