すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:Workbench を使用したファイルのアップロードまたはダウンロード

最終更新日:May 16, 2026

Workbench のファイル管理機能を使用して、Elastic Compute Service (ECS) インスタンスとの間でファイルをアップロードまたはダウンロードします。

注意事項

  • ファイルサイズの制限:Linux インスタンスは最大 1200 MB、Windows インスタンスは最大 100 MB です。これより大きいファイルの場合は、他のファイル転送方法を使用してください。

  • 転送速度:ピーク時には転送が遅くなる場合があります。その場合は、他のファイル転送方法を使用してください。

  • セッション管理接続:この機能はサポートされていません。

ファイルのアップロード

重要

複数のファイルをアップロードするには、1つのファイルに圧縮してインスタンスに転送し、解凍してください。詳細については、「ファイルの圧縮とアップロード」をご参照ください。

Linux インスタンス

Workbench 1.0 と 2.0 のどちらを使用しているかを確認する方法

Workbench 2.0

  1. Workbench を使用して Linux インスタンスにログインします。

    宛先フォルダーへの書き込み権限を持つ root ユーザーまたはユーザーとしてログインしてください。そうでない場合、アップロードは失敗します。
  2. 左側のナビゲーションペインで image をクリックしてファイル管理を開きます。インスタンス名をクリックして、ファイルツリーを展開します。

    image でインスタンス名をクリックすると、「現在のログイン方法ではファイル管理はサポートされていません」というエラーメッセージが表示される

    • 現象

      次の図に示すエラーメッセージが表示され、インスタンス名の後に ssm (セッション管理) 識別子が表示されます。

      image

    • 原因

      セッション管理接続でインスタンスに接続している場合、この機能はサポートされていません。

    • 解決策

  3. 宛先フォルダーを右クリックし、[ファイルをアップロード] をクリックして、アップロードするファイルを選択します。

    ファイルツリー内のフォルダーをダブルクリックし、[ファイルをアップロード] をクリックするか、右側のペインにファイルをドラッグすることもできます。
  4. アップロードが完了するまで待ちます。

    アップロードの進捗状況は、ページの右下隅に表示されます。

    image

Workbench 1.0

  1. Workbench を使用して Linux インスタンスにログインします。

    宛先フォルダーへの書き込み権限を持つ root ユーザーまたはユーザーとしてログインしてください。そうでない場合、アップロードは失敗します。
  2. 左上隅のメニューバーで[ファイル] > [新しいファイルツリーを開く] を選択します。

    image

    「新しいファイルツリーを開く」機能が見つからない

    • 現象

      image

    • 原因

      セッション管理接続でインスタンスに接続している可能性があります。この機能はセッション管理接続ではサポートされていません。

      セッション管理接続を使用していない場合は、ページを更新するか、インスタンスに再接続してみてください。

    • 解決策

  3. ファイルツリーで宛先フォルダーを右クリックし、[ファイルをアップロード] をクリックします。

  4. アップロードするファイルを選択します。

    アップロードが完了すると、成功メッセージが表示されます。Upload complete

    説明

    ファイルのアップロードに失敗した場合は、タスクを再試行または削除してください。失敗したすべてのファイルを再アップロードするには、[失敗したすべてのアイテムを再アップロード] をクリックしてください。

    ファイルリストから、アップロードされたファイルを変更、削除、ダウンロード、または名前変更できます。

Windows インスタンス

  1. Workbench を使用して Windows インスタンスに接続します

  2. [このPC] を検索して開きます。

    [このPC] が見つからない場合は、[エクスプローラー] を開き、左側のナビゲーションペインで[このPC] をクリックします。
  3. [リダイレクトされたドライブとフォルダー] セクションで、xxx@ 上の Workbench ドライブをダブルクリックします。

    image

  4. ローカルコンピューターから test.txt などのファイルをこのフォルダーにドラッグします。

    image

  5. このフォルダーから C ドライブまたは別のドライブにファイルをドラッグします。

    重要

    インスタンスに再接続するかインスタンスを終了すると、Workbench は[リダイレクトされたドライブとフォルダー] からアップロードされたすべてのファイルを消去します。このフォルダーは転送専用のため、ここにファイルを保存しないでください。

ファイルのダウンロード

Linux インスタンス

Workbench 1.0 と 2.0 のどちらを使用しているかを確認する方法

Workbench 2.0

  1. Workbench を使用して Linux インスタンスにログインします。

    ターゲットファイルに対する読み取り権限を持つ root ユーザーまたはユーザーとしてログインしてください。そうでない場合、ダウンロードは失敗します。
  2. 左側のナビゲーションペインで image をクリックしてファイル管理を開きます。インスタンス名をクリックして、ファイルツリーを展開します。

    image でインスタンス名をクリックすると、「現在のログイン方法ではファイル管理はサポートされていません」というエラーメッセージが表示される

    • 現象

      次の図に示すエラーメッセージが表示され、インスタンス名の後に ssm (セッション管理) 識別子が表示されます。

      image

    • 原因

      セッション管理接続でインスタンスに接続している場合、この機能はサポートされていません。

    • 解決策

  3. ダウンロードするファイルを右クリックし、[ファイルをダウンロード] をクリックします。

    ファイルツリー内のフォルダーをダブルクリックし、[操作] 列で[image] [ダウンロード] をクリックすることもできます。
  4. ダウンロードが完了するまで待ちます。

    [ダウンロード] をクリックすると、ダウンロードの進捗状況がページの右下隅に表示されます。

Workbench 1.0

  1. Workbench を使用して Linux インスタンスにログインします。

    ターゲットファイルに対する読み取り権限を持つ root ユーザーまたはユーザーとしてログインしてください。そうでない場合、ダウンロードは失敗します。
  2. 左上隅のメニューバーで[ファイル] > [新しいファイルツリーを開く] を選択します。

    image

    「新しいファイルツリーを開く」機能が見つからない

    • 現象

      image

    • 原因

      セッション管理接続でインスタンスに接続している可能性があります。この機能はセッション管理接続ではサポートされていません。

      セッション管理接続を使用していない場合は、ページを更新するか、インスタンスに再接続してみてください。

    • 解決策

  3. ファイルツリーでダウンロードするファイルを右クリックし、[ファイルをダウンロード] をクリックします。

    ダウンロードが完了すると、成功メッセージが表示されます。Download complete

    説明

    ファイルのダウンロードに失敗した場合は、タスクを再試行または削除してください。失敗したすべてのファイルを再ダウンロードするには、[失敗したすべてのアイテムを再ダウンロード] をクリックしてください。

Windows インスタンス

重要

空のファイルはダウンロードできません。

  1. Workbench を使用して Windows インスタンスに接続します

  2. [このPC] を検索して開きます。

  3. [リダイレクトされたドライブとフォルダー] セクションで、xxx@ 上の Workbench ドライブをダブルクリックします。

    image

  4. C ドライブまたは別のドライブから[ダウンロード] フォルダーにファイルをドラッグします。ファイルがローカルコンピューターにダウンロードされます。

よくある質問

Workbench 1.0 と 2.0 のどちらを使用しているかを確認する方法は? 2.0 に切り替える方法は?

UI でバージョンを識別します。Workbench 2.0 では左上隅に Workbench アイコン image が表示されますが、Workbench 1.0 では[WORKBENCH] と表示されます。左側のナビゲーションペインも異なります。

Workbench 2.0

Workbench 1.0

image

image

バージョンを切り替えるには、2.0 へは右上隅の[新しいバージョン] を、1.0 へは[前のバージョン] をクリックします。

「現在のログイン方法ではファイル管理はサポートされていません」というメッセージが表示される

  • 現象

    次の図に示すエラーメッセージが表示され、インスタンス名の後に ssm (セッション管理) 識別子が表示されます。

    image

  • 原因

    セッション管理接続でインスタンスに接続している場合、この機能はサポートされていません。

  • 解決策

上部メニューが見つからない

  • 現象:Workbench インターフェイスの上部にメニューバーと[ファイル] ボタンが表示されません。

  • 原因:上部メニューが非表示になっています。

  • 解決策:ターミナルインターフェイスを右クリックし、[メニューバーの表示/非表示] をクリックしてください。

Linux インスタンスへの接続時に「新しいファイルツリーを開く」機能が見つからない

  • 現象

    image

  • 原因

    セッション管理接続でインスタンスに接続している可能性があります。この機能はセッション管理接続ではサポートされていません。

    セッション管理接続を使用していない場合は、ページを更新するか、インスタンスに再接続してみてください。

  • 解決策

ローカルコンピューターからファイルをアップロードできず、「権限がありません」というエラーが表示される

  • 現象

    image

  • 原因

    ログインユーザーに宛先フォルダーへの書き込み権限がない可能性があります。たとえば、ecs-user としてログインし、/opt フォルダーにアップロードすると、このエラーが発生します。

  • 解決策

    • root ユーザーとしてログインしてファイルをアップロードする

      root として再度ログインし、ファイルをアップロードしてください。

      インスタンスの作成時にログインユーザー名として ecs-user を選択した場合は、root としてログインする前にroot パスワードをリセットしてください。
    • 現在のユーザーのホームディレクトリにファイルをアップロードする

      たとえば、ecs-user としてログインする場合は、/home/ecs-user にファイルをアップロードしてください。