説明
この API は廃止されました。一時的にアクセス可能ですが、更新やバグ修正対応は一切行われません。代わりに Vpc(2016-04-28) - UnassociateEipAddress への移行を推奨します。より強化された機能に加え、サポートも引き続きご利用いただけます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
vpc:UnassociateEipAddress |
update |
*All Resource
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
任意 |
DescribeRegions API を呼び出します。 |
|
| AllocationId |
string |
必須 |
|
|
| InstanceId |
string |
必須 |
AllocationId からインスタンス ID を自動的に判別します。 |
|
| InstanceType |
string |
任意 |
|
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
|
例
成功レスポンス
JSONJSON
{
"RequestId": ""
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | IncorrectEipStatus | Current elastic IP status does not support this operation. | |
| 400 | InvalidInstanceId.NotFound | Specified instance does not exist. | |
| 400 | IncorrectInstanceStatus | The current status of instance does not support this operation. | |
| 400 | InvalidInstanceType.ValueNotSupported | The specified value of InstanceType is not supported. | |
| 400 | IncorrectHaVipStatus | This operation is denied because satus of the specified HaVip is neither Available nor InUse. | |
| 400 | OperationDenied | Eip of default vpc not allow this operation | |
| 400 | InvalidParameter | The specified parameter is not valid. | |
| 400 | Forbbiden | The eip instance owener error | |
| 400 | TaskConflict | The eip operate too frequent, TaskConflict. | |
| 400 | InvalidBindingStatus | The eip binding status invalid. | |
| 400 | Forbidden.FinancialLocked | The ip business status is invalid. | |
| 400 | InvalidIpStatus.HasBeenUsedBySnatTable | The removed ip address has been used by snat table. | |
| 400 | InvalidIpStatus.HasBeenUsedByForwardEntry | The specified address has been used by forwardTable. | |
| 400 | InvalidEIPStatus.BizDisabled | The EIP has been locked. | |
| 400 | InvalidStatus.EcsStatusNotSupport | The special instance status Pending is not support operate | |
| 400 | InvalidStatus.EniStatusNotSupport | %s | |
| 400 | InvalidStatus.SnatOrDnat | Operation failed because snat or dnat in unstable status. | |
| 400 | DependencyViolation.SnatEntry | The specified eip is in ip pool. | |
| 400 | InvalidInstance.NotVpc | Bound instance is not vpc instance. | |
| 400 | InvalidStatus.NotAllow | Bound instance status is invalid. | |
| 404 | InvalidAllocationId.NotFound | Specified allocation ID is not found | |
| 404 | InvalidHaVip.NotFound | The specified HaVip does not exist. | |
| 404 | Forbidden.RegionNotFound | Specified region is not found during access authentication. | |
| 404 | OperationUnsupported.ServiceManaged | Operation of resource is forbidden because this instance belongs to Service manager. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。