すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:UnassociateEipAddress

最終更新日:Apr 16, 2026

説明

この API は廃止されました。一時的にアクセス可能ですが、更新やバグ修正対応は一切行われません。代わりに Vpc(2016-04-28) - UnassociateEipAddress への移行を推奨します。より強化された機能に加え、サポートも引き続きご利用いただけます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

vpc:UnassociateEipAddress

update

*All Resource

*

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

RegionId

string

任意

EIP が配置されているリージョンの ID です。最新のリージョンリストを取得するには、DescribeRegions API を呼び出します。

AllocationId

string

必須

EIP のアロケーション ID です。

InstanceId

string

必須

このパラメーターはオプションです。システムは、指定されたAllocationId からインスタンス ID を自動的に判別します。

InstanceType

string

任意

関連付けられたインスタンスのタイプです。有効な値:
  • EcsInstance:ECS インスタンス。デフォルトです。
  • SlbInstance:Classic Load Balancer (CLB) インスタンス。
  • Nat:NAT ゲートウェイ。
  • HaVip:高可用性仮想 IP アドレス (HaVip)。
  • NetworkInterface:セカンダリ弾性ネットワークインターフェース。

レスポンスフィールド

フィールド

型

説明

例

object

RequestId

string

一意のリクエスト ID。

例

成功レスポンス

JSONJSON

{
  "RequestId": ""
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 IncorrectEipStatus Current elastic IP status does not support this operation.
400 InvalidInstanceId.NotFound Specified instance does not exist.
400 IncorrectInstanceStatus The current status of instance does not support this operation.
400 InvalidInstanceType.ValueNotSupported The specified value of InstanceType is not supported.
400 IncorrectHaVipStatus This operation is denied because satus of the specified HaVip is neither Available nor InUse.
400 OperationDenied Eip of default vpc not allow this operation
400 InvalidParameter The specified parameter is not valid.
400 Forbbiden The eip instance owener error
400 TaskConflict The eip operate too frequent, TaskConflict.
400 InvalidBindingStatus The eip binding status invalid.
400 Forbidden.FinancialLocked The ip business status is invalid.
400 InvalidIpStatus.HasBeenUsedBySnatTable The removed ip address has been used by snat table.
400 InvalidIpStatus.HasBeenUsedByForwardEntry The specified address has been used by forwardTable.
400 InvalidEIPStatus.BizDisabled The EIP has been locked.
400 InvalidStatus.EcsStatusNotSupport The special instance status Pending is not support operate
400 InvalidStatus.EniStatusNotSupport %s
400 InvalidStatus.SnatOrDnat Operation failed because snat or dnat in unstable status.
400 DependencyViolation.SnatEntry The specified eip is in ip pool.
400 InvalidInstance.NotVpc Bound instance is not vpc instance.
400 InvalidStatus.NotAllow Bound instance status is invalid.
404 InvalidAllocationId.NotFound Specified allocation ID is not found
404 InvalidHaVip.NotFound The specified HaVip does not exist.
404 Forbidden.RegionNotFound Specified region is not found during access authentication.
404 OperationUnsupported.ServiceManaged Operation of resource is forbidden because this instance belongs to Service manager.

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。