すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:StopInstance

最終更新日:Sep 15, 2026

ECS インスタンスを停止します。異なるシャットダウン方法、停止モード、およびバッチ操作モードを選択して、インスタンスを停止できます。

操作説明

この操作は非同期です。インスタンスはすぐには停止しません。呼び出しが成功すると、インスタンスは最初に Stopping 状態になります。 DescribeInstanceStatus を呼び出して、インスタンスステータスをクエリできます。返されるステータスが Stopped の場合、インスタンスは正常に停止されています。

開始前に

  • セキュリティ上の理由でロック済みのインスタンスは、この操作の呼び出しでは停止できません。詳細については、「API 呼び出しに対するリソースセキュリティロックの影響」を参照してください。

  • VPC 内のインスタンスに対して節約モードを有効にした場合、設定項目で StoppedMode=KeepCharging を設定して標準停止モードを有効にできます。ECS インスタンスの停止後も課金は継続され、ECS インスタンスタイプの在庫とインターネット IP アドレスが保持されます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:StopInstance

update

*Instance。

acs:ecs:{#regionId}:{#accountId}:instance/{#instanceId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

InstanceId

string

必須

インスタンス ID

i-bp67acfmxazb4ph****

ConfirmStop

boolean

任意

このパラメーターは非推奨であり、互換性のためにのみ保持されています。この操作の呼び出し時は、このパラメーターを無視してください。

true

ForceStop

boolean

任意

インスタンスを強制停止するかどうかを指定します。有効な値:

  • true: インスタンスを強制停止します。これは通常の仕事率オフ操作と同等です。ストレージデバイスに書き込まれていないすべてのキャッシュデータが失われます。

  • false: 法線にインスタンスを停止します。

デフォルト値: false。

false

StoppedMode

string

任意

従量課金 ECS インスタンスの停止モード。有効な値:

  • StopCharging: 節約モード。節約モードを有効にすると、以下のようになります。

    • コンピューティングリソース (vCPU、メモリ、GPU)、イメージライセンス料金、および静的パブリック IP アドレスの帯域幅課金モードの課金が停止されます。

    • システムディスク、データディスク、および EIP の帯域幅課金モードの課金は継続されます。

    • コンピューティングリソースが回収されるため、在庫不足によりインスタンスの起動に失敗する場合があります。この場合は、後でもう一度試すか、インスタンスタイプを変更してください。

    • インスタンスの停止前に EIP がインスタンスに関連付けられている場合、インスタンスの再起動後も IP アドレスは変更されません。それ以外の場合、静的パブリック IP アドレスは変更される可能性がありますが、非公開 IP アドレスは変更されません。

    詳細については、「節約モード」を参照してください。

    重要 インスタンスが節約モードをサポートしていない場合、API はエラーを返しません。インスタンスの停止の優先度が高くなっています。節約モードをサポートしていないインスタンスタイプには、ローカルディスクを備えたインスタンスとサブスクリプションインスタンスが含まれます。

  • KeepCharging: 標準停止モード。インスタンスの停止後も課金は継続されます。

デフォルト値: ECS コンソールで VPC 内のインスタンスに対して節約モードを有効にしており (詳細については、「デフォルトで節約モードを有効にする」を参照してください)、条件を満たしている場合、デフォルト値は StopCharging です。それ以外の場合、デフォルト値は KeepCharging です。

KeepCharging

DryRun

boolean

任意

ドライランを実行するかどうかを指定します。有効な値:

  • true: インスタンスを停止せずにドライランを実行します。システムは、必須パラメーターが指定されているか、リクエストの初期化が有効か、サービス制限を満たしているか、および ECS の在庫が十分かどうかをチェックします。チェックに失敗すると、対応するエラーが返されます。チェックに合格すると、エラーコード DryRunOperation が返されます。

  • false: 通常のリクエストを実行します。チェックに合格すると、インスタンスが停止されます。

デフォルト値: false。

true

Hibernate

boolean

任意

説明

このパラメーターは招待プレビュー中であり、使用できません。

hide

レスポンスフィールド

フィールド

型

説明

例

object

RequestId

string

リクエスト ID

1C488B66-B819-4D14-8711-C4EAAA13AC01

例

成功レスポンス

JSONJSON

{
  "RequestId": "1C488B66-B819-4D14-8711-C4EAAA13AC01"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidParameter.Encrypted.KmsNotEnable The operation failed because KMS is not activated. Please activate KMS in the KMS console and try again.
400 DiskError IncorrectDiskStatus. 指定されたディスクの状態が無効です。
500 InternalError The request processing has failed due to some unknown error.
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
403 InstanceLockedForSecurity The specified operation is denied as your instance is locked for security reasons. ディスクがアタッチされているインスタンスは、セキュリティ上の理由によりロック済みです。
403 InstanceType.ParameterMismatch The input parameter ConfirmStop must be true when an instance have localstorage. インスタンスがローカル記憶域を使用している場合、ConfirmStop パラメーターを true に設定する必要があります。
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 InvalidInstanceId.NotSupport Classic network Instance does not support this operation. スポットインスタンスでは、この操作はサポートされていません。
403 InvalidParameter.KMSKeyId.CMKUnauthorized The CMK needs to be added ECS tag
403 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be enabled.
403 InvalidParameter.KMSKeyId.KMSUnauthorized The ECS service is not authorized to access your KMS key. Please grant the ECS service permission to use the key and try again.
403 HibernationConfigured.InstanceOperationForbidden The operation is not permitted due to limit of the hibernation configured instance. インスタンスが休止状態オプションの有効化要件を満たしていないため、操作は許可されません。
403 HibernationConfigured.NotEnabled The instance hibernation configured option is not enabled.
403 InvalidOperation.KMSKeyIdNotFound The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region.
403 InvalidOperation.KMSServiceNotOpen KMS service is currently not open. Key Management Service (KMS) サービスが有効化されていません。
403 OperationDenied.SystemInstanceNotSupport The system instance does not support the %s operation because %s.
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。
503 LimitedOperation.ServiceUnavailable The service is currently unavailable. Please try again later. サービスは現在ご利用いただけません。後でもう一度お試しください。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。