すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:StartImagePipelineExecution

最終更新日:Sep 09, 2026

イメージテンプレートを使用してイメージ構築タスクを実行します。

操作説明

  • イメージテンプレートの作成後、この操作を呼び出してイメージ構築タスクを実行します。システムは、イメージテンプレートの設定で指定されたパラメーターに基づいて、共有イメージの構築、配布、および作成を実行します。

  • 同じイメージテンプレートに対して、一度に実行できるイメージ構築タスクは 1 つだけです。CancelImagePipelineExecution を同時に複数回呼び出すことができます。イメージ構築タスクをキャンセルしても、他のイメージ構築タスクには影響しません。

  • イメージ構築テンプレートを実行すると、イメージの構築を支援するために複数の中間インスタンスが作成されます。中間インスタンスは、従量課金の支払い方法を使用する ECS インスタンスであり、課金料金が発生します。詳細については、「従量課金」を参照してください。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:StartImagePipelineExecution

update

*イメージパイプ回線。

acs:ecs:{#regionId}:{#accountId}:imagepipeline/{#imagepipelineId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

RegionId

string

必須

リージョン ID。 DescribeRegions を呼び出して、最新のリージョンリストを照会できます。

cn-hangzhou

TemplateTag deprecated

array<object>

任意

このパラメーターは非推奨です。

object

任意

Key

string

任意

このパラメーターは非推奨です。

null

Value

string

任意

このパラメーターは非推奨です。

null

Tag

array<object>

任意

タグ。

object

任意

タグオブジェクト。

Key

string

任意

タグのキー。N の有効な値: 1~20。タグキーは空の文字列にすることはできません。タグキーの長さは最大 128 文字で、aliyun または acs: で始めることはできません。タグキーに http:// または https:// を含めることはできません。

TestKey

Value

string

任意

タグの値。N の有効な値: 1~20。タグ値は空の文字列にすることができます。タグ値の長さは最大 128 文字で、acs: で始めることはできません。タグ値に http:// または https:// を含めることはできません。

TestValue

ImagePipelineId

string

必須

イメージテンプレートの ID。

ip-2ze5tsl5bp6nf2b3****

ClientToken

string

任意

リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認してください。ClientToken には ASCII 文字のみを使用でき、長さは 64 文字以下にする必要があります。詳細については、「べき等性を確保する方法」を参照してください。

123e4567-e89b-12d3-a456-426655440000

レスポンスフィールド

フィールド

型

説明

例

object

ExecutionId

string

構築タスクの ID。

exec-5fb8facb8ed7427c****

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "ExecutionId": "exec-5fb8facb8ed7427c****",
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidImage.OsTypeUnsupported The specified base image does not support image building. 指定されたベースイメージのオペレーティングシステムは、イメージ構築をサポートしていません。
400 InvalidParameter.BuildContent %s. 構築テンプレートの内容が無効です。
400 InvalidParameter.TestContent %s. テストテンプレートの内容が無効です。
400 InvalidImageComponent.NotSupported %s. 指定されたイメージコンポーネントは利用できません。
400 Duplicate.TagKey The Tag.N.Key contain duplicate key. タグ内に重複するキーが存在します。すべてのキーが一意であることを確認してください。
400 InvalidTagKey.Malformed The specified Tag.N.Key is not valid. Tag keys cannot be empty or null, support up to 128 characters, cannot start with "aliyun" or "acs:", and cannot contain "http://" or "https://". 指定されたタグキーパラメーターが無効です。
400 InvalidTagValue.Malformed The specified Tag.N.Value is not valid. Tag values support up to 128 characters, and cannot contain "http://" or "https://". 指定されたタグ値パラメーターが無効です。
400 InvalidDockerRepositoryCredential.DockerRegistryMalformed The specified parameter DockerRepositoryCredential.DockerRegistry is invalid. The length should be between 1 to 512 characters. 指定された Docker レジストリの長さは 1 文字から 512 文字の間である必要があります。
400 InvalidDockerRepositoryCredential.UserMalformed The specified parameter DockerRepositoryCredential.User is invalid. The length should be between 1 to 128 characters. 指定されたユーザー名の長さは 1 文字から 128 文字の間である必要があります。
400 InvalidImageName.Duplicated The specified image name is already in use. イメージ名はすでに存在します。
500 StartImagePipelineExecution.Failed Start image pipeline execution failed. イメージテンプレートタスクの実行に失敗しました。
403 InvalidImagePipeline.HasRunningExecution %s
403 InvalidImagePipeline.OSSObjectNotAuthorized The ImportImageOptions.DiskDeviceMappings.OSSObject of the specified ImagePipeline is not allowed to access. ImagePipeline で指定された ImportImageOptions.DiskDeviceMappings.OSSObject へのアクセスは許可されていません。
403 InvalidImagePipeline.OSSObjectNeedRestore The ImportImageOptions.DiskDeviceMappings.OSSObject of the specified ImagePipeline is an archived object and needs to be restored first. ImagePipeline で指定された ImportImageOptions.DiskDeviceMappings.OSSObject はアーカイブ済みオブジェクトであるため、先に復元する必要があります。
403 InvalidOperation.NoRightAccessOSS ECS service is not authorized to access your OSS. Check your RAM roles and policies, and ensure that ecs.aliyuncs.com is authorized to assume AliyunECSImageImportDefaultRole. ECS に OSS へのアクセス権限がありません。RAM ロールとポリシーを確認し、「ecs.aliyuncs.com」に「AliyunECSImageImportDefaultRole」ロールの偽装権限が付与されていることを確認してください。
404 InvalidImagePipeline.NotFound %s
404 InvalidInstanceType.NotFound The specified instance type does not exist. 指定された InstanceType パラメーターは存在しません。
404 InvalidVSwitchId.NotFound The specified VSwitchId does not exist. 指定された vSwitch ID が存在しません。
404 InvalidRegionId.NotFound %s 指定された RegionId が存在しません。このリージョンでプロダクトが利用可能かどうかを確認してください。
404 InvalidImage.NotFound %s. 指定されたソースイメージ ID が存在しません。
404 ImageComponent.NotFound %s. 指定されたイメージコンポーネント ID が見つかりませんでした。
404 InvalidImagePipeline.BaseImageNotFound The BaseImage of the specified ImagePipeline is not found. 指定されたテンプレートのベースイメージが見つかりませんでした。
404 InvalidImagePipeline.OSSObjectNotFound The ImportImageOptions.DiskDeviceMappings.OSSObject of the specified ImagePipeline is not found in this region. ImagePipeline で指定された ImportImageOptions.DiskDeviceMappings.OSSObject が現在のリージョンで見つかりませんでした。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。