インスタンスのスナップショットを使用して、クラウドディスクをロールバックします。
操作説明
この API は非推奨です。クラウドディスクのロールバックには、ResetDisk を使用してください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ResetDisks |
update |
*Disk
*Snapshot
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
必須 |
リージョン ID。最新のリージョン一覧を表示するには、DescribeRegions API を呼び出します。 |
cn-hangzhou |
| DryRun |
boolean |
任意 |
ドライランを実行するかどうかを指定します。有効な値:
デフォルト値: false。 |
false |
| Disk |
array<object> |
必須 |
ロールバックするディスク。最大 10 個のディスクを指定できます。 |
|
|
object |
任意 |
|||
| SnapshotId |
string |
任意 |
ディスクのロールバックに使用するスナップショットの ID。 |
s-j6cdofbycydvg7ey**** |
| DiskId |
string |
任意 |
ロールバックするディスクの ID。 |
d-j6cf7l0ewidb78lq**** |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
リクエスト ID。 |
3D66C85C-AA97-4A00-B0ED-2D9A80FE782C |
| OperationProgressSet |
object |
||
| OperationProgress |
array<object> |
1 つ以上のクラウドディスクのロールバックのステータスを含む配列。 |
|
|
array<object> |
|||
| ErrorMsg |
string |
エラーメッセージ。ロールバックが成功した場合、このパラメーターは空になります。 エラーコードとエラーメッセージについては、「エラーセンター」をご参照ください。 |
testErrorMsg |
| ErrorCode |
string |
エラーコード。ロールバックが成功した場合、このパラメーターは空になります。 エラーコードとエラーメッセージについては、「エラーセンター」をご参照ください。 |
400 |
| OperationStatus |
string |
操作結果。操作が成功した場合、 |
Success |
| RelatedItemSet |
object |
||
| RelatedItem |
array<object> |
関連リソースのリスト。 |
|
|
object |
|||
| Name |
string |
リソース識別子のタイプ。 |
SnapshotId |
| Value |
string |
リソース ID。 |
s-j6cdofbycydvg7ey**** |
例
成功レスポンス
JSONJSON
{
"RequestId": "3D66C85C-AA97-4A00-B0ED-2D9A80FE782C",
"OperationProgressSet": {
"OperationProgress": [
{
"ErrorMsg": "testErrorMsg",
"ErrorCode": "400",
"OperationStatus": "Success",
"RelatedItemSet": {
"RelatedItem": [
{
"Name": "SnapshotId",
"Value": "s-j6cdofbycydvg7ey****"
}
]
}
}
]
}
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | DiskCategory.OperationNotSupported | The operation is not supported to the specified disk due to its disk category. | |
| 400 | InvalidRegionId.MalFormed | The specified RegionId is not valid. | |
| 400 | DryRunOperation | Request validation has been passed with DryRun flag set. | |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | InstanceLockedForSecurity | The instance is locked due to security. | |
| 403 | InvalidParameter.Mismatch | The specified snapshot is not created from the specified disk. | |
| 403 | InvalidSnapshot.TooOld | The snapshotId is created before 2013-07-15, it cannot be restored since the first time the disk detached. | |
| 403 | InstanceExpiredOrInArrears | The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode). | |
| 403 | OperationDenied | The specified snapshot dees not support ResetDisk. | |
| 403 | InvalidSnapshotId.NotReady | The specified snapshot has not completed yet. | |
| 403 | InvalidAccountStatus.NotEnoughBalance | Your account does not have enough balance. | |
| 403 | InvalidAccountStatus.SnapshotServiceUnavailable | Snapshot service has not been opened yet. | |
| 403 | Operation.Conflict | The operation may conflicts with others. | |
| 403 | UserNotInTheWhiteList | The user is not in disk white list. | |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | The CMK needs to be added ECS tag. | |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | The CMK needs to be enabled. | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | ECS service have no right to access your KMS. | |
| 403 | IncorrectDiskStatus.HasUnfinishedSnapshot | The current disk has unfinished snapshot. | |
| 403 | InvalidRegion.NotSupport | The specified region does not support resetting disks. | |
| 403 | InvalidOperation.MultiAttachDisk | Multi attach disk does not support this operation. | |
| 403 | InvalidDisk.ShareVolume | The specified diskId is invalid. The shared volume does not support creating a snapshot group. | |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | |
| 404 | Disk.NotFound | The specified disk does not exist. | |
| 404 | InvalidSnapshotId.NotFound | The specified SnapshotId does not exist. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | |
| 404 | InvalidRegionId.NotFound | The RegionId provided does not exist in our records. | |
| 404 | InvalidSnapshot.NotFound | The SnapshotId provided does not exist in our records. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。