すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:ReInitDisk

最終更新日:Jun 19, 2026

ディスクを作成時の初期状態に再初期化します。

操作説明

このオペレーションを呼び出す際は、以下の項目に注意してください:

  • ディスクは 使用中 (In_use) 状態であり、ディスクがアタッチされている ECS インスタンスは 停止済み (Stopped) 状態である必要があります。

  • インスタンスが最初に起動される時間の前に、そのインスタンスにアタッチされているディスクを再初期化することはできません。

  • ローカルスナップショットを持つディスクを再初期化することはできません。

  • システムディスクの場合、ディスクはイメージの初期状態に再初期化されます。ディスクの作成に使用されたソースイメージが削除されている場合、ディスクを再初期化することはできません。

  • ゼロから作成されたデータディスクの場合、ディスクは空のディスクに再初期化されます。スナップショットから作成されたデータディスクの場合、ディスクはスナップショットの状態に再初期化されます。ソーススナップショットが削除されている場合、ディスクを再初期化できず、エラーが返されます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:ReInitDisk

update

*Disk

acs:ecs:{#regionId}:{#accountId}:disk/{#diskId}

  • ecs:PasswordCustomized
なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DiskId

string

必須

再初期化するディスクの ID。

d-bp67acfmxazb4ph****

Password

string

任意

システムディスクの再初期化時に ECS インスタンスのユーザー名とパスワードをリセットするかどうかを指定します。パスワードは 8~30 文字の長さで、大文字、小文字、数字、特殊文字のうち少なくとも 3 種類を含む必要があります。以下の特殊文字がサポートされています:

()`~!@#$%^&*-_+=|{}[]:;'<>,.?/

Windows インスタンスの場合、パスワードはフォワードスラッシュ (/) で始めることはできません。

説明

Password パラメーターを指定する場合は、パスワードの漏洩を避けるために HTTPS を使用してリクエストを送信してください。

EcsV587!

KeyPairName

string

任意

キーペアの名前。

説明

このパラメーターは Linux インスタンスにのみ適用されます。システムディスクの再初期化時に、ログイン認証情報として SSH キーペアを ECS インスタンスにアタッチできます。SSH キーペアを使用すると、ユーザー名とパスワードによるログイン方法は無効になります。

testKeyPairName

AutoStartInstance

boolean

任意

このオペレーションを呼び出してディスクを再初期化した後にインスタンスを自動的に起動するかどうかを指定します。有効な値:

  • true: インスタンスを自動的に起動します。

  • false: インスタンスを自動的に起動しません。

デフォルト値: false。

true

SecurityEnhancementStrategy

string

任意

システムディスクの再初期化後に無料のセキュリティセンターサービスを使用するかどうかを指定します。有効な値:

  • Active: アクティブなセキュリティセンターサービスを使用します。この値はパブリックイメージにのみ適用されます。

  • Deactive: セキュリティセンターサービスを使用しません。この値はすべてのイメージに適用されます。

デフォルト値: Deactive。

Active

レスポンスフィールド

フィールド

型

説明

例

object

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーレスポンス

JSONJSON

{
    "RequestId":"F3CD6886-D8D0-4FEE-B93E-1B73239673DE"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 LoginAsNonRoot.ImageNotSupport The specified image does not support login as non-root.
400 DiskHasSnapshotsWithInstantAccessEnabled.OperationNotSupported The operation is not supported to the specified disk that have snapshots with InstantAccess enabled.
400 InvalidPassword.Malformed The specified parameter "Password" is not valid.
400 InvalidKeyPairName.NotFound The specified KeyPairName does not exist.
400 DependencyViolation.IoOptimize The specified parameter InstanceId is not valid.
400 DiskCategory.OperationNotSupported The operation is not supported to the specified disk due to its disk category.
400 InvalidRegionId.MalFormed The specified RegionId is not valid.
500 InternalError The request processing has failed due to some unknown error, exception or failure.
403 LoginAsNonRoot.RegionNotSupport The specified region does not support login as non-root.
403 IncorrectDiskStatus The current disk status does not support this operation.
403 IncorrectInstanceStatus The current status of the resource does not support this operation.
403 InstanceLockedForSecurity The instance is locked due to security.
403 InvalidSnapshot.TooOld The disk is created from a snapshotId made before 2013-07-15, it cannot be re-initiated the specified disk any more since the detached first time.
403 OperationDenied The snapshot which is used to create the specified disk has been deleted.
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 DiskCreatingSnapshot The operation is denied due to a snapshot of the specified disk is not completed yet.
403 SharedImageDeleted The specified image by others shared is deleted.
403 DependencyViolation.WindowsInstance The instance creating is windows, cannot use ssh key pair to login.
403 InvalidDisk.DiskFromClonedNotSupport The specified disk %s is cloned from source disk %s, so not support reinit
403 UserNotInTheWhiteList The user is not in volume white list.
403 InvalidParameter.KMSKeyId.CMKNotEnabled The CMK needs to be enabled.
403 InvalidParameter.KMSKeyId.KMSUnauthorized ECS service have no right to access your KMS.
403 HibernationConfigured.InstanceOperationForbidden The operation is not permitted due to limit of the hibernation configured instance.
403 InvalidOperation.MultiAttachDisk Multi attach disk does not support this operation.
403 InvalidParameter.KMSKeyId.CMKUnauthorized The CMK needs to be added ECS tag.
403 InvalidSourceSnapshot The source snapshot of the disk has been deleted and cannot support the current operation.
403 InvalidOperation.ReInitUnsupported The specified disk does not support reInit. 指定云盘不支持重新初始化。
404 InvalidDiskId.NotFound The specified disk does not exist.
404 InvalidImageId.NotFound The specified ImageId does not exist.
404 InvalidDiskId.OperationNotSupported The operation is not supported due to image not exist.

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。