Elastic Network Interface (ENI) の属性を変更します。変更対象には、キュー数、関連付けられたセキュリティグループ、キューの深さ、通信モード、および関連付けられたインスタンスのリリース時に ENI を保持するかどうかの設定が含まれます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ModifyNetworkInterfaceAttribute |
update |
*NetworkInterface。
*SecurityGroup。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
必須 |
ネットワークインターフェースのリージョン ID。 DescribeRegions を呼び出して、最新のリージョンリストをクエリできます。 |
cn-hangzhou |
| NetworkInterfaceName |
string |
任意 |
ネットワークインターフェースの名前。名前の長さは 2~128 文字で、英字または漢字で始まる必要があります。 デフォルト値: 空。 |
eniTestName |
| NetworkInterfaceId |
string |
必須 |
ネットワークインターフェースの ID。 |
eni-bp67acfmxazb4p**** |
| QueueNumber |
integer |
任意 |
ENI のキュー数。有効な値: 1~2048。
|
8 |
| Description |
string |
任意 |
ネットワークインターフェースの説明。説明の長さは 2~255 文字で、http:// または https:// で始めることはできません。 デフォルト値: 空。 |
testDescription |
| SecurityGroupId |
array |
任意 |
セキュリティグループ ID のリスト。セカンダリネットワークインターフェースは指定されたセキュリティグループに参加し、既存のセキュリティグループから削除されます。
|
|
|
string |
任意 |
セキュリティグループ ID のリスト。
|
sg-bp67acfmxazb4p**** |
|
| DeleteOnRelease |
boolean |
任意 |
関連付けられたインスタンスのリリース時に ENI を保持するかどうかを指定します。有効な値:
|
true |
| RxQueueSize |
integer |
任意 |
ネットワークインターフェースのインバウンドキューの深さ。 説明
このパラメーターは招待プレビュー中であり、一般公開されていません。このパラメーターを使用するには、チケットを提出してアクセス権限をリクエストしてください。 以下の点にご注意ください。
|
8192 |
| TxQueueSize |
integer |
任意 |
ネットワークインターフェースのアウトバウンドキューの深さ。 説明
このパラメーターは招待プレビュー中であり、一般公開されていません。このパラメーターを使用するには、チケットを提出してアクセス権限をリクエストしてください。 以下の点にご注意ください。
|
8192 |
| NetworkInterfaceTrafficConfig |
object |
任意 |
ネットワークインターフェースの通信パラメーター。 |
|
| NetworkInterfaceTrafficMode |
string |
任意 |
ネットワークインターフェースの通信パターン。有効な値:
ネットワークインターフェースがアタッチされた状態の場合、以下の点にご注意ください。
説明
このパラメーターは招待プレビュー中であり、一般公開されていません。 |
HighPerformance |
| QueueNumber |
integer |
任意 |
ネットワークインターフェースのキュー数。 ネットワークインターフェースがアタッチされた状態の場合、以下の点にご注意ください。
説明
このパラメーターは招待プレビュー中であり、一般公開されていません。 |
8 |
| QueuePairNumber |
integer |
任意 |
ネットワークインターフェースの RDMA キュー数。 ネットワークインターフェースがアタッチされた状態の場合、以下の点にご注意ください。
説明
このパラメーターは招待プレビュー中であり、一般公開されていません。 |
8 |
| RxQueueSize |
integer |
任意 |
ネットワークインターフェースのインバウンドキューの深さ。 説明
このパラメーターは招待プレビュー中であり、一般公開されていません。このパラメーターを使用するには、チケットを提出してアクセス権限をリクエストしてください。 以下の点にご注意ください。
|
8192 |
| TxQueueSize |
integer |
任意 |
ネットワークインターフェースのアウトバウンドキューの深さ。 説明
このパラメーターは招待プレビュー中であり、一般公開されていません。このパラメーターを使用するには、チケットを提出してアクセス権限をリクエストしてください。 以下の点にご注意ください。
|
8192 |
| ConnectionTrackingConfiguration |
object |
任意 |
ネットワーク接続性の追跡構成。 このパラメーターを使用する前に、「接続タイムアウト管理」をお読みください。 |
|
| TcpEstablishedTimeout |
integer |
任意 |
確立された TCP 接続のタイムアウト期間。単位: 秒。有効な値: [30, 60, 80, 100, 200, 300, 500, 700, 910]。 デフォルト値: 910。 |
910 |
| TcpClosedAndTimeWaitTimeout |
integer |
任意 |
TIME_WAIT および CLOSED 状態の TCP 接続のタイムアウト期間。単位: 秒。有効な値: 3~15 の整数。 デフォルト値: 3。 説明
ECS インスタンスを NLB または CLB と併用する場合、 |
3 |
| UdpTimeout |
integer |
任意 |
UDP フローのタイムアウト期間。単位: 秒。有効な値: [10, 20, 30, 60, 80, 100]。 デフォルト値: 30。 説明
ECS インスタンスを NLB または CLB と併用する場合、デフォルト値は 100 秒です。 |
30 |
| EnhancedNetwork |
object |
任意 |
このパラメーターは一般公開されていません。 |
|
| EnableSriov |
boolean |
任意 |
このパラメーターは一般公開されていません。 |
true |
| EnableRss |
boolean |
任意 |
説明
このパラメーターは一般公開されていません。 |
false |
| VirtualFunctionTotalQueueNumber |
integer |
任意 |
||
| VirtualFunctionQuantity |
integer |
任意 |
||
| EnableExpress |
boolean |
任意 |
||
| SourceDestCheck |
boolean |
任意 |
ソース/送信先チェックを有効にするかどうかを指定します。ネットワークセキュリティを強化するために、この特徴を有効にすることを推奨します。有効な値:
デフォルト値: false。 説明
この特徴は特定のリージョンでのみサポートされています。この特徴を使用する前に、「ソース/送信先チェック」をお読みください。 |
false |
| EnablePrimaryIPv6 |
boolean |
任意 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
リクエスト ID |
||
| RequestId |
string |
リクエスト ID |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3**** |
例
成功レスポンス
JSONJSON
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidOperation.NotSupportModifyQueueNumber | %s | |
| 400 | MissingParameter | %s | 指定されたパラメーターのうち少なくとも 1 つを指定する必要があります。すべてを空にすることはできません。 |
| 400 | UnsupportedParameter | %s | 指定されたパラメーターはサポートされていません。 |
| 400 | InvalidParameter | %s | 指定されたパラメーターの組み合わせが無効です。 |
| 400 | InvalidInstanceID.Malformed | %s | |
| 400 | InvalidOperation.InvalidEcsState | %s | インスタンスの現在のステータスでは、この操作はサポートされていません。 |
| 400 | InvalidOperation.InvalidEniState | %s | 現在の ENI のステータスでは、ENI の属性を変更できません。 |
| 400 | InvalidOperation.DetachPrimaryEniNotAllowed | %s | インスタンスからプライマリ ENI をデタッチすることは許可されていません。 |
| 400 | InvalidParams.EniId | %s | 指定された EniId パラメーターが無効です。 |
| 400 | Forbidden.RegionId | %s | 現在のリージョンでは、このサービスを一時的にご利用いただけません。 |
| 400 | JoinedGroupLimitExceed | %s | 指定されたリソースが参加できるセキュリティグループの最大数に達しました。詳細については、エラーメッセージ内の %s プレースホルダーの実際の戻り結果を参照してください。 |
| 400 | InvalidEniQueueSize.RegionOrUserNotSupported | The specified parameter RxQueueSize or TxQueueSize is not supported in this region, or this account is not in the whitelist of using eni QueueSize. | リージョンまたはユーザーは、ネットワークインターフェースのキュー深さの設定をサポートしていません。 |
| 400 | InvalidParameter.EniQueueSize | The specified parameter TxQueueSize and RxQueueSize are not equal or exceed limit. | アウトバウンドおよびインバウンドの ENI キュー深さが等しくないか、許可された範囲内にありません。 |
| 400 | InvalidParameter.Conflict | %s | 現在の操作では、diskId と imageId を同時に指定することはできません。diskId または imageId のいずれかが空でないことを確認してください。 |
| 400 | InvalidConnectionTrackingConfiguration.RegionOrUserNotSupported | The specified parameter ConnectionTrackingConfiguration is not supported in this region, or this account is not in the whitelist of using network interface ConnectionTrackingConfiguration. | 該当リージョンまたはユーザーは、ネットワークインターフェース接続設定のセットをサポートしていません。 |
| 400 | InvalidParameter.InvalidQueuePairNumber | The specified parameter QueuePairNumber exceeds limit. | 指定された RDMA ネットワークインターフェースキューの数が上限を超えています。 |
| 400 | InvalidParameter.EniConnectionTrackingConfiguration | The specify network interface connection tracking configuration exceeds limit. | ネットワークインターフェースコントローラー (NIC) に指定されたネットワーク接続性構成が、許可された範囲を超えています。 |
| 400 | InvalidOperation.MaxEniQueuePairNumberExceed | The QueuePairNumber on the RDMA ENI exceeds the upper limit allowed for a single ENI. | Elastic Network Interface (ENI) に関連付けられた ECS インスタンスの RDMA キュー総数が、インスタンスタイプの制限を超えています。 |
| 400 | InvalidOperation.HighPerformanceEniPerInstanceLimitExceeded | The number of RDMA ENIs attached to the ECS instance exceeds the upper limit. | 現在の ECS インスタンスにアタッチされている RDMA 対応ネットワークインターフェースの数が、ターゲットインスタンスタイプの上限を超えています。 |
| 400 | InvalidOperation.InstanceTypeNotSupportHighPerformance | The ECS instance type where the ENI is located does not support the RDMA mode. | Elastic Network Interface (ENI) がアタッチされている ECS インスタンスのインスタンスタイプは、RDMA 通信モードをサポートしていません。 |
| 400 | InvalidTrafficMode.ModifyToStandardNotSupported | The specified parameter NetworkInterfaceTrafficMode is not supported to modify to Standard. | ネットワークインターフェースの通信モードを RDMA から TCP に変更することはできません。 |
| 400 | InvalidOperation.EniTrafficModeNotSupportIPv6 | The ENI using High Performance traffic mode does not support IPv6. | |
| 400 | InvalidOperation.EniQueuePairNumberOverflow | The RDMA QueuePairNumber of the ECS instance associated with the specified ENI exceeds the limit. | インスタンスにアタッチされている Elastic Network Interface (ENI) のキューペアの合計数が、指定されたインスタンスタイプで許可されている最大値を超えています。 |
| 400 | InvalidParameter.QueuePairNumberMustEmpty | When the traffic mode is set to Standard, the QueuePairNumber must be empty. | Traffic Mode が標準に設定されている場合、指定された QueuePairNumber パラメーターは空である必要があります。 |
| 400 | InvalidParameter.EniTrafficMode | The ENI traffic mode is set incorrectly, it must be either Standard or HighPerformance. | ネットワークインターフェースコントローラー (NIC) の通信モードが無効です。有効な値: Standard、HighPerformance。 |
| 400 | InvalidOperation.InstanceTypeNotSupportRss | The ECS instance type does not support Rss. | 指定されたインスタンスのインスタンスタイプは、RSS の有効化をサポートしていません。 |
| 400 | InvalidParameter.EniEnhancedNetwork | The input parameter "EnhancedNetwork" is illegal, when EnableSriov is true, VirtualFunctionTotalQueueNumber must not be empty, and VirtualFunctionQuantity must be 1 to 256. When EnableSriov is empty or false, VirtualFunctionTotalQueueNumber and VirtualFunctionQuantity must be empty. | 指定されたネットワーク強化パラメーターが無効です。EnableSriov が true に設定されている場合、VirtualFunctionTotalQueueNumber は空にできず、VirtualFunctionQuantity は 1~256 の範囲内である必要があります。EnableSriov が空または false に設定されている場合、VirtualFunctionTotalQueueNumber および VirtualFunctionQuantity は空である必要があります。 |
| 400 | InvalidOperation.NotSupportModifyVFQueueNumberAndVFQuantity | The ENI not support modify VirtualFunctionTotalQueueNumber and VirtualFunctionQuantity when EnableSriov is true. | EnableSriov が true に設定されている場合、VirtualFunctionTotalQueueNumber および VirtualFunctionQuantity の変更はサポートされていません。 |
| 400 | InvalidOperation.TrunkAttachmentMustEmpty | The Attachment of the current Trunk type Network Interface must be empty when modify EnableSriov to true. | EnableSriov を true に設定する場合、トランク ENI にアタッチされているデバイスは空である必要があります。 |
| 400 | Throttling | Request was denied due to request throttling, try again later. | リクエストがスロットルされました。クエリには PageNumber ベースのページング方式ではなく、NextToken ベースのページング方式を使用してください。 |
| 400 | InvalidOperation.SourceDestCheckUnsupported | Modifying sourceDestCheck attribute for network interface is not allowed in the %s region. | 現在のリージョンでは、ネットワークインターフェースの SourceDestCheck プロパティの変更はサポートされていません。 |
| 400 | InvalidOperation.EnablePrimaryIPv6 | The specified ENI can not enable primary IPv6 or already has primary IPv6. | 指定された ENI はプライマリ IPv6 を有効にできないか、すでにプライマリ IPv6 アドレスを持っています。 |
| 500 | InternalError | The request processing has failed due to some unknown error, exception or failure. | リクエストの送信中にエラーが発生しました。後でもう一度お試しください。 |
| 403 | InvalidUserType.NotSupported | %s | ユーザータイプパラメーターが無効です。 |
| 403 | Abs.InvalidAccount.NotFound | %s | Alibaba Cloud アカウントが存在しないか、AccessKey が有効期限切れです。 |
| 403 | Forbidden.NotSupportRAM | %s | Resource Access Management (RAM) ユーザーはこの操作を実行することはサポートされていません。 |
| 403 | Forbidden.SubUser | %s | お使いのアカウントには、このリソースを操作する権限がありません。Alibaba Cloud アカウントに必須の権限をリクエストしてください。 |
| 403 | MaxEniCountExceeded | %s | 操作可能なエラスティックネットワークインターフェイス (ENI) の最大値を超えています。 |
| 403 | EniPerInstanceLimitExceeded | %s | インスタンスにアタッチされている Elastic Network Interface (ENI) の数が最大値に達しました。これ以上インスタンスに Elastic Network Interface (ENI) をアタッチできません。 |
| 403 | InvalidOperation.AvailabilityZoneMismatch | %s | ネットワークインターフェースコントローラー (NIC) と ECS インスタンスの vSwitch が異なるゾーンにあるため、同じゾーンにありません。 |
| 403 | InvalidOperation.VpcMismatch | %s | ネットワークインターフェースの VPC がセキュリティグループの VPC と一致しません。 |
| 403 | SecurityGroupInstanceLimitExceed | %s | セキュリティグループ内のインスタンス数が最大値に達しました。 |
| 403 | InvalidSecurityGroupId.NotVpc | %s | 参数SecurityGroupId无效,该安全组的网络类型不是专有网络。 |
| 403 | InvalidOperation.InvalidEniType | %s | 現在の Elastic Network Interface (ENI) のタイプでは、この操作はサポートされていません。ネットワークインターフェイスコントローラー (NIC) のタイプに互換性がありません。 |
| 403 | InvalidOperation.EniServiceManaged | %s | 無効な操作です。 |
| 403 | InvalidOperation.MultiGroupType | The specified instance can't join different types of security group. | 指定されたインスタンスは、異なるタイプのセキュリティグループに参加できません。 |
| 403 | InvalidOperation.EniCountExceeded | The maximum number of eni in a enterprise level security group is exceeded. | 現在の ECS インスタンスにアタッチされている Elastic Network Interface (ENI) の数が、ターゲットインスタンスタイプの Elastic Network Interface (ENI) の制限を超えています。 |
| 403 | InvalidParams.NetworkInterfaceName | %s | |
| 403 | InvalidOperation.ModifyPrimaryEniQueueNumber | Primary NetworkInterface is not allowed to modify queue number. | |
| 403 | InvalidOperation.InvalidEniState | Available status or ECS instance attached is Stopped is allowed to modify network interface queue number. | 現在の ENI のステータスでは、ENI の属性を変更できません。 |
| 403 | InvalidOperation.ResourceManagedByCloudProduct | %s | リソースがクラウドサービスによって管理されているため、この操作はサポートされていません。対応するクラウドサービスに連絡して理由を確認してください。 |
| 403 | InvalidParameter.InvalidEniQueueNumber | %s | ネットワークインターフェースコントローラー (NIC) キューの数が正しくありません。詳細については、エラーメッセージ内の %s プレースホルダーの実際の返却結果を参照してください。 |
| 403 | InvalidOperation.MaxEniQueueNumberExceeded | %s | Elastic Network Interface (ENI) のキュー数が上限を超えています。詳細については、エラーメッセージ内の %s プレースホルダーの実際の戻り結果を参照してください。 |
| 403 | InvalidOperation.ExceedInstanceTypeQueueNumber | %s | 現在の ECS インスタンスにアタッチされている Elastic Network Interface (ENI) キューの数が、ターゲットインスタンスタイプのネットワークインターフェースコントローラー (NIC) キュー上限を超えています。 |
| 403 | AclLimitExceed | %s | ENI またはインスタンスのセキュリティグループルールの数がクォータを超えています。 |
| 403 | InvalidOperation.EniTypeUnsupported | The specified eni type does not supported. | 指定されたビジネスタイプはサポートされていません。 |
| 403 | InvalidVSwitch.Ipv6NotEnabled | The VSwitch of ENI does not support IPv6 feature. | |
| 404 | InvalidEcsId.NotFound | %s | 指定されたインスタンス ID が存在しません。 |
| 404 | InvalidEniId.NotFound | %s | |
| 404 | InvalidVSwitchId.NotFound | %s | 指定された vSwitch が存在しません。 |
| 404 | InvalidSecurityGroupId.NotFound | %s | 指定されたセキュリティグループが存在しません。 |
| 404 | InvalidOperation.PrimaryEniOnlySupportModifyNameAndDesc | Primary NetworkInterface is only allowed to modify name and description. | プライマリ ENI では、ENI 名と説明の変更のみがサポートされています。 |
| 404 | InvalidParameter.SecurityGroupIdRepeated | The specified security group ids has repeated. | セキュリティグループが重複しています。 |
| 409 | OperationConflict | Request was denied due to conflict with a previous request,please try again later. | リクエストされたリソースが以前のリクエストと競合しています。 |
| 409 | TokenProcessing | The previous token request is still processing. Please try again later. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。