すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:ModifyDiskSpec

最終更新日:Sep 15, 2026

ディスクタイプ、または ESSD (エンタープライズ SSD) のパフォーマンスレベル (PL) を変更します。リージョン ESSD、ベーシックディスク、エラスティックエフェメラルディスク、およびローカルディスクは、ディスクタイプの変更をサポートしていません。

操作説明

仕様変更がワークロードに与える影響を最小限に抑えるため、オフピーク時間に変更を実行してください。

このオペレーションを呼び出す際は、次の点に注意してください。

  • ESSD (エンタープライズ SSD) のパフォーマンスレベル (PL) を変更する場合:

    • サブスクリプションの ESSD は、パフォーマンスレベル (PL) のアップグレードのみをサポートします。

    • 従量課金の ESSD は、パフォーマンスレベル (PL) のアップグレードとダウングレードの両方をサポートしますが、PL0 へのダウングレードはできません。

    • ESSD は、[In_use] または [Available] 状態である必要があります。

    • ESSD が ECS インスタンスにアタッチされている場合、インスタンスは [Running] または [Stopped] 状態である必要があります。インスタンスが期限切れ状態または支払い遅延状態であってはなりません。

    • ESSD のパフォーマンスレベルはディスク容量に依存するため、パフォーマンスレベルをアップグレードできない場合は、ディスクをスケールアウト (ResizeDisk) してから再試行してください。詳細については、「Enterprise SSD」をご参照ください。

  • ディスクタイプの変更に関する注意事項については、「ディスクタイプの変更」をご参照ください。

  • サポートされているディスクタイプの変更については、「サポートされているディスクタイプの変更」をご参照ください。

ディスクタイプの変更後、課金は次のように変わります。

  • 従量課金ディスク:新しいディスクタイプに基づいて課金されます。

  • サブスクリプションディスク:追加料金は、新旧の構成の価格差と、課金サイクルの残り日数 (翌日の 00:00 から有効期間の終了まで) に基づいて計算されます。

ディスクの課金情報については、「ブロックストレージの課金」をご参照ください。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:ModifyDiskSpec

update

*Disk。

acs:ecs:{#regionId}:{#accountId}:disk/{#diskId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DiskId

string

必須

ディスクの ID。

d-bp131n0q38u3a4zi****

PerformanceLevel

string

任意

ESSD (エンタープライズ SSD) の新しいパフォーマンスレベル (PL) を指定します。有効な値は次のとおりです。

  • PL0:ディスクあたり最大 10,000 のランダム読み取り/書き込み IOPS。

  • PL1:ディスクあたり最大 50,000 のランダム読み取り/書き込み IOPS。

  • PL2:ディスクあたり最大 100,000 のランダム読み取り/書き込み IOPS。

  • PL3:ディスクあたり最大 1,000,000 のランダム読み取り/書き込み IOPS。

デフォルト値:PL1。

PL2

DiskCategory

string

任意

新しいディスクタイプを指定します。有効な値は次のとおりです。

  • cloud_essd:ESSD (エンタープライズ SSD)。

  • cloud_auto:ESSD AutoPL ディスク。

  • cloud_ssd:標準 SSD。

  • cloud_efficiency:Ultra ディスク。

デフォルト値:空。このパラメーターを指定しない場合、ディスクタイプの変更は実行されません。

説明
  • 上記の有効な値は、パフォーマンスが高い順に記載されています。指定されたディスクがサブスクリプションディスクの場合、ディスクタイプをダウングレードすることはできません。

cloud_essd

DryRun

boolean

任意

このリクエストのドライランのみを実行するかどうかを指定します。有効な値は次のとおりです。

  • true:ドライランを実行します。システムは、必須パラメーターが指定されているか、リクエストフォーマットが有効か、ビジネス上の制限が満たされているか、ECS リソースが十分かをチェックします。チェックに失敗した場合は、対応するエラーが返されます。チェックに合格した場合は、エラーコード DryRunOperation が返されます。

  • false:実際のリクエストを実行します。チェックに合格すると、2XX の HTTP ステータスコードが返され、ディスクタイプの変更または ESSD パフォーマンスレベルの変更が実行されます。

デフォルト値:false。

false

ProvisionedIops

integer

任意

ESSD AutoPL ディスクのプロビジョニングされた読み取り/書き込み IOPS の新しい値を指定します。

有効な値:0~min{50,000, 1,000 × 容量 - ベースラインパフォーマンス}。

ベースラインパフォーマンス = min{1,800 + 50 × 容量, 50,000}。

説明

このパラメーターは、DiskCategory が cloud_auto に設定されている場合にのみ有効です。詳細については、「ESSD AutoPL ディスク」および「ESSD AutoPL ディスクのプロビジョニングされたパフォーマンスの変更」をご参照ください。

50000

PerformanceControlOptions

object

任意

ディスクパフォーマンスコントロールパラメーターのコレクション。

IOPS

integer

任意

ディスクのターゲット IOPS を指定します。専用ブロックストレージクラスターディスクの IOPS のみ変更できます。

有効な値:900 から単一ディスクの最大 IOPS まで、100 刻み。

詳細については、「ディスクパフォーマンス」をご参照ください。

2000

Recover

string

任意

ディスクパフォーマンスをリセットします。このパラメーターは、専用ブロックストレージクラスターディスクの場合にのみ有効です。

このパラメーターが指定されている場合、PerformanceControlOptions.IOPS および PerformanceControlOptions.Throughput パラメーターは無視されます。

現在、All のみがサポートされており、ディスク IOPS とスループットを初期値にリセットします。

All

Throughput

integer

任意

ディスクのターゲットスループット (MB/秒) を指定します。専用ブロックストレージクラスターディスクのスループットのみ変更できます。

有効な値:60 から単一ディスクの最大スループットまで。

詳細については、「ディスクパフォーマンス」をご参照ください。

200

DestinationZoneId

string

任意

説明

このパラメーターは現在、招待制プレビューのため、ご利用いただけません。

cn-hangzhou-g

レスポンスフィールド

フィールド

型

説明

例

object

OrderId

string

生成された注文の ID です。

説明

注文 ID は、サブスクリプションディスクが変更または修正された場合にのみ返されます。

20413515388****

RequestId

string

リクエスト ID です。

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

TaskId

string

ディスクタイプ変更タスクの ID です。

説明

このパラメーターは、ESSD (エンタープライズ SSD) のパフォーマンスレベル (PL) のみを変更した場合は返されません。

t-bp67acfmxazb4p****

例

成功レスポンス

JSONJSON

{
  "OrderId": "20413515388****",
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E",
  "TaskId": "t-bp67acfmxazb4p****"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidPerformanceLevel.Malformed The specified parameter PerformanceLevel is not valid. 指定された PerformanceLevel パラメーターが無効です。有効なフォームを指定してください。
400 InvalidDiskCategory.ValueNotSupported The specified parameter "DiskCategory" is not valid. 指定されたシステムディスクタイプおよびデータディスクタイプはサポートされていません。
400 InvalidPerformanceLevelParam.Mismatch The specified parameter PerformanceLevel should be null when DiskCategory is not cloud_essd.
400 OperationDenied.DiskInDedicatedBlockStorageCluster The disk in dedicated block storage cluster is not allowed to do this operation.
400 IncorrectDiskStatus.ReplicationStatusNotFound Disk replication status not found.
400 IncorrectDiskStatus.InReplication Disk already in replication.
400 ProvisionedIopsForDiskCategoryUnsupported The specified disk category does not support provisioned iops. 指定されたディスクタイプはプロビジョニング済み IOPS をサポートしていません。
400 InvalidProvisionedIops.LimitExceed The provisioned iops exceeds the limit. 指定された ProvisionedIops パラメーターが上限を超えています。
400 QuotaExceed.DiskCapacity The used capacity of disk type has exceeded the quota in the zone, %s. 指定されたディスクタイプの使用済み容量がアクティブなゾーンのクォータ制限を超えています。クォータセンターに移動して、ディスク容量クォータのクエリおよび増加リクエストを行ってください。
400 MalformedParameter.PerformanceControlOptions Parameter invalid, %s. パラメーターが無効です。
400 InvalidPerformanceControlOptions.ModifyOperationUnsupported The specified performance control options are conflicts with disk category or performance level or ProvisionIOPS. ディスクパフォーマンスコントロールパラメーターが、ディスクタイプ、ディスクパフォーマンスレベル、またはプロビジョニング済み IOPS パラメーターと競合しています。
400 NoPermission.Price The operation requires price permission. Please either apply for permission from your main account or set the parameter AutoPay to true.
400 NoPermission.Refund The operation requires refund permission. Please apply for permission from your main account. アカウントに返金を実行する権限がありません。プライマリアカウントが返金関連のフォーム権限を付与する必要があります。
400 InvalidOperation.InstanceRenewWithDowngradeInPlan The operation is denied due to the specified instance has renew with downgrade record in plan. 未発効の更新およびスペックダウン注文が存在します。注文が有効になるまで、この操作は実行できません。
400 InvalidOperation.InstanceStatusUnsupported The specified instance status is not supported for this operation. The expected status is Running or Stopped.
400 MissingParameter.DestinationZoneId The parameter DestinationZoneId must be specified when modifying the disk specification from a regional disk to a zone disk. リージョナルディスクをゾーンレベルのディスクに変更する場合、DestinationZoneId を指定する必要があります。
400 InvalidDestinationZoneId.Mismatch The specified DestinationZoneId of the regional disk with 'In-use' status should remain consistent with the ZoneId of instance. アタッチ済みのリージョナルディスクの仕様変更を実行する場合、指定された DestinationZoneId はインスタンスのものと同じである必要があります。
400 InvalidOperation.MultiAttachRegionalDiskUnsupported The multi-attach regional disk with 'In-use' status attached to more than one instance is not allowed to modify disk spec. アタッチ済みのマルチアタッチリージョナルディスクは、仕様変更を実行する前に 1 つのインスタンスにのみアタッチされている必要があります。
400 InvalidDestinationZoneId.DiskCategoryUnsupported The specified disk category does not allow the DestinationZoneId parameter for this operation. 指定されたディスクのディスクタイプは、仕様変更時の DestinationZoneId の指定をサポートしていません。
400 IncorrectInstanceStatus The current status of the instance does not support this operation. 現在のインスタンスステータスでは、この操作はサポートされていません。
400 InvalidOperation.DiskStatusNotSupported The specified disk is not in a valid status for the current operation. Ensure the disk is in a valid status before you modify its specification.
500 InternalError The request processing has failed due to an internal error and you may retry later or contact support with the request ID.
403 DiskInArrears The specified operation is denied because the disk has overdue payments. Please settle the outstanding balance.
403 InstanceExpiredOrInArrears The specified operation is denied as your prepay instance is expired (prepay mode) or in arrears (afterpay mode).
403 IncorrectDiskStatus The current disk status does not support this operation.
403 DiskCreatingSnapshot The operation is denied due to a snapshot of the specified disk is not completed yet.
403 OperationDenied The type of the disk does not support the operation. 指定されたスナップショットではデータボリュームの作成が許可されていません。
403 InvalidPerformanceLevel.TooLow Specified new performance level is lower than the original performance level.
403 OperationDenied.PerformanceLevelNotMatch The specified PerformanceLevel and disk size do not match. 指定されたパフォーマンスレベルがディスクサイズと一致しません。
403 UserNotInTheWhiteList The user is not in modify disk category white list.
403 InvalidRegion.NotSupport The specified region does not support modify disk category.
403 InvalidDiskCategory.ValueNotSupported The current disk category of the resource does not support this operation. 指定されたシステムディスクタイプおよびデータディスクタイプはサポートされていません。
403 Downgrade.NotSupported Downgrade operation for prepay resource is not supported.
403 InvalidInstanceType.NotSupportDiskCategory The instanceType of the specified instance does not support this disk category. 指定されたインスタンスタイプ (InstanceType) が現在のインスタンスのディスクカテゴリをサポートしていません。別のインスタンスタイプを試してください。各インスタンスタイプでサポートされるディスクタイプについては、インスタンスファミリーのドキュメントを参照してください。
403 ModifyingDiskCategoryLimitExceed The amount of modifying disk category exceeds the limit. 現在のリージョンでサイズ変更中のディスク数が上限を超えています。
403 DiskInCoolingPeriod There is a cooling period after the disk is successfully modified. ディスクは仕様変更のクールダウン期間内であり、再度サイズ変更することはできません。
403 DiskHasFlashSnapshot The specified disk with flash snapshots do not support modify disk category.
403 NoChangeInDiskCategoryAndPerformanceLevel There is no change between the parameters transmitted and the current. 指定されたディスクカテゴリおよびパフォーマンスレベルは、現在のディスクと同じです。
403 OperationDenied.NoStock The requested resource is sold out in the specified zone; try other types of resources or other regions and zones. 指定されたディスクカテゴリが指定されたゾーンまたはクラスターに存在しないか、指定されたゾーンがクラスターと一致しません。
403 InvalidOperation.MultiAttachDisk Multi attach disk does not support this operation. マルチアタッチが有効なディスクはこの操作をサポートしていません。
403 OperationDenied.DiskExpansionUnfinished The instance has not been restarted after a previous disk expansion.
403 InvalidDiskCategory.NotSupported The specified disk category is not supported. 指定されたディスクカテゴリは、インスタンスタイプでサポートされていません。
403 InvalidPerformanceParameter.DiskNotInDedicatedStorageCluster The specified disk is not in a dedicated storage cluster. Performance control options cannot be modified.
403 InvalidStatus.DiskUnderPerformanceControl The specified disk is under performance control. Any modifications to the category or performance level of the specified disk are unsupported.
403 InvalidStatus.DiskNotReady The specified disk is not ready. The status must be either In_use or Available.
403 InvalidOperation.DiskInReplicaPairsUnsupported The disk in replication pairs does not support this operation. ディスク非同期レプリケーションペア内のディスクでは、ディスクタイプの変更はサポートされていません。
403 InvalidDisk.DetachedSystemDisk The specified resource is/has a detached system disk %s , not support current operation. 指定されたディスクはデタッチされたシステムディスクであり、現在の操作をサポートしていません。
403 InvalidDiskCategory.InstanceTypeUnsupported The current instance type does not support the specified disk category. Please check the list of disk category supported by the instance type and select an appropriate disk category for configuration. 現在のインスタンスタイプは、指定されたディスクカテゴリをサポートしていません。インスタンスタイプでサポートされているディスクタイプのリストを確認し、有効なディスクカテゴリを選択してください。
403 InvalidOperation.CMKNotEnabled The specified KMS key must be in an enabled state. Please enable the key in the KMS console and try again.
403 InvalidOperation.CMKUnauthorized The specified KMS key is not authorized for the ECS service. Please grant the ECS service permission to use the key in the KMS console and try again.
403 InstanceLockedForSecurity The instance is locked for security reasons. Please contact Security Technical Support for assistance. ディスクがアタッチされているインスタンスは、セキュリティ上の理由によりロック済みです。
404 InvalidDiskId.NotFound The specified disk does not exist. 指定されたディスクが存在しません。ディスク ID が正しいかどうかを確認してください。
404 InvalidInstanceId.NotFound The specified InstanceId does not exist. 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。
404 InternalError The request processing has failed due to an internal error and you may retry later or contact support with the request ID.
404 InvalidDiskCategory.ValueUnauthorized The specified DiskCategory is not authorized.
404 OperationDenied The specified InstanceType or Zone is not available or not authorized.

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。