この API は廃止されました。一時的にアクセス可能ですが、更新やバグ修正対応は一切行われません。代わりに Vpc(2016-04-28) - DescribeEipMonitorData への移行を推奨します。より強化された機能に加え、サポートも引き続きご利用いただけます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
vpc:DescribeEipMonitorData |
get |
*Address
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| RegionId |
string |
任意 |
リージョン ID |
|
| AllocationId |
string |
必須 |
EIP インスタンスの ID。 |
|
| StartTime |
string |
必須 |
クエリする時間有効値の開始時刻。ISO 8601 標準の |
|
| EndTime |
string |
必須 |
クエリする時間有効値の終了時刻。ISO 8601 標準の |
|
| Period |
integer |
任意 |
各モニタリングデータエントリの持続時間。単位: 秒。有効な値: 60 (デフォルト)、300、900、3600。 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
応答パラメーター。 |
||
| RequestId |
string |
リクエスト ID |
|
| EipMonitorDatas |
object |
EIP のモニタリングデータ。 |
|
| EipMonitorData |
array<object> |
EIP のモニタリングデータエントリ。 |
|
|
object |
EIP のモニタリングデータ。 |
||
| EipTX |
integer |
EIP の送信トラフィック (TX)。単位:kbit/s。 |
|
| EipPackets |
integer |
EIP の秒間パケット数 (pps)。 |
|
| EipBandwidth |
integer |
EIP の帯域幅。単位:Mbit/s。 |
|
| TimeStamp |
string |
データポイントのタイムスタンプ。値は |
|
| EipFlow |
integer |
EIP の接続数。 |
|
| EipRX |
integer |
EIP の受信トラフィック (RX)。単位:kbit/s。 |
例
成功レスポンス
JSONJSON
{
"RequestId": "",
"EipMonitorDatas": {
"EipMonitorData": [
{
"EipTX": 0,
"EipPackets": 0,
"EipBandwidth": 0,
"TimeStamp": "",
"EipFlow": 0,
"EipRX": 0
}
]
}
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidParameter.TooMany | monitor parameter too many data required. | |
| 400 | InvalidStartTime.Malformed | The specified parameter "StartTime" is not valid. | |
| 400 | InvalidEndTime.Malformed | The specified parameter "EndTime" is not valid. | |
| 400 | InvalidPeriod.ValueNotSupported | The specified parameter "Period" is not valid. | |
| 400 | InvalidStartTime.TooEarly | The specified parameter "StartTime" is too early. | |
| 400 | InvalidAllocationId.NotFound | Specified allocation id is not found. | |
| 400 | InvalidParameter | Specified value of "Period" is not valid | |
| 400 | OperationDenied.TooManyDataQueried | Specified operation is denied as too many data to return. | |
| 400 | InvalidRegionInstance | The specified InstanceId does not exist in given region. | |
| 404 | InvalidIpInstanceId.NotFound | The specified Eip InstanceId does not exist in our records. | |
| 404 | InvalidInstanceId.NotFound | The InstanceId provided does not exist in our records. | |
| 404 | Forbidden.RegionNotFound | Specified region is not found during access authentication. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。