すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:DeleteDisk

最終更新日:Jul 14, 2026

従量課金制のデータクラウドディスクをリリースします。クラウドディスクのタイプには、基本クラウドディスク、Ultra クラウドディスク、標準 SSD、エンタープライズ SSD があります。

操作説明

この操作を呼び出す際は、以下の項目にご注意ください。

  • ディスクの手動スナップショットは保持されます。

  • ModifyDiskAttribute を呼び出して、自動スナップショットをディスクと一緒に保持するかリリースするかの設定項目を設定できます。不要なスナップショットは速やかに削除し、エポックベースの自動スナップショットポリシーのための十分なスナップショットクォータを維持してください。

  • リリース時に、ディスクはアタッチ待ち (使用可能) の状態である必要があります。

  • 指定された ID のディスクが存在しない場合、リクエストは無視されます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

ecs:DeleteDisk

delete

*Disk

acs:ecs:{#regionId}:{#accountId}:disk/{#diskId}

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

DiskId

string

必須

リリースするディスクの ID。

d-bp14k9cxvr5uzy5****

レスポンスフィールド

フィールド

型

説明

例

object

RequestId

string

リクエスト ID

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

例

成功レスポンス

JSONJSON

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidRegionId.MalFormed The specified parameter RegionId is not valid.
500 InternalError The request processing has failed due to some unknown error.
403 IncorrectDiskStatus The current disk status does not support this operation.
403 DiskNotPortable The specified disk is not a portable disk.
403 DiskTypeViolation The specified disk is a system disk and cannot support the operation. 指定されたディスクはシステムディスクであるため、デタッチできません。
403 DiskCreatingSnapshot The operation is denied due to a snapshot of the specified disk is not completed yet.
403 IncorrectDiskStatus.Initializing The current disk status does not support this operation.
403 DiskStillAttached The disk is still attached to the disk.
403 UserNotInTheWhiteList The user is not in disk white list. ユーザーが ARN 関連パラメーター操作リストに含まれていません。
403 InvalidDiskStatus.DeleteProtection The specified disk is under delete protection. It cannot be deleted.
404 InvalidDiskId.NotFound The specified disk does not exist. 指定されたディスクが存在しません。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。