従量課金制のデータクラウドディスクをリリースします。クラウドディスクのタイプには、基本クラウドディスク、Ultra クラウドディスク、標準 SSD、エンタープライズ SSD があります。
操作説明
この操作を呼び出す際は、以下の項目にご注意ください。
ディスクの手動スナップショットは保持されます。
ModifyDiskAttribute を呼び出して、自動スナップショットをディスクと一緒に保持するかリリースするかの設定項目を設定できます。不要なスナップショットは速やかに削除し、エポックベースの自動スナップショットポリシーのための十分なスナップショットクォータを維持してください。
リリース時に、ディスクはアタッチ待ち (使用可能) の状態である必要があります。
指定された ID のディスクが存在しない場合、リクエストは無視されます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:DeleteDisk |
delete |
*Disk
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| DiskId |
string |
必須 |
リリースするディスクの ID。 |
d-bp14k9cxvr5uzy5**** |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
リクエスト ID |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
例
成功レスポンス
JSONJSON
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidRegionId.MalFormed | The specified parameter RegionId is not valid. | |
| 500 | InternalError | The request processing has failed due to some unknown error. | |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | DiskNotPortable | The specified disk is not a portable disk. | |
| 403 | DiskTypeViolation | The specified disk is a system disk and cannot support the operation. | 指定されたディスクはシステムディスクであるため、デタッチできません。 |
| 403 | DiskCreatingSnapshot | The operation is denied due to a snapshot of the specified disk is not completed yet. | |
| 403 | IncorrectDiskStatus.Initializing | The current disk status does not support this operation. | |
| 403 | DiskStillAttached | The disk is still attached to the disk. | |
| 403 | UserNotInTheWhiteList | The user is not in disk white list. | ユーザーが ARN 関連パラメーター操作リストに含まれていません。 |
| 403 | InvalidDiskStatus.DeleteProtection | The specified disk is under delete protection. It cannot be deleted. | |
| 404 | InvalidDiskId.NotFound | The specified disk does not exist. | 指定されたディスクが存在しません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。