高可用性仮想 IP アドレス(HaVip)を指定されたインスタンスに関連付けます。
この API は廃止されました。一時的にアクセス可能ですが、更新やバグ修正対応は一切行われません。代わりに Vpc(2016-04-28) - AssociateHaVip への移行を推奨します。より強化された機能に加え、サポートも引き続きご利用いただけます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
vpc:AssociateHaVip |
update |
*Instance
*HaVip
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
||
| RegionId |
string |
必須 |
||
| HaVipId |
string |
必須 |
||
| InstanceId |
string |
必須 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
例
成功レスポンス
JSONJSON
{
"RequestId": ""
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidVip.Status | vip invalid status | |
| 400 | IncorrectHaVipStatus | HaVip can be operated by this action only when it's status is Available or InUse. | |
| 400 | IncorrectInstanceStatus | ECS instance can be operated by this action only when it??s status is Running or Stopped. | |
| 400 | CountLimitExceed.HaVipOnInstance | The amount of HaVip associated with the specified Instance reach its limits. | |
| 400 | CountLimitExceeded.HaVipOnECSInstance | The amount of Instance associated with the specified HaVip reach its limits. | |
| 400 | OperationFailed.DistibuteLock | Distibute lock fail. | |
| 400 | Forbidden.HaVip | No permissions to perform operations on HAVIPs. Please apply for privilege--vpc_privilege_allow_buy_havip_instance. | |
| 400 | OperationUnsupported.BindMultipleType | You cannot bind HaVip to multiple instance types. | |
| 404 | InvalidHaVip.Exist | haVip already bind exist. | |
| 404 | InvalidRegionId.NotFound | The RegionId provided does not exist in our records. | |
| 404 | InvalidHaVipId.NotFound | The specified HaVip does not exist in the specified region. | |
| 404 | InvalidInstanceId.NotFound | The specified Instance does not exist in the specified region. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。