すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:AssociateEipAddress

最終更新日:Apr 18, 2026

説明

この API は廃止されました。一時的にアクセス可能ですが、更新やバグ修正対応は一切行われません。代わりに Vpc(2016-04-28) - AssociateEipAddress への移行を推奨します。より強化された機能に加え、サポートも引き続きご利用いただけます。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

vpc:AssociateEipAddress

update

*All Resource

*

なし なし

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

RegionId

string

任意

AllocationId

string

必須

InstanceId

string

必須

InstanceType

string

任意

レスポンスフィールド

フィールド

型

説明

例

object

レスポンスパラメーター。

RequestId

string

RequestId。

例

成功レスポンス

JSONJSON

{
  "RequestId": ""
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 InvalidAction.Denied Action is denied due to unfinished Eip configuration modification.
400 InvalidAssociation.Duplicated Specified instance already is associated.
400 OperationDenied Specified instance is not in VPC.
400 InvalidParameter.Mismatch Specified elastic IP address and ECS instance are not in the same region.
400 IncorrectEipStatus Current elastic IP status does not support this operation
400 IncorrectInstanceStatus Current instance status does not support this operation.
400 InvalidInstanceType.ValueNotSupported The specified value of InstanceType is not supported.
400 IncorrectHaVipStatus HaVip can be operated by this action only when it's status is Available or InUse.
400 InvalidParameter The specified parameter is not valid.
400 ReserveIpFail Reserve eip failed.
400 Forbbiden The eip instance owener error
400 TaskConflict The eip operate too frequent, TaskConflict.
400 InvalidBindingStatus The eip binding status invalid.
400 BIND_INSTANCE_HAVE_PORTMAP_OR_BIND_EIP The instance may have portMap or already bind eip.
400 EIP_CAN_NOT_ASSOCIATE_WITH_PUBLIC_IP instance already bind natpublicip,cannot bind eip.
400 BIND_INSTANCE_OWENER_ERROR Cannot operate the eip.
400 QuotaExceeded.NumberOfTrafficEip The number of traffic eip on natgw exceed limitation.
400 QuotaExceeded.NumberOfEip Binded eip Quota exceed on this NatGw.
400 InvalidEipBandwidth.OutOfMaxValue ""
400 Forbidden.EipCanNotBindGatgw Eip can not bind on natgw.
400 Forbidden.InstanceBandwidthNotZero Eip can not bind with instance when it's bandwidth is not zero.
400 INSTANCE_TYPE_NOT_SUPPORT The instance type is invalid.
400 InvalidStatus.EcsStatusNotSupport The special instance status Pending is not support operate
400 NATGATEWAY_FINANCIALLOCKED The NatGateway has expire, cannot do bind operation.
400 InvalidParameter.InstanceTypeNotSupport The specified instance type is not support.
400 InstanceType.NotSupport The instance type is invalid.
400 InvalidParams.NotFound instance not found
400 BindInstance.NotSupported bind instance type %s is not supported.
400 ServerRegion.Invalid Eip bind remote server region invalid.
400 Eni.Attached The eni should be detached from ecs when associating with direct eip.
400 Invalid.DirectEip.BindType The direct eip can be only associated with eni.
400 InvalidStatus.EniStatusNotSupport %s
400 InvalidParameter.EniInstanceId %s
400 InvalidNexthop.DirectEni The direct Eni cannot be nexthop.
400 InvalidEIPStatus.BizDisabled The EIP has been locked.
400 OperationFailed.EniSubIp Eni has sub ip can not bind direct eip.
400 InvalidEip.EipQuotaExceeded The specified eni assigned eip is more than privateIp.
400 OperationFailed.QueryCommodityInfo Operation failed because quey commodity info error.
400 OperationUnsupported.MultiIp Multi ip function is not support.
400 InvalidNicOrVm.NotFound Bind nic or vm not exist.
400 OperationUnsupported.EipBindModel The instance type of ecs does not support MULTI_BINDED model Eip.
400 IncorrectStatus.NatGateway %s
400 InvalidParameter.BindingInstanceRegion The specified BindingInstanceRegion is not supported.
400 OperationFailed.HavipBoundPortmap %s
400 InvalidStatus.NotAllow Bound instance status is invalid.
400 InvalidInstance.NotVpc Bound instance is not vpc instance.
400 InvalidStatus.InstanceHasBandWidth The specified instance bandwidth invalid.
400 OperationDenied.CloudBoxResourceExist The operation is not allowed because the resource to be bound is a CloudBox resource.
404 InvalidAllocationId.NotFound Specified allocation ID is not found.
404 InvalidInstanId.NotFound Specified instance does not exist.
404 InvalidHaVip.NotFound The specified HaVip does not exist.
404 Forbidden.RegionNotFound Specified region is not found during access authentication.
404 InvalidRegionId.NotFound Specified value of InstanceRegionId is not supported.
404 InvalidInstance.NotExist Bind instance data not exist.
503 ServiceUnavailable The request has failed due to a temporary failure of the server.

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。