すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:変更追跡タスクの設定 (新しいコンソール)

最終更新日:Jul 25, 2026

Data Transmission Service (DTS) は、使いやすい変更追跡機能を提供します。DTS コンソールで簡単なステップで変更追跡タスクを設定できます。

注意事項

このトピックでは、変更追跡タスクを設定するための一般的な手順について説明します。さまざまなデータソースの詳細な例については、「変更追跡シナリオの概要」をご参照ください。

説明

このトピックでは、ApsaraDB RDS for MySQL インスタンスを例として使用します。パラメーター設定は参考用です。実際の UI は異なる場合があります。

前提条件

  • DTS がサポートするソースデータベースインスタンスを作成済みであること。サポートされているデータベースとバージョンについては、「変更追跡シナリオの概要」をご参照ください。

  • ソースデータベースが自己管理データベースの場合は、DTS の環境要件を満たすための準備も必要です。詳細については、「事前準備」をご参照ください。

操作手順

  1. 次のいずれかの方法で [変更追跡タスク] ページに移動し、変更追跡インスタンスが存在するリージョンを選択します。

    DTS コンソール

    1. DTS コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、[変更追跡] をクリックします。

    3. ページの左上隅で、変更追跡インスタンスが存在するリージョンを選択します。

    DMS コンソール

    説明

    実際の操作は、DMS コンソールのモードとレイアウトによって異なる場合があります。詳細については、「シンプルモードコンソール」および「DMS コンソールのレイアウトとスタイルをカスタマイズ」をご参照ください。

    1. DMS コンソールにログインします。

    2. 上部のナビゲーションバーで、ポインターを [データ + AI] > [DTS (DTS)] > [変更追跡] に移動します。

    3. [変更追跡タスク] の右側にあるドロップダウンリストから、変更追跡インスタンスが存在するリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページに移動します。

  3. (任意) ページの右上隅にある 新バージョンの設定ページを試してみる をクリックします。

    説明
    • ページの右上隅に 旧バージョンの設定ページに戻る ボタンが表示されている場合は、このステップをスキップしてください。

    • 設定ページの新旧バージョンでは、一部のパラメーターが異なる場合があります。新しい設定ページを使用することを推奨します。

  4. [ソースデータベース] および [コンシューマーネットワークタイプ] セクションでパラメーターを設定します。

    警告

    ソースデータベースインスタンスを指定した後、ページの上部に表示される [使用制限] をお読みになることを推奨します。そうしないと、タスクが失敗したり、追跡対象データが消費できなくなったりする可能性があります。

    セクション

    パラメーター

    説明

    N/A

    タスク名

    変更追跡タスクの名前。DTS はタスクに自動的に名前を割り当てます。タスクを識別しやすいように、わかりやすい名前を指定することを推奨します。一意のタスク名を使用する必要はありません。

    移行元データベース

    既存の接続情報の選択

    この例では、既存の接続を選択せず、次のフィールドでデータベースの詳細を設定します。

    データベースタイプ

    MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ApsaraDB RDS for MySQL インスタンスが配置されているリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    現在の Alibaba Cloud アカウント内のデータベースインスタンスを使用する場合は、× を選択します。

    RDS インスタンス ID

    ご利用の ApsaraDB RDS for MySQL インスタンスの ID を選択します。

    データベースアカウント

    ApsaraDB RDS for MySQL データベースの [読み取り専用アカウント]、または [REPLICATION CLIENT]、[REPLICATION SLAVE]、[SHOW VIEW]、[SELECT] 権限を持つカスタムアカウントを入力します。

    データベースのパスワード

    データベースインスタンスへのアクセスに使用するパスワード。

    暗号化

    この例では、デフォルト設定のままにすることができます。

    コンシューマーネットワークタイプ

    ネットワークタイプ

    [ネットワークタイプ] パラメーターの値は [VPC] に固定されています。[VPC] と [vSwitch] を選択する必要があります。詳細については、「VPC」をご参照ください。

    説明
    • 変更追跡タスクを設定した後は、[コンシューマーネットワークタイプ] セクションの設定を変更することはできません。

    • 変更追跡クライアントが VPC にデプロイされている場合は、クライアントに接続されているのと同じ [VPC] と [vSwitch] を選択することを推奨します。

    • 内部ネットワーク経由でデータ変更を追跡する場合、ネットワーク遅延は最小限に抑えられます。

  5. ページの下部で、[接続をテストして続行] をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、DTS サーバーの CIDR ブロックがソースデータベースとターゲットデータベースのセキュリティ設定に自動または手動で追加できることを確認してください。詳細については、「DTS サーバーの IP アドレスをホワイトリストに追加」をご参照ください。

    • ソースデータベースが自己管理データベースで、その [アクセス方法] が [Alibaba Cloud インスタンス] に設定されていない場合は、[DTS サーバーの CIDR ブロック] ダイアログボックスで [接続をテスト] をクリックします。

  6. 変更追跡のオブジェクトを設定します。

    1. オブジェクト設定 ページで、変更追跡のオブジェクトを設定します。

      パラメーター

      説明

      データ変更タイプ

      データ変更タイプ オプションはデフォルトで選択されており、変更できません。

      • データ更新

        DTS は、選択したオブジェクトのデータ更新 (INSERT、DELETE、UPDATE 操作を含む) を追跡します。

      • [スキーマ更新]

        DTS は、ソースインスタンスのすべてのオブジェクトスキーマに対して実行される作成、削除、変更操作を追跡します。追跡するデータをフィルターするには、変更追跡クライアントを使用する必要があります。

      ソースオブジェクト

      [ソースオブジェクト] セクションから 1 つ以上のオブジェクトを選択し、Right arrow アイコンをクリックして、オブジェクトを [選択したオブジェクト] セクションに追加します。

      説明

      変更追跡のオブジェクトとして、テーブルまたはデータベースを選択できます。

      • オブジェクトとしてデータベースを選択した場合、DTS はデータベース内の新しいオブジェクトを含む、すべてのオブジェクトの増分データを追跡します。

      • オブジェクトとしてテーブルを選択した場合、DTS はこのテーブルの増分データのみを追跡します。この場合、別のテーブルのデータ変更を追跡するには、そのテーブルをオブジェクトリストに追加する必要があります。詳細については、「変更追跡のオブジェクトを変更」をご参照ください。

    2. 詳細設定へ をクリックして、詳細設定を行います。

      この例では、デフォルト設定のままにすることができます。ビジネス要件に基づいてパラメーターを設定することもできます。

      設定の詳細

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS はタスクを共有クラスターにスケジュールします。このパラメーターを設定する必要はありません。指定した仕様の専用クラスターを購入して、DTS 変更追跡タスクを実行できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      接続失敗時の再試行時間範囲。変更追跡タスクが失敗した場合、DTS は時間範囲内に即座に接続を再試行します。有効値:10~1440。単位:分。デフォルト値:720。このパラメーターは 30 より大きい値に設定することを推奨します。指定した時間範囲内に DTS がソースデータベースインスタンスに再接続されると、DTS は変更追跡タスクを再開します。それ以外の場合、変更追跡タスクは失敗します。

      説明
      • データベースインスタンスに対して複数の変更追跡タスクが設定されている場合、最も短い再試行時間範囲が優先されます。たとえば、同じデータベースインスタンスに対してタスク A とタスク B が設定されているとします。タスク A の再試行時間範囲は 30 分、タスク B の再試行時間範囲は 60 分に設定されています。この場合、30 分の再試行時間範囲が優先されます。

      • DTS が接続を再試行すると、料金が発生します。ビジネス要件に基づいて再試行時間範囲を指定するか、ソースデータベースインスタンスがリリースされた後、できるだけ早く DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      その他の問題に対する再試行時間範囲。たとえば、変更追跡タスクの開始後に DML 操作の実行に失敗した場合、DTS は再試行時間範囲内に即座に操作を再試行します。有効値:1~1440。単位:分。デフォルト値:10。このパラメーターは 10 より大きい値に設定することを推奨します。指定した再試行時間範囲内に失敗した操作が正常に実行されると、DTS は変更追跡タスクを再開します。それ以外の場合、変更追跡タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 パラメーターの値は、失敗した接続の再試行時間 パラメーターの値より小さくする必要があります。

      環境タグ

      ビジネス要件に基づいてインスタンスを識別するために、環境タグを選択できます。

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンスの実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。

      • ○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローニングなどの機能に干渉する可能性があります。

      監視アラート

      変更追跡タスクのアラート機能を有効にするかどうかを指定します。アラート機能が設定されており、タスクが失敗するか、レイテンシがしきい値を超えた場合、アラート通知が送信されます。有効値:

      • [いいえ]:アラート機能を有効にしません。

      • [はい]:アラート機能を有効にします。この場合、アラートのしきい値とアラート通知設定も設定する必要があります。詳細については、「インスタンス設定時のアラート設定」をご参照ください。

  7. ページの下部で、[次へ: タスク設定を保存して事前チェック] をクリックします。

    • 関連する API オペレーションを呼び出して DTS タスクを設定する際に指定するパラメーターを表示するには、ポインターを 次:タスク設定の保存と事前チェック に移動し、OpenAPI パラメーターのプレビュー をクリックします。

    • パラメーターを表示する必要がない場合、または表示済みの場合は、ページの下部にある 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 変更追跡タスクを開始する前に、DTS は事前チェックを実行します。タスクが事前チェックに合格した後にのみ、変更追跡タスクを開始できます。

    • タスクが事前チェックに合格しなかった場合は、失敗した各項目の横にある [詳細の表示] をクリックします。エラーメッセージに基づいて問題をトラブルシューティングした後、再度事前チェックを実行できます。

    • 事前チェック中に項目に対してアラートが生成された場合は、シナリオに基づいて次の操作を実行します:

      • 無視できないアラート項目の場合は、失敗した項目の横にある [詳細の表示] をクリックして問題をトラブルシューティングします。その後、再度事前チェックを実行します。

      • アラート項目を無視できる場合は、[アラート詳細の確認] をクリックします。[詳細の表示] ダイアログボックスで、[無視] をクリックします。表示されるメッセージで [OK] をクリックします。その後、[再事前チェック] をクリックして再度事前チェックを実行します。アラート項目を無視すると、データの不整合が発生し、ビジネスに潜在的なリスクが生じる可能性があります。

  8. インスタンスの購入

    1. [成功率] が [100%] になるまで待ってから、[次へ: インスタンスの購入] をクリックします。

    2. [購入] ページで、変更追跡インスタンスの課金方法を指定します。次の表にパラメーターを示します。

      パラメーター

      説明

      課金方法

      • サブスクリプション:インスタンスを作成するときにサブスクリプション料金を支払います。サブスクリプション課金方法は、長期間の使用において従量課金方法よりも費用対効果が高くなります。サブスクリプション期間が長いほど、価格は低くなります。

      • 従量課金:従量課金インスタンスは時間単位で課金されます。短期間の使用には、従量課金方法を選択することを推奨します。従量課金インスタンスが不要になった場合は、インスタンスをリリースしてコストを削減できます。

      リソースグループの設定項目

      インスタンスが属するリソースグループ。デフォルト値:[デフォルトリソースグループ]。詳細については、「Resource Management とは」をご参照ください。

      [変更追跡インスタンスの課金タイプ]

      サブスクリプション課金方法を選択した場合、[変更追跡インスタンスの課金タイプ] パラメーターには [全額設定料金 (データトラフィック料金なし)] のみを選択できます。

      サブスクリプション期間

      サブスクリプション課金方法を選択した場合は、サブスクリプション期間と作成するインスタンスの数を設定します。サブスクリプション期間は、1~9 か月、1 年、2 年、3 年、または 5 年です。

      説明

      このパラメーターは、サブスクリプション 課金方法を選択した場合にのみ利用できます。

    3. [Data Transmission Service (従量課金) 利用規約] を読み、選択します。

    4. [購入して開始] をクリックして、変更追跡タスクを開始します。タスクリストでタスクの進行状況を確認できます。

次のステップ

追跡対象データの消費