すべてのプロダクト
Search
ドキュメントセンター

DataWorks:リソースの計画と設定

最終更新日:Jun 22, 2026

API を呼び出すと、リソースグループのリソースが消費されます。データソースへのアクセス失敗、CPU やメモリ不足による API 呼び出しの失敗、高頻度リクエスト時のレート制限といった問題を回避するため、リソースグループが適切なネットワーク接続と十分なパフォーマンスを備えていることを確認してください。このトピックでは、リソースグループの計画に関する主要な考慮事項について説明し、さまざまなタイプのリソースグループの使用に関する推奨事項を提供します。

用語

リソースグループとは、DataService Studio で API 呼び出しを実行するために使用されるコンピューティングリソースです。通常、特定量の CPU、メモリ、および帯域幅を持つマシンとして認識されます。API 呼び出しのフローは次のとおりです。ユーザーが API リクエストを送信すると、まず API ゲートウェイがリクエストを受信し、次に DataService Studio サーバーに転送され、最終的にターゲットデータソースに送信されてクエリが実行されます。

image

リソースグループのタイプ

リソースグループは、パブリックリソースグループと専用リソースグループの 2 つのカテゴリに分類されます。

  • 専用リソースグループ (推奨):

    専用リソースグループは、購入後にユーザーが専用で使用するものです。同時実行性が高い、または高頻度の API 呼び出しには、サーバーレスリソースグループ (推奨) または DataService Studio 専用リソースグループを使用します。

    説明

    DataService Studio 専用リソースグループは、中国 (上海) リージョンでのみ利用可能です。

  • パブリックリソースグループ (テスト用のみ):

    パブリックリソースグループは、すべてのユーザー間で共有され、DataWorks によって提供されます。ピーク利用時間帯には、ユーザー間でリソースの競合が発生する可能性があります。詳細については、「パブリックリソースグループの使用」をご参照ください。

リソース計画の主要な側面:接続とパフォーマンス

リソースグループを使用する際には、接続とパフォーマンスの 2 つの側面に焦点を当てます。

  • 接続:

    API リクエストを送信すると、リクエストは DataService Studio サーバーにルーティングされ、データソースに転送されてクエリが実行されます。リソースグループがターゲットデータソースとそのネットワークにアクセスできることを確認してください。ネットワーク接続を確認した後にのみ DataService Studio を使用してください。接続がない場合、API リクエストは実行できません。

  • パフォーマンス:

    API タスクを実行すると、リソースグループをホストするマシンの CPU、メモリ、ネットワークリソースが消費されます。リソースが不足すると、API 呼び出しの失敗、高頻度の呼び出し時のレート制限、またはクエリ応答の遅延が発生する可能性があります。スムーズな API 実行を保証するために、十分なリソースを割り当ててください。 共有のパブリックリソースによる干渉を受けない分離された環境で API タスクを実行するために、専用リソースグループを使用することを推奨します。専用リソースグループのパフォーマンスメトリクスについては、「DataService Studio 専用リソースグループの課金:サブスクリプション」をご参照ください。

リソースグループの比較と推奨事項

シナリオによって、必要なリソースグループのタイプは異なります。次の表では、パブリックリソースグループと専用リソースグループを、所有権、ネットワーク接続、課金、パフォーマンスなどの観点から比較しています。ニーズに応じて、API 作成時に適切なリソースグループを選択してください。

カテゴリ

専用リソースグループ

パブリックリソースグループ

リソース所有権

DataWorks によって維持管理され、各テナントが専用で使用します。

DataWorks によって維持管理され、すべてのテナントが共有し、リソースを競合します。

ネットワーク

パブリックネットワーク、Alibaba Cloud VPC (インスタンスモードおよび接続文字列モード) 、IDC ネットワーク内のデータソースをサポートします。

パブリックネットワーク、Alibaba Cloud VPC (インスタンスモード) 、および Alibaba Cloud クラシックネットワーク内のデータソースをサポートします。

説明

深圳の金融クラウドでは、パブリックリソースグループを使用したクラシックネットワークデータソースへのアクセスはサポートされていません。

課金方法

リソースグループの仕様に基づくサブスクリプション課金。

呼び出し回数と期間に基づく従量課金で、段階的な価格設定が適用されます。

サポートされるデータソース

ClickHouse、Hologres、RDS、MySQL、PostgreSQL、SQL Server、Oracle、Table Store、AnalyticDB for MySQL 2.0、AnalyticDB for MySQL 3.0、AnalyticDB for PostgreSQL、MongoDB、DRDS、StarRocks、Doris (継続的に拡張中)

Hologres、RDS、MySQL、PostgreSQL、SQL Server、Oracle、Table Store、AnalyticDB for MySQL 2.0、AnalyticDB for MySQL 3.0、AnalyticDB for PostgreSQL、MongoDB、DRDS

最大秒間クエリ数 (QPS)①

QPS のしきい値は、専用リソースグループの仕様によって異なります:

  • サーバーレスリソースグループは、最小 125 QPS をサポートします。

  • DataService Studio 専用リソースグループは、最小 500 QPS をサポートします。

必要な QPS レベルに応じた仕様を選択してください。

説明

1つの専用リソースグループを複数のワークスペースとAPIにアタッチできます。

API トラフィックがリソースグループ仕様の QPS しきい値を超えると、システムはレート制限を適用し、API 呼び出しは失敗します。

各テナントアカウントは、リージョンごとに最大 200 QPS をサポートします。この制限を引き上げるには、専用リソースグループに切り替えてください。

API トラフィックが 200 QPS を超えると、システムはレート制限を適用し、API 呼び出しは失敗します。

タイムアウト制限

30 秒

10 秒

信頼性

高

低

セキュリティ

高

高

シナリオ

同時実行性が高い、高頻度のオンライン呼び出し、複雑なクエリ、および大規模なデータ取得。

同時実行性が低い、低頻度の呼び出し。

推奨度

★★★★★

★★★

説明
  • 注 1:専用リソースグループの 1 秒あたりの最大クエリ数(QPS)は、実際のビジネスシナリオに基づいて計算されます。次の情報を使用して、QPS しきい値を推定できます:

    • スクリプトモードで API を生成するかどうか。

    • API 呼び出しでページネーション機能が有効になっているため、返された結果が複数のページに表示されるかどうか。

    • API 呼び出しに設定された SQL ステートメントの平均実行時間は、データソースで 100 ミリ秒です。

    • 1 回の API 呼び出しで返されるデータの平均サイズは 3,000 バイトです。

    ビジネスシナリオが上記のシナリオと異なる場合は、DataWorks DingTalk グループに参加して、ビジネスシナリオに適した適切な仕様を入手してください。

上記の比較に基づき、API 呼び出しには専用リソースグループを使用することを推奨します。

リソースグループの設定ガイダンス

サーバーレスリソースグループの DataService Studio クォータ設定

DataService Studio でサーバーレスリソースグループを使用している場合は、[サービスリソースグループの設定] で Exclusive Resource Group for DataService Studio を選択する前に、DataService Studio のクォータを設定してください。

説明

サーバーレスリソースグループに DataService Studio のクォータを設定しない場合、次の問題が発生する可能性があります:

  • データソースと DataService Studio リソースグループ間のネットワーク接続テストが失敗します。

  • 専用リソースグループを設定する際に、ターゲットリソースグループを選択できません。

  1. [リソースグループ] ページに移動します。

    DataWorks コンソールにログインします。 左側のナビゲーションウィンドウで、[リソースグループ] をクリックします。

  2. Serverless リソースグループの横にあるアクションアイコン image をクリックし、クォータ管理 を選択します。従量課金制リソースグループの場合は 現在占有されているCU を、サブスクリプションリソースグループの場合は CU保証 を データサービス に割り当てます。

    従量課金リソースグループ

    サブスクリプションリソースグループ

    [クォータ管理] ダイアログボックスで、 [DataService Studio] の行を見つけます。 [現在の CU 使用量] 列の編集アイコンをクリックし、CU 値を目的の量 (例: 1) に設定します。編集後、"Detected a change in DataService Studio CU guarantee. Click Confirm to reinitialize. Estimated wait time: 3 minutes." というメッセージが表示されます。 [確認] をクリックして設定を完了します。

    [クォータ管理] ダイアログボックスで、現在の仕様は 4 CU です。 [DataService Studio] の [CU 保証] を 4 に設定し、 [確認] をクリックします。

  3. Current CU Usage を割り当てた後、Confirm をクリックして保存します。

  4. DataService Studio のページに移動し、DataService Studio 専用リソースグループを再設定します。

    [Serverless_Resource] (従量課金) リソースグループを選択します。