すべてのプロダクト
Search
ドキュメントセンター

Cloud Parallel File Storage:CreateProtocolMountTarget

最終更新日:Sep 08, 2026

プロトコルサービスのエクスポートディレクトリを作成します。

操作説明

  • この操作は、Cloud Parallel File Storage (CPFS) ファイルシステムにのみ適用されます。

  • 事前準備

    対象の CPFS ファイルシステムが実行中 (Running) 状態であり、プロトコルサービスが作成されている必要があります。

  • その他の情報

    • プロトコルサービスエクスポートの VPC CIDR ブロックは、ファイルシステムの VPC CIDR ブロックと重複してはなりません。

    • 同じプロトコルサービス上の複数のエクスポートの VPC CIDR ブロックは、互いに重複してはなりません。

    • 1 つのプロトコルサービスに対して最大 10 個のエクスポートディレクトリを作成できます。

    • プロトコルサービスエクスポートディレクトリを作成すると、指定された vSwitch から IP アドレスが消費されます (最大 32 個の IP アドレス)。対象の vSwitch に十分な IP アドレスリソースがあることを確認してください。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

この操作の認証情報はありません。問題が発生した場合は、アカウントマネージャーにご連絡ください。

リクエストパラメーター

パラメーター

型

必須 / 任意

説明

例

ProtocolServiceId

string

必須

プロトコルサービスの ID。

ptc-197ed6a00f2b****

FileSystemId

string

必須

ファイルシステムの ID。

説明

この操作を呼び出す前に、対象の CPFS ファイルシステムが実行中 (Running) 状態である必要があります。作成後、ファイルシステムが実行中状態になるまで約 20~40 分かかります。 DescribeFileSystems (開発者リファレンス) を呼び出して Status フィールドをポーリングできます (Running は準備完了を示します)。

cpfs-099394bd928c****

VpcId

string

任意

プロトコルサービスエクスポート用の VPC の ID。

説明

選択した VPC の CIDR ブロックは、対象の CPFS ファイルシステムの VPC CIDR ブロックと重複してはなりません。VPC の DescribeVpcs 操作を呼び出して各 VPC の CidrBlock フィールドをクエリして比較し、競合せず、かつファイルシステムと同じゾーンにある VPC を選択できます。

vpc-2vct297b8157bth9z****

VSwitchId

string

任意

プロトコルサービスエクスポート用の vSwitch の ID。

ファイルシステムのストレージの冗長性タイプがゾーン冗長ストレージ (ZRS) でない場合、VpcId が指定されているときにこのパラメーターは必須です。

説明

vSwitch は、対象の CPFS ファイルシステムと同じゾーンにある必要があります (ZoneId の値が一致している必要があります)。 DescribeFileSystems (開発者リファレンス) を呼び出してファイルシステムの ZoneId フィールドをクエリし、同じゾーンの vSwitch を選択できます。

vsw-2vc3c2lybvdllxyq4****

FsetId

string

任意

エクスポートするファイルセットの ID。

使用制限:

  • ファイルセットがすでに存在している必要があります。

  • 各ファイルセットに対して作成できるエクスポートディレクトリは 1 つだけです。

  • FsetId と Path のいずれか一方のみを指定する必要があります。

fset-1902718ea0ae****

Path

string

任意

エクスポートする CPFS ディレクトリのパス。

使用制限:

  • ディレクトリが CPFS ファイルシステム上にすでに存在している必要があります。

  • 同じディレクトリに対して作成できるエクスポートは 1 つだけです。

  • FsetId と Path のいずれか一方のみを指定する必要があります。

フォーマット:

  • パスの長さは 1~1,024 文字である必要があります。

  • パスは UTF-8 でエンコードされている必要があります。

  • パスはフォワードスラッシュ (/) で始まり、フォワードスラッシュ (/) で終わる必要があります。ルートディレクトリは / です。

/

AccessGroupName

string

任意

権限グループの名前。

デフォルト値: DEFAULT_VPC_GROUP_NAME。

DEFAULT_VPC_GROUP_NAME

Description

string

任意

プロトコルサービスエクスポートディレクトリの説明。これはコンソールで エクスポートディレクトリ名 として表示されます。

使用制限:

  • 説明の長さは 2~128 文字で、英字および漢字を含めることができます。

  • 説明は英字または漢字で始める必要があります。http:// または https:// で始めることはできません。

  • 説明には数字、コロン (:)、アンダースコア (_)、およびハイフン (-) を含めることができます。

このエクスポートディレクトリの説明

ClientToken

string

任意

リクエストのべき等性を保証します。クライアントからパラメーター値を生成し、異なるリクエスト間で値が一意になるようにします。

ClientToken は ASCII 文字のみをサポートし、長さは 64 文字を超えることはできません。詳細については、「べき等性を確保する方法」を参照してください。

説明

このパラメーターを指定しない場合、システムは API リクエストの RequestId を ClientToken として自動的に使用します。RequestId は API リクエストごとに異なる場合があります。

473469C7-AA6F-4DC5-B3DB-A3DC0DE3****

DryRun

boolean

任意

このリクエストのドライランを実行するかどうかを指定します。ドライランでは、実際にインスタンスを作成したり、料金を発生させたりすることなく、パラメーターの有効性と依存関係をチェックします。

有効な値:

  • true: エクスポートディレクトリを作成せずにドライランリクエストを送信します。チェック項目には、必須パラメーターが指定されているかどうか、リクエストフォーマット、およびビジネス制限の依存関係が含まれます。チェックに失敗した場合、対応するエラーが返されます。チェックに成功した場合、HTTP 状態コード 200 が返されますが、ExportId は空になります。

  • false (デフォルト): 通常のリクエストを送信します。チェックに成功した後、インスタンスが直接作成されます。

true

VSwitchIds

array

任意

プロトコルサービスエクスポート用の vSwitch ID のリスト。

string

任意

プロトコルサービスエクスポート用の vSwitch ID のリスト。

ファイルシステムのストレージの冗長性タイプがゾーン冗長ストレージ (ZRS) である場合、VpcId が指定されているときに、VPC 内の 3 つの異なるゾーンの vSwitch ID を指定する必要があります。

vsw-123xxx

レスポンスフィールド

フィールド

型

説明

例

object

レスポンスのスキーマ。

RequestId

string

リクエスト ID。

473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E

ExportId

string

プロトコルサービスエクスポートディレクトリの ID。

exp-19abf5beab8d****

例

成功レスポンス

JSONJSON

{
  "RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E",
  "ExportId": "exp-19abf5beab8d****"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 MissingFileSystemId FileSystemId is mandatory for this action. FileSystemId パラメーターが指定されていません。
400 MissingProtocolServiceId ProtocolServiceId is mandatory for this action. ProtocolServiceId パラメーターが指定されていません。サービスパラメーターが必要です。
403 Instance.IncorrectStatus The specified instance is in an incorrect status. 現在の状態では、この操作は許可されていません。
403 InvalidVSwitchId.IpShortage The specified vswitch ip shortage.
403 InvalidFset.InUse Fset already used by other export. 指定された Fileset はすでに使用中です。
403 MntPathConflict.InvalidParam FilesetId and Path must and can only be specified one. Fileset または Path のいずれか一方のみを指定する必要があります。
403 OperationDenied.TooManyDepth The operation is denied due to Fsets path too deep. インテリジェントディレクトリのパスの深さがしきい値を超えています。
403 OperationDenied.InvalidPtcStatus The operation is denied due to invalid protocol service status. 現在のプロトコルサービスのサービスステータスでは、この操作はサポートされていません。
403 OperationDenied.InvalidState The operation is denied due to invalid file system state.
403 OperationDenied.CrossVPCExceedLimit Cross vpc mount exceed limit. クロス VPC エクスポートディレクトリの数が、現在のプロトコルサービス仕様の上限を超えました。
403 OperationDenied.NoMountTargetQuota No mount target quota on this protocol service. プロトコルサービスのエクスポートディレクトリクォータが枯渇しています。
403 OperationDenied.NotSupported The operation is denied due to not supported. ファイルシステムはプロトコルサービスをサポートしていません。
404 InvalidFileSystem.NotFound The specified file system does not exist. 指定されたファイルシステムが存在しません。
404 InvalidProtocolService.NotFound The specified protocol service does not exist. 指定されたプロトコルサービスが存在しません。
404 InvalidVpcId.ConflictVpcCidr Vpc cidr conflict with file system 指定された VPC の CIDR ブロックが、ファイルシステムの VPC の CIDR ブロックと重複しています。
404 InvalidFsetId.NotFound The specified fileset ID does not exist.
404 Fset.IncorrectStatus The specified fset is in an incorrect status. 指定された fileset は使用できません。
404 InvalidFileSystemPath.InvalidCharacters The specified fileset path contains invalid characters. 指定された Fileset パスに無効な文字が含まれています。
404 InvalidAccessGroupName.NotFound The specified access group does not exist. 指定された権限グループが存在しません。
404 InvalidAccessGroupName.NotAccessRule There has no rule in access group. 指定された権限グループにはルールが含まれていません。
404 InvalidDescription.InvalidFormat Description format is invalid. 指定された説明のフォーマットが無効です。
404 InvalidParameter.VpcNotFound The specified VPC does not exist. 指定された VPC が存在しません。
404 InvalidParameter.VswNotFound The specified VSwitch does not exist.

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。