アクセスの制御コントロールポリシーの設定を変更します。
操作説明
この操作は、Cloud Firewall を通過するトラフィックを許可、拒否、または監視するアクセスの制御コントロールポリシーの設定を変更するために使用します。
QPS 制限
この操作のシングルユーザー QPS 制限は、1 秒あたり 10 回の呼び出しです。制限を超えると、API 呼び出しがスロットリングされ、ビジネスに影響を与える可能性があります。この操作は適切な頻度で呼び出してください。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
yundun-cloudfirewall:ModifyControlPolicy |
update |
*ControlPolicy。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
べき等性トークン。 |
ddadxefexxxx |
| DryRun |
boolean |
任意 |
ドライランのみを実行するかどうかを指定します。 |
|
Lang
deprecated
|
string |
任意 |
リクエストと応答の言語。有効な値:
|
zh |
| AclAction |
string |
任意 |
アクセスの制御コントロールポリシーがファイアウォールを通過するトラフィックに対して実行する操作。有効な値:
|
accept |
ApplicationName
deprecated
|
string |
任意 |
アクセスの制御コントロールポリシーでサポートされているアプリケーションタイプ。次のアプリケーションタイプがサポートされています。
説明
ANY は、ポリシーがすべてのタイプのアプリケーションに適用されることを示します。 説明
ApplicationNameList または ApplicationName のいずれかを指定する必要があります。両方のパラメーターを空にすることはできません。両方のパラメーターを指定した場合、ApplicationNameList の値が優先されます。 |
HTTP |
| Description |
string |
任意 |
アクセスの制御コントロールポリシーの説明。 |
test |
| DestPort |
string |
任意 |
アクセスの制御コントロールポリシーの宛先ポート。 |
80 |
| Destination |
string |
任意 |
アクセスの制御コントロールポリシーの送信先アドレス。
|
192.0.XX.XX/24 |
| DestinationType |
string |
任意 |
アクセスの制御コントロールポリシーの送信先アドレスのタイプ。有効な値:
|
net |
| Direction |
string |
任意 |
アクセスの制御コントロールポリシーのトラフィックの方向。有効な値:
|
in |
| Proto |
string |
任意 |
アクセスの制御コントロールポリシーのプロトコルの種類。次のプロトコルタイプがサポートされています。
説明
ANY は、ポリシーがすべてのプロトコルタイプに適用されることを示します。 説明
トラフィックの方向がアウトバウンドで、送信先アドレスがドメインタイプの脅威インテリジェンスアドレス帳またはクラウドサービスアドレス帳である場合、プロトコルを TCP または ANY にセットできます。TCP を選択した場合、アプリケーションは HTTP、HTTPS、SMTP、SMTPS、または SSL にセットできます。ANY を選択した場合、アプリケーションは ANY にのみセットできます。 |
TCP |
| Source |
string |
任意 |
アクセスの制御コントロールポリシーのソースアドレス。
|
192.0.XX.XX/24 |
| AclUuid |
string |
必須 |
アクセスの制御コントロールポリシーの一意な ID。 説明
アクセスの制御コントロールポリシーを変更するには、ポリシーの一意な ID を指定する必要があります。ID を取得するには、 DescribeControlPolicy 操作を呼び出します。 |
00281255-d220-4db1-8f4f-c4df221ad84c |
| SourceType |
string |
任意 |
アクセスの制御コントロールポリシーのソースアドレスのタイプ。有効な値:
|
net |
| DestPortType |
string |
任意 |
アクセスの制御コントロールポリシーの宛先ポートのタイプ。有効な値:
|
ポート |
| DestPortGroup |
string |
任意 |
アクセスの制御コントロールポリシーの宛先ポートアドレス帳の名前。 |
my_ポート_グループ |
| Release |
string |
任意 |
アクセスの制御コントロールポリシーの有効化ステータス。有効な値:
|
true |
| ApplicationNameList |
array |
任意 |
アプリケーション名リスト。 説明
ApplicationNameList または ApplicationName のいずれかを指定する必要があります。両方のパラメーターを空にすることはできません。両方のパラメーターを指定した場合、ApplicationNameList の値が優先されます。 |
|
|
string |
任意 |
アプリケーション名。 |
HTTP |
|
| RepeatType |
string |
任意 |
アクセスの制御コントロールポリシーのポリシー有効期間の繰り返し頻度のタイプ。有効な値:
列挙値:
|
Permanent |
| RepeatDays |
array |
任意 |
アクセスの制御コントロールポリシーが効果を持つ曜日または日付。ポリシー有効期間の設定項目。
説明
RepeatType が Weekly にセットされている場合、RepeatDays の値は重複できません。
説明
RepeatType が Monthly にセットされている場合、RepeatDays の値は重複できません。 |
|
|
integer |
任意 |
アクセスの制御コントロールポリシーのポリシー有効期間の繰り返し頻度の日。繰り返し頻度の日の設定項目。 説明
RepeatType が Weekly にセットされている場合、有効な値は 0 から 6 です。週は日曜日に始まります。 RepeatType が Monthly にセットされている場合、有効な値は 1 から 31 です。 |
1 |
|
| RepeatStartTime |
string |
任意 |
ポリシー有効期間の繰り返し頻度の開始時刻。時間は HH:mm フォーマットで、24 時間制を使用します。例: 08:00。 説明
RepeatType が Permanent または None にセットされている場合、このパラメーターは空のままにします。RepeatType が Daily、Weekly、または Monthly にセットされている場合、このパラメーターは必須です。 |
08:00 |
| RepeatEndTime |
string |
任意 |
ポリシー有効期間の繰り返し頻度の終了時刻。時間は HH:mm フォーマットで、24 時間制を使用します。例: 23:00。 説明
RepeatType が Permanent または None にセットされている場合、このパラメーターは空のままにします。RepeatType が Daily、Weekly、または Monthly にセットされている場合、このパラメーターは必須です。 |
23:30 |
| StartTime |
integer |
任意 |
アクセスの制御コントロールポリシーのポリシー有効期間の開始時刻。値は秒フォーマットの UNIX タイムスタンプです。時間は 00 分または 30 分である必要があり、終了時刻より少なくとも 30 分前である必要があります。開始時刻の設定項目。 説明
RepeatType が Permanent にセットされている場合、このパラメーターは空のままにします。RepeatType が None、Daily、Weekly、または Monthly にセットされている場合、このパラメーターは必須です。 |
1694761200 |
| EndTime |
integer |
任意 |
アクセスの制御コントロールポリシーのポリシー有効期間の終了時刻。値は秒フォーマットの UNIX タイムスタンプです。時間は 00 分または 30 分である必要があり、開始時刻より少なくとも 30 分後である必要があります。終了時刻の設定項目。 説明
RepeatType が Permanent にセットされている場合、このパラメーターは空のままにします。RepeatType が None、Daily、Weekly、または Monthly にセットされている場合、このパラメーターは必須です。 |
1694764800 |
| DomainResolveType |
string |
任意 |
アクセスの制御コントロールポリシーのドメインの名前解決メソッド。有効な値:
|
FQDN |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| DryRun |
boolean |
リクエストがドライランかどうかを示します。値が true の場合、ドライランのみが実行され、実際の変更は行われなかったことを示します。 |
|
| RequestId |
string |
リクエスト ID。 |
CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D |
例
成功レスポンス
JSONJSON
{
"DryRun": false,
"RequestId": "CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | ErrorParametersUid | The aliUid parameter is invalid. | Aliuid が無効です。 |
| 400 | ErrorParametersDirection | The direction is invalid. | 方向が無効です。 |
| 400 | ErrorDBSelect | An error occurred while querying database. | サーバー側のデータベース読み取り例外が発生しました。後でもう一度お試しください。問題が解決しない場合は、テクニカルサポートにお問い合わせください。 |
| 400 | ErrorRecordLog | An error occurred while updating the operation log. | ログの書き込みに失敗しました。 |
| 400 | ErrorParameters | Error Parameters | パラメーターエラーが発生しました。 |
| 400 | ErrorParametersSource | The source is invalid. | ソースが無効です。 |
| 400 | ErrorParametersDestination | The Destination parameter is invalid. | 送信先が無効です。 |
| 400 | ErrorParametersFtpNotSupport | domain destination not support ftp. | ポリシーの送信先がドメイン名の場合、FTP アプリケーションはサポートされません。 |
| 400 | ErrorAclDomainAnyCountExceed | The number of resolved domain names cannot exceed 200. ACL configuration can be continued for HTTP, HTTPS, SMTP, SMTPS, and SSL applications. | 名前解決されたドメイン名の数が 200 を超えています。HTTP、HTTPS、SMTP、SMTPS、および SSL アプリケーションでは、より多くの設定がサポートされています。 |
| 400 | ErrorAclNotExist | The ACL does not exist. | 指定された ACL が存在しません。 |
| 400 | ErrorAclEffectiveTimeNonPermanent | ACL rule is not allowed to update status when effective is not permanent. | アクセスの制御ポリシーのステータスは、有効期間が永久に設定されていない場合、更新できません。 |
| 400 | ErrorAclExtendedCountExceed | ACL or extended ACL rules are not matched. | ACL または拡張 ACL ルールが一致しません。 |
| 400 | ErrorDBUpdate | internal error: sql updat. | データベース更新操作が失敗したため、リクエストが失敗しました。 |
| 400 | ErrorDBInsert | An error occurred while performing an insert operation in the database. | データベース挿入操作中に内部エラーが発生しました。 |
| 400 | ErrorMarshalJSON | An error occurred while encoding JSON. | 内部エラーが発生しました: JSON のエンコードに失敗しました。 |
| 400 | ErrorParametersDestinationCount | Exceeding the number of countries in a single ACL. | 単一の ACL で選択されたリージョンの数が上限を超えています。ACL を複数の ACL に分割してください。 |
| 400 | ErrorEmptyDomainResolveType | Empty DomainResolveType only support HTTP/HTTPS/SSL/SMTP/SMTPS apps. | 空のドメイン名解決モードはサポートされていません。 |
| 400 | ErrorParametersApplicationName | Specified parameter ApplicationName is not valid. | アクセス制御ポリシーでサポートされているアプリケーションタイプが無効です。 |
| 400 | ErrorParametersApplicationNameList | Specified parameter ApplicationNameList is not valid. | アクセス制御ポリシーでサポートされているアプリケーションタイプのリストが無効です。 |
| 400 | ErrorParametersAclUuid | Specified parameter AclUuid is not valid. | 指定された ACL UUID が無効です。 |
| 400 | ErrorAddressGroupNotExist | The address group does not exist. | アドレス帳が存在しません。 |
| 400 | ErrorParametersProtoAppsMismatch | The protocol and applicationName mismatch. | プロトコルがアプリケーションと一致しません。 |
| 400 | ErrorApplicationTemplateNotFound | Application template not found. | アプリケーションテンプレートが存在しません。 |
| 400 | ErrorWebFilterTemplateNotFound | Web filter template not found. | Web フィルターテンプレートが存在しません。 |
| 400 | InvalidClientToken | ClientToken format invalid. Only ASCII letters, digits, hyphens and underscores are allowed, max 64 characters. | |
| 400 | IdempotentParameterMismatch | The request uses the same client token as a previous, but non-identical request. Do not reuse a client token with different requests, unless the requests are identical. | このリクエストでは、以前のリクエストと同じクライアントトークンが使用されていますが、リクエスト内容は同一ではありません。リクエストが同一でない限り、異なるリクエストにクライアントトークンを再利用しないでください。 |
| 409 | IdempotentToken.Processing | A previous request with the same ClientToken is still being processed. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。