すべてのプロダクト
Search
ドキュメントセンター

Cloud Firewall:CreateNatFirewallControlPolicy

最終更新日:Jun 09, 2026

NAT ファイアウォールにアクセス制御ポリシーを追加します。

操作説明

この API は、NAT ファイアウォールを通過するトラフィックを許可、拒否、または監視するポリシーを作成します。

今すぐお試しください

この API を OpenAPI Explorer でお試しください。手作業による署名は必要ありません。呼び出しに成功すると、入力したパラメーターに基づき、資格情報が組み込まれた SDK コードが自動的に生成されます。このコードをダウンロードしてローカルで使用できます。

テスト

RAM 認証

下表に、この API を呼び出すために必要な認証情報を示します。認証情報は、RAM (Resource Access Management) ポリシーを使用して定義できます。以下で各列名について説明します。

  • アクション:特定のリソースに対して実行可能な操作。ポリシー構文ではAction要素として指定します。

  • API:アクションを具体的に実行するための API。

  • アクセスレベル:各 API に対して事前定義されているアクセスの種類。有効な値:create、list、get、update、delete。

  • リソースタイプ:アクションが作用するリソースの種類。リソースレベルでの権限をサポートするかどうかを示すことができます。ポリシーの有効性を確保するため、アクションの対象として適切なリソースを指定してください。

    • リソースレベルの権限を持つ API の場合、必要なリソースタイプはアスタリスク (*) でマークされます。ポリシーのResource要素で対応する ARN を指定してください。

    • リソースレベルの権限を持たない API の場合、「すべてのリソース」と表示され、ポリシーのResource要素でアスタリスク (*) でマークされます。

  • 条件キー:サービスによって定義された条件のキー。このキーにより、きめ細やかなアクセス制御が可能になります。この制御は、アクション単体に適用することも、特定のリソースに対するアクションに適用することもできます。Alibaba Cloud は、サービス固有の条件キーに加えて、すべての RAM 統合サービスに適用可能な一連の共通条件キーを提供しています。

  • 依存アクション:ある特定のアクションを実行するために、前提として実行が必要となる他のアクション。依存アクションの権限も RAM ユーザーまたは RAM ロールに付与する必要があります。

アクション

アクセスレベル

リソースタイプ

条件キー

依存アクション

yundun-cloudfirewall:CreateNatFirewallControlPolicy

作成

* NAT ファイアウォールコントロールポリシー

acs:yundun-cloudfirewall::{#accountId}:natfirewallcontrolpolicy/*

なし なし

リクエストパラメーター

パラメーター

必須 / 任意

説明

Lang

string

任意

レスポンスメッセージの言語です。

有効な値:

  • zh:中国語 (デフォルト)

  • en:英語

zh

AclAction

string

必須

アクセス制御ポリシーに一致するトラフィックに対して Cloud Firewall が実行するアクションです。

有効な値:

  • accept:トラフィックを許可します。

  • drop:トラフィックをドロップします。

  • log:トラフィックをログに記録します。

log

ApplicationNameList

array

必須

アクセス制御ポリシーが適用されるアプリケーションのリストです。

string

任意

アクセス制御ポリシーが適用されるアプリケーションです。

ANY

Description

string

必須

アクセス制御ポリシーの説明です。

トラフィックを許可

DestPort

string

任意

トラフィックの宛先ポートです。このパラメーターの値は、Proto および DestPortType パラメーターによって異なります。

  • ProtoICMP の場合、このパラメーターは空のままにします。

説明

ICMP トラフィックのアクセス制御は、宛先ポートに基づいて設定することはできません。

  • 宛先ポートタイプ (DestPortType) が group の場合、このパラメーターは空のままにします。

説明

DestPortTypegroup に設定されている場合、選択したポートアドレス帳で必要なポートが定義されているため、宛先ポートを指定する必要はありません。

  • プロトコルが TCP、UDP、または ANY で、宛先ポートタイプ (DestPortType) が port の場合は、宛先ポート番号を指定します。

80

Destination

string

必須

アクセス制御ポリシーの宛先アドレスです。

このパラメーターの値は、DestinationType の値によって異なります:

  • DestinationTypenet の場合は、このパラメーターを宛先 CIDR に設定します。

    例:1.2.XX.XX/24

  • DestinationTypegroup の場合は、このパラメーターを宛先アドレス帳の名前に設定します。

    例:db_group

  • DestinationTypedomain の場合は、このパラメーターを宛先ドメインに設定します。

    例: *.aliyuncs.com

  • DestinationTypelocation の場合は、このパラメーターを宛先ロケーションに設定します。

    例: ["BJ11", "ZB"]

XX.XX.XX.XX/24

DestinationType

string

必須

アクセス制御ポリシーの宛先タイプです。

有効な値:

  • net:宛先 CIDR

  • group:宛先アドレス帳

  • domain:宛先ドメイン

net

NatGatewayId

string

必須

NAT ゲートウェイのインスタンス ID です。

ngw-2vc2ustolqn6sr0******

Proto

string

必須

アクセス制御ポリシーのトラフィックのプロトコルです。

有効な値:

  • ANY:すべてのプロトコル

  • TCP

  • UDP

  • ICMP

説明

宛先がドメイン、脅威インテリジェンスアドレス帳、またはクラウドサービスアドレス帳の場合、このパラメーターは TCP にのみ設定できます。サポートされているアプリケーションは、HTTP、HTTPS、SMTP、SMTPS、および SSL です。

ANY

Source

string

必須

アクセス制御ポリシーの送信元アドレスです。

このパラメーターの値は、SourceType パラメーターの値によって異なります:

  • SourceTypenet の場合は、このパラメーターを送信元 CIDR に設定します。

    例: 10.2.4.0/24

  • SourceTypegroup の場合は、このパラメーターを送信元アドレス帳の名前に設定します。

    例: db_group

192.168.0.25/32

SourceType

string

必須

アクセス制御ポリシーの送信元タイプです。

有効な値:

  • net:送信元 CIDR

  • group:送信元アドレス帳

net

NewOrder

string

必須

アクセス制御ポリシーの優先度です。値は 1 から始まります。値が小さいほど、優先度が高くなります。

1

DestPortType

string

任意

宛先ポートのタイプです。

  • port:ポートまたはポート範囲

  • group:ポートアドレス帳

port

DestPortGroup

string

任意

宛先ポートアドレス帳の名前です。

説明

DestPortTypegroup に設定されている場合、このパラメーターは必須です。

my_port_group

Release

string

任意

アクセス制御ポリシーを有効にするかどうかを指定します。デフォルトでは、ポリシーは作成時に有効になります。有効な値:

  • true:ポリシーを有効化します。

  • false:ポリシーを無効化します。

true

DomainResolveType

integer

任意

ドメイン名前解決方法です。有効な値:

  • 0:FQDN ベースの名前解決

  • 1:動的 DNS ベースの名前解決

  • 2:FQDN ベースおよび動的 DNS ベースの名前解決

説明

解決方法に FQDN が含まれる場合、プロトコルは TCP にのみ設定できます。サポートされているアプリケーションは、HTTP、HTTPS、SMTP、SMTPS、および SSL です。

0

IpVersion

string

任意

アクセス制御ポリシーの IP バージョンです。有効な値:

  • 4 (デフォルト):IPv4

4

Direction

string

必須

アクセス制御ポリシーのトラフィックの方向です。有効な値:

  • out:アウトバウンドトラフィック

out

RepeatType

string

任意

ポリシーの有効期間の繰り返しタイプです。有効な値:

  • Permanent (デフォルト):ポリシーは常にアクティブです。

  • None:ポリシーは指定された期間に 1 回実行されます。

  • Daily:ポリシーは毎日繰り返されます。

  • Weekly:ポリシーは指定された時間範囲内で毎週繰り返されます。

  • Monthly:ポリシーは指定された時間範囲内で毎月繰り返されます。

列挙値:

  • Daily :

    Daily

  • Monthly :

    Monthly

  • Permanent :

    Always

  • Weekly :

    Weekly

  • None :

    One-time

Permanent

RepeatDays

array

任意

ポリシーが繰り返される曜日または日です。

  • RepeatTypePermanentNone、または Daily に設定されている場合、このパラメーターは空のままにします。例:[]

  • RepeatTypeWeekly の場合、このパラメーターは必須です。例:[0, 6]

説明

RepeatTypeWeekly の場合、RepeatDays の値は一意である必要があります。

  • RepeatTypeMonthly の場合、このパラメーターは必須です。例:[1, 31]

説明

RepeatTypeMonthly の場合、RepeatDays の値は一意である必要があります。

integer

任意

繰り返される日です。

説明

RepeatTypeWeekly の場合、有効な値の範囲は 0 から 6 です。週は日曜日から始まります。 RepeatTypeMonthly の場合、有効な値の範囲は 1 から 31 です。

1

RepeatStartTime

string

任意

繰り返しの開始時刻です。時刻は正時または30分とし、終了時刻の少なくとも30分前である必要があります。

説明

このパラメーターは、RepeatTypeDailyWeekly、または Monthly に設定されている場合に必須です。RepeatTypePermanent または None の場合、このパラメーターは空のままにします。 時刻は HH:mm 形式 (24 時間表記) です。例:08:00 または 23:30

08:00

RepeatEndTime

string

任意

繰り返しの終了時刻です。時刻は正時または30分とし、開始時刻の少なくとも30分後である必要があります。

説明

このパラメーターは、RepeatTypeDailyWeekly、または Monthly に設定されている場合に必須です。RepeatTypePermanent または None の場合、このパラメーターは空のままにします。 時刻は HH:mm 形式 (24 時間表記) です。例:08:00 または 23:30

23:30

StartTime

integer

任意

ポリシーの有効期間の開始時刻をUNIX タイムスタンプで指定します。時刻は正時または30分とし、終了時刻の少なくとも30分前である必要があります。

説明

このパラメーターは、RepeatTypeNoneDailyWeekly、または Monthly に設定されている場合に必須です。RepeatTypePermanent の場合、このパラメーターは空のままにします。

1694761200

EndTime

integer

任意

ポリシーの有効期間の終了時刻をUNIX タイムスタンプで指定します。時刻は正時または30分とし、開始時刻の少なくとも30分後である必要があります。

説明

このパラメーターは、RepeatTypeNoneDailyWeekly、または Monthly に設定されている場合に必須です。RepeatTypePermanent の場合、このパラメーターは空のままにします。

1694764800

レスポンスフィールド

フィールド

説明

オブジェクト

AclUuid

文字列

アクセス制御ポリシーの一意の ID です。

説明

アクセス制御ポリシーを変更するには、このポリシーの一意の ID を指定する必要があります。この ID は、DescribeNatFirewallControlPolicy オペレーションを呼び出すことで取得できます。

6504d2fb-ab36-49c3-92a6-*****

RequestId

文字列

リクエスト ID です。

0DC783F1-B3A7-578D-8A63-*****

成功レスポンス

JSON JSON

{
  "AclUuid": "6504d2fb-ab36-49c3-92a6-*****",
  "RequestId": "0DC783F1-B3A7-578D-8A63-*****"
}

エラーコード

HTTP ステータスコード

エラーコード

エラーメッセージ

説明

400 ErrorParametersUid The aliUid parameter is invalid. aliUid パラメーターが無効です。
400 ErrorUUIDNew The UUID is invalid. UUID が無効です。
400 ErrorParametersSource The source is invalid. ソースが無効です。
400 ErrorParametersDestination The Destination parameter is invalid. Destination パラメーターが無効です。
400 ErrorParametersProto The protocol is invalid. プロトコルが無効です。
400 ErrorParametersDestPort The dst_port is invalid. dst_port が無効です。
400 ErrorParametersAction The action is invalid. アクションが無効です。
400 ErrorDBSelect An error occurred while querying database. データベースのクエリ中にエラーが発生しました。
400 ErrorParameters A parameter error occurred. パラメーターエラーが発生しました。
400 ErrorAddressCountExceed The maximum number of addresses is exceeded. アドレスの最大数を超えています。
400 ErrorParametersNewOrder The newOrder is invalid. newOrder が無効です。
400 ErrorDBInsert An error occurred while performing an insert operation in the database. データベースへの挿入操作中にエラーが発生しました。
400 ErrorDBDelete An error occurred while deleting the database. データベースの削除中にエラーが発生しました。
400 ErrorRecordLog An error occurred while updating the operation log. 操作ログの更新中にエラーが発生しました。
400 ErrorAclDomainAnyCountExceed The number of resolved domain names cannot exceed 200. ACL configuration can be continued for HTTP, HTTPS, SMTP, SMTPS, and SSL applications. ドメイン名が 200 個を超える IP アドレスに解決されています。アクセス制御ポリシーのアプリケーションには、HTTPS、 SMTP、 SMTPS、または SSL を設定することを推奨します。
400 ErrorParametersNatGatewayId Invalid parameters NatGatewayId. リクエストパラメーター NatGatewayId が無効か、または存在しません。
400 ErrorParameterIpVersion The IP version is invalid. IP バージョンが無効です。
400 ErrorParametersDirection The direction is invalid. 方向が無効です。
400 ErrorDomainResolve An error occurred while resolving the domain. ドメインの解決中にエラーが発生しました。
400 ErrorParametersPageSizeOrNo Either pageSize or pageNo is invalid. pageSize または pageNo のいずれかが無効です。
400 ErrorMarshalJSON An error occurred while encoding JSON. JSON のエンコーディング中にエラーが発生しました。
400 ErrorParametersDestinationCount Exceeding the number of countries in a single ACL. 1 つの ACL で選択した地域の数が上限を超えています。複数の ACL に分割することを推奨します。
400 ErrorStartTimeOrEndTime The start time or end time is invalid. The time must be the hour or half hour, and the start time must be 30 minutes earlier than the end time. 開始時刻または終了時刻が無効です。時刻は正時または 30 分単位で指定する必要があり、開始時刻は終了時刻より 30 分早く設定する必要があります。
400 ErrorParametersFtpNotSupport domain destination not support ftp. ポリシーのデスティネーションがドメイン名の場合、FTP アプリケーションはサポートされません。
400 ErrorAclExtendedCountExceed ACL or extended ACL rules are not matched. ACL または拡張 ACL ルールが一致しません。
400 ErrorAddressGroupNotExist The address group does not exist. アドレスグループが存在しません。
400 ErrorParametersApplicationNameList Specified parameter ApplicationNameList is not valid. 指定されたパラメーター ApplicationNameList が無効です。

完全なリストについては、「エラーコード」をご参照ください。

変更履歴

完全なリストについては、「変更履歴」をご参照ください。