NAT ファイアウォールにアクセス制御ポリシーを追加します。
操作説明
この API は、NAT ファイアウォールを通過するトラフィックを許可、拒否、または監視するポリシーを作成します。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
yundun-cloudfirewall:CreateNatFirewallControlPolicy |
作成 |
* NAT ファイアウォールコントロールポリシー
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| Lang |
string |
任意 |
レスポンスメッセージの言語です。 有効な値:
|
zh |
| AclAction |
string |
必須 |
アクセス制御ポリシーに一致するトラフィックに対して Cloud Firewall が実行するアクションです。 有効な値:
|
log |
| ApplicationNameList |
array |
必須 |
アクセス制御ポリシーが適用されるアプリケーションのリストです。 |
|
|
string |
任意 |
アクセス制御ポリシーが適用されるアプリケーションです。 |
ANY |
|
| Description |
string |
必須 |
アクセス制御ポリシーの説明です。 |
トラフィックを許可 |
| DestPort |
string |
任意 |
トラフィックの宛先ポートです。このパラメーターの値は、
説明
ICMP トラフィックのアクセス制御は、宛先ポートに基づいて設定することはできません。
説明
|
80 |
| Destination |
string |
必須 |
アクセス制御ポリシーの宛先アドレスです。 このパラメーターの値は、
|
XX.XX.XX.XX/24 |
| DestinationType |
string |
必須 |
アクセス制御ポリシーの宛先タイプです。 有効な値:
|
net |
| NatGatewayId |
string |
必須 |
NAT ゲートウェイのインスタンス ID です。 |
ngw-2vc2ustolqn6sr0****** |
| Proto |
string |
必須 |
アクセス制御ポリシーのトラフィックのプロトコルです。 有効な値:
説明
宛先がドメイン、脅威インテリジェンスアドレス帳、またはクラウドサービスアドレス帳の場合、このパラメーターは |
ANY |
| Source |
string |
必須 |
アクセス制御ポリシーの送信元アドレスです。 このパラメーターの値は、
|
192.168.0.25/32 |
| SourceType |
string |
必須 |
アクセス制御ポリシーの送信元タイプです。 有効な値:
|
net |
| NewOrder |
string |
必須 |
アクセス制御ポリシーの優先度です。値は 1 から始まります。値が小さいほど、優先度が高くなります。 |
1 |
| DestPortType |
string |
任意 |
宛先ポートのタイプです。
|
port |
| DestPortGroup |
string |
任意 |
宛先ポートアドレス帳の名前です。 説明
|
my_port_group |
| Release |
string |
任意 |
アクセス制御ポリシーを有効にするかどうかを指定します。デフォルトでは、ポリシーは作成時に有効になります。有効な値:
|
true |
| DomainResolveType |
integer |
任意 |
ドメイン名前解決方法です。有効な値:
説明
解決方法に FQDN が含まれる場合、プロトコルは TCP にのみ設定できます。サポートされているアプリケーションは、HTTP、HTTPS、SMTP、SMTPS、および SSL です。 |
0 |
| IpVersion |
string |
任意 |
アクセス制御ポリシーの IP バージョンです。有効な値:
|
4 |
| Direction |
string |
必須 |
アクセス制御ポリシーのトラフィックの方向です。有効な値:
|
out |
| RepeatType |
string |
任意 |
ポリシーの有効期間の繰り返しタイプです。有効な値:
列挙値:
|
Permanent |
| RepeatDays |
array |
任意 |
ポリシーが繰り返される曜日または日です。
説明
説明
|
|
|
integer |
任意 |
繰り返される日です。 説明
|
1 |
|
| RepeatStartTime |
string |
任意 |
繰り返しの開始時刻です。時刻は正時または30分とし、終了時刻の少なくとも30分前である必要があります。 説明
このパラメーターは、 |
08:00 |
| RepeatEndTime |
string |
任意 |
繰り返しの終了時刻です。時刻は正時または30分とし、開始時刻の少なくとも30分後である必要があります。 説明
このパラメーターは、 |
23:30 |
| StartTime |
integer |
任意 |
ポリシーの有効期間の開始時刻をUNIX タイムスタンプで指定します。時刻は正時または30分とし、終了時刻の少なくとも30分前である必要があります。 説明
このパラメーターは、 |
1694761200 |
| EndTime |
integer |
任意 |
ポリシーの有効期間の終了時刻をUNIX タイムスタンプで指定します。時刻は正時または30分とし、開始時刻の少なくとも30分後である必要があります。 説明
このパラメーターは、 |
1694764800 |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
オブジェクト |
|||
| AclUuid |
文字列 |
アクセス制御ポリシーの一意の ID です。 説明
アクセス制御ポリシーを変更するには、このポリシーの一意の ID を指定する必要があります。この ID は、 |
6504d2fb-ab36-49c3-92a6-***** |
| RequestId |
文字列 |
リクエスト ID です。 |
0DC783F1-B3A7-578D-8A63-***** |
例
成功レスポンス
JSON JSON
{
"AclUuid": "6504d2fb-ab36-49c3-92a6-*****",
"RequestId": "0DC783F1-B3A7-578D-8A63-*****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | ErrorParametersUid | The aliUid parameter is invalid. | aliUid パラメーターが無効です。 |
| 400 | ErrorUUIDNew | The UUID is invalid. | UUID が無効です。 |
| 400 | ErrorParametersSource | The source is invalid. | ソースが無効です。 |
| 400 | ErrorParametersDestination | The Destination parameter is invalid. | Destination パラメーターが無効です。 |
| 400 | ErrorParametersProto | The protocol is invalid. | プロトコルが無効です。 |
| 400 | ErrorParametersDestPort | The dst_port is invalid. | dst_port が無効です。 |
| 400 | ErrorParametersAction | The action is invalid. | アクションが無効です。 |
| 400 | ErrorDBSelect | An error occurred while querying database. | データベースのクエリ中にエラーが発生しました。 |
| 400 | ErrorParameters | A parameter error occurred. | パラメーターエラーが発生しました。 |
| 400 | ErrorAddressCountExceed | The maximum number of addresses is exceeded. | アドレスの最大数を超えています。 |
| 400 | ErrorParametersNewOrder | The newOrder is invalid. | newOrder が無効です。 |
| 400 | ErrorDBInsert | An error occurred while performing an insert operation in the database. | データベースへの挿入操作中にエラーが発生しました。 |
| 400 | ErrorDBDelete | An error occurred while deleting the database. | データベースの削除中にエラーが発生しました。 |
| 400 | ErrorRecordLog | An error occurred while updating the operation log. | 操作ログの更新中にエラーが発生しました。 |
| 400 | ErrorAclDomainAnyCountExceed | The number of resolved domain names cannot exceed 200. ACL configuration can be continued for HTTP, HTTPS, SMTP, SMTPS, and SSL applications. | ドメイン名が 200 個を超える IP アドレスに解決されています。アクセス制御ポリシーのアプリケーションには、HTTPS、 SMTP、 SMTPS、または SSL を設定することを推奨します。 |
| 400 | ErrorParametersNatGatewayId | Invalid parameters NatGatewayId. | リクエストパラメーター NatGatewayId が無効か、または存在しません。 |
| 400 | ErrorParameterIpVersion | The IP version is invalid. | IP バージョンが無効です。 |
| 400 | ErrorParametersDirection | The direction is invalid. | 方向が無効です。 |
| 400 | ErrorDomainResolve | An error occurred while resolving the domain. | ドメインの解決中にエラーが発生しました。 |
| 400 | ErrorParametersPageSizeOrNo | Either pageSize or pageNo is invalid. | pageSize または pageNo のいずれかが無効です。 |
| 400 | ErrorMarshalJSON | An error occurred while encoding JSON. | JSON のエンコーディング中にエラーが発生しました。 |
| 400 | ErrorParametersDestinationCount | Exceeding the number of countries in a single ACL. | 1 つの ACL で選択した地域の数が上限を超えています。複数の ACL に分割することを推奨します。 |
| 400 | ErrorStartTimeOrEndTime | The start time or end time is invalid. The time must be the hour or half hour, and the start time must be 30 minutes earlier than the end time. | 開始時刻または終了時刻が無効です。時刻は正時または 30 分単位で指定する必要があり、開始時刻は終了時刻より 30 分早く設定する必要があります。 |
| 400 | ErrorParametersFtpNotSupport | domain destination not support ftp. | ポリシーのデスティネーションがドメイン名の場合、FTP アプリケーションはサポートされません。 |
| 400 | ErrorAclExtendedCountExceed | ACL or extended ACL rules are not matched. | ACL または拡張 ACL ルールが一致しません。 |
| 400 | ErrorAddressGroupNotExist | The address group does not exist. | アドレスグループが存在しません。 |
| 400 | ErrorParametersApplicationNameList | Specified parameter ApplicationNameList is not valid. | 指定されたパラメーター ApplicationNameList が無効です。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。