コントロールポリシーを追加します。
操作説明
この操作を呼び出して、Cloud Firewall を通過するトラフィックを許可、拒否、または監視するポリシーを作成できます。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
yundun-cloudfirewall:AddControlPolicy |
create |
*ControlPolicy。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
べき等性トークン。 |
ddadxefexxxx |
| DryRun |
boolean |
任意 |
ドライランを実行するかどうかを指定します。 |
|
SourceIp
deprecated
|
string |
任意 |
リクエストのソース IP アドレス。 |
192.0.XX.XX |
| Lang |
string |
任意 |
リクエストおよびレスポンスの言語。有効な値: |
zh |
| AclAction |
string |
必須 |
Cloud Firewall を通過するトラフィックに対するコントロールポリシーで設定される操作。有効な値: |
accept |
ApplicationName
deprecated
|
string |
任意 |
コントロールポリシーでサポートされるアプリケーションタイプ。有効な値: |
ANY |
| Description |
string |
必須 |
コントロールポリシーの説明。 |
Release flow |
| DestPort |
string |
任意 |
コントロールポリシーの宛先ポート。有効な値: |
80 |
| Destination |
string |
必須 |
コントロールポリシーの送信先アドレス。 |
192.0.XX.XX/24 |
| DestinationType |
string |
必須 |
コントロールポリシーの送信先アドレスタイプ。有効な値: |
net |
| Direction |
string |
必須 |
コントロールポリシーのトラフィックの方向。有効な値: |
in |
| Proto |
string |
必須 |
コントロールポリシーのプロトコルの種類。有効な値: |
ANY |
| Source |
string |
必須 |
コントロールポリシーのソースアドレス。有効な値: |
192.0.XX.XX/24 |
| SourceType |
string |
必須 |
コントロールポリシーのソースアドレスタイプ。有効な値: |
net |
| NewOrder |
string |
必須 |
コントロールポリシーの優先度。優先度の値は 1 から始まります。値が小さいほど優先度が高くなります。 |
1 |
| DestPortType |
string |
任意 |
コントロールポリシーの宛先ポートタイプ。 |
ポート |
| DestPortGroup |
string |
任意 |
コントロールポリシーの宛先ポートアドレス帳の名前。 |
my_ポート_グループ |
| Release |
string |
任意 |
コントロールポリシーを有効にするかどうかを指定します。ポリシーは作成後、デフォルトで有効になります。有効な値: |
true |
| IpVersion |
string |
任意 |
サポートされる IP アドレスバージョン。 |
6 |
| ApplicationNameList |
array |
任意 |
コントロールポリシーでサポートされるアプリケーションタイプのリスト。 |
|
|
string |
任意 |
コントロールポリシーでサポートされるアプリケーションタイプ。有効な値: |
["ANY"] |
|
| RepeatType |
string |
任意 |
コントロールポリシーのポリシー有効期間の繰り返し頻度タイプ。有効な値: 列挙値:
|
Permanent |
| RepeatDays |
array |
任意 |
コントロールポリシーのポリシー有効期間の繰り返し頻度の曜日。 |
|
|
integer |
任意 |
コントロールポリシーのポリシー有効期間の繰り返し頻度の曜日。 |
1 |
|
| RepeatStartTime |
string |
任意 |
コントロールポリシーのポリシー有効期間の繰り返し開始時刻。例: 08:00。値は正時または 30 分単位である必要があり、繰り返し終了時刻より少なくとも 30 分前である必要があります。 |
08:00 |
| RepeatEndTime |
string |
任意 |
コントロールポリシーのポリシー有効期間の繰り返し終了時刻。例: 23:30。値は正時または 30 分単位である必要があり、繰り返し開始時刻より少なくとも 30 分後である必要があります。 |
23:30 |
| StartTime |
integer |
任意 |
コントロールポリシーのポリシー有効期間の開始時刻。値は秒単位の UNIX タイムスタンプです。値は正時または 30 分単位である必要があり、終了時刻より少なくとも 30 分前である必要があります。 |
1694761200 |
| EndTime |
integer |
任意 |
コントロールポリシーのポリシー有効期間の終了時刻。値は秒単位の UNIX タイムスタンプです。値は正時または 30 分単位である必要があり、開始時刻より少なくとも 30 分後である必要があります。 |
1694764800 |
| DomainResolveType |
string |
任意 |
コントロールポリシーのドメイン名解決メソッド。有効な値: |
FQDN |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| AclUuid |
string |
インターネット境界ファイアウォールのコントロールポリシーの一意の ID。 |
00281255-d220-4db1-8f4f-c4df221ad84c |
| RequestId |
string |
リクエスト ID。 |
CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D |
例
成功レスポンス
JSONJSON
{
"AclUuid": "00281255-d220-4db1-8f4f-c4df221ad84c",
"RequestId": "CBF1E9B7-D6A0-4E9E-AD3E-2B47E6C2837D。"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | ErrorAddressCountExceed | The maximum number of addresses is exceeded. | |
| 400 | ErrorParametersSource | The source is invalid. | |
| 400 | ErrorDomainResolve | An error occurred while resolving the domain. | |
| 400 | ErrorParametersDirection | The direction is invalid. | |
| 400 | ErrorDBSelect | An error occurred while querying database. | |
| 400 | ErrorParameterIpVersion | The IP version is invalid. | |
| 400 | ErrorParametersDestination | The Destination parameter is invalid. | |
| 400 | ErrorParametersProto | The protocol is invalid. | |
| 400 | ErrorParametersDestPort | The dst_port is invalid. | |
| 400 | ErrorParametersAction | The action is invalid. | |
| 400 | ErrorParametersUid | The aliUid parameter is invalid. | |
| 400 | ErrorAclDomainAnyCountExceed | The number of resolved domain names cannot exceed 200. ACL configuration can be continued for HTTP, HTTPS, SMTP, SMTPS, and SSL applications. | |
| 400 | ErrorParametersGroupPort | The group port is invalid. | |
| 400 | ErrorParametersFtpNotSupport | domain destination not support ftp. | |
| 400 | ErrorAclExtendedCountExceed | ACL or extended ACL rules are not matched. | |
| 400 | ErrorParametersDestinationCount | Exceeding the number of countries in a single ACL. | |
| 400 | ErrorSrcMand | Source is mandatory for this action. | |
| 400 | ErrorEmptyDomainResolveType | Empty DomainResolveType only support HTTP/HTTPS/SSL/SMTP/SMTPS apps. | |
| 400 | ErrorAddressGroupNotExist | The address group does not exist. | |
| 400 | ErrorParametersApplicationNameList | Specified parameter ApplicationNameList is not valid. | |
| 400 | ErrorParametersApplicationName | Specified parameter ApplicationName is not valid. | |
| 400 | ErrorApplicationTemplateNotFound | Application template not found. | |
| 400 | ErrorWebFilterTemplateNotFound | Web filter template not found. | |
| 400 | ErrorParameters | Parameters error. | |
| 400 | InvalidClientToken | ClientToken format invalid. Only ASCII letters, digits, hyphens and underscores are allowed, max 64 characters. | |
| 400 | IdempotentParameterMismatch | The request uses the same client token as a previous, but non-identical request. Do not reuse a client token with different requests, unless the requests are identical. | |
| 409 | IdempotentToken.Processing | A previous request with the same ClientToken is still being processed. |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。