Menghapus file cadangan data instans ApsaraDB RDS.
Deskripsi operasi
Mesin yang didukung
ApsaraDB RDS for MySQL
ApsaraDB RDS for PostgreSQL
Hanya instans Edisi Ketersediaan Tinggi yang didukung.
Deskripsi fitur
Saat Anda memanggil operasi ini untuk menghapus file cadangan data, hanya set cadangan dari instans itu sendiri yang dihapus. Set cadangan dari instans terkait, seperti instans baca-saja, instans pemulihan bencana, dan instans klon, tidak dihapus.
Catatan penting
Saat Anda memanggil operasi ini, instans harus memenuhi kondisi berikut. Jika tidak, operasi akan gagal:
Status instans adalah Running.
Jika cadangan log dinonaktifkan, instans ApsaraDB RDS tidak mendukung pemulihan ke titik pengatur waktu tertentu. Dalam hal ini, Anda dapat menghapus file cadangan data apa pun yang dibuat lebih dari tujuh hari yang lalu.
Jika cadangan log diaktifkan dan periode retensi cadangan log lebih pendek daripada periode retensi cadangan data, file cadangan data yang melebihi periode retensi cadangan log dapat dihapus.
Coba sekarang
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
rds:DeleteBackup |
delete |
*DBInstance
|
None | None |
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| DBInstanceId |
string |
Yes |
ID instans. Anda dapat memanggil DescribeDBInstances untuk mengkueri ID instans. |
rm-uf6wjk5**** |
| BackupId |
string |
Yes |
ID set cadangan. Anda dapat memanggil DescribeBackups untuk mengkueri ID set cadangan. Pisahkan beberapa ID dengan koma (,). Anda dapat menentukan hingga 100 ID dalam satu permintaan. Catatan
Hanya set cadangan yang StoreStatus-nya Enabled dalam tanggapan DescribeBackups yang dapat dihapus. |
32490**** |
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
Parameter tanggapan. |
||
| RequestId |
string |
ID permintaan. |
37441409-FFD1-40AA-8EC5-9ECF5E2F7C29 |
Contoh
Respons sukses
JSONformat
{
"RequestId": "37441409-FFD1-40AA-8EC5-9ECF5E2F7C29"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | ReadDBInstanceNotSupport | The operation is not permitted due to type of the instance. | Operasi ini tidak diizinkan pada instans read-only. |
| 400 | ParameterLeastAssociate | Must input at least one optional parameter | Waktu pemulihan dan set cadangan tidak boleh kosong secara bersamaan. Tentukan setidaknya satu lalu coba lagi. |
| 400 | DeleteBackupSetNumExceed | Delete backup set number is more than 100. | Jumlah set cadangan yang akan dihapus melebihi 100. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Instans dalam paket tidak dapat dioperasikan secara individual. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Hasil rencana harga tidak ditemukan. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Anda belum menyelesaikan verifikasi identitas dan tidak memenuhi syarat untuk melakukan pembelian. Masuk ke Biaya dan Tagihan untuk menyelesaikan verifikasi identitas. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Saldo akun Anda kurang dari 0. Isi ulang akun Anda sebelum mencoba melakukan pembelian. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Pemanggilan ke layanan komoditas gagal. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud berencana mengoptimalkan dan menyesuaikan wilayah saat ini. Layanan cloud di wilayah ini akan dihentikan. Untuk memastikan kelangsungan bisnis dan migrasi data yang lancar, Anda tidak dapat membuat pesanan pembelian baru saat ini. Terima kasih atas pengertian dan dukungan Anda. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | Modul yang Anda beli tidak valid. Beli modul yang valid. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Wilayah yang ditentukan telah dihentikan. |
| 400 | Price.CommoditySys | Commodity system call exception. | Terjadi pengecualian saat memanggil sistem komoditas. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | Periode langganan yang dipilih tidak valid. Pilih periode langganan yang berbeda. |
| 400 | pay.noCreditCard | Account not bound to credit card. | Akun tidak dikaitkan dengan kartu kredit. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Terdapat pesanan yang belum dibayar untuk layanan yang Anda pilih. Bayar atau batalkan pesanan yang ada sebelum membuat pesanan baru. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Tidak ada metode pembayaran yang ditentukan untuk akun Anda. Tambahkan metode pembayaran. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Informasi Anda tidak lengkap. Lengkapi informasi Anda sebelum melanjutkan. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Akun Anda mengalami pengecualian. Hubungi layanan pelanggan untuk detailnya. |
| 400 | Api.NotSupport | Specified api is not supported. | Operasi saat ini tidak didukung. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Terdapat tag yang memblokir pesanan. Hubungi distributor Anda untuk menyelesaikan masalah ini. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | Instans yang ditentukan tidak ada. Periksa apakah instans ada dan belum dihapus. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | Tipe instans saat ini tidak mendukung tipe penyimpanan ini. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | Operasi gagal. Parameter tidak valid. |
| 400 | KmsApiError | User secret key invalid. | Kunci pengguna tidak valid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Akun tidak ada. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | Perintah SQL gagal dieksekusi atau waktu habis. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | Versi Mesin DPI instans saat ini tidak mendukung pengarsipan data dingin. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | Versi kernel saat ini tidak mendukung pengarsipan data dingin. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | Tipe instans saat ini tidak mendukung operasi ini. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | Nama alamat koneksi duplikat. Tentukan string koneksi yang berbeda. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parameter yang diperlukan hilang. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter tidak valid. Periksa parameter. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Pengarsipan data dingin tidak mendukung cadangan lintas wilayah atau cadangan snapshot frekuensi tinggi. Periksa kebijakan cadangan. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | Status instans tidak mendukung operasi ini. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Kebijakan retensi data cadangan yang diarsipkan setelah instans dirilis tidak valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | Tipe engine database instans tidak mendukung operasi ini. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Operasi ini tidak didukung untuk instans jenis jaringan VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Image instans database sudah ada. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | Tipe instans tidak lagi tersedia untuk dibeli. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | Database yang ditentukan tidak ada dalam set cadangan. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Gagal mengkueri produk. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | Instans telah dirilis. Verifikasi instans sebelum membuat pesanan. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | Wilayah yang ditentukan telah dihentikan. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | Permintaan gagal. Coba lagi nanti. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | Permintaan gagal. Coba lagi nanti atau hubungi dukungan teknis. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | Permintaan gagal karena kegagalan layanan API RDS. |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | Operasi gagal. Status instans saat ini tidak mendukung operasi ini. Coba lagi nanti. |
| 403 | IncorrectDBInstanceType | Current DB instance engine and type does not support operations. | Operasi gagal. Engine dan tipe instans database saat ini tidak didukung. |
| 403 | IncorrectDBInstanceCharacterType | Current DB Instance character_type does not support this operation. | Operasi ini tidak didukung untuk tipe karakter instans DB saat ini. |
| 403 | OperationDenied.BackupSetDeleteNotSupport | The Specified backup does not support this operation. | Set cadangan saat ini tidak dapat dihapus. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Instans memiliki pesanan yang belum dibayar. Bayar pesanan tersebut dan coba lagi. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | Kapasitas target untuk skala-mati tidak boleh kurang dari penggunaan penyimpanan saat ini. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Operasi ini tidak didukung untuk cloud disk SSD. Tingkatkan ke ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | Izin pengguna tidak mendukung operasi ini. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | Format VSwitchId yang ditentukan tidak valid atau kosong. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | Versi minor engine saat ini tidak mendukung operasi ini. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Tidak ada zona inventaris yang tersedia. |
| 403 | NotInFlowController | Sorry,no permission. | Operasi ini tidak tersedia untuk pengguna cloud non-perusahaan. Anda tidak memiliki izin yang diperlukan. |
| 403 | InvalidKmsKey | Kms key is disabled. | Kunci KMS dinonaktifkan. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | Operasi gagal. Kode spesifikasi yang ditentukan tidak mendukung jumlah titik akhir yang ditentukan. Periksa jumlah shard dan jumlah titik akhir saat ini. |
| 403 | Permission.NotSupport | User's permission not support the action. | Cadangan data dan cadangan log di bawah akun saat ini tunduk pada kebijakan perlindungan. Operasi berikut tidak didukung: menghapus cadangan, mengurangi periode retensi cadangan, atau mengurangi frekuensi cadangan. |
| 403 | IncorrectBackupSetMethod | Current backup set method does not support operations. | Operasi gagal. Set cadangan yang ditentukan tidak mendukung pemulihan database dan tabel. |
| 403 | IncorrectBackupSetState | Current backup set state does not support operations. | Operasi gagal. Status set cadangan saat ini tidak mendukung operasi ini. |
| 404 | InvalidDBInstanceName.NotFound | Invalid DBInstanceId NotFound. | ID instans yang ditentukan tidak ada. Verifikasi ID instans lalu coba lagi. |
| 404 | IncorrectDBInstanceLockMode | Current DB instance lock mode does not support this operation. | Operasi gagal. Instans terkunci. |
| 404 | InvalidBackupSetID.NotFound | Specified backup set ID does not exist. | Set cadangan tidak ada. Periksa set cadangan yang ada. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | Instans saat ini tidak diizinkan untuk mengakses Key Management Service. |
| 404 | Request.NotFound | The requested resource is not available. | Sumber daya yang diminta tidak tersedia. |
| 404 | HostInfo.NotFound | The specified host info is not found. | Informasi host yang ditentukan tidak ada. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.