Memulihkan data lintas wilayah ke instans baru.
Deskripsi operasi
Catatan Penggunaan
Sebelum pemulihan, kami menyarankan Anda memanggil operasi CheckCreateDdrDBInstance untuk melakukan pemeriksaan awal apakah set cadangan lintas wilayah dari instans RDS tujuan dapat digunakan untuk pemulihan lintas wilayah.
Mesin yang Didukung
RDS MySQL
RDS PostgreSQL
RDS SQL Server.
Dokumentasi Terkait
Coba sekarang
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
rds:CreateDdrInstance |
create |
*全部资源
|
None | None |
Parameter permintaan
|
Parameter |
Type |
Required |
Description |
Example |
| RegionId |
string |
Yes |
ID wilayah tujuan. Anda dapat memanggil operasi DescribeRegions untuk mengkueri ID wilayah. |
cn-hangzhou |
| Engine |
string |
Yes |
Jenis database tujuan. Nilai valid:
|
MySQL |
| EngineVersion |
string |
Yes |
Versi database tujuan. Nilai valid bervariasi berdasarkan nilai parameter Engine:
Catatan
Untuk instans SQL Server, |
5.6 |
| DBInstanceClass |
string |
No |
Tipe instans dari instans tujuan. Untuk informasi lebih lanjut, lihat Tipe instans. |
rds.mysql.s1.small |
| DBInstanceStorage |
integer |
No |
Kapasitas penyimpanan instans tujuan. Nilai valid: 5 hingga 2000. Nilai harus merupakan kelipatan 5. Unit: GB. Untuk informasi lebih lanjut, lihat Tipe instans. |
20 |
| SystemDBCharset |
string |
No |
Set karakter instans tujuan. Nilai valid:
|
uft8 |
| DBInstanceNetType |
string |
Yes |
Jenis koneksi jaringan instans tujuan. Nilai valid:
|
Intranet |
| DBInstanceDescription |
string |
No |
Nama instans tujuan. Panjang nama harus 2 hingga 256 karakter dan diawali dengan huruf atau karakter Tionghoa. Nama dapat berisi angka, karakter Tionghoa, huruf, garis bawah (_), dan tanda hubung (-). Catatan
Nama tidak dapat diawali dengan |
testdb |
| SecurityIPList |
string |
Yes |
Daftar putih IP instans tujuan. Beberapa alamat IP harus dipisahkan dengan koma (,). Alamat IP duplikat tidak diperbolehkan. Anda dapat menambahkan maksimum 1.000 alamat IP ke daftar putih. Dua format berikut didukung:
|
127.0.0.1 |
| ClientToken |
string |
No |
Token klien yang digunakan untuk memastikan idempotensi permintaan dan mencegah pengiriman berulang. Nilai dihasilkan oleh klien dan harus unik di antara permintaan yang berbeda. Panjang maksimum adalah 64 karakter ASCII, dan nilai tidak dapat berisi karakter non-ASCII. |
ETnLKlblzczshOTUbOCz**** |
| PayType |
string |
Yes |
Metode penagihan instans tujuan. Nilai valid:
|
Prepaid |
| ZoneId |
string |
No |
ID zona instans tujuan. Jika Anda ingin menggunakan beberapa zona, pisahkan ID zona dengan titik dua (:). Catatan
Parameter ini diperlukan saat Anda menentukan VPC dan vSwitch, agar sesuai dengan zona vSwitch. |
cn-hangzhou-b |
| InstanceNetworkType |
string |
No |
Jenis jaringan instans tujuan. Nilai valid:
Catatan
Jika Anda menetapkan parameter ini ke VPC, Anda juga harus menentukan VpcId dan VSwitchId. |
Classic |
| ConnectionMode |
string |
No |
Mode akses instans tujuan. Nilai valid:
|
Standard |
| VPCId |
string |
No |
ID VPC instans tujuan. Catatan
|
vpc-**** |
| VSwitchId |
string |
No |
ID vSwitch instans tujuan. Beberapa nilai harus dipisahkan dengan koma (,). Catatan
|
vsw-**** |
| PrivateIpAddress |
string |
No |
Alamat IP pribadi instans tujuan. Alamat IP harus berada dalam rentang alamat IP vSwitch yang ditentukan. Secara default, sistem menetapkan alamat IP berdasarkan VPCId dan VSwitchId. |
172.XX.XX.69 |
| UsedTime |
string |
No |
Durasi langganan. Nilai valid:
Catatan
Parameter ini diperlukan saat PayType ditetapkan ke Prepaid. |
2 |
| Period |
string |
No |
Jenis langganan instans tujuan. Nilai valid:
Catatan
Parameter ini diperlukan saat PayType ditetapkan ke Prepaid. |
Year |
| ResourceGroupId |
string |
No |
ID kelompok sumber daya. |
rg-acfmy**** |
| RestoreType |
string |
Yes |
Metode pemulihan. Nilai valid:
|
BackupSet |
| BackupSetId |
string |
No |
ID set cadangan yang digunakan untuk pemulihan. Anda dapat memanggil operasi DescribeCrossRegionBackups untuk mengkueri ID set cadangan. Catatan
Parameter ini diperlukan saat RestoreType=BackupSet. |
14**** |
| BackupSetRegion |
string |
No |
Wilayah tempat set cadangan berada. |
cn-beijing |
| RestoreTime |
string |
No |
Pengatur waktu yang ingin Anda gunakan untuk memulihkan data. Pengatur waktu harus lebih awal dari waktu saat ini. Format: yyyy-MM-ddTHH:mm:ssZ (waktu UTC). Catatan
Parameter ini diperlukan saat RestoreType=BackupTime. |
2019-05-30T03:29:10Z |
| SourceRegion |
string |
No |
ID wilayah sumber untuk pemulihan pengatur waktu. Catatan
Parameter ini diperlukan saat RestoreType=BackupTime. |
cn-hangzhou |
| SourceDBInstanceName |
string |
No |
ID instans sumber untuk pemulihan pengatur waktu. Catatan
Parameter ini diperlukan saat RestoreType=BackupTime. |
rm-uf6wjk5**** |
| DBInstanceStorageType |
string |
No |
Jenis penyimpanan instans tujuan. Nilai valid: Catatan
Kami menyarankan Anda menggunakan jenis penyimpanan yang sama dengan instans sumber. . |
local_ssd |
| RoleARN |
string |
No |
Nama Sumber Daya Alibaba Cloud (ARN) yang memberikan izin kepada akun layanan cloud RDS untuk mengakses KMS bagi akun utama instans SQL Server. Anda dapat memanggil operasi CheckCloudResourceAuthorized untuk mengkueri informasi ARN. |
acs:ram::1406****:role/aliyunrdsinstanceencryptiondefaultrole |
| EncryptionKey |
string |
No |
ID kunci kustom yang digunakan untuk enkripsi disk pada instans SQL Server. Jika Anda menentukan parameter ini, enkripsi disk akan diaktifkan (tidak dapat dinonaktifkan setelah diaktifkan), dan Anda juga harus menentukan RoleARN. Anda dapat Tampilan ID kunci di konsol Key Management Service, atau Anda dapat membuat kunci baru. Catatan
Anda dapat mengosongkan parameter ini dan hanya menentukan RoleARN, yang menunjukkan bahwa jenis enkripsi disk instans adalah CMK layanan default yang dikelola RDS. |
749c1df7-****-****-****-**** |
Contoh Penggunaan SQL Server
Elemen respons
|
Element |
Type |
Description |
Example |
|
object |
Detail parameter tanggapan. |
||
| ConnectionString |
string |
String koneksi instans baru. Catatan
Parameter DBInstanceNetType menentukan apakah alamat tersebut adalah alamat internal atau publik. |
rm-****.mysql.rds.aliyuncs.com |
| DBInstanceId |
string |
ID instans baru. |
rm-**** |
| OrderId |
string |
ID pesanan. |
2038691**** |
| Port |
string |
Port koneksi instans baru. Catatan
Parameter DBInstanceNetType menentukan apakah port tersebut adalah port internal atau publik. |
3306 |
| RequestId |
string |
ID permintaan. |
E52666CC-330E-418A-8E5B-A19E3FB42D13 |
Contoh
Respons sukses
JSONformat
{
"ConnectionString": "rm-****.mysql.rds.aliyuncs.com",
"DBInstanceId": "rm-****",
"OrderId": "2038691****",
"Port": "3306",
"RequestId": "E52666CC-330E-418A-8E5B-A19E3FB42D13"
}
Kode kesalahan
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidZoneId.NotSupported | The Specified vpc Zone not supported. | |
| 400 | InvalidDBInstanceName.Format | Specified DB instance name is not valid. | |
| 400 | InvalidDBInstanceName.Duplicate | Specified DB instance name already exists in the Aliyun RDS. | |
| 400 | InvalidRegion.Format | Specified Region is not valid. | |
| 400 | InvalidServiceType.Format | Specified service type is not valid. | |
| 400 | InvalidEngine.Malformed | Specified engine is not valid. | |
| 400 | InvalidEngineVersion.Malformed | Specified engine version is not valid. | |
| 400 | InvalidConnectionString.Format | Specified connection string is not valid. | |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the Aliyun RDS. | |
| 400 | InvalidCharacterSetName.Format | Specified character set name is not valid. | |
| 400 | InvalidDBInstanceType.Format | Specified instance type is not valid. | |
| 400 | InvalidPort.Malformed | Specified port is not valid. | |
| 400 | InvalidBackupRetentionPeriod.Malformed | Specified backup retention period is not valid. | |
| 400 | InvalidPreferredBackupTime.Format | Specified preferred backup time is not valid. | |
| 400 | InvalidPreferredBackupPeriod.Malformed | Specified backup period is not valid. | |
| 400 | InvalidOptmizationService | Specified optmization service is not valid. | |
| 400 | InvalidExpiredTime.Format | Specified expired time is not valid. | |
| 400 | InvalidSecurityIPList.Format | Specified security IP list format is not valid. | |
| 400 | InvalidSecurityIPList.Duplicate | Specified security IP list is not valid: Duplicate IP address in the list | |
| 400 | InvalidSecurityIPList.QuotaExceeded | Specified security IP list is not valid: Exceeding the allowed amount of IP address in the list. | |
| 400 | InvalidDBInstanceDescription.Format | Specified DB instance description is not valid. | |
| 400 | InvalidStorage.Format | Specified Storage is not valid. | |
| 400 | InvalidDBInstanceConnType.Format | Specified DB instance conn type is not valid. | |
| 400 | PreCheckInvalid | CreateDdrInstance PreCheck Is Invalid | |
| 400 | IncorrectDBInstanceType | Current DB instance engine and type does not support operations. | |
| 400 | InvalidRestoreType.Format | Specified restore type is not valid. | |
| 400 | NoBackupSetRegion | BackupSetRegion is absence. | |
| 400 | IncorrectBackupSetType | Backup set type should be value ddr. | |
| 400 | NoBaksetName | BaksetName is absence. | |
| 400 | NoSourceInstanceName | No SourceDBInstanceName. | |
| 400 | NoAvailableDisasterRestoreBakset | No available disaster restore bakset. | |
| 400 | InvalidBackupType.Format | Specified backup type is not valid. | |
| 400 | IncorrectEngineVersion | Current engine version does not support operations. | |
| 400 | DisasterRestoreRegionNotMatched | Disaster restore should be operated in the ddr region or source region. | |
| 400 | InvalidVpcIdRegion.NotSupported | The Specified vSwitchId zone not supported. | |
| 400 | VswitchIpExhausted | No available ip in the specified vswitch. | |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | |
| 400 | Price.CommoditySys | Commodity system call exception. | |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | |
| 400 | pay.noCreditCard | Account not bound to credit card. | |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | |
| 400 | Api.NotSupport | Specified api is not supported. | |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | |
| 400 | KmsApiError | User secret key invalid. | |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | |
| 400 | RequiredParam.NotFound | Required input param is not found. | |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | |
| 400 | OrdTCommodityQueryError | Failed to query for product. | |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | |
| 403 | IncorrectBackupSetMethod | Current backup set method does not support operations. | |
| 403 | IncorrectBaksetVersion | Current bakset version does not support operations. | |
| 403 | CrossRegionUnsupportTDE | Cross-region disaster restore not support TDE bakset. | |
| 403 | OperationDenied.Resource | Specified DB instance class or storage is not available in all Availability Zones. | |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | |
| 403 | NotInFlowController | Sorry,no permission. | |
| 403 | InvalidKmsKey | Kms key is disabled. | |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | |
| 404 | InvalidRegion.NotFound | Specified Region does not exist in the RDS | |
| 404 | InvalidClusterName.NotFound | The specified cluster name is not available. | |
| 404 | InvalidDBInstanceClass.NotFound | Specified DB instance class is not found. | |
| 404 | InvalidDBInstanceNetType.NotFound | Specified DB instance net type is not found. | |
| 404 | RestoreType.NotFound | RestoreType is not found. | |
| 404 | InvalidBackupSetID.NotFound | Specified backup set ID does not exist. | |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | |
| 404 | Request.NotFound | The requested resource is not available. | |
| 404 | HostInfo.NotFound | The specified host info is not found. |
Lihat Error Codes untuk daftar lengkap.
Catatan rilis
Lihat Release Notes untuk daftar lengkap.